Ubuntu

k10temp: there is no support for k10-thermal-sensors in kernel 2.6.32

Reported by paulle on 2009-12-24
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by RK

Bug Description

there is no support for k10-thermal-sensors in kernel 2.6.32. kernel 2.6.33 seems to have this support and sometimes it might be very useful one see temperature and/or fan rotation of the computer.
so please include the support for k10 thermal sensors if possible.

paulle (orj-gmail) wrote :

On Fri, 27 Nov 2009 16:43:33 +0100 Jean Delvare <email address hidden> wrote:
- Hide quoted text -
- Show quoted text -

> Hi Clemens,
> On Tue, 24 Nov 2009 09:43:39 +0100, Clemens Ladisch wrote:
> > This adds a driver for the internal temperature sensor of AMD Family 10h
> > and 11h CPUs.

> > Signed-off-by: Clemens Ladisch <email address hidden>
> > ---
> > v3: added 'force' parameter for CPUs with buggy sensor; more documentation
> > v4: added max/crit values, other changes suggested by Jean Delvare

> > Documentation/hwmon/k10temp | 60 +++++++++
> > drivers/hwmon/Kconfig | 12 +
> > drivers/hwmon/Makefile | 1
> > drivers/hwmon/k10temp.c | 197 ++++++++++++++++++++++++++++++++
> > 4 files changed, 270 insertions(+)

> Looks alright to me.

> Acked-by: Jean Delvare <email address hidden>

> If this is OK with you, I can add this patch to my hwmon tree and
> schedule it for merge in kernel 2.6.33.

Sounds good, thanks.

David Tombs (dgtombs) wrote :

Hi paulle, I'm not clear as to what you are asking for in this report. Are you asking for this support to be patched in to 2.6.32 from 2.6.33 for Lucid?

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Andy Whitcroft (apw) on 2010-01-13
tags: added: kernel-series-unknown
RK (kubuntu-rk) wrote :

> Are you asking for this support to be patched in to 2.6.32 from 2.6.33 for Lucid?

I'm not paulle, but yes, he is. 2.6.33 contains k10temp, 2.6.32 does not, so no thermal control for popular CPUs. The driver is pretty small, adding it will not affect anything else.

summary: - there is no support for k10-thermal-sensors in kernel 2.6.32
+ k10temp: there is no support for k10-thermal-sensors in kernel 2.6.32
Ancoron Luziferis (ancoron) wrote :

I have been using the k10temp (built manually) since kernel 2.6.31 within several different Ubuntu installations with success.

As Ubuntu Lucid is going to be an LTS release there is no reason not supporting this sensor. As it is included in the final 2.6.33 kernel it can be seen as being stable enough.

Ubuntu Lucid will be installed on a lot of servers and most of the installations on AMD systems will be using a K10 processor, namely Opteron. Lm-sensors is used often as a base for collecting sensor data for monitoring and thermal data is one of the very vital things in server environments.

I followed all those discussions and the progress of KMS/DRM/GPU stuff going backported into 2.6.32. So this little tool would be the least of all the problems that may be introduced by backporting.

I for myself am not asking for a 2.6.32 patch. I would rather see it in the backports-modules section. As most vital hardware does provide other sensors via SMBus or the like I don't think that it is vital to exist in the basic kernel image.

This is not criticism, I just want to push it to exist somewhere in the official repositories.

David Tombs (dgtombs) on 2010-03-15
tags: added: lucid
removed: k10 kernel-series-unknown sensors thermal
David Clayton (dcstar) wrote :

The K10temp module is also required for newer Athlon chips (like the 235e that I use), so not having it in 10.04 Lucid will be a major issue for people who expect that hardware that has been available for almost a year is supported by a new release.

Gunnar Thielebein (lorem-ipsum) wrote :

I would appreciate k10temp support because I have Phenom IV CPU and Turion X2 Dual Core Mobile both need the k10temp module. Do you accept dkms or m-a patches for this?

Gunnar Thielebein (lorem-ipsum) wrote :

k10temp-dkms added to my ppa: https://launchpad.net/~lorem-ipsum/

I would appreciate test and feedback.

Ancoron Luziferis (ancoron) wrote :

Nearly perfect!

+ The multiple kernel feature, very nice and convenient. But I have some upstream kernels installed that already have the module compiled and enabled, so you should check for that and disable integration for those kernels. In addition I noticed that it only integrates the module into kernels that are at the version I currently run and above, but e.g. I have the stock Lucid kernel "2.6.32-21-generic" but I currently run "2.6.32.11+drm33.2-duallink-fix" (like stock kernel plus a patch, same config). And here it doesn't update the stock kernel. Is it because "-" is lower than "."?

Anyway it just loads fine after installation:

$ uname -r
2.6.32.11+drm33.2-duallink-fix
$ sudo modprobe k10temp
$ sensors
it8720-isa-0228
Adapter: ISA adapter
in0: +1.02 V (min = +0.00 V, max = +4.08 V)
in1: +1.49 V (min = +0.00 V, max = +4.08 V)
in2: +3.36 V (min = +0.00 V, max = +4.08 V)
in3: +3.04 V (min = +0.00 V, max = +4.08 V)
in4: +3.02 V (min = +0.00 V, max = +4.08 V)
in5: +1.94 V (min = +0.00 V, max = +4.08 V)
in6: +4.08 V (min = +0.00 V, max = +4.08 V)
in7: +2.18 V (min = +0.00 V, max = +4.08 V)
Vbat: +3.25 V
fan1: 712 RPM (min = 0 RPM)
fan2: 0 RPM (min = 0 RPM)
fan3: 0 RPM (min = 0 RPM)
fan5: 0 RPM (min = 0 RPM)
temp1: +44.0°C (low = +127.0°C, high = +127.0°C) sensor = thermistor
temp2: +29.0°C (low = +127.0°C, high = +70.0°C) sensor = thermal diode
temp3: +39.0°C (low = +127.0°C, high = +127.0°C) sensor = thermistor
cpu0_vid: +0.413 V

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +35.1°C (high = +70.0°C, crit = +79.0°C)

Thanx for that!

Boerny (b-stader) wrote :

tried k10temp and worked like a charm.
did
$ sudo sensors-detect
and added k10temp to /etc/modules

$ sensors
k10temp-pci-00c3
Adapter: PCI adapter
temp1: +62.1°C (high = +70.0°C)

Use the k10temp (lmsensors/k10temp/temp1) in plasma-widget temperature.

Thanks!

Jaap Versteegh (j-r-versteegh) wrote :

I've been using k10temp since 2.6.28 (jaunty) by applying the kernel patch. I am surprised support still hasn't been added for such common CPU's....

I've also put up a k10temp ppa some time ago:

https://launchpad.net/~dasprid/+archive/dasprid

Upgraded to Lucid/10.04 yesterday. Now sensors work as expected.

davidr (davaweb) wrote :

Reving this thread:

"I've also put up a k10temp ppa some time ago:

https://launchpad.net/~dasprid/+archive/dasprid"

I get 'You are not allowed in here'.

Please help? Thanks
David

David Tombs (dgtombs) wrote :

I get the same error. I guess the PPA has disappeared.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers