nic-usb-modules should include asix

Bug #499785 reported by Thierry Carrez on 2009-12-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

Modern USB NIC adapters (USB2.0 / Gb networking) mostly use the asix chipset. In order to support them in the installer, we need to have the asix minimodule enabled. It's currently missing from the list in nic-usb-modules.

Example device currently not supported:
Trendnet TU2-ETG USB to Gigabit Ethernet adapter
0b95:1780 ASIX Electronics Corp. AX88178

Double-checked with Colin:
<cjwatson> ttx: asix> ask the kernel team to add it to nic-usb-modules - it seems perfectly reasonable to me, but I'd just be proxying your request through to the kernel team anyway :)

Thierry Carrez (ttx) on 2009-12-23
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in linux (Ubuntu):
importance: Wishlist → Medium

Hi Thierry,

Just want to double check you need this for Lucid correct?

Thierry Carrez (ttx) wrote :

Hey Leann, yes this would just be needed for Lucid (and going forward).

Andy Whitcroft (apw) on 2010-01-05
tags: added: lucid
Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)

Hi Thierry,

I've submitted a patch to the kernel-team ml. Thanks.

https://lists.ubuntu.com/archives/kernel-team/2010-January/008232.html

Changed in linux (Ubuntu):
status: Triaged → In Progress
Andy Whitcroft (apw) on 2010-01-05
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (9.6 KiB)

This bug was fixed in the package linux - 2.6.32-10.14

---------------
linux (2.6.32-10.14) lucid; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms: fix LVDS setup on r4xx
    - LP: #493795

  [ Andy Whitcroft ]

  * Revert "(pre-stable) acpi: Use the ARB_DISABLE for the CPU which model
    id is less than 0x0f."
  * config-check -- ensure the checks get run at build time
  * config-check -- check the processed config during updateconfigs
  * config-check -- CONFIG_SECCOMP may not be present
  * TUN is now built in ignore
  * SAUCE: acpi battery -- delay first lookup of the battery until first
    use
  * SAUCE: async_populate_rootfs: move rootfs init earlier
  * ubuntu: AppArmor -- update to mainline 2010-01-06
  * SAUCE: move RLIMIT_CORE pipe dumper marker to 1
    - LP: #498525

  [ Dave Airlie ]

  * (pre-stable) drm/radeon/kms: fix crtc vblank update for r600

  [ Leann Ogasawara ]

  * Add asix to nic-usb-modules file
    - LP: #499785

  [ Peter Zijlstra ]

  * (pre-stable) sched: Fix balance vs hotplug race

  [ Tim Gardner ]

  * [Config] Enable CONFIG_FUNCTION_TRACER
    - LP: #497989
  * [Config] Drop lpia from getabis
  * [Config] Build in TUN/TAP driver
    - LP: #499491
  * [Config] DH_COMPAT=5

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: Avoid NULL dereference with
    component_only tv_modes"
  * Revert "(pre-stable) drm/i915: Fix sync to vblank when VGA output is
    turned off"
  * USB: usb-storage: fix bug in fill_inquiry
  * USB: option: add pid for ZTE
  * firewire: ohci: handle receive packets with a data length of zero
  * rcu: Prepare for synchronization fixes: clean up for non-NO_HZ handling
    of ->completed counter
  * rcu: Fix synchronization for rcu_process_gp_end() uses of ->completed
    counter
  * rcu: Fix note_new_gpnum() uses of ->gpnum
  * rcu: Remove inline from forward-referenced functions
  * perf_event: Fix invalid type in ioctl definition
  * perf_event: Initialize data.period in perf_swevent_hrtimer()
  * perf: Don't free perf_mmap_data until work has been done
  * PM / Runtime: Fix lockdep warning in __pm_runtime_set_status()
  * sched: Check for an idle shared cache in select_task_rq_fair()
  * sched: Fix affinity logic in select_task_rq_fair()
  * sched: Rate-limit newidle
  * sched: Fix and clean up rate-limit newidle code
  * x86/amd-iommu: attach devices to pre-allocated domains early
  * x86/amd-iommu: un__init iommu_setup_msi
  * x86, Calgary IOMMU quirk: Find nearest matching Calgary while walking
    up the PCI tree
  * x86: Fix iommu=nodac parameter handling
  * x86: GART: pci-gart_64.c: Use correct length in strncmp
  * x86: ASUS P4S800 reboot=bios quirk
    - LP: #366682
  * x86, apic: Enable lapic nmi watchdog on AMD Family 11h
  * ssb: Fix range check in sprom write
  * ath5k: allow setting txpower to 0
  * ath5k: enable EEPROM checksum check
  * hrtimer: Fix /proc/timer_list regression
  * ALSA: hrtimer - Fix lock-up
  * ALSA: hda - Terradici HDA controllers does not support 64-bit mode
  * KVM: x86 emulator: limit instructions to 15 bytes
  * KVM: s390: Fix prefix register checking in arch/s390/kvm/sigp.c
  * KVM: s390: Make psw available on all exits...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
SirFrankie (junkert-ferenc) wrote :

Hi, just want to ask, it would be much hard work, to support this devices in Karmic, next kernel release?

Bus 001 Device 005: ID 1737:0039 Linksys USB1000

i think, this is same device, with same driver ( just think, looks like if i see the MS driver what is created for this devices)

[Manufacturer]

%ASIX% = USB

[ControlFlags]

ExcludeFromSelect = USB\VID_0B95&PID_1780

ExcludeFromSelect = USB\VID_1737&PID_0039 ;Linksys

[USB]

%AX88178.DeviceDesc% = AX88178.Ndi,USB\VID_0B95&PID_1780

%AX88178L.DeviceDesc% = AX88178.Ndi,USB\VID_1737&PID_0039 ;Linksys

and asix's driver dont work for it.... Thanks for any answer...

    SirFrankie

Todd Cole (tcole3737) wrote :

Sabrent AX88178 still not working in 11.04 Kernal 2.6.38-7 generic 64Bit should this be working by now or just wait?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers