Resume from suspend fails on Dell XPS M1330

Bug #499221 reported by Javier Jardón on 2009-12-21
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Build Version/Date: Lucid updated 20091221
Environment used for testing: Dell XPS 1330 All Intel

Summary:
System seems to suspend, but opening the lid left the backlight on but no system active. I attempted to get to a VT but was not able to. No message from apport after hard reboot

This is very similar to bug #412271, but this affects lucid, not karmic (I have karmic installed too (2.6.31.16.29 kernel) and suspend/resume works)

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jjardon 1581 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero ó directorio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 21'
   Mixer name : 'Silicon Image SiI1392 HDMI'
   Components : 'HDA:83847616,1028020a,00100201 HDA:10951392,1028020a,00100000'
   Controls : 32
   Simple ctrls : 19
Date: Mon Dec 21 21:00:07 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091209)
MachineType: Dell Inc. XPS M1330
Package: linux-image-2.6.32-9-generic 2.6.32-9.13
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-9-generic root=UUID=333c4e2d-40bb-45a8-9ca1-cc709450230a ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Tags: lucid regression-potential
TestedUpstream: Yes
Uname: Linux 2.6.32-9-generic x86_64
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0N6705
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn0N6705:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

Javier Jardón (jjardon) wrote :
Javier Jardón (jjardon) on 2009-12-21
description: updated
Andy Whitcroft (apw) wrote :

Could you try the steps which are suggested in teh Debugging Suspend section of the document below and report back here:

    https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume#Debugging%20Suspend

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Javier Jardón (jjardon) wrote :

Hello Andy,

I've followed the steps of that page and suspend/resume works without problems.

So, I reboot in normal mode and disabled wireless network through the networmanager-applet and now suspend/resume works again.

So I think the problem is the with the suspend/resume of the wireless card (intel 4965 AGN)

Do you need any specific information?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Javier Jardón (jjardon) wrote :

Hello, I'm the reporter of the upstream bug too.
The upstream bug is marked as fixed because I don't have this problem with 2.6.23rc2 kernel from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc2/

Will this kernel be included in lucid?

Chase Douglas (chasedouglas) wrote :

@Javier:

The lucid kernel will be based on 2.6.32. In order to fix Lucid, a single (or set of) patch(es) needs to be determined as the fix. Can you bisect the mainline kernel or find the fix some other way so that we may be able to pull it into Lucid?

Thanks

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Chase Douglas (chasedouglas) wrote :

@Javier:

Please retest against 2.6.32-16 or later. These kernels have the graphics drivers backported from 2.6.33. If your issue was related to the graphics drivers, then it likely is solved by the update.

Thanks

Javier Jardón (jjardon) wrote :

@Chase:

No, the problem was related to wifi drivers.
Anyway, I tested today and suspend/resume works again, so closing as fixed :)

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.