[lucid] unable to shutdown

Bug #498607 reported by Seth Hikari on 2009-12-19
108
This bug affects 19 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Seth Hikari

Bug Description

No matter what I do I can't complete the shutdown process I have to remove the power from my computer.

I attached a video of me running

sudo shutdown now

I was able to shutdown in Karmic

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: seth 1593 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe020000 irq 21'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:11d4198b,1043829b,00100400 HDA:10de0002,10de0101,00100000'
   Controls : 52
   Simple ctrls : 28
Date: Sat Dec 19 13:42:15 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091209)
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux-image-2.6.32-8-generic 2.6.32-8.12
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-8-generic root=UUID=cb58c7db-35e8-44f7-9a0e-749ba467ddb5 ro splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-8.12-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
RfKill:

SourcePackage: linux
Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-8-generic x86_64
dmi.bios.date: 01/05/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M3N-HT Deluxe ACPI BIOS Revision 1901
dmi.board.name: M3N-HT DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM3N-HTDeluxeACPIBIOSRevision1901:bd01/05/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3N-HTDELUXE:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Seth Hikari (sethhikari) wrote :
Ron Bakker (r0n) wrote :

On my laptop (Acer Aspire 5535) the shutdown or reboot say's:

hal main process (683) terminated with status 1
avahi-deamon main process (688) terminated with status 255
modem-manager: caught signal 15, shutting down
init: Disconnected from system bus

After this nothing happens and I must switch the laptop hardware off.
Karmic has no problems, it's only in 10.04.

Seth Hikari (sethhikari) wrote :

Yes this is what I see too most of the time. I believe it is the same bug.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Christopher (soft-kristal) wrote :

Same with both computers with Lucid partitions. The desktop has a GeForce 6400 graphic card and will no longer boot. It hangs; displaying the desktop after several minutes (previously about 12 seconds) and has nothing in the panels.

I cannot boot at all on that computer in Recovery mode but can access the terminal via Ctrl+Alt+F2 in the hanged boot.

Surbhi Palande (csurbhi) wrote :

@Christopher, your problem seems to be different than this bug. Please file another bug for your issue.

Surbhi Palande (csurbhi) wrote :

@Seth Hikari, Thanks for the video and the bug report. Can you please confirm if this problem persists for the latest Lucid image (i.e daily build or alpha 2) ?

Kim Tucker (ktucker) wrote :

On Portégé R600-10Q shutdown freezes with:

init: Disconnected from system bus
init: plymouth post-start process (12485) killed by TERM signal

Seth Hikari (sethhikari) wrote :

@Surbhi Palande
Yes I have just re-upgaded to Lucid again and this bug still persists in the daily builds.

Seth Hikari (sethhikari) wrote :

Now it seems while it is stuck if I press ctr-alt-delete I get alsa-mixer-save (foo#) caught signal 1
Every time I hit it same thing with different. process ID
That should help

emarkay (mrk) wrote :

I get periodic partial closing - exits "X" and then hangs on a line (something like error 15 - I will document next time it happens). No recourse but to power off manually. This happens on 2 different machines - and yes I have uninstalled Plymouth.

Seth Hikari (sethhikari) wrote :

OH! I know what this is! maybe... So one time when I noticed that my computer booted with networking disabled I am able to shut down.

me too, I have Thinkpad T500, I have to hold shutdown button to turn off laptop

Waldgeist_dI (noway) wrote :

I experience a similar problem an a Lucid system (32 bit) installed with the Alpha 2 ISO and updated via apt ever since.

sudo reboot now

works, but

sudo shutdown -hP now

only ends the GUI, leaving a completely blank screen.

C+A+D produced a message about alsa-mixer for a split-second, then the machine reboots instead of shutting down.

mf (mat-fletcher) wrote :
Jones D. Le (joneslee85) wrote :

I confirm this on my IBM X200.

I have 2.6.34-020634rc1-generic kernel and lucid hangs on shutdown

Vanishing (vanishing) wrote :

Samething happens to my t500 lucid install, 32 bit..
init errors when shutdown

double (doppelbauer) wrote :

I have a Acer K70A - powerdown works perfekt in Karmic (and before).
Powerdown in Lucid -> Reboot.

Seth Hikari (sethhikari) wrote :

Could everyone this effects please attach output from

lspci

Thanks

Vanishing (vanishing) wrote :

I just tried the 64 version of ubuntu 10.04, both shutdown and reboot works, but it freezes for 10 secs or so before it really shutdown/reboot..
here is lspci:
vanishing@Vanishing:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LF Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5300
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)

Seth Hikari (sethhikari) wrote :

looks like you were not suffering from the same bug, still have issues on the latest build that I think may be caused with a problem with ralink wirless chips. As I get a traceback dealing with RT2600 drivers

Waldgeist_dI (noway) wrote :

The problem still exists for me. Reboot works, Shutdown ends the GUI, but the screen with 10.04 and the four dots stay visible forever. I connected to the box from my laptop via ssh and looked for zombies in "top" but couldn't find any. So the system was still running and accessible with ssh. Issuing "shutdown -hP now" worked from the ssh connection, the system did shutdown with that second instruction.

As requested the output from "lspci"

...@...:~$ lspci
00:00.0 Host bridge: ALi Corporation M1697 HTT Host Bridge
00:01.0 PCI bridge: ALi Corporation PCI Express Root Port
00:03.0 PCI bridge: ALi Corporation PCI Express Root Port
00:05.0 Host bridge: ALi Corporation M1695 K8 Northbridge [PCI Express and HyperTransport]
00:06.0 PCI bridge: ALi Corporation PCI Express Root Port
00:07.0 PCI bridge: ALi Corporation PCI Express Root Port
00:08.0 PCI bridge: ALi Corporation PCI Express Root Port
00:11.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:13.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:13.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:13.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:13.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
00:14.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host Controller (rev 01)
00:15.0 ISA bridge: ALi Corporation PCI to LPC Controller (rev 10)
00:15.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:16.0 IDE interface: ALi Corporation M5229 IDE (rev c7)
00:16.1 IDE interface: ALi Corporation ULi M5288 SATA
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GTX] (rev a1)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
06:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
06:0c.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
06:0c.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
06:0d.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

Waldgeist_dI (noway) wrote :

This time I tried to shutdown the system remotely only by a ssh connection. The first "shutdown -hP now" brought up the now familiar screen with

Ubuntu 10.04
   . . . .

with those four dots changing their color and closed the ssh connection but the system hung there, anyway. I had to connect to the box a second time. Another shutdown command yielded the information about alsa again, then the system went down (this time without rebooting!)

double (doppelbauer) wrote :

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series]
01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
02:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller (rev b0)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Seth Hikari (sethhikari) wrote :

Yay a breakthrough! I have finished the upstream testing and confirmed that this bug is not present in the Linux kernel 2.6.34-rc2.

I hope that a backport of kernel 2.6.33 into Lucid which I believe was already planed to be an option will fix this issue.

I encourage all who are experiencing this bug to test the upstream kernel as well. I followed these steps using the optional Ubuntu configuration.

https://wiki.ubuntu.com/KernelTeam/GitKernelBuild

tags: removed: needs-upstream-testing
tags: added: kernel-bug
Seth Hikari (sethhikari) wrote :

If some one whom this effects would like to test to see if the problem exists in Fedora 12( updated so as to have 2.6.32 not 2.6.31 ) and see if the problem is there as well that would be great, also Fedora alpha but I am not to sure on the kernel version.

Nano (fermace1) wrote :

Like this:

init: Disconnected from system bus
init: plymouth post-start process (12485) killed by TERM signal

in Dell Inspiron 1750.

Vanishing (vanishing) wrote :

This was solved for me by upgrading to the newest kernel(32.19).

Seth Hikari (sethhikari) wrote :

@Vanishing I have tested teh 32.19 Kernel and the problem still exists for me, may be different bug but grats for you

Problem is not in the new R3 kernel either

@Nano , does it hang there until you remove the power?

Nano (fermace1) wrote :

@Seth Hikari, yes.

But I installed the kernel v2.6.34-rc1 from http://kernel.ubuntu.com, just to test, and the problem disappeared. Tomorrow I'll try to test the right way to do like you mentioned a few posts behind.

Seth Hikari (sethhikari) wrote :

You have done it just fine if you got the Kernel to install I only had to follow the Ubuntu instructions because of a Kernel Panic at boot.

This confirms the issue is fixed in Upstream, Backport maybe?

Nano (fermace1) wrote :

I think it is confirmed.

Seth Hikari (sethhikari) wrote :

Yes! It is here! 2.6.32-20 Fixed this problem, I hope that it does the same for all of you!

Changed in linux (Ubuntu):
status: Triaged → Fix Released
tags: added: iso-testing
Fabio Marzocca (thesaltydog) wrote :

My Acer 3810T does not shut down/restart/close session from GUI, with kernel 2.6.32-20 (64bit).
In order to switch off the laptop I need to open a terminal and type 'sudo poweroff'.

I think the problem is related to grants on the user applet...

Seth Hikari (sethhikari) wrote :

@Fabio

You are experiencing a different bug that you should report, this bug would not let you finish shutting down ever from the terminal.

Nano (fermace1) wrote :

I think this bug is related to the default video driver. I had the problem because a bug prevented me have the fglrx proprietary driver. When I install the fglrx I solved the problem even with the kernel 2.6.32-19. I think it could be an interesting track for this bug.

Magnus Kulke (magnus-kulke) wrote :

i have this problem on an 'hp compaq 6715s' laptop. the update to 2.6.32-21-generic did not help.

Nano (fermace1) wrote :

@Magnus Kulke

Try to install the proprietary driver for your video card.

Magnus Kulke (magnus-kulke) wrote :

@nano:

i can't. the hardware drivers thingie does not offer any drivers for my card. i installed the fglrx drivers manually, but they do not seem to fit to my hardware (ATI Technologies Inc RS690M).

Waldgeist_dI (noway) wrote :

For me the problem still persists, as well. And according to the Ubuntu home page the installer from the NVidia driver won't work in the current state of affairs. So I am stuck with the Ubuntu driver for my Geforce 7900GTX. Anything else I can test ...?

showgun (showgun) wrote :

On my pc and laptop, selecting shut down, or restart from the menu has no effect" but this is not something that repeats all the time

The culprit in my case seems to be cause by the OOo quickstarter
every times the problem happens all I have to do is exit the quickstarter and do the shutdown and it works just fine..
Hope this helps...

Cymaphore (cymaphore) wrote :

In my case, I resolved it that way:

NetworkManager blocked poweroff.

Solution (in my case):

--- /etc/init/network-manager.conf.orig 2010-05-03 14:56:09.745071317 +0200
+++ /etc/init/network-manager.conf 2010-05-03 14:56:43.075152939 +0200
@@ -8,6 +8,7 @@
 start on (local-filesystems
          and started dbus)
 stop on stopping dbus
+stop on runlevel [06]

 expect fork
 respawn

double (doppelbauer) wrote :

For me it was kexec
/etc/default/kexec -> LOAD_KEXEC=false

# Defaults for kexec initscript
# sourced by /etc/init.d/kexec and /etc/init.d/kexec-load

# Load a kexec kernel (true/false)
LOAD_KEXEC=false

# Kernel and initrd image
KERNEL_IMAGE="/vmlinuz"
INITRD="/initrd.img"

# If empty, use current /proc/cmdline
APPEND=""

Waldgeist_dI (noway) wrote :

For me, shutdown works now with the latest Lucid version, on both platforms (32 and 64 bit). No more problems, as far as I can see.

denislegrand (denisgg) wrote :

For me shutdown don't works. PC stopped a few seconds then restart. Solutions : press the powerbutton or press 'c' in the grub menu (grub-pc) and command 'halt'.
No /etc/default/kexec in my /

What stop on runlevel [06] is doing ? Do i try it ?

Uname -a : 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

lspci and dmesg in attachment

Lot of others as the same bug in ubuntu.fr forum.

denislegrand (denisgg) wrote :

and the dmesg attachment...

Seth Hikari (sethhikari) wrote :

The original bug reported is fixed, if you are still having problems you should file another bug.

denislegrand (denisgg) wrote :

@seth hikari. Thanks. I had do it in new bug 580867.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions