Please include VMware vmw_pvscsi SCSI HBA driver in Lucid linux package

Bug #497156 reported by Bhavesh Davda on 2009-12-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Tim Gardner

Bug Description

VMware's vmw_pvscsi SCSI HBA driver is now in the mainline kernel targeted for of 2.6.33. The kernel config option to compile it is:

CONFIG_VMWARE_PVSCSI=m

The commit that added vmw_pvscsi to mainline is:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=851b164231d1117673aa44c00c7622e48b7dfcf4

This bug is a feature request to backport the vmw_pvscsi patch to 2.6.32 for inclusion in the Lucid linux package. Thanks!

Andy Whitcroft (apw) on 2009-12-15
tags: added: kernel-series-unknown
Nick Barcet (nijaba) on 2009-12-17
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
milestone: none → lucid-alpha-3
Alok Kataria (akataria) wrote :

Now that alpha-2 is out of the door, I think this might be the right time to check the status of including the pvscsi driver in the Lucid tree for it to be available with alpha-3

I just tried merging the mainline commit (851b164231d1117673aa44c00c7622e48b7dfcf4 - which introduced this driver) to Lucid's git tree and the merge looks successful.

Please let me know if you would need any more info before the actual commit to Lucid can be done.

Thanks.

Andy Whitcroft (apw) on 2010-01-19
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Tim Gardner (timg-tpi)
Launchpad Janitor (janitor) wrote :
Download full text (15.5 KiB)

This bug was fixed in the package linux - 2.6.32-11.15

---------------
linux (2.6.32-11.15) lucid; urgency=low

  [ Andy Whitcroft ]

  * Revert "(pre-stable) drm/radeon/kms: fix crtc vblank update for r600"
  * Revert "(pre-stable) sched: Fix balance vs hotplug race"
  * Revert "[Upstream] acerhdf: Limit modalias matching to supported
    boards"
  * Revert "[Upstream] mmc: prevent dangling block device from accessing
    stale queues"
  * Revert "SAUCE: Fix nx_enable reporting"
  * Revert "SAUCE: [x86] fix report of cs-limit nx-emulation"
  * Revert "SAUCE: [x86] implement cs-limit nx-emulation for ia32"
  * SAUCE: i915 -- disable powersave by default
    - LP: #492392

  [ Kees Cook ]

  * SAUCE: [x86] implement cs-limit nx-emulation for ia32
    - LP: #369978
  * SAUCE: [x86] fix report of cs-limit nx-emulation
    - LP: #454285
  * SAUCE: Fix nx_enable reporting
    - LP: #454285

  [ Tim Gardner ]

  * [Upstream] b43: Declare all possible firmware files.
    - LP: #488636
  * [Config] updateconfigs after adding pvscsi
    - LP: #497156
  * [Config] CONFIG_BT=m

  [ Upstream Kernel Changes ]

  * Revert "x86: Side-step lguest problem by only building cmpxchg8b_emu
    for pre-Pentium"
  * SCSI: ipr: fix EEH recovery
  * SCSI: qla2xxx: dpc thread can execute before scsi host has been added
  * SCSI: st: fix mdata->page_order handling
  * SCSI: fc class: fix fc_transport_init error handling
  * sched: Fix task_hot() test order
  * x86, cpuid: Add "volatile" to asm in native_cpuid()
  * sched: Select_task_rq_fair() must honour SD_LOAD_BALANCE
  * clockevents: Prevent clockevent_devices list corruption on cpu hotplug
  * pata_hpt3x2n: fix clock turnaround
  * pata_cmd64x: fix overclocking of UDMA0-2 modes
  * ASoC: wm8974: fix a wrong bit definition
  * sound: sgio2audio/pdaudiocf/usb-audio: initialize PCM buffer
  * ALSA: hda - Fix missing capsrc_nids for ALC88x
  * acerhdf: limit modalias matching to supported
    - LP: #435958
  * ACPI: EC: Fix MSI DMI detection
  * ACPI: Use the return result of ACPI lid notifier chain correctly
  * powerpc: Handle VSX alignment faults correctly in little-endian mode
  * ASoC: Do not write to invalid registers on the wm9712.
  * drm/radeon: fix build on 64-bit with some compilers.
  * USB: emi62: fix crash when trying to load EMI 6|2 firmware
  * USB: option: support hi speed for modem Haier CE100
  * USB: Fix a bug on appledisplay.c regarding signedness
  * USB: musb: gadget_ep0: avoid SetupEnd interrupt
  * Bluetooth: Prevent ill-timed autosuspend in USB driver
  * USB: rename usb_configure_device
  * USB: fix bugs in usb_(de)authorize_device
  * drivers/net/usb: Correct code taking the size of a pointer
  * x86: SGI UV: Fix writes to led registers on remote uv hubs
  * md: Fix unfortunate interaction with evms
  * dma: at_hdmac: correct incompatible type for argument 1 of
    'spin_lock_bh'
  * dma-debug: Do not add notifier when dma debugging is disabled.
  * dma-debug: Fix bug causing build warning
  * cifs: NULL out tcon, pSesInfo, and srvTcp pointers when chasing DFS
    referrals
  * x86/amd-iommu: Fix initialization failure panic
  * ioat3: fix p-disabled q-continuation
  * ioat2,3: put channel...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Alok Kataria (akataria) wrote :

The installer kernel for Ubuntu 10.04 Alpha 3 seems to be missing this driver. Can someone confirm if this can be included in the next update ?

Thanks.

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Alok Kataria (akataria) wrote :

Reopening the bug to get the driver in the installer kernel.

Tim Gardner (timg-tpi) wrote :

Alok - kernel/drivers/scsi/vmw_pvscsi.ko is still part of the Lucid generic/server kernel package (at least it is for the 64 bit version). What makes you think its not on the installer disk? And why wouldn't the module be getting installed? It does, after all, register as a PCI device so udev should be loading it assuming PCI_DEVICE_ID_VMWARE_PVSCSI is present in the VM.

Andy Whitcroft (apw) wrote :

@Alok -- if you are saying that this module is not available in the alternate installer then it would be best to file a new bug for that, as the module as built and installed in the linux package as we can see below which was the aim of this bug:

    $ find /lib/modules/2.6.32-15-generic/ -name vmw_\*
    /lib/modules/2.6.32-15-generic/kernel/drivers/scsi/vmw_pvscsi.ko

Alok Kataria (akataria) on 2010-03-02
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Alok Kataria (akataria) wrote :

Okay let me close this one, but yes I did mean that the installer kernel doesn't have the pvscsi module.
I have filed a new one bug, https://bugs.launchpad.net/ubuntu/+bug/531017 with all the necessary information.

Thanks.

Andy Whitcroft (apw) on 2010-03-04
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints