Can't unblank Dell Inspiron 640m after closing and reopening the lid

Bug #496842 reported by Eric Appleman on 2009-12-15
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Eric Appleman

Bug Description

Binary package hint: gnome-power-manager

I can't get my laptop (Dell Inspiron 640m) to unblank after a lid close unless I apply this dirty fix: http://ubuntuforums.org/showpost.php?p=8448660&postcount=25

99% of the time, closing my lid will force a reboot to restore my display. Even with the aforementioned fix, I still have to reboot at least 70% of the time.
---
Architecture: i386
CheckboxSubmission: b8398b21075a3a8723b2ba20478c4f9e
CheckboxSystem: 703a6ca1eefae989daaf40c6bb6aa94a
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091218.1)
Package: gnome-power-manager 2.28.1-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-genusername
Tags: lucid lucid
Uname: Linux 2.6.32-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: eric 1770 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801d8,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 12
   Simple ctrls : 7
CheckboxSubmission: b8398b21075a3a8723b2ba20478c4f9e
CheckboxSystem: 703a6ca1eefae989daaf40c6bb6aa94a
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=497355ee-924b-6989-81d4-1a964f21b4b4
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
MachineType: Dell Inc. MXC061
Package: linux 2.6.32.11.11
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-genusername root=UUID=16c1de69-d7ea-41c2-9fdf-400057d603ba ro quiet
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-genusername
Regression: Yes
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/10/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0MG532
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd07/10/2007:svnDellInc.:pnMXC061:pvr:rvnDellInc.:rn0MG532:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXC061
dmi.sys.vendor: Dell Inc.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: eric 1756 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801d8,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 12
   Simple ctrls : 7
CheckboxSubmission: b8398b21075a3a8723b2ba20478c4f9e
CheckboxSystem: 703a6ca1eefae989daaf40c6bb6aa94a
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=497355ee-924b-6989-81d4-1a964f21b4b4
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
MachineType: Dell Inc. MXC061
Package: linux 2.6.32.11.11
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-genusername root=UUID=16c1de69-d7ea-41c2-9fdf-400057d603ba ro quiet
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-genusername
Regression: No
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
Tags: lucid needs-upstream-testing
TestedUpstream: No
Uname: Linux 2.6.32-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/10/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0MG532
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd07/10/2007:svnDellInc.:pnMXC061:pvr:rvnDellInc.:rn0MG532:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXC061
dmi.sys.vendor: Dell Inc.

summary: - gpm lacks proper dpms blanking and unblanking
+ gpm lacks proper vbetool blanking and unblanking

I can confirm here, though can you run `apport-collect 496842` to attach the appropriate information to this report? Thanks.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed

Architecture: i386
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: gnome-power-manager 2.29.1-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic-pae
Tags: lucid lucid
Uname: Linux 2.6.32-11-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

apport information

apport information

apport information

apport information

description: updated
summary: - gpm lacks proper vbetool blanking and unblanking
+ Ubuntu lacks proper vbetool blanking and unblanking
summary: - Ubuntu lacks proper vbetool blanking and unblanking
+ Can't unblank my Inspiron 640m after a lid close

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 94
3/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

description: updated

I'm not yet convinced this is a kernel related issue. However, for good measure can you run:

apport-collect -p linux 496842

This will gather and attach the kernel related debugging bits. Thanks.

Changed in linux (Ubuntu):
status: New → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: serg 2598 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,1028024d,00100302 HDA:80862802,80860101,00100000'
   Controls : 24
   Simple ctrls : 15
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=d7a5b32f-cf4a-44b1-98f5-a53c6a7852cf
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Dell Inc. Latitude E4300
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-generic-pae root=UUID=a53e4e84-f926-4246-8c6f-821bb93ad686 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic-pae
Regression: Yes
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-11-generic-pae i686
UserGroups:

dmi.bios.date: 02/16/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.asset.tag: 8F4Y14J
dmi.board.vendor: Dell Inc.
dmi.chassis.asset.tag: 8F4Y14J
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd02/16/2009:svnDellInc.:pnLatitudeE4300:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E4300
dmi.sys.vendor: Dell Inc.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I have same issue with Dell E4300

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Same Problem here. If I can help by providing Information, let me know.

Mathieu Pellerin (nirvn-asia) wrote :

Same problem on my Dell Latitude D830, Intel video

Eric Appleman (erappleman) wrote :

This should go without saying, but Sergey reminded me.

THIS. BUG. SHIPPED. WITH. KARMIC.

It surfaced towards the very end of the Karmic dev cycle and I didn't see fit to file a bug because of my shameless use of xorg-edgers.

Eric Appleman (erappleman) wrote :

Any updates?

Eric Appleman (erappleman) wrote :

I forgot to mention that Alt+SysRq+K is the only thing that will bring back the screen. Of course, this implies that X is restarted.

Can somebody please elevate this bug? It's a system crippler.

summary: - Can't unblank my Inspiron 640m after a lid close
+ Can't unblank my Dell Inspiron 640m after a lid close
summary: - Can't unblank my Dell Inspiron 640m after a lid close
+ Can't unblank certain Dell laptops after closing and reopening the lid
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Can't unblank certain Dell laptops after closing and reopening the lid
+ Can't unblank certain laptops after closing and reopening the lid

It seems that this bug is don't affect my laptop (dell 640m) any more.
Running Ubuntu 10.4 and 10.10 my Laptop blanks and unblanks correctly when I close and open the Lid.

Victor Vargas (kamus) wrote :

Eric, any news about this issue? Please could you check if this behaviour is still affecting you under latest release included in Ubuntu Maverick? Thanks

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: linux (not installed)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-22.73-generic
Uname: Linux 2.6.31-22-generic i686
UserGroups: cdrom fuse sudo

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
summary: - Can't unblank certain laptops after closing and reopening the lid
+ Can't unblank Dell Inspiron 640m after closing and reopening the lid
tags: added: lucid needs-upstream-testing

Eric Appleman, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

no longer affects: acpid (Ubuntu)
no longer affects: gnome-power-manager (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers