No internal mic on LG R510 laptop (Intel HDA ICH9, ALC268)

Bug #495134 reported by claudio on 2009-12-10
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

I have already asked this as a question but I am now reporting it to be a bug, as I've tried several things to fix this myself.

I have tried upgrading to the last alsa version and also changing the model in the alsa-base.conf file. Since Karmic it is now not necessary to use de model option to hear sounds. Before Karmic, I was using model=toshiba.

Several models work for this particular sound card, but none of them recognises the microphone. When I say microphone I am talking about internal microhpone, plugging an external one works properly.

When I record sounds with Audacity (or any other software) I only hear noise (like "fffffff"), but I never hear my voice.

I provide here the alsa-info.sh output: http://www.alsa-project.org/db/?f=32ec89682bee5649c684198911df985a0fd281e9
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2765 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdb300000 irq 22'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:10ec0268,18541775,00100003 HDA:11c11040,18541775,00100200 HDA:10de0003,10de0101,00100000'
   Controls : 17
   Simple ctrls : 9
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Tags: lucid
Uname: Linux 2.6.32-16-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2794 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdb300000 irq 22'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:10ec0268,18541775,00100003 HDA:11c11040,18541775,00100200 HDA:10de0003,10de0101,00100000'
   Controls : 17
   Simple ctrls : 9
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Tags: lucid
Uname: Linux 2.6.32-16-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

buzonn (buzonn) wrote :

I'll attach more information on ubuntu 9.10.

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubu-odin 2055 F.... pulseaudio
 /dev/snd/pcmC0D0p: ubu-odin 2055 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd8800000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0268,18541773,00100003 HDA:11c11040,18541773,00100200 HDA:80862802,80860101,00100000'
   Controls : 21
   Simple ctrls : 12
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-driver (not installed)
ProcEnviron:
 SHELL=/bin/bash
 LANG=es_ES.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
Uname: Linux 2.6.31-17-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

buzonn (buzonn) wrote : BootDmesg.txt
tags: added: apport-collected
Brad Figg (brad-figg) wrote :

Hi claudio,

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 495134

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-test-current-image no-sound-mic
Changed in alsa-driver (Ubuntu):
status: New → Incomplete

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Simple mixer control 'Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 2
  Front Left: 0 [0%] <---
  Front Right: 0 [0%] <---

Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-16.50dB] [on] <---
  Front Right: Capture 0 [0%] [-16.50dB] [on] <---

Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 2
  Front Left: 0 [0%] <---
  Front Right: 0 [0%] <---

claudio (claudio-noguera) wrote :

Doesn't matter, when I raise it to 100% all I get is noise.

On Mon, Mar 29, 2010 at 3:53 PM, Daniel T Chen <email address hidden>wrote:

> Simple mixer control 'Mic Boost',0
> Capabilities: volume penum
> Playback channels: Front Left - Front Right
> Capture channels: Front Left - Front Right
> Limits: 0 - 2
> Front Left: 0 [0%] <---
> Front Right: 0 [0%] <---
>
>
> Simple mixer control 'Capture',0
> Capabilities: cvolume cswitch penum
> Capture channels: Front Left - Front Right
> Limits: Capture 0 - 31
> Front Left: Capture 0 [0%] [-16.50dB] [on] <---
> Front Right: Capture 0 [0%] [-16.50dB] [on] <---
>
>
> Simple mixer control 'Internal Mic Boost',0
> Capabilities: volume penum
> Playback channels: Front Left - Front Right
> Capture channels: Front Left - Front Right
> Limits: 0 - 2
> Front Left: 0 [0%] <---
> Front Right: 0 [0%] <---
>
> --
> No internal mic on LG R510 laptop (Intel HDA ICH9, ALC268)
> https://bugs.launchpad.net/bugs/495134
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Claudio

Brad Figg (brad-figg) on 2010-03-31
tags: added: lucid

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Brad Figg (brad-figg) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired

Hi. The bug is still here with us.

Brad Figg escribió:
> This bug report was marked as Incomplete and has not had any updated
> comments for quite some time. As a result this bug is being closed.
> Please reopen if this is still an issue in the current Ubuntu release
> http://www.ubuntu.com/getubuntu/download . Also, please be sure to
> provide any requested information that may have been missing. To reopen
> the bug, click on the current status under the Status column and change
> the status back to "New". Thanks.
>
> [This is an automated message. Apologies if it has reached you
> inappropriately; please just reply to this message indicating so.]
>
>
> ** Tags added: kj-expired
>
> ** Changed in: alsa-driver (Ubuntu)
> Status: Incomplete => Expired
>
>

Can you reproduce this symptom using linux-alsa-driver-modules-$(uname -r)
from ppa:ubuntu-audio-dev? If so, does adding the following line to
/etc/modprobe.d/alsa-base.conf (and rebooting) resolve the symptom?

options snd-hda-intel position_fix=1

On May 29, 2010 9:00 PM, "buzonn" <email address hidden> wrote:

Hi. The bug is still here with us.

Brad Figg escribió:

> This bug report was marked as Incomplete and has not had any updated
> comments for quite some tim...

I can't reopen the bug, i get an error. I get the same error if I try to
post in the web, I only can from my mail. I thought it was because of
the referer, but after check it I saw I have it in "send always mode".

Reopened.

This bug needs to be solved.

Changed in alsa-driver (Ubuntu):
status: Expired → New
status: New → Confirmed
David Henningsson (diwic) wrote :

I've been trying it with the latest upstream code, where it seems like it should work. No auto-switch though.
That is, try installing https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules , then reboot. You'll have to select what mic you have manually, e g in gnome-volume-control (try both "Microphone 1" and "Microphone 2") or alsamixer (Input source should be set to "Front mic" - the external mic is labeled just "Mic").

Report back whether it worked or not. Thanks!

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
David Henningsson (diwic) wrote :

@kbyo, thanks for testing, I'm a little surprised that it didn't work though. Can you attach an alsa-info according to https://wiki.ubuntu.com/Audio/AlsaInfo (with the latest drivers installed, according to comment #42), to see if that gives me a hint?

David Henningsson (diwic) wrote :

@kbyo, can you try model=auto, that is, in /etc/modprobe.d/alsa-base.conf, add this line:

options snd-hda-intel model=auto

Reboot, and see if it works? If it does, please also test whether everything else (speakers, headphones, external mic) works as expected. Thanks!

@David, it worked! But the sound level is quite low. When I change the level to 100% from No amplification the quality of the sound is very bad, but at least I can hear my voice!
Speakers, headphones and so on work correctly.

David Henningsson (diwic) wrote :

@kbyo: Do you know if the quality is what you would expect from an internal mic (many of those are not very good), or do you think something is still broken?

@David, the quality is not the better (there is a slight background sound/noise) but I think is enough. I have found a compromising solution between the quality and the sound level.
In Windows the quality is much better but the quality in Ubuntu is enough as I have said.

David Henningsson (diwic) wrote :
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed
Alejandro P. (pintadus) wrote :

Thanks a lot!!!!
Great!!
Finally Skype working!!!

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Steve Conklin (sconklin) wrote :

Due to national holidays, the deadline for verification of fixes for the -proposed kernel has been extended thru Monday, November 15th.

If verification that this bug is fixed by the -proposed kernel has not occurred by that date, the change will be reverted and this bug will be set to incomplete.

If you have tested the kernel in -proposed and found that it fixes the bug on the original hardware, please change the bug tag "verification-needed" to "verification-done".

The new stable kernel release process under which these actions are being taken is still being refined, and is documented here:

https://wiki.ubuntu.com/Kernel/StableReleaseCadence

Discussions about the new process tend to take place in #ubuntu-kernel on IRC, so please contribute to the discussion there if you would like.

Thank you!

buzonn (buzonn) wrote :

Oh, sorry, I didn't read that. I'm using now 9.10. I tried only the maverick livecd and I think It worked.

Brad Figg (brad-figg) wrote :

This patch was applied as a "pre-stable" patch. It has not come in via a stable upstream patchset so does not need to be re-verified.

tags: removed: verification-needed
Brad Figg (brad-figg) on 2010-11-15
tags: removed: kj-expired kj-triage needs-test-current-image
Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 2.6.35-23.40

---------------
linux (2.6.35-23.40) maverick-proposed; urgency=low

  [ Brad Figg ]

  * No change rebuild.

linux (2.6.35-23.39) maverick-proposed; urgency=low

  [ Brad Figg ]
    - LP: #676214

  [ Ricardo Salveti de Araujo ]

  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - LP: #663642

linux (2.6.35-23.38) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Revert "SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI
    on"

  [ Upstream Kernel Changes ]

  * Revert "(upstream) ALSA: hda - Apply ALC269 VAIO fix-up to all Sony
    laptops with ALC269"
  * Revert "ALSA: HDA: Correctly apply position_fix quirks for ATI and VIA
    controllers"
  * Buglink Fixup for reverted unverified fixes

linux (2.6.35-23.37) maverick-proposed; urgency=low

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

linux (2.6.35-23.36) maverick-proposed; urgency=low

  [ Andy Whitcroft ]

  * reduce disk usage during buildd builds
    - LP: #645653

  [ Brad Figg ]

  * ARM: Temporarily disable module check for armel

  [ Enric Balletbo i Serra ]

  * ARM: igepv2: Adding support for VBUS and overcurrent
    - LP: #651589
  * ARM: igepv2: Fix and improve LED handling
    - LP: #654582
  * ARM: igepv2: Introduce function to dectect HW version
    - LP: #654586
  * ARM: igepv2: Fix handling of GPIOs for WLAN-BT combo
    - LP: #654590
  * ARM: igepv2: Add i2c eeprom driver to read EDID
    - LP: #654594
  * ARM: igepv2: Remove VMMC2 regulator
    - LP: #654595

  [ Leann Ogasawara ]

  * ARM: Temporarily disable module check for armel

  [ Mathieu Poirier ]

  * SAUCE: ARM: Add DSS2 support for Overo board
    - LP: #660811

  [ Maurus Cuelenaere ]

  * SAUCE: ARM: OMAP3: Add S-Video output to IGEPv2 board
    - LP: #607250

  [ Ricardo Salveti de Araujo ]

  * [Config] Remove CONFIG_FIXED_PHY and move CONFIG_SMSC911X from m to y
    for omap
    - LP: #645689
  * SAUCE: ARM: OMAP3: Adding vdd_sdi regulator supply to IGEPv2 board
    - LP: #607250
  * SAUCE: ARM: OMAP3: beagle: use GPIO2 on the xM A3 to turn DVI on
    - See: #663642

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ALSA: HDA: Use model=auto for LG R510"
  * Revert "(pre-stable) ALSA: hda - Rename iMic to Int Mic on Lenovo
    NB0763"
  * Revert "Input: appletouch - fix integer overflow issue"
  * Revert "ALSA: hda - Handle pin NID 0x1a on ALC259/269"
  * Revert "ALSA: hda - Handle missing NID 0x1b on ALC259 codec"
  * Revert "(pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant
    5066, tested on HP G60"
  * Revert "mmc: build fix: mmc_pm_notify is only available with
    CONFIG_PM=y"
  * Revert "mmc: fix all hangs related to mmc/sd card insert/removal during
    suspend/resume"
  * Revert "(pre-stable) bounce: call flush_dcache_page() after
    bounce_copy_vec()"
  * Revert "Input: i8042 - reset keyboard controller wehen resuming from
    S2R"
  * Revert "ALSA: HDA: Enable internal speaker on Dell M101z"
  * Revert "(pre-stable) drm/i915: don't enable self-refresh on Ironlake"
  * Revert "drm/i915: Allow LVDS on pipe A on gen4+"
  * (pre-stable) ACPI: enable repeated...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.