UEC Lucid 20091209 image fails to boot on UEC

Bug #494611 reported by Thierry Carrez on 2009-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned

Bug Description

Trying to boot i386 UEC Lucid 20091209 image on UEC/Lucid, it fails to boot.
See console output below.
I did not test (yet) the amd64 image or a karmic image for good measure, so more coming tomorrow.

Thierry Carrez (ttx) wrote :
Thierry Carrez (ttx) wrote :

KVM cmdline on UEC/NC:

/usr/bin/kvm -S -M pc-0.11 -m 256 -smp 1 -name i-41E80826 -uuid 3cff1d81-0d14-931d-63f8-3b8cc60babe7 -nographic -monitor unix:/var/lib/libvirt/qemu/i-41E80826.monitor,server,nowait -boot c -kernel /var/lib/eucalyptus/instances/admin/i-41E80826/kernel -append root=/dev/sda1 console=ttyS0 -drive file=/var/lib/eucalyptus/instances/admin/i-41E80826/disk,if=scsi,index=0,boot=on -net nic,macaddr=d0:0d:41:e8:08:26,vlan=0,model=e1000,name=e1000.0 -net tap,fd=17,vlan=0,name=tap.0 -serial file:/var/lib/eucalyptus/instances/admin/i-41E80826/console.log -parallel none -usb

Andy Whitcroft (apw) on 2009-12-09
tags: added: kernel-series-unknown
Scott Moser (smoser) on 2009-12-09
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Scott Moser (smoser)
Scott Moser (smoser) wrote :

This is due to changes made for https://wiki.ubuntu.com/ServerLucidCloudKernelRamdisk . We had hoped to make UEC and EC2 instances not need a ramdisk. I thought I had tested that it was functional, but was unable to reproduce that now.

To fix this without ramdisk, bug 494565 will need to be fixed.

The ramdisk publishing was disabled with:
  http://bazaar.launchpad.net/%7Eubuntu-on-ec2/vmbuilder/automated-ec2-builds/revision/57

For now, I'll modify vmbuilder-uec-ec2-fixes so that only '-ec2' ramdisk is removed.

Scott Moser (smoser) wrote :

build 20091209.1 is running now. I've verified that the ramdisk will be published for -virtual, and verified that the following boots (given a working 'disk.img' disk with root filesystem on first partition):

kvm -drive file=disk.img,if=scsi
  -kernel /tmp/lucid-uec-i386-vmlinuz-virtual
  -initrd /tmp/lucid-uec-i386-initrd-virtual
  -append single root=/dev/sda1

So, If the build goes correctly, I expect that this will be fixed.

Scott Moser (smoser) wrote :

http://uec-images.ubuntu.com/lucid/20091209.1/ is up now.
verified that there are ramdisks in the tarballs:

$ tar -tvzf lucid-uec-i386.tar.gz
-rw-r--r-- vmbuilder/vmbuilder 2147483648 2009-12-09 18:45 lucid-uec-i386.img
-rw-r--r-- vmbuilder/vmbuilder 3726800 2009-12-09 18:45 lucid-uec-i386-initrd-virtual
-rw-r--r-- vmbuilder/vmbuilder 4021376 2009-12-09 18:45 lucid-uec-i386-vmlinuz-virtual

Changed in linux (Ubuntu):
assignee: Scott Moser (smoser) → nobody
status: Triaged → Fix Released
Scott Moser (smoser) wrote :

Thierry,
  I've verified that the 20091209.1 i386 image boots in my karmic eucalyptus.
  I did have a problem running in in the my 'm1.small' would terminate immediately. The karmic i386 runs fine in m1.small , both are 2G disk images. I don't even believe it was starting the vm before terminating.

   Please verify that the image boots for you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers