Ubuntu

Kernel panic is reached while toggling wifi off using Fn+F2 keys (rfkill) in Realtek's 8187SE wireless card [10ec:8199]

Reported by Wilford Argandoña on 2009-12-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

DESCRIPTION:

I have a netbook with the Realtek's 8187SE wireless card, I got a kernel panic while disabling the wifi using the Fn+F2 keys. No problems while turning on the wifi.

The "uname -a" output is:

Linux jalasoft-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Note that the problem looks very similar to the reported issue with the rt2860 card (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/404626), I tried with the fix provided on that thread but no luck.

REQUIREMENTS

- Make sure that you have a Ubuntu 9.10 karmic Koala (kernel 2.6.31-14) installed and
- Realtek's 8187SE wireless card.
- Machine must be on, with wireless enabled before starting the test.
- This test can be made using graphical mode, or console mode

 STEPS

1. Verify that the wifi is enabled; the wifi led should be on
2. Disable the wifi by using the Fn+F2 Keys
3. Verify the OS is available for working with it

ACTUAL RESULTS

While using the graphical mode, the OS hangs and displays a black background screen.
If using the console mode, a kernel panic message is displayed

EXPECTED RESULTS

Wireless must be turned off without problems in the OS (OS must be available for interacting with)

Wilford Argandoña (wilford) wrote :
Wilford Argandoña (wilford) wrote :
Wilford Argandoña (wilford) wrote :
Wilford Argandoña (wilford) wrote :
Andy Whitcroft (apw) on 2009-12-09
tags: added: kernel-series-unknown
Andy Whitcroft (apw) on 2009-12-09
tags: added: karmic
removed: kernel-series-unknown
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Pablo (azeropr) wrote :

I also have a have a netbook (it's a CW001 from FIC - http://www.fic.com.tw/product/cw001.aspx) with the Realtek's 8187SE card, with the same problems reported by Wilford. The thing is that I could run 9.04 with a patch (attached source code and compiled kernel) that I got from the vendor and the following instructions:

1. Modify kernel config file:
     $> sudo dpkg -i linux-image-2.6.28-11-generic_2.6.28-11.42_i386.deb
   This instruction modifies /boot/grub/menu.lst which you need to change later.
2. Modify /etc/modules:
     Add line “pciehp pciehp_force=1” and line "rfkill_input" at end of file.
3. Modify /etc/modprobe.d/blacklist.conf
     Add “blacklist rtl8187se” at end of file
4. Install wifi modules from source code:
     In source directory:
           $> make
           $> sudo make install
5. Add acpi_osi parameter in file /boot/grub/menu.lst:
     kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=e35bc47f-035e-46c9-9bd8-b4ac5c632d02 ro acpi_osi=Linux quiet splash
6. Reboot:
     $> sudo reboot

It looks like it is possible to install this patch in a ubuntu machine with kernel previous to 2.6.30. I tried with kernel 2.6.31 but got a lot of compilation errors. So there were some important changes in the current kernel version used by karmic. I’ll keep on trying but a piece of advice and technical information about the changes needed would be of help.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers