Ubuntu

[Lenovo SL300] suspend hangs system with any 2.6.32 kernel

Reported by Gary Trakhman on 2009-12-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Karmic worked fine, since I've started testing lucid, I've had problems with 2.6.32. First suspend is usually ok. Second will hang the laptop and requires hard reboot. I've tried the ubuntu linux-image-generic, and zen-kernel as well through multiple rc's of 2.6.32 hoping it would get fixed. With zen-kernel, tuxonice would have the same problems in 2.6.32. Currently running stock linux-image-generic.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gary 23963 F.... pulseaudio
 /dev/snd/pcmC0D0p: gary 23963 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfd8f4000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:14f15051,17aa2106,00100000 HDA:80862802,80860101,00100000'
   Controls : 18
   Simple ctrls : 8
Date: Fri Dec 4 19:36:48 2009
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=a3262b51-d1b4-4034-a925-2adc821552f7
MachineType: LENOVO 2738CTO
Package: linux-image-2.6.32-6-generic 2.6.32-6.8
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-6-generic root=UUID=19501820-c156-4621-aa99-604f60c279f2 ro quiet splash acpi_backlight=vendor elevator=deadline resume=swap:/dev/sda6
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.27
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Tags: lucid needs-upstream-testing regression-release
TestedUpstream: No
Uname: Linux 2.6.32-6-generic x86_64
dmi.bios.date: 08/26/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6AET59WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 2738CTO
dmi.board.vendor: LENOVO
dmi.board.version: LENOVO 6AET59WW
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: LENOVO 6AET59WW
dmi.modalias: dmi:bvnLENOVO:bvr6AET59WW:bd08/26/2009:svnLENOVO:pn2738CTO:pvrThinkPadSL300:rvnLENOVO:rn2738CTO:rvrLENOVO6AET59WW:cvnLENOVO:ct10:cvrLENOVO6AET59WW:
dmi.product.name: 2738CTO
dmi.product.version: ThinkPad SL300
dmi.sys.vendor: LENOVO

Gary Trakhman (gary-trakhman) wrote :
Gary Trakhman (gary-trakhman) wrote :

I'm a somewhat advanced user, I will try and test it more within two weeks. Any suggestions as to the best way for me to proceed to help get this fixed?

Gary Trakhman (gary-trakhman) wrote :

2.6.32-7 released, still hangs on second suspend. 2.6.31-14 works great. This may be specific to SL series lenovo? Kernel folks have made a lot of changes to suspend code in 2.6.32.

summary: - suspend hangs system with any 2.6.32 kernel
+ [Lenovo SL300] suspend hangs system with any 2.6.32 kernel

Hi Gary,

Might be helpful to confirm with the latest upstream 2.6.32 mainline kernel build just to confirm the issue exists upstream as well and is not an Ubuntu specific regression that was introduced. http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32/ . If the issue does remain with the upstream vanilla kernel, it'd be good to also open an upstream bug report at bugzilla.kernel.org so that the upstream developers are also notified. If you post the link to the upstream bug report here we can set up an upstream bug watch from this report. Thanks.

tags: added: regression-potential
removed: regression-release
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Thanks, will do.

On Mon, Dec 7, 2009 at 9:16 PM, Leann Ogasawara
<email address hidden> wrote:
> Hi Gary,
>
> Might be helpful to confirm with the latest upstream 2.6.32 mainline
> kernel build just to confirm the issue exists upstream as well and is
> not an Ubuntu specific regression that was introduced.
> http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32/ .  If the issue
> does remain with the upstream vanilla kernel, it'd be good to also open
> an upstream bug report at bugzilla.kernel.org so that the upstream
> developers are also notified.  If you post the link to the upstream bug
> report here we can set up an upstream bug watch from this report.
> Thanks.
>
> ** Tags added: regression-potential
> ** Tags removed: regression-release
>
> ** Changed in: linux (Ubuntu)
>   Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
>       Status: New => Triaged
>
> --
> [Lenovo SL300] suspend hangs system with any 2.6.32 kernel
> https://bugs.launchpad.net/bugs/492684
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Gary Trakhman (gary-trakhman) wrote :

Yes, it hangs with 020632-generic mainline kernel, and is fine with 2.6.31-ubuntu14. Oddly enough, it works fine while at the GDM prompt. It is only after gnome login that it will hang. I considered a compiz issue, disabled it, no effect.

tags: added: resume suspend
phedders (paul+ubuntu) wrote :

Same issue (still) with an IBM/Lenovo X60t.

Seems to be related to the wireless drivers - if I remove them before suspend everything is ok.

wireless is iwl3945

Linux tapz 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux

ii linux-image-2.6.32-14-generic 2.6.32-14.20 Linux kernel image for version 2.6.32 on x86/x86_64

2.6.31 works fine.

Gary Trakhman (gary-trakhman) wrote :

I've got atheros with ath5k

On Tue, Mar 2, 2010 at 4:58 PM, phedders <email address hidden> wrote:
> Same issue (still) with an IBM/Lenovo X60t.
>
> Seems to be related to the wireless drivers - if I remove them before
> suspend everything is ok.
>
> wireless is iwl3945
>
> Linux tapz 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009
> i686 GNU/Linux
>
> ii  linux-image-2.6.32-14-generic                     2.6.32-14.20
> Linux kernel image for version 2.6.32 on x86/x86_64
>
> 2.6.31 works fine.
>
> --
> [Lenovo SL300] suspend hangs system with any 2.6.32 kernel
> https://bugs.launchpad.net/bugs/492684
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chase Douglas (chasedouglas) wrote :

@phedders:

Your issue seems to be different from Gary's. Please open a new bug for it.

Thanks

Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Fix Released
Changed in linux:
importance: Unknown → Medium
tags: removed: regression-potential

Gary Trakhman, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.