Ubuntu

Ubuntu 9.10 does not detect HP LaserJet 1020 on cold-plugging

Reported by Andre Luis da Silva on 2009-12-01
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
udev (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: cups

See comment #5: The HP LaserJet 1020 is not detected on cold-plugging (booting the system with the printer connected and turned on) while on hot-plugging (connect or turn on the printer after system boot has completed) the printer is recognized perfectly. As the printer is not visible with "lsusb" when cold-plugged, the problem is not of CUPS or HPLIP but of the kernel or perhaps UDEV. An additional problem especially for the HP LaserJet 1020 is also that the printer's firmware does not get loaded into the printer during system boot.

Original bug report:

I have an HP 1020 printer.
I have successfully used it with Ubuntu 7.04 to 9.04. In these cases, I have used the package foo2zjs.
However, after upgrade to Ubuntu 9.10, the package foo2zjs do not work anymore. I tried to install it again, but I have no success.
In a trial and error approach, I deleted the printer using the cups graphical user interface (system-config-printer 1.1.12) and installed foo2zjs again. But this make make the problem worst. After this, system-config-printer 1.1.12 can not find the printer anymore, while lsusb does.
I then installed hplip. But this package still do not find the printer.
In all the cases, if a boot the system with the printer connected and turned on, the boot process crashes with the following message:
usb 5-2: device descriptor read/8, error -110
I already read similar bug reports here. But no one helped me.
Thanks in advance

This BUG is NOT a duplicate of bug #489750. In fact, the HPLIP and CUPS do not find any printer in my system. Bu the printer is connected to the USB port and it is found by lsub. This happened after I delete the printer in the CUPS interface, trying to reset it.

When I try to create a new printer, I get the error: CUPS server error "client-error-not-possible"

When I try to create a new printer, I get the error: CUPS error "client-error-not-possible"

I discovered the reason why the CUPS and HPLIP do not find the printer. This happens because, in the system boot, the printer, by a reason that I don't know, is not recognized in the usb port. So, CUPS is started, in the system boot, with the printer not connect, in way that nor CUPS nor HPLIP can find it. However, when I restart the printer, after the boot, it appears in the lsusb command. After this, I restart the cups and the printer can be found. After found, I reinstalled its driver, via the HPLIP software, so the printer goes to run. I prints a test page without problems.

summary: - HPLIP and CUPS do not find HP 1020 printer in Ubuntu 9.10
+ Ubuntu 9.10 does not detect HP LaserJet 1020 on cold-plugging
description: updated
affects: cups (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in udev (Ubuntu):
status: New → Triaged
importance: Undecided → High

Perfect Till, this is the correct description.

mutineer612 (mutineer612) wrote :

After a recent upgrade from 9.04 to 9.10 I am experiencing this same problem. In my situation when restarting the printer after a reboot the lsusb displays the printer, but I've tried restarting cups and the printer is not detected. I've also tried manually specifying the bus and device id from the lsusb output in the hp-setup command with no luck.

Jeremy Foshee (jeremyfoshee) wrote :

Andre,

Jeremy Foshee (jeremyfoshee) wrote :

Have you checked this against the latest Lucid Beta? I know that there have been some changes in the way we handle things for printers between the releases, so I'd be interested in what the results of your testing are. This will help us bisect what changed and will allow us to focus on why the change created the new behavior.

Thanks!

~JFo

Martin Pitt (pitti) wrote :

If it's not in lsusb at coldplug, then this isn't an udev bug. Keeping the Linux task.

Changed in udev (Ubuntu):
status: Triaged → Invalid

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers