Kernel upgrade does not update initrd.lz on a live usb

Bug #489736 reported by Daniel Rangel on 2009-11-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-generic

when you update your system and upgrade the kernel image a new initrd.gz file is made but not a new initrd.lz on the casper folder

Related branches

tags: added: kernel live upgrade usb
Andy Whitcroft (apw) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and tag it kj-linux-meta, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
tags: added: kernel-series-unknown

Hi Daniel,

Please, can you comment whether this is still an issue for you?

If so, please, could you run the following command from a
Terminal (Applications->Accessories->Terminal) while running Karmic. It
will automatically gather and attach updated debug information to this
report.

apport-collect -p linux 489736

Thanks in advance

Changed in linux (Ubuntu):
status: New → Incomplete
Haggai Eran (haggai-eran) wrote :

I believe I have also encountered this bug.
I tried upgrading the kernel in a Live USB based on Lucid Alpha 3 version (64bit). The upgrade was completed sucessfully, but indeed didn't update the initrd.lz file.
After booting, I get the following error:
> Coud not find /lib/modules/2.6.32-15-generic/modules.dep
Followed by:
> Unable to find a medium containing a live filesystem.

Haggai

Colin Watson (cjwatson) wrote :

This is a bug in casper, not linux.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.230

---------------
casper (1.230) lucid; urgency=low

  * Don't save the hardware clock on live CD reboot; we used to do this in
    the sysvinit world, but it regressed when we switched to Upstart
    (thanks, Norm Pierce; LP: #436535).
  * When running update-initramfs on writable media, update initrd.lz rather
    than initrd.gz if it's present, and make the update process a bit safer
    while we're there (LP: #489736).
  * Handle toram and todisk=DEVICE options on command line (LP: #526305).
  * Policy version 3.8.4: no changes required.
  * Convert to source format 3.0 (native).
 -- Colin Watson <email address hidden> Tue, 30 Mar 2010 11:41:24 +0100

Changed in casper (Ubuntu):
status: New → Fix Released
FiX (fix-kowalski) wrote :

I have the same error message using install from scratch (official Lucid, not one of the alpha or the beta) on an HP 8730w mobile workstation (x86_64). I get the initial boot screen (select language & boot options), then after a while, I get something like (sorry, probably not the exact error message):

(initramfs) Unable to find a live filesystem image

I get this error message both booting from the CD-ROM or from the SD-card reader. No way I can reinstall the system from scratch.

This is a regression from previous alpha/beta/rc: My system was previously installed using an ISO image from those previews. I was willing to re-install from scratch using the clean published version, but this does not seem to work.

Anything else I can provide to fix this, please let me know. Finally, please not that I am not sure this is exactly the same bug.. the message is pretty short.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers