Module acer-wmi causes suspend problems on Acer Aspire 1410

Bug #489449 reported by RabidNelson
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: module-init-tools

Description: Ubuntu 9.10
Release: 9.10

module-init-tools:
  Installed: 3.10-3
  Candidate: 3.10-3
  Version table:
 *** 3.10-3 0
        500 http://jp.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

linux-image-2.6.31-14-generic:
  Installed: 2.6.31-14.48
  Candidate: 2.6.31-14.48
  Version table:
 *** 2.6.31-14.48 0
        500 http://jp.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

On my new Acer Aspire 1410-Kk22 that I bought in Japan, suspending was not working. When I tried to come back from suspend, the wireless, keyboard, and a number of other things would become unresponsive. I could still open new programs with my mouse, but even shutting down would fail. Once I added "blacklist acer-wmi" to "/etc/modprobe.d/blacklist.conf", all my problems were solved. Please make this the default configuration to this kind of laptop. Thank you.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 20eef74aec0ff2390508665e3c9d3964
CheckboxSystem: c69722ecac764861be52925fa50b4dcc
Date: Sat Nov 28 12:29:55 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: module-init-tools 3.10-3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: module-init-tools
Uname: Linux 2.6.31-15-generic x86_64

Revision history for this message
RabidNelson (ourfateisninja) wrote :
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Sounds more like we should fix the driver rather than blacklist it for everyone

affects: module-init-tools (Ubuntu) → linux (Ubuntu)
Andy Whitcroft (apw)
tags: added: kernel-karmic
Revision history for this message
Sergey Demurin (kakty3) wrote :

Yes, I have the same problems with wi-fi on my Acer Aspire 1410. Also, after awakeing, terminal doesn't work(not gnome-terminal, not terminator, not tilda, not xterm).

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Hi RabidNelson,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Brad Figg (brad-figg) wrote : Unsupported series, setting status to "Won't Fix".

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers