Suspend/resume with nvidia driver fails

Bug #488720 reported by demoneivo
228
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
Mactel Support
Invalid
Undecided
Unassigned
pm-utils
Fix Released
High
linux (Ubuntu)
Invalid
Low
Unassigned
Lucid
Invalid
Low
Unassigned
pm-utils (Ubuntu)
Fix Released
Medium
Martin Pitt
Lucid
Fix Released
Medium
Martin Pitt

Bug Description

Linux Kernel 2.6.32-5 completely fails to resume in my Macbook 5.1
I am reporting this bug, because with previous version of this kernel (2.6.32-*), resume was long and sometimes machine went back to suspend but it always succed in resuming.
Now, it is impossible to resume because the screen stays black and I am oblige to force the shutdown with the power button
I am on:
Ubuntu lucid (development branch)
10.04

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: demoneivo 1968 F.... pulseaudio
CRDA: Error: [Errno 2] Nessun file o directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xd3380000 irq 16'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b3f00,00100103'
   Controls : 36
   Simple ctrls : 20
Date: Thu Nov 26 12:50:26 2009
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=cc355bac-f00f-457c-99b0-4ddbb235f90e
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Apple Inc. MacBook5,1
NonfreeKernelModules: wl nvidia
Package: linux-image-2.6.32-5-generic 2.6.32-5.6
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-generic root=UUID=2a913905-8671-4792-b1a6-c335d9cb798d ro quiet splash
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-5.6-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.25
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Tags: regression-potential
TestedUpstream: Yes
Uname: Linux 2.6.32-5-generic x86_64
dmi.bios.date: 10/29/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB51.88Z.0073.B06.0810291326
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.0073.B06.0810291326:bd10/29/08:svnAppleInc.:pnMacBook5,1:pvr1.0:rvnAppleInc.:rnMac-F42D89C8:rvrProto:cvnAppleInc.:ct10:cvrMac-F42D89C8:
dmi.product.name: MacBook5,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Revision history for this message
demoneivo (ivano-banfi) wrote :
Changed in linux (Ubuntu):
status: New → Confirmed
demoneivo (ivano-banfi)
summary: - Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1
+ REGRESSION-POTENTIAL: Linux Kernel 2.6.32-5 completely fails to resume
+ on Macbook 5.1
demoneivo (ivano-banfi)
Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Kernel Team (ubuntu-kernel-team)
Andy Whitcroft (apw)
summary: - REGRESSION-POTENTIAL: Linux Kernel 2.6.32-5 completely fails to resume
- on Macbook 5.1
+ Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1
Andy Whitcroft (apw)
tags: added: kernel-lucid
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
importance: Undecided → Low
Revision history for this message
In , Michael Evans (mjevans1983) wrote :

Created an attachment (id=31817)
Do not set quirk-no-chvt for nvidia cards

After finally tracking down that KDE4 uses pm-utils instead of allowing the end user to select a suspend/resume method I began to investigate why suspend/resume failed to resume with a working X session.

It turned out that commenting out a single line in the nvidia section of pm/sleep.d/98smart-kernel-video solved my issues. Dropping the chvt causes my X session to resume with garbled garbage.

01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GT] (rev a1)
01:00.0 0300: 10de:0391 (rev a1) (prog-if 00 [VGA controller])
        Subsystem: 1682:2220
Nvidia driver 190.42
Xorg server 1.7.2-2
pm-utils 1.2.6.1-1

Revision history for this message
In , Michael Evans (mjevans1983) wrote :

504faf0a0c31cbdbc03a608cf633d58f12e49eb7 is the first bad commit
commit 504faf0a0c31cbdbc03a608cf633d58f12e49eb7
Author: Victor Lowther <email address hidden>
Date: Sat Nov 7 23:21:45 2009 -0600

    Make kernel modesetting detection a little smarter.

    It turns out that the method we were using to detect kernel modesetting
    support was not very accurate. It turns out there is no bulletproof way
    for us to tell if KMS is being used, but Michael Biebl found a way that
    sucks less than out current method. Hopefully the framebuffer drivers
    will grow a flag in sysfs somewhere that tells us that KMS is in use.

:040000 040000 0489d094c01a7d2fa9cc8c45abaea22211062667 9a4a74d5e9b6eafae8305259ddfdc138f6a1fa0e M pm
bisect run success

tags: added: lucid
removed: kernel-lucid
Revision history for this message
In , vlowther (victor-lowther) wrote :

Interesting -- has this always happened, or did it start happening fairly recently? I have been skipping the chvt for nvidia drivers on my test system for somewhere around 6 months -- IIRC nvidia driver 180 and below have always worked for me.

Revision history for this message
In , Michael Evans (mjevans1983) wrote :

I always used chvt. Only recently when I did a system upgrade things broke. Most likely when the early November commit changed the default behavior and made it downstream is when things really broke.

I do use a suspend/resume progress indicator, which could be the reason I -require- chvt, but the point still stands; this is a change in default behavior that broke my system.

Really, there should be a separate control for chvt or not which is easier to configure than an absolute deep in some distribution file.

Revision history for this message
In , vlowther (victor-lowther) wrote :

(In reply to comment #3)
> I always used chvt. Only recently when I did a system upgrade things broke.
> Most likely when the early November commit changed the default behavior and
> made it downstream is when things really broke.
>
> I do use a suspend/resume progress indicator, which could be the reason I
> -require- chvt, but the point still stands; this is a change in default
> behavior that broke my system.

Which progress indicator do you use?

> Really, there should be a separate control for chvt or not which is easier to
> configure than an absolute deep in some distribution file.

Revision history for this message
Colin D Bennett (colinb) wrote : Re: Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1

The problems demoneivo reports from Karmic sound really similar the problems I experience on my MacBook since I upgraded to Karmic from Jaunty. Suspend/resume on Jaunty worked perfectly, but since upgrading (full reinstall from scratch) to Karmic the system takes a variable amount of time to resume when the lid is opened (from about 4 seconds to about 30 seconds before even the text mode blinking cursor appears, then within a second or so, the X desktop is shown). But worse, my wireless card stops working after a resume from suspend mode. It simply doesn't see my wireless network, or just can't connect (I'm not sure which). I have to reboot to get my wireless working again. Wired ethernet works fine. Occasionally (perhaps 5% of the time) the wireless actually does work after resume.

Can anyone refer me to a more appropriate bug for my problem? I want to do whatever I can to help get this fixed in Lucid at least... it is *really* frustrating that suspend/resume works fine in Jaunty but has regressed in Karmic, and according to demoneivo has regressed even more in Lucid! This is terrrible.

Revision history for this message
In , Michael Evans (mjevans1983) wrote :
Revision history for this message
Chase Douglas (chasedouglas) wrote : Re: Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1

I have a Karmic installation on a Macbook 5,1. I've seen the variable resumes along with resumes that immediately go back into suspend.

I have also verified that I cannot resume from suspend in Lucid. When I try to resume the display fails to come up at all.

I tried installing the Lucid kernel on my Karmic installation. Resumes worked just as well as when using the Karmic kernel. This leads me to believe this is a Lucid userspace issue. I also saw the following in /var/log/messages when resuming in Lucid:

gnome-screensav[4376]: segfault at 0 ip 00007f6de7962210 sp 00007fff1ec2eae0 error 4 in libGL.so.190.53[7f6de78cb000+a5000]

My guess is that gnome-screensaver is crashing on resume, and that's the underlying issue.

Note: I'm currently using the nvidia graphics driver (not nv, nor nouveau).

Revision history for this message
Chase Douglas (chasedouglas) wrote :

As a follow up, I've done more testing and found that X isn't related to this issue at all. I have recreated the issue from a virtual terminal without X being started at all. I have also recreated without the nvidia or nv modules loaded. I have sent an email to the linux-pm mailing list to see if they have any advice.

Changed in linux (Ubuntu):
assignee: Ubuntu Kernel Team (ubuntu-kernel-team) → Chase Douglas (chasedouglas)
status: Confirmed → Triaged
tags: added: resume suspend
Revision history for this message
In , Chase Douglas (chasedouglas) wrote :

I can confirm that this change fixes my Macbook (5,1) resuming on Ubuntu Lucid. The graphics card is a GeForce 9400M.

Revision history for this message
In , Chase Douglas (chasedouglas) wrote :

Created an attachment (id=33224)
Patch against current git sources

I've attached a new patch that can be applied directly to the latest git sources for pm-utils.

Revision history for this message
Chase Douglas (chasedouglas) wrote : Re: Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1

I just tried a new install of Lucid and resume almost started to work perfectly again with the nvidia drivers. There's a regression in pm-utils that forces me to manually switch vts to get X back, but the patch from https://bugs.freedesktop.org/show_bug.cgi?id=25488 fixes it.

Changed in pm-utils (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Martin Pitt,

Can you take a look at fixing this?

Changed in linux (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
status: Triaged → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

I subscribed to the upstream bug, and will pull the patch once it's got accepted.

Changed in pm-utils (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Christian Schürer-Waldheim (quincunx) wrote :

N.B.: The fix solved the problem on my computer. Thanks!

Revision history for this message
In , Martin Pitt (pitti) wrote :

In the downstream bug (https://launchpad.net/bugs/488720) we got several more confirmations that this fixes suspend/resume with nvidia.

Revision history for this message
Noel J. Bergman (noeljb) wrote : Re: Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1

The fix resolved my issue, as well. I've marked my bug as a duplicate of this one.

Revision history for this message
Anton Eliasson (eliasson) wrote :

Is this file (98smart-kernel-video) supposed to be in /etc/pm/sleep.d? In that case I don't have it, possibly because I'm currently running the free nv driver?

Changed in pm-utils:
status: Unknown → In Progress
Martin Pitt (pitti)
Changed in pm-utils (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
summary: - Linux Kernel 2.6.32-5 completely fails to resume on Macbook 5.1
+ Suspend/resume with nvidia driver fails
Revision history for this message
Per Ångström (autark) wrote :

> Is this file (98smart-kernel-video) supposed to be in /etc/pm/sleep.d?
I think it is supposed to be in /usr/lib/pm-utils/sleep.d , correct me if I'm wrong.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Anton Eliasson:

The file is supposed to be at /usr/lib/pm-utils/sleep.d/98smart-kernel-video. It will not depend on the driver you are using. However, the fix only works for those running the nvidia driver. If you are using the -vesa driver you will not be able to suspend and resume because that driver doesn't support it (at least for nvidia cards, don't know about others). I don't know if you can suspend and resume if you are using the -nv driver, but if not this fix will not help.

Changed in linux:
status: New → Fix Released
Changed in mactel-support:
status: New → Invalid
Revision history for this message
Ryan Daly (daly-ctcnet) wrote :

Is this fix supposed to have been released in Karmic? I'm seeing issues with resuming from a suspend. It seems that things wake up, but my X display never wakes up and instead shows me vertical lines that eventually change to white. I cannot change to a vt, either. My version of pm-utils is below. Please let me know what I can do to help troubleshoot.

: riddler 6#; dpkg -l pm-utils
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=====================================-=====================================-==========================================================================================
ii pm-utils 1.2.5-2ubuntu7 utilities and scripts for power management

Thanks.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Ryan,

The fix mentioned here for pm-utils in Lucid is a regression from Karmic. The error does not exist in the Karmic pm-utils package. If you are having issues under Karmic you should open a new bug for it.

Thanks

Revision history for this message
Ryan Daly (daly-ctcnet) wrote :

Thanks, Chase.

Just opened bug 522472.

Revision history for this message
David Planella (dpm) wrote :

Applying the patch to /usr/lib/pm-utils/sleep.d/98-video-quirk-db-handler did indeed fix the problem I reported as a duplicate.

Thanks!

Revision history for this message
Noel J. Bergman (noeljb) wrote :

It appears to be broken again in Lucid after last night's nvidia-current switch from 190 to 195. I'm reverting to 190.53 from http://us.archive.ubuntu.com/ubuntu/pool/restricted/n/nvidia-graphics-drivers to try to verify whether that is the exact cause.

Revision history for this message
Christian Schürer-Waldheim (quincunx) wrote :

Noel, recent updates of nvidia did not make this bug come back on my computer.

Revision history for this message
David Planella (dpm) wrote :

I can confirm Noel's comment. Recent updates seem to have brought the bug back (i.e. inability to resume from suspend), even with a patched /usr/lib/pm-utils/sleep.d/98-video-quirk-db-handler file.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

David, if you reinstall 190.53 does suspend/resume work for you again? It does for me.

Revision history for this message
owen.c (owen-c93) wrote :

I get this bug but I can get back into my desktop after typing and squiggling my mouse, however now I have nnumerous graphic glitches. Is this the same bug or a different one.?

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@owen.c:

I think your issue may be related to bug 510004. Unfortunately, a fix hasn't been found for it yet.

Revision history for this message
Christian Schürer-Waldheim (quincunx) wrote :

The problem with the faulty quirks (the line "--quirk-no-chvt" for nvidia cards should be removed) is not fixed in 1.3.0~rc3-2. The line is still there, causing my system to hang after resume again. Please don't forget to remove it, thanks!

Revision history for this message
Markus Kolb (mkolb) wrote :

Ok, commenting out the line works for me at the problem after resume from suspend to disk.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pm-utils - 1.3.0~rc3-2git1

---------------
pm-utils (1.3.0~rc3-2git1) lucid; urgency=low

  Upload current Debian packaging git head.

  * Add 11_nvidia_suspend.patch: Re-enable chvt quirk for nvidia driver, to
    repair suspend with the current driver versions. (LP: #488720)
 -- Martin Pitt <email address hidden> Thu, 04 Mar 2010 15:57:01 +0100

Changed in pm-utils (Ubuntu Lucid):
status: Triaged → Fix Released
Revision history for this message
Per Ångström (autark) wrote :

I see no change, no improvement, after updating to the fixed version: after resume, I only see a blinking text-mode cursor. This is what I have to do get back to a graphics display:

1) Switch to tty1.
2) Switch to tty8.
3) Wait some 15 seconds until the graphics display comes to life.
4) If the display is all black, repeat steps 1 and 2.

Revision history for this message
Per Ångström (autark) wrote :

Upgrading to kernel 2.6.33-020633-generic solves this issue for me.

Revision history for this message
David Planella (dpm) wrote :

In my case, the fix in pm-utils seemed to work for a while, until the upgrade to the 195 driver.

After that, I get one of the two situations whenever I suspend and try to resume:

a) After pressing the power button to resume, the screen is powered, but remains blank, there is disk activity. I then need to do a hard shutdown by keeping the power button pressed. I cannot switcht to any tty

b) After pressing the power button to resume, the screen comes back, but I get to see only the GDM background without login dialog. The mouse seems to work, but there is nothing I can do to come bac to my session. If I try to switch to a tty, I can never go back to the graphical session.

I'm wondering what other people's experiences are, as in my case, the bug seems not fixed (either in the kernel or in the driver)

Revision history for this message
Alex Murray (alexmurray) wrote : Re: [Mactel-support] [Bug 488720] Re: Suspend/resume with nvidia driver fails
Download full text (3.6 KiB)

@Per - The latest update to pm-utils did not fix this for me either,
and instead when resuming from suspend X crashes (I assume) since I
hear the gdm login sound but the screen remains black although
backlight is on. At this point I have to reboot. Will try 2.6.33 and
see if this helps. Cheers

On 5 March 2010 21:05, Per Ångström <email address hidden> wrote:
> Upgrading to kernel 2.6.33-020633-generic solves this issue for me.
>
> --
> Suspend/resume with nvidia driver fails
> https://bugs.launchpad.net/bugs/488720
> You received this bug notification because you are a member of Mactel
> Support, which is the registrant for Mactel Support.
>
> Status in The Linux Kernel: Fix Released
> Status in Mactel Support: Invalid
> Status in pm-utils: In Progress
> Status in “linux” package in Ubuntu: Fix Released
> Status in “pm-utils” package in Ubuntu: Fix Released
> Status in “linux” source package in Lucid: Fix Released
> Status in “pm-utils” source package in Lucid: Fix Released
>
> Bug description:
> Linux Kernel 2.6.32-5 completely fails to resume in my Macbook 5.1
> I am reporting this bug, because with previous version of this kernel (2.6.32-*), resume was long and sometimes machine went back to suspend but it always succed in resuming.
> Now, it is impossible to resume because the screen stays black and I am oblige to force the shutdown with the power button
> I am on:
> Ubuntu lucid (development branch)
> 10.04
>
> ProblemType: Bug
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Architecture: amd64
> AudioDevicesInUse:
>  USER        PID ACCESS COMMAND
>  /dev/snd/controlC0:  demoneivo   1968 F.... pulseaudio
> CRDA: Error: [Errno 2] Nessun file o directory
> Card0.Amixer.info:
>  Card hw:0 'NVidia'/'HDA NVidia at 0xd3380000 irq 16'
>   Mixer name   : 'Realtek ALC889A'
>   Components   : 'HDA:10ec0885,106b3f00,00100103'
>   Controls      : 36
>   Simple ctrls  : 20
> Date: Thu Nov 26 12:50:26 2009
> DistroRelease: Ubuntu 10.04
> HibernationDevice: RESUME=UUID=cc355bac-f00f-457c-99b0-4ddbb235f90e
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
> MachineType: Apple Inc. MacBook5,1
> NonfreeKernelModules: wl nvidia
> Package: linux-image-2.6.32-5-generic 2.6.32-5.6
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-generic root=UUID=2a913905-8671-4792-b1a6-c335d9cb798d ro quiet splash
> ProcEnviron:
>  LANG=it_IT.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-5.6-generic
> Regression: Yes
> RelatedPackageVersions: linux-firmware 1.25
> Reproducible: Yes
> RfKill:
>  0: hci0: Bluetooth
>        Soft blocked: no
>        Hard blocked: no
> SourcePackage: linux
> Tags:  regression-potential
> TestedUpstream: Yes
> Uname: Linux 2.6.32-5-generic x86_64
> dmi.bios.date: 10/29/08
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MB51.88Z.0073.B06.0810291326
> dmi.board.asset.tag: Base Board Asset Tag#
> dmi.board.name: Mac-F42D89C8
> dmi.board.vendor: Apple Inc.
> dmi.board.version: Proto
> dmi.chassis.asset.tag: Asset Tag#
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-F42D89C8
> dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.0073.B06.0810291326:bd10...

Read more...

Revision history for this message
Alex Murray (alexmurray) wrote :

@David - didn't see your reply earlier but my experience is the same as yours - at least for a) not b) although have only tested a couple times. Would be keen to hear if the trying the 2.6.33 kernel fixes this for you - unfortunately am on an expensive low bandwidth connection for the next couple days so wont be able to try installing it and test it myself till probably Monday.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Per's test on the latest kernel gives us some good information. On top of that, we have made a decision to base Lucid on the 2.6.32 kernel, but with the drm stack backported from 2.6.33. The first official kernel with the .33 drm stack has yet to be released, but there is a test kernel available in the "red" ppa: https://launchpad.net/~apw/+archive/red. It would be very helpful for us if someone were to test this kernel to see if it fixes the issue. If it does, great. If not, we still have a good lead on the fact that stuff is broken in 2.6.32 but fixed in 2.6.33.

Revision history for this message
Alex Willmer (alex-moreati) wrote :

I've just upgraded to this kernel, and I don't believe it's fixed the issue. Here are the details, following a dist-upgrade with that PPA:

Reboot - GDM login screen displays, login bongos play
Press return, to select default user - Screen blanks, a few coloured blocks appear briefly, GDM reappears, login bongos play again.
Press return, to select default user - password box appears, accepts password, login completes.
Suspend laptop - screen fades to black, laptop powers down, power LED pulsates indicating suspend mode
Press power, to resume - laptop powers up, screen is blank black, GDM login bongos play
Switch VT twice - After a couple of attempts GDM screen is displayed,

alex@martha:~$ uname -a
Linux martha 2.6.32-16-generic #23~drm33v5-Ubuntu SMP Thu Mar 4 17:20:55 UTC 2010 x86_64 GNU/Linux
alex@martha:~$ aptitude show nvidia-current | grep Ver
Version: 195.36.08-0ubuntu1
alex@martha:~$ lsmod | grep nv
nvidia 10783166 43

Hope that helps

Revision history for this message
Noel J. Bergman (noeljb) wrote :

@Alex, is the behavior fixed by reverting to nvidia 190.53?

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Clearly this is an issue with the kernel still. Thus, I'm reverting the status back. I'm going to try to do some bisect work on my own laptop to figure out what's going wrong.

Changed in linux (Ubuntu Lucid):
status: Fix Released → In Progress
assignee: nobody → Chase Douglas (chasedouglas)
Revision history for this message
Alex Willmer (alex-moreati) wrote :

@Noel Sorry for the probably dumb question. How do I do that? I cannot start X using the nvidia.com download, due to a mismatch between the kernel module and the X driver, and AFAICT the 190.53 Ubuntu package is unavailable now.

Revision history for this message
Miloš Mandarić (mandzo18) wrote :

I am seeing some progress here. Sometimes just works, sometimes I get logged-out and sometimes I get blank screen.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

I see that they purged the driver from the repository. Fortunately, I cached the 64 bit 190.53 deb locally. I've temporarily posted it to http://www.devtech.com/tmp/ for anyone who wants to try reverting and report the results.

Revision history for this message
Alex Willmer (alex-moreati) wrote :

@Noel Thank you. Suspend and resume work for me with nvidia-current 190.53-0ubuntu14 and kernel 2.6.32-16-generic #23~drm33v5-Ubuntu.

The pretty boot splash doesn't show and GDM still restarts itself once on first boot, when I press return to show the password box. I'm guessing that has a separate cause.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

> Suspend and resume work for me with nvidia-current 190.53-0ubuntu14
> and kernel 2.6.32-16-generic #23~drm33v5-Ubuntu.

So 190.53 works, and 195.36.08 fails? Just confirming.

> The pretty boot splash doesn't show and GDM still restarts itself once on first boot, when I press return

That's a different bug. Un-install or downgrade plymouth. The last known working version of plymouth was 0.8.0~-7, which I've also posted to my server.

Revision history for this message
Alex Willmer (alex-moreati) wrote : Re: [Bug 488720] Re: Suspend/resume with nvidia driver fails

On 6 March 2010 01:49, Noel J. Bergman <email address hidden> wrote:
>> Suspend and resume work for me with nvidia-current 190.53-0ubuntu14
>> and kernel 2.6.32-16-generic #23~drm33v5-Ubuntu.
>
> So 190.53 works, and 195.36.08 fails?  Just confirming.

Yes.

--
Alex Willmer <email address hidden>
http://moreati.org.uk/blog

Revision history for this message
Markus Kolb (mkolb) wrote :

For me, with the drm kernel, it works better but not 100 percent.
Sometimes/rarely I still get a black screen after resuming from suspend. No VT switching possible.
After waking up from standby I've just logged in to GDM and tried to switch to VT => black screen and no VT.
Switching back to X doesn't work either.
Looks like a kernel bug. Hopefully this will get fixed until lucid release. My laptop already works perfectly with jaunty.
By the way the standby doesn't lock the user, the session is logged out, but this should be another bug.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

 Markus, which driver are you using? The 190 or 195 driver?

Revision history for this message
Rocko (rockorequin) wrote :

Like Markus, I also get logged out on resume with Lucid alpha 3. I guess gdm crashes on either suspend or resume. It might be on suspend because sometimes the laptop doesn't suspend successfully but instead gdm tries to restart - I get the purple login background screen - but never gets as far as displaying the login prompt. Does anybody know if there is another bug open for this?

I'm using the 2.6.33 kernel and the 195 driver. It happens with both 195.36.08 and 195.30.

Revision history for this message
Rocko (rockorequin) wrote :

An update on my last comment: adding the kernel boot option nomodeset to kernel 2.6.33 fixes the suspend/resume X crash for me. I now get the screensaver password prompt instead of a new login when I resume. I added it to /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT entry and ran sudo update-grub to update /boot/grub/grub.cfg.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

For everyone doing testing, please use the latest lucid stock kernel. We have transitioned it to the .33 drm, so we really only need to test against it (not the full 2.6.33 kernel if anyone is testing against it).

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Rocko:

I've heard someone else have the same issue (X crashes on resume) with intel graphics, so I do not believe this is the same issue. Please look for another bug to handle that issue or create a new bug.

Thanks

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I just tried out nvidia 195.36.08 with lucid 2.6.32-16.24 kernel. Suspend/resume worked fine, though X was hosed when it came back up. I'm not sure exactly what's going wrong for others though.

Revision history for this message
Anton Eliasson (eliasson) wrote :

I'm currently using the old nvidia 173, not nvidia-current, with lucid kernel 2.6.32-14-generic-pae. Suspend/resume works fine. Graphics are messed up a few seconds on resume, but X and GDM survives without restart

Revision history for this message
Noel J. Bergman (noeljb) wrote :

> I just tried out nvidia 195.36.08 with lucid 2.6.32-16.24 kernel. Suspend/resume worked fine,

Define "fine"

> though X was hosed when it came back up.

From what I can see, the system does resume, but X never comes back up, hence not fine and still confirming the report "the screen stays black and I am oblige to force the shutdown with the power button."

I just verified this with a fully updated Lucid. Now I will restore the working driver (190.53) and put a hold on it again until trere is something new to try.

Revision history for this message
Loris Zinsou (nepenthes) wrote :

Could you please define what is a "black screen" ?
I experience this bug, but sometimes, the screen of my laptop (a Dell XPS m1330 with nvidia graphics) does not wakes up ! It just black AND switched off, while the hard drive, wifi and bluetooth LEDs are blinking (as usual). Trying to switch VTs doesn't do anyting, but typing my password makes me ear the ubuntu welcome sound.
Sometimes, I only get a black AND switched on screen (but it's blank).

Are these two different issues ?

Revision history for this message
Noel J. Bergman (noeljb) wrote :

> Could you please define what is a "black screen" ?

My experience sounds similar to yours.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Noel:

When I tested resuming, I believe the display came back (backlight was on), but X didn't come back so I think I was sitting at a black screen. I switched to a VT and restarted gdm and everything worked. This is much different than the drivers not resuming the device such that the backlight does not come on. This bug is specifically for the driver side of resume. If anyone is seeing X crash on resume and can bring everything back by restarting gdm then it's a different bug. They should look for a similar bug elsewhere or open a new one.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

> I switched to a VT and restarted gdm and everything worked.

I've tried that on mine, and it doesn't work -- no VT, no display at all.

> This bug is specifically for the driver side of resume.

Which seems to be what I'm experiencing, as is the original reporter, if I understand your distinction.

Let me know what, if anything, I can do to help get this resolved. For now, I'm just sticking with the last working driver, 190.53.

Revision history for this message
Mark Baas (mark-baas123) wrote :

nvidia-current works fine, but you have to mv /etc/init/plymouth-splash.conf /etc/init/plymouth-splash.conf.disabled AND append nomodeset to grub default options in /etc/default/grub (dont forget to do a update-grub).

Revision history for this message
Mark Baas (mark-baas123) wrote :

however this only seems to work when doing pm-suspend from cli, somehow when doing it from gnome it crashes

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I haven't been able to reproduce this issue, so I'm removing myself as the assignee. I'll still monitor this bug in case any fixes or other test scenarios come up.

Changed in linux (Ubuntu Lucid):
assignee: Chase Douglas (chasedouglas) → nobody
status: In Progress → Triaged
Revision history for this message
mabawsa (mabawsa) wrote :

Still getting this bug.

Revision history for this message
mabawsa (mabawsa) wrote :

http://linuxers.org/article/linux-nvidia-drivers-might-also-have-gpu-fan-speed-issue
Dunno if this can be verified but I am going to switch to nouveau for now.

Revision history for this message
In , Martin Pitt (pitti) wrote :
Changed in pm-utils:
status: In Progress → Fix Released
Revision history for this message
thomasn80 (thomasn80) wrote :

Hmm, fix released... I still have a non-working resume. Also, suspend takes 20-30 seconds. On Karmic it only took < 5 seconds. Do I have another bug?

I have prop. nvidia "current" (as reported by jockey) driver.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@ThomasNovin:

There was an original bug that was fixed in pm-utils. I should have asked people at that point to open a new bug if they still have non-working suspend/resume on nvidia.

It's probably a good time to do that now. If you or someone else open a new bug to track further issues with resume/suspend please note the bug here.

Thanks

Changed in linux (Ubuntu Lucid):
status: Triaged → Invalid
Revision history for this message
thomasn80 (thomasn80) wrote :

Ok I have created bug #540739. My problem is fixed by switching to nouveau so for me it seems to be the proprietary nvidia-driver that's causing trouble.

Revision history for this message
mabawsa (mabawsa) wrote :

OK tried the 195.36.15 drivers from ppa:thomas-arcila/nvidia and I can now suspend and resume without issues.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

Fixed for me, too, with 195.36.15.

Revision history for this message
David Planella (dpm) wrote :

I stopped using the nvidia driver, but I still have a non-working suspend/resume on nouveau.

As per Chase's comment, I've opened (well un-duplicated) a new bug to track this: it's bug 523072

Revision history for this message
Νίκος Αλεξανδρής (nikos.alexandris) wrote :

FYI,

I 've never had problems (the last months) with suspend/resume (on MBP5,1). Yet, [slightly off-topic?] I've never (I think never) have seen a successful resume (after suspending) while working with an external LCD (set-up using TwinView).

Anybody else using an external display?

Revision history for this message
MikeN (mike-mtb) wrote :

Just a slight off-topic. I do not believe that bug #513890 is necessarily a duplicate of this (which is nVidia focused) as I have suspend/hibernate issues with a Dell 9400 which is ATI based (more details to be found in #513890).

Revision history for this message
Anton Eliasson (eliasson) wrote :

Bug #513890 is also Nvidia-specific, I just didn't know that when I reported it. Longer answer can be found in the #513890 comments

Revision history for this message
Paul Harper (pharper26855) wrote :

I'm seeing similar behaviour on a Dell C610 with an ATI Technologies Inc Radeon Mobility M6 LY graphics chip. Suspend and resume work as expected in 9.10 but in 10.4 resume results in a blank display and I must power cycle to clear up the issue. I have not seen another bug specific to ATI. Should I post details here?

Revision history for this message
Anton Eliasson (eliasson) wrote :

No, this bug concerns Nvidia-users only. Report your issue as a new bug

Revision history for this message
pmos69 (pmos69) wrote :

Just marked https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568711 as a duplicate of this.
Any workaround at this time?

Revision history for this message
pmos69 (pmos69) wrote :

why is this marked as invalid?

Revision history for this message
Ricky Campbell (cyberdork33) wrote :

It is only marked as invalid against the projects that it was marked against inappropriately.

The other projects are all at a "Fix Released" status. The bug you marked as a duplicate is likely not a duplicate...

Revision history for this message
pmos69 (pmos69) wrote :

OK, removed the duplicate state.
Thanks.

Revision history for this message
Sergey Chistovich (theigel) wrote :

After fresh install Lucid final, with all updates (two days ago), resume doesn't work at Lenovo IdeaPad B450 (NVIDIA GeForce G105M). To be exact:

- suspend seems to work (the computer goes to sleep OK)
- on resume, the computer powers up, the HDD works for a while, the screen powers up, but no image appears.

Resume from _hibernate_ worked at least once, though I should experiment more to be sure.

Not sure, which driver is used by default (the notebook isn't mine), can post details later.

Revision history for this message
Anton Eliasson (eliasson) wrote :

Make sure you're using the proprietary nvidia-driver, not the open one because suspend probably doesn't work with that

Revision history for this message
Sergey Chistovich (theigel) wrote :

Yes, you're right - after installing proprietary driver everything works fine.

Changed in pm-utils:
importance: Unknown → High
Changed in pm-utils:
importance: High → Unknown
Changed in pm-utils:
importance: Unknown → High
Revision history for this message
unDEFER (undefer) wrote :

I have this problem in Ubuntu 10.10 (Maverick):
can't to resume after `pm-hibernate`.

Kernel: 2.6.35-22-generic (linux package version 2.6.35.22.23)
Nvidia driver: 96.43.19-0ubuntu1

Revision history for this message
unDEFER (undefer) wrote :
Revision history for this message
Mark Yisri (markyisri) wrote :

Hi, I know this is an old bug, but I'm experiencing this problem on the latest 4.13 kernel. I didn't have the issue on an older 4.10 kernel.

What I have found is that if I switch with Ctrl+Alt+F1, then suspend, then resume and switch back to X, it works. If I just suspend I'm left with a black screen.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.