Ubuntu

Reboot hangs on Dell Optiplex 760 (workaround: reboot=bios)

Reported by Geir Ove Myhr on 2009-11-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Medium
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

I have two Dell Optiplex 760 Ultra Smal Form Factor running Karmic. They hang on reboot after shutting down the system. Adding reboot=bios as a kerner parameter works around it. This seems to be bug 115011 (which is for Optiplex 745) all over again on a new model.

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gomyhr 1809 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe6dc000 irq 16'
   Mixer name : 'Analog Devices AD1984A'
   Components : 'HDA:11d4194a,1028027f,00100400'
   Controls : 34
   Simple ctrls : 20
Date: Wed Nov 25 12:06:03 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=90780839-8893-4bd1-aa43-dc6c9da0e48e
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. OptiPlex 760
Package: linux-image-2.6.31-15-generic-pae 2.6.31-15.50
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-15-generic-pae root=UUID=0ff4f513-9207-477c-9145-0aea1c38f74e ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic-pae
RelatedPackageVersions:
 linux-backports-modules-2.6.31-15-generic-pae N/A
 linux-firmware 1.25
RfKill:

SourcePackage: linux
Uname: Linux 2.6.31-15-generic-pae i686
XsessionErrors:
 (gnome-settings-daemon:1823): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1823): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1920): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1912): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:1911): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -12 and height 24
dmi.bios.date: 08/17/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0G919G
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 16
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd08/17/2009:svnDellInc.:pnOptiPlex760:pvr:rvnDellInc.:rn0G919G:rvrA01:cvnDellInc.:ct16:cvr:
dmi.product.name: OptiPlex 760
dmi.sys.vendor: Dell Inc.

Geir Ove Myhr (gomyhr) wrote :
Geir Ove Myhr (gomyhr) wrote :

Seems we need another reboot quirk. I'll try to get a test kernel built. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Andy Whitcroft (apw) on 2009-11-30
tags: added: kernel-karmic
Geir Ove Myhr (gomyhr) wrote :

I will only have access to this hardware for two more weeks - I hope I can get any testing done before that.

While I'm normally running with reboot=bios, I did some more testing without it today. It turns out that it does not always fail to reboot without the kernel option, only sometimes. I also tried the mainline kernel linux-image-2.6.32-020632rc8-generic and it behaved the same as the karmic kernel.

Hi Geir,

I've built and uploaded a test kernels at the following:

http://people.canonical.com/~ogasawara/lp488319/

Can you please install and test (ie with this test kernel you should not need to use reboot=bios). Please let us know your results. Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress
Geir Ove Myhr (gomyhr) wrote :

Thank you for building the test kernel. I have tested remotely over ssh (I'm currently at home and the computer is at my workplace). After installing the test kernel, resetting the kernel parameters in /etc/default/grub, doing an update-grub and rebooting, I was able to reboot successfully 16 times.

To make sure that I still had problems rebooting this way with the old kernel, I removed the test kernel so that it would boot the normal karmic kernel 2.6.31-15-generic-pae. After the reboot into 2.6.31-15 the first reboot went fine, but the next time the computer did not come back online. Presumably frozen on reboot until I press the power button tomorrow morning.

Summary: The test kernel works :-)

Thanks, I'll work to get this patch submitted upstream and then pulled back down into the Ubuntu kernel.

Thank you! For reference, may I ask what the patch is? Are you
quirking on DMI_PRODUCT_NAME only or also the DMI_BOARD_NAME? Good to
know if in the future Dell puts out 760s with the same problem and
different board name and someone with that problem comes across this
bug report.

Oops, my bad. I usually put the patch with the test kernels. It's there now:

http://people.canonical.com/~ogasawara/lp488319/0001-x86-add-Dell-OptiPlex-760-reboot-quirk.patch

Indeed, I'm quirking based on DMI vendor, product name, and board name. I suppose I could drop the board name specifics, but seems previous quirks did the same.

Geir Ove Myhr (gomyhr) wrote :

Thanks. In the 745 case IIRC, the DMI_BOARD_NAME was eventually
dropped, since it turned out to be several (i.e. more than two)
different board names out there (cf. bug 115011). Actually, there
seems to be redundant 745 quirks in reboot.c now, since one of them
only checks for DMI_SYS_VENDOR and DMI_PRODUCT_NAME while the others
also check for DMI_BOARD_NAME.

Anyhow, it may be better to quirk conservatively, and then extend if
needed. At least it is now documented here that if someone has this
problem on an Optiplex 760 USFF after this bug has been marked as
fixed, the first thing to look for is if the board name is 0G919G, and
if it's not, the quirk needs an update. (The board name can be found
in the output of `sudo dmidecode`).

trulyliu (trulyliu) wrote :

I encounter this problem with my Dell Optiplex 755.
How can I resolve it ?

Hi Geir,

When speaking with upstream, they've inquired if reboot=acpi works on this system. Can you test and let us know?

http://marc.info/?l=linux-kernel&m=126463856231820&w=2

Also, since upstream is now on a much newer 2.6.33-rc5 kernel, if you could confirm with this newer kernel version that would be great:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc5/

Thanks.

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Geir Ove Myhr (gomyhr) wrote :

It seems that reboot=acpi does not work.

I installed 2.6.33-rc6 (from today) and rebooted successfully 4 times after booting with reboot=bios, like before. I then changed the boot parameter to reboot=acpi. After booting with this the first time, the computer came back up successfully after a reboot. The next time, however, the computer didn't come back up.

Since I have moved to Norway and the two affected computers are located in Canada I had to do this via ssh and playing with /etc/default/grub and update-grub. I can't hit the power button or verify that it wasn't something else that went wrong. I hope this testing is sufficient. If necessary, I can try without any reboot option with 2.6.33-rc6 once someone comes to work after the weekend and gives it a power cycle.

madbiologist (me-again) wrote :

The patch containing this quirk has been included in Kernel 2.6.33-rc7. The changelog contains the following comment:

commit 35ea63d70f827a26c150993b4b940925bb02b03f
Author: Leann Ogasawara
Date: Wed Jan 27 15:29:18 2010 -0800

    x86: Add Dell OptiPlex 760 reboot quirk

    Dell OptiPlex 760 hangs on reboot unless reboot=bios is used. Add quirk
    to reboot through the BIOS.

    BugLink: https://bugs.launchpad.net/bugs/488319

    Signed-off-by: Leann Ogasawara
    <snip>
    Signed-off-by: H. Peter Anvin

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (11.7 KiB)

This bug was fixed in the package linux - 2.6.32-13.18

---------------
linux (2.6.32-13.18) lucid; urgency=low

  [ Andy Whitcroft ]

  * Revert "enforcer -- make the enforcement configuration common"
  * Revert "(pre-stable) Input: ALPS - add interleaved protocol support
    (Dell E6x00 series)"
  * Revert "(pre-stable) driver-core: fix devtmpfs crash on s390"
  * Revert "(pre-stable) Driver-Core: devtmpfs - set root directory mode to
    0755"
  * Revert "SAUCE: Adds support for COMPAL JHL90 webcam"
  * Revert "SAUCE: fix kernel oops in VirtualBox during paravirt patching"
  * Revert "SAUCE: make fc transport removal of target configurable"
  * enforcer -- make the enforcement configuration common
  * getabis -- add preempt flavour to the list
  * [Config] enforce DEVTMPFS options
  * [Config] armel -- cleanup to-be builtin modules
  * [Config] cleanup ports configs
  * [Config] enable CRYPTO_GHASH_CLMUL_NI_INTEL
    - LP: #485536
  * add printdebian target to find branch target
  * distclean -- do not remove debian.env
  * [Config] generic-pae switch to M586TSC
    - LP: #519448
  * git-ubuntu-log -- commonise duplicated log handling
  * git-ubuntu-log -- tighten up Bug: NNNN matching
  * git-ubuntu-log -- sort the bug numbers

  [ Chris Wilson ]

  * (pre-stable) drm/i915: Increase fb alignment to 64k
    - LP: #404064

  [ Eric Miao ]

  * arm -- enable ubuntu/ directory

  [ Huang Ying ]

  * SAUCE: crypto: ghash - Add PCLMULQDQ accelerated implementation
  * SAUCE: crypto: ghash-intel - Fix building failure on x86_32

  [ Loïc Minier ]

  * [Config] cleanup preempt configuration
  * [Config] versatile: Fix video output
    - LP: #517594
  * [Config] armel DEFAULT_MMAP_MIN_ADDR=32768
  * [Config] Large update to armel/versatile
  * [Config] versatile: Add RTC support
  * [Config] armel: Enable NEON
  * [Config] versatile: Builtin MMC support
  * [Config] versatile Builtin SCSI controller
  * [Config] armel Disable dma_cache_sync callers
  * [Config] armel Disable asm/time.h users
  * [Config] armel Disable out of range udelay()
  * [Config] armel Disable flush_cache_range() users
  * [Config] armel -- Enable ubuntu/ drivers

  [ Steve Conklin ]

  * SAUCE: drm/i915: Add display hotplug event on Ironlake
  * SAUCE: drm/i915: Add ACPI OpRegion support for Ironlake

  [ Upstream Kernel Changes ]

  * Revert "[Upstream]: oprofile/x86: add Xeon 7500 series support"
  * Revert "Revert "[Bluetooth] Eliminate checks for impossible conditions
    in IRQ handler""
  * clockevent: Don't remove broadcast device when cpu is dead
  * clockevents: Add missing include to pacify sparse
  * ACPI: don't cond_resched if irq is disabled
  * be2net: Add support for next generation of BladeEngine device.
  * be2net: Add the new PCI IDs to PCI_DEVICE_TABLE.
  * mpt2sas: New device SAS2208 support is added
  * ar9170: Add support for D-Link DWA 160 A2
  * powerpc/fsl: Add PCI device ids for new QoirQ chips
  * davinci: dm646x: Add support for 3.x silicon revision
  * Input: ALPS - add interleaved protocol support (Dell E6x00 series)
  * Driver-Core: devtmpfs - set root directory mode to 0755
  * driver-core: fix devtmpfs crash on s390
  * vfs: get_sb_single() ...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Phil (neo6238-ubuntu) wrote :

I have got an Optiplex 760 and since upgrading to 11.04 (from 10.04) this bug seems to appear. At reboot it hangs. Trying the workaround now.

Phil, this bug report has been closed, and comments on closed bug
reports are not monitored by developers. In order to get someone to
look at this, file a new bug report using the ubuntu-bug command. Use
this bug report as a model and collect the same information that I
have attached here. I don't have access to the 760s anymore, so I
won't be able to test. It is best if you can also test with the
current development version, since that is where this is most likely
to be fixed.

We've come acros Dell OptiPlex 760 systems with a different DMI_BOARD_NAME, more information:

https://bugzilla.kernel.org/show_bug.cgi?id=54051

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
status: Fix Released → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.