Ubuntu

kubuntu 6.06 LTS does not support Realtek 8139 network card

Reported by rozen on 2006-06-05
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

/var/log/messages reports:

8139too:probe of 0000:00:08:0 failed with error -16
8139cp: 10/100 PCQ Ethernet driver v1.2 (Mar 22, 2004)
8139cp: pci dev 0000:00:08:0 (id ioec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.

Phil Worrall (phil-w) wrote :

I can confirm this bug on Ubuntu LTS 6.06 LTS using any of the 2.6.15-x series kernels.

Upon booting I would get the exact same message as the previous poster.
/sbin/ifconfig eth0 reports "Device not found"

The bug is not present in the Ubuntu Hoary or Ubuntu Breezy distributions because they use older kernels.

I think this problem may be an upstream problem, perhaps due to http://bugzilla.kernel.org/show_bug.cgi?id=5507, because Ive compiled a 2.6.18-rc1 series MM kernel and that doesn't exhibit the same problem.

derjames (derjames) wrote :

This bug does not only occurs in Kubuntu but Ubuntu 32 and 64 bits editions are affected as well:

I can confirm the bug during the boot process of the live CD of both Ubuntu 32 and Ubuntu 64

the last lines of the boot log are

8139cp 10/100 PCI Ethernet driver V1.2(MAr 22, 2004)
8139cp PCI dev 0000:03:04.0 (id 10ec:8139 rev10) is not an 8139c+ compatible chip
8139cp Try the 8139too driver instead
8139too fast Ethernet driver 0.9.27
ACPI interrupt 0000:03:04.0[A] GSI 16 (level, low) -> IRQ 177
eth0:Realtek RTL8139 at 0xffffc200|00 b.c00 00:40:45:2c:85:c0, IRQ 177

after showing the last line the system freeze and you need to apply a reset.

This particular PC is a laptop Philips X56 - Core 2 Duo T5600 - 1 GB RAM, - 80 GB hard drive - ethernet device Realtek RTL8139/810x - Wireless adapter Intel PRO/Wireless 3945ABG - Display adapter Intel 945GM.

The problem has also been reported at the Ubuntuforums in the same Laptop model:

http://ubuntuforums.org/showthread.php?t=292408&highlight=Philips+x56

and also a solution was posted, but requires the Instalation of Ubuntu Breeze and a Kernel recompilation,

http://ubuntuforums.org/showthread.php?t=287939&highlight=Philips+x56

however not all the user (including me) do have an available copy of Breeze.

Jim

derjames (derjames) wrote :

I did forget to specify the Ubuntu version; is 6.06 Dapper for both 32 and 64 bits...

Jim

derjames (derjames) wrote :

Hi there!,

The Ubuntu 6.10 releases for both 32 and 64 bits have the same problem... they fail to detect the network adapter and the installation halts abruptly...

Jim

cbrockman (mr-chuck) wrote :

Installation of the the Realtek 8139 network card also fails on my computer. I'm running the version 2.6.15-23-386 kernel (Xubuntu 6.06). When the boot stalls at "8139too Fast Ethernet driver 0.9.27" I can get past the hangup by removing and then reinserting the network cable. The next message in the dmesg log ("PCI: Setting latency timer of device 0000:00:0b.0 to 64") is not displayed on the terminal until the boot continues past the stall. Adding "irqpoll" and "noapic" to the boot command line have no effect.

The pertinent sequences from dmesg and lspci are shown in the attached 8139fail.txt.

This same network card worked in this computer with the Breezy Badger release of Xubuntu.

cbrockman (mr-chuck) wrote :

Apparently there is an upstream fix for this RTL8139 problem. I tried a floppy-booted install of Debian Sarge (version 3.1) which recognized the 8139D just fine. That Debian distribution had trouble partitioning one of my hard disk drives to ext3 so I created the boot, root and network driver floppies for the current beta of Debian Etch (version 4.0). That 2.6.18-4-486 kernel had no trouble with the Realtek card nor the partitioning so I did a full install of that distribution. Now I have my network back.

Chuck

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux-source-2.6.15:
status: Confirmed → Incomplete
Jerzy Jalocha N (jjalocha) wrote :

Is this a duplicate of Bug #90271 ?

derjames (derjames) wrote :

@Jerzy

Yes, it seems to be the same...

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers