Ubuntu

Can't disable fbcon

Reported by Shentino on 2009-11-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

I just found out that a dependency in fbcon is hard-coded in Xorg for whenever kernel mode switching is used.

Attempting to manually hide fbcon.ko results in massive screen corruption.

Version: Karmic Koala
Up to date as of: Nov 15

Expected outcome:

Without fbcon, switching VTs should have dropped the screen back into text mode. The kernel or whatever code handling the mode switch should have noticed that it needed to go into text mode, and actually done so.

Actual outcome:

Without fbcon, the screen got horrendously corrupted. Almost as if the console was treating the video memory as if it was in text mode, but the screen was still in graphics mode.

Why this is a bug:

Text mode 80x25 is very useful for doing work on muds and the kernel development. I use it extensively because it's fast and snappy. Making the console a framebuffer slows things WAY down.

Switching between text and graphics modes shouldn't result in corruption. Attempting to force-load fbcon is not only an apparent kludge, but it's also an improper forcing of system policy.

Shentino (shentino) on 2009-11-15
description: updated
description: updated
Shentino (shentino) wrote :

Just confirmed with the intel folks.

this is not a bug. KMS conflicts with vga console and thus fbcon is mandatory.

Anyone wishing to take advantage of KMS, kiss text mode goodbye.

Changed in xorg (Ubuntu):
status: New → Invalid
Shentino (shentino) wrote :

Link to where this decision was made official.

http://lists.freedesktop.org/archives/intel-gfx/2009-February/001215.html

Any resolution of this problem will require cooperation from intel.

Changed in xorg (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) wrote :

Hi shentino,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Shentino (shentino) wrote :

I have more information.

It's not limited to intel gfx.

I've just found out that nouveau and radeon are also falling in line to disable vga console during KMS.

This seems more like a conspiracy to kill vgacon. All three major vendors are refusing to support it with KMS enabled.

This is a bona fide regression (loss of functionality), but as a practical matter it may not be possible to resolve with anything short of a spec change such that vgaconsole is defined as officially deprecated.

Apparently, the upstreams have spoken and this is fait accompli.

Shentino (shentino) wrote :
Shentino (shentino) wrote :
Bryce Harrington (bryce) wrote :

Really this is a kernel issue, especially with KMS xorg isn't involved in setting up the consoles.

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
Shentino (shentino) wrote :

The official upstream kernel at kernel.org, version 2.6.32.1 reveals that fbcon is now a hard dependency of both intel and radeon kms, and nvidia already ditched vgacon ages ago.

Personally, I don't like that vgacon was pulled out from under me so suddenly but unless someone wants to fight with the kernel devs over this...

Confirmed deprecations of vgacon with KMS:
intel (confirmed in attached 2.6.32.1 Kconfig file)
nvidia (nouveau) (confirmed at http://nouveau.freedesktop.org/wiki/KernelModeSetting)
ati (radeon) (confirmed in attached 2.6.32.1 Kconfig file)

...and the list will likely only grow with the passage of time.

Furthermore, I've noticed that almost universally fbcon is lauded as a wonderful feature, and even suggesting vgacon compatibility is pretty much blasphemy, especially with the intel-gfx devs on freenode. I sensed active hostility against vgacon and felt I needed to leave before finding myself forcibly removed from the channel.

So it's official: vgacon is extinct, and fbcon is here to stay.

I suspect that with trends the way they are, even the vga standard itself (which vgacon is based on) will be going bye bye in the future. Even BIOSes are starting to shun text mode at every point except the boot, and the open graphics card project hates it.

Unless ubuntu wants to get into a fight with the upstreams over this then the correct response is most likely to officially deprecate vgacon in favor of fbcon.

Under protest I advise that this bug be closed.

Shentino (shentino) wrote :

Marking "fix released" as the upstream now forbids usage of KMS without fbcon.

Changed in linux (Ubuntu):
status: New → Fix Released
status: Fix Released → In Progress
Shentino (shentino) wrote :

Remarking as "in progress" since I'm not sure if the ubuntu version of the kernel has the upstream dependency fix yet.

Shentino (shentino) on 2009-12-21
Changed in linux (Ubuntu):
assignee: nobody → Shentino (shentino)
pegranka (peterb-zeta) wrote :

Forcing fbcon is a problem with HP nx6125, which has Radeon XPRESS 200M, as this laptop cannot resume from suspend if a framebuffer is used. I had to disable KMS so I could use suspend/resume. So I hope we are not forced to use fbcon.
I don't understand the remarks about a text console, as I don't have any vga drivers loaded, and can still use ctrl-alt-F1 to get a text console.

Shentino (shentino) wrote :

Personally I really don't like the fact that kms forces fbcon, or that later versions of the video card drivers make kms mandatory.

Text consoles are fast and snappy and have that 9th pixel column to cleanly separate characters from each other, something that fbcon lacks.

Since the upstreams have already officially deprecated vgacon there is absolutely nothing that can be done short of surrendering to the inevitable and shoehorning everything else into being compatible with it.

Shentino (shentino) wrote :

Just a note though, if they could find a way to simulate the 9x16 character cell behavior of legacy vga console I'd be an order of magnitude more tolerant of fbcon.

Shentino, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
assignee: Shentino (shentino) → nobody
importance: Undecided → Low
status: In Progress → Incomplete

Turns out this isn't actually a bug, but a deliberate policy decision
upstream in the kernel.

fbcon is now mandatory if you use kernel modesetting.

I've also spoken to developers of graphics drivers and going back would
bring in VGA which would cause hardware conflicts with modern GPU
operations. To be blunt, fbcon is here to stay and there's nothing anyone
can or will do about it.

Please close this as obsolete.

On Sun, Dec 22, 2013 at 2:55 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> Shentino, this bug was reported a while ago and there hasn't been any
> activity in it recently. We were wondering if this is still an issue? If
> so, could you please test for this with the latest development release
> of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
> /daily-live/current/ .
>
> If it remains an issue, could you please run the following command in
> the development release from a Terminal
> (Applications->Accessories->Terminal), as it will automatically gather
> and attach updated debug information to this report:
>
> apport-collect -p linux <replace-with-bug-number>
>
> Also, could you please test the latest upstream kernel available (not the
> daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It
> will allow additional upstream developers to examine the issue. Once you've
> tested the upstream kernel, please comment on which kernel version
> specifically you tested. If this bug is fixed in the mainline kernel,
> please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.13-rc3
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: linux (Ubuntu)
> Status: In Progress => Incomplete
>
> ** Changed in: linux (Ubuntu)
> Assignee: Shentino (shentino) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/483301
>
> Title:
> Can't disable fbcon
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/483301/+subscriptions
>

Shentino, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/483301/comments/15 regarding this being obsolete. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers