Ubuntu server kernel will not boot.

Bug #48266 reported by Liz on 2006-06-03
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.15

I put the 6.06 Server CD I burned in and followed the installation procedures for a LAMP server. There were no problems during the installation.

However, I went I go to actually boot, the following happens. The computer turns on, and GRUB is able to load just fine, but whichever of the 2 kernels I try to boot (either the regular server one or the recovery mode one), the same thing happens. It detects the ext2 filesystem properly. Then I see initrd [kernel location], followed by Linux [something, too fast to read it], saveddefault, and boot.

Then the computer reboots itself, and so if I let it sit, it just loops through turning on/trying to boot kernel/turning off/etc.

In the past, the computer has had some power supply issues, so I decided to change the power supply, but replacing the power supply with a correctly functioning one makes no difference in the aforementioned behavior.

I'm pretty sure this is an issue with the server kernel.

(Hopefully I did this right...I'm new to the Ubuntu distro...)

Alex Pardoe (digitalpardoe) wrote :

I'm getting the same problem on my MiniITX server. I've been running Debian Sarge with no problems but the server release of Dapper from the Server CD will not work the exact same problem as above occurs. I was trying to install with ReiserFS if that makes any difference.

Liz (liesbyomission) wrote :

I just used all the defaults on the LAMP install process. I got around it by doing the server install on the alternate CD and then manually installing the AMP. The computer I'm doing this on is just one I had lying around, no exotic hardware or anything, and since the install on the alternate CD works fine, I'm pretty sure it's somehting with the server CD's kernel.

flod (linux-lodolo) wrote :

Confirming the problem: I'm trying to install ubuntu-server 6.06 ISO (LAMP Server option) on a mini-itx Epia ME-6000.

I've started with the cd using the option "rescue a broken system" and I did "apt-get install linux-386": the system works with this kernel 2.6.15-23-386

Patje (patrick-coeman) wrote :

Here the same with a older Epia 533 board and a Ubuntu server 6.06 386 ISO. I did the LAMP install and get the same loop in boot up.

After folowing Flod's instructions it seems to work fine...

Alex Pardoe (digitalpardoe) wrote :

If the problem is occuring for everyone based on EPIA or VIA C3 processors maybe it has something to do with the documented instruction set problem that these particular processors have in their i686 emulation. If this is the case then we will all have to just make do.

DDC (coquet) wrote :

Same problem here also on an EPIA 800 with the server install cd. I've only tried the non-LAMP server option. The text install on the alternate CD worked for me. I assumed I had a botched ISO, but the MD5's match.

jmunin (jmunin) wrote :

Same problem here also on an INTEL PENTIUM 200 MMX + ALI M1542 A1 MOTHERBOARD CHIPSET with the server install cd.
I've tried both options: the non-LAMP server option and LAMP server option too.

Aurimas B (a-barcevicius) wrote :

Same for me. Installed ubuntu-server 6.06.1 on Pentium 200MMX, Intel motherboard (unfortunately I forgot chipset number). Went for plain server, not LAMP. After passing grub, it prints out lines mentioning kernel image, then "savedefault", then "boot" and thats it - reboot, rinse, repeat.

Martin Brook (martin.brook) wrote :

I've found various posts about this on ubuntuforums.org, which have suggested using the alternate install CD instead.

I Tried this and it worked fine (I was also having the same problem using the server install on an AMD-K6 processor).

So, what is different about the alternate install CD?

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
PVi (petervilhan) wrote :

Like a flod, boot from the install cd and select "rescue a broken system". Then follow the instruction until "Installing base component" appears on the screen. After finishing this step, press ESC to get into install menu and select smth.like "manually select components to install". On the next screen, the kernel list appears. Select the first "linux-386". Then continue with install, reboot and enjoy. System will use 2.6.15-23-386 kernel.

hope,this help.
:)

Peter

DonBurch (donald-burch) wrote :

Still happening with 6.10 server CD, on my old AMD K6-2 @300MHz. The Desktop and Alternate CDs work fine though - but I just want an integrated LAMP server.

bond2u (bond2u) wrote :

I've been been having the same problem. I read up on the Ubuntu site and it seems that the Dapper 6.0.6 LTS had the kernel set up for higher end memory (certainly meaning more memory than I have 192MB). I also read that the kernel could be changed to make it work...which has led me to this site and reading all your posts...so you've got the answer already...go with it ... and thanks!!!!

I had the LAMP running on a faster machine, but for the life of me couldn't figure out Apache2 and it's virtual site stuff, so I went back to 2000 Server on that machine...but I really want Unix as well (on the slower machine). I did find out that using SSH and webmin to control the LAMP from a windows machine made a great difference for me. So I'm going to use flod's instructions!

japuzzo (japuzzo) wrote :

This problem still occurs even in the latest build on my oldest system ( AMD-K6 500mhz with 377mb ). The solution is to also install the linux-image-<version>-generic. This way if the server kernel does not work, the admin can use the generic kernel to correct the problem. Which in my case was to install linux-image-2.6.20-8-386 and make it the default. Without including another image to boot from make ubuntu-server useless on systems that can not boot the server kernel.

The work-a-round was to boot into rescue mode, then chroot and install the i386 kernel image, then reboot. Once the i386 kernel was booted I was able to change /boot/grub/menu.lst to boot from that kernel. After that the system boots with no issues.

DonBurch (donald-burch) wrote :

This really gets my goat!

Obviously I've misunderstood the objective of Ubuntu. I thought you were trying to make linux easier to use, and more accessible. I've tried the desktop version, and it certainly lives up to this promise.

What about older less powerful machines, such as the ones which posters here are using. You can run Ubuntu desktop on them, or use them as a "server" with an old version of Windows --- but for some reason you can't use it as an Ubuntu server ?!?!

So what is the issue ? Is it really that the cut-down Ubuntu server software _requires_ a new top-end computer to run on; or that the developer in a moment of brain-freeze removed the wrong module, which provides support for older CPUs ? The same PC runs the desktop install; so it must be the latter.

My experience trying to set up a basic LAMP and email server has soured me on Ubuntu. Being forced to learn the lunux command line is bad enough, but the Ubuntu server documentation is incomplete and out-of-date. And if I have to use a different distro for the server, then I should be consistent by swapping to its desktop as well.

If you are so focussed on the Ubuntu desktop that you can't add the missing module back into the server - then stop diverting your resources to produce a half-baked server edition.. There is also the legal issue of your advertising a product which doesn't work.

japuzzo (japuzzo) wrote :

The fix for this would be to always install the server kernel and the generic kernel defaulting to the server kernel.
This way there is no change to the current flow, but if installed on a system that does not support the server kernel there is an easy option to correct the problem by changing GRUB to boot the generic kernel.

Not fixing this is not acceptable.
Defaulting to the "work around" ( see above) is also not an acceptable long term solution.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

This bug report was marked as Confirmed a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers