Ubuntu

[regression] Wired ethernet (VIA VT6102 Rhine II) and Wireless (RaLink 2500) no longer work under 6.06 (needs acpi=noirq blacklisting)

Reported by Michael R. Bernstein on 2006-06-03
78
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Ben Collins
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

I have installed Dapper on an Averatec 3250HX-01, and the networking does not work (ie. nothing but the machine's own IP can even be pinged), despite being recognized and setup.

This laptop has a Via VT6102 networking chipset (Rhine II) and a RaLink RT2500 wireless chipset.

If I try to 'bounce' (disable and then enable) the wired (or wireless) ethernet using the 'Networking' program, the machine locks up.

dmesg indicates there is some kind of IRQ conflict (both the wired and wireless chipsets are assigned to IRQ 11).

Wired networking works perfectly under Breezy (I verified this by booting from a Breezy LiveCD) despite the same conflict. Furthermore, under Breezy the video chipset is *also* assigned to IRQ 11, so this may be a red-herring.

A helpful soul on #ubuntu suggested I try adding pci=routeirq to the boot params, but this did nothing.

Please note the attachments to this bug, which now include (from Dapper, unless otherwise noted) dmesg output, 'lspci -vv output', and 'cat /proc/interrupts' output, from both my 3250HX-01 laptop as well as Centaur5's 3225HS-20 laptop, which has identical networking chipsets and identical symptoms.

Also attached is some output from Breezy, under which the networking works correctly, unlike Dapper.

This is the output of dmesg on my Averatec 3250-HX-01.

This is the output of lspci on my Averatec 3250HX-01.

This is the output from dmesg

Centaur5 (djacks555) wrote :

This is the output from dmesg on my Averatec 3225HS-20

I upgraded from Breezy to Dapper and immediately after rebooting the network devices no longer worked. Using the VIA 6102 I can get an IP address from my router or use static but either way I can't ping the router or the outside. If I try to restart the network device then the laptop freezes.

I tried to start the wireless but it locks up the machine immediately. It often locks up when I'm trying to input the wireless essid into the network manager. Setting up the wireless connection via iwconfig and then using ifconfig to start the device causes an immediate freeze.

This is the output from lspci on my Averatec 3225HS-20

description: updated

This is the output of 'lspci -vv' on an Averatec 3250HX-01.

Output of 'cat /proc/interrupts' on an Averatec 3250HX-01.

description: updated

Output of lspci -vv on my Averatec 3225HS-20

Output of cat /proc/interrupts on my Averatec 3225HS-20

This is the 'lspci -vv' output under breezy on an Averatec 3250HX-01. The only notable difference from Dapper (to my inexpert eyes) is that the S3 video chipset *also* gets IRQ 11 (instead of IRQ 9), for a total of three devices assigned to that IRQ (lines 24, 116, and 126). For whatever reason, this does not seem to cause any problems under Breezy, so perhaps the IRQ collision issue is a red herring.

This is the output from dmesg under Breezy on an Averatec 3250HX-01. Hopefully it holds some clue as to why networking doesn't work under Dapper but does under Breezy.

Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-kernel-network
status: Unconfirmed → Confirmed
Changed in linux-image-2.6.15-23-386:
assignee: ubuntu-kernel-team → ubuntu-kernel-network

A lot of the ralink drivers are not compatible with preempt, which is most apparent when "bouncing" (up->down->up) the interface causes a kernel panic.

John, Please note that the problem happens even when 'bouncing' eth0 (the Via VT6102), not just the RT2500. And when Centaur5 tried blacklisting the RT2500 module on his 3225HS-20, the problem still occurred.

description: updated
description: updated
description: updated
Changed in linux-image-2.6.15-23-386:
status: Confirmed → Rejected
Paul Sladen (sladen) wrote :

Please don't confirm your own bugs; it defeats the point.

Changed in linux-source-2.6.15:
status: Confirmed → Unconfirmed
description: updated

Does removing the module with 'modprobe -r' and then reinserting it with 'modprobe' cause the network device(s) to work normally again?

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info

i tryed "modprobe -r via_rhine" and "modprobe via_rhine" but it didn't help.

Paul, I was unsure which module you meant, so I guessed at the following testing procedure:

1) sudo modprobe -r rt2500

    result: ra0 (wireless) now no longer appears in 'Networking'.

2) sudo modprobe -r via-rhine

    result: eth0 (wired) now no longer appears in 'Networking'.

3) sudo modprobe via-rhine

    result: eth0 now reappears in 'Networking'.

4) Deactivate and activate wired network in 'Networking'.

    result: system freezes.

For completeness sake I've now also tried the following testing procedure:

1) sudo modprobe -r rt2500

    result: ra0 (wireless) now no longer appears in 'Networking'.

2) sudo modprobe -r via-rhine

    result: eth0 (wired) now no longer appears in 'Networking'.

3) sudo modprobe rt2500

    result: ra0 now reappears in 'Networking'.

4) Deactivate and activate wireless network in 'Networking'.

    result: system freezes.

Paul asked what the exact reproducible steps are to duplicate the crash. This had been described in general terms earlier, but here it is:

1) Go to 'System > Administration > Networking'.

    'Networking' GUI comes up.

2) Click either the wireless (ra0) or wired (eth0) interfaces to select it.

    Interface is selected.

3) Click 'Deactivate' button.

    Selected interface is disabled (greyed out) in the GUI.

4) Click 'Activate' button.

    'Spinner' mouse cursor starts after the click, but then the screen freezes (the animated cursor even stops in mid-spin), and no further interaction with the laptop is possible by keyboard or mouse.

At this point, I have tried switching to a virtual terminal (by ctrl-alt-F1, for example), retsarting X by ctrl-alt-backspace, and rebooting by ctrl-alt-delete. Nothing works, the screen remains frozen, and the only option is to power down the laptop and reboot.

If anyone wants a non-GUI test procedure, the following reproduces the problem:

1) sudo ifdown eth0

2) sudo ifup eth0

Result: screen freezes and no further interaction with the laptop is possible by keyboard or mouse.

I adjusted the titles of all attachements to be more informative.

This is a screenshot of the crash output after the following procedure:

1) boot in recovery mode

    Network is up, can access the network and get DHCP lease

2) start X

3) stop X (ctrl-alt-backspace)

    Network now is no longer accessible to pings.

4) Try dhclient (or ifup/ifdown)

    System crashes.

Further investigation shows that the drm and via modules are loaded by X and not unloaded afterwards. However, manually unloading these modules after stopping X is not enough to prevent the crash.

Ben Collins noted that the screenshot above showed the ralink driver crashing, despite the fact that it is eth0 that is being 'bounced', so I did the following:

0) boot in recovery mode

1) ifconfig

    Output shows only eth0 and lo

2) ping www.google.com

    Result: ping succeeds

3) use 'dhclient' command

    Result: DHCP client lease renewed

4) modprobe -r rt2500

    Output: '[42944724.053000] ACPI: PCI interrupt for device 0000:00:09.0 disabled'

5) ping www.google.com

    Result: ping succeeds

6) use 'dhclient' command

    Result: DHCP client lease renewed

7) startx

8) stop X (ctrl-alt-backspace)

9) ping www.google.com

    Result: ping fails

10) use 'dhclient' command

    Result: dhclient times out

Followup - Continuing the above test as follows provokes the crash again:

11) modprobe rt2500

    Output:
    [4294798.815000] ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKA] -> GSI 11 (level,low) -> IRQ 11
    [4294798.815000] rt2500 1.1.0 BETA3 2005/07/31 http://rt2x00.serialmonkey.com

12) run 'dhclient'

    Result: system crash, as before

Followup to the followup:

OK, looks like I overlooked something. running dhclient by itself implicitly target the ra0 interface *if it is available*.

Explicitly running 'dhclient eth0', does not provoke a crash under recovery mode, even after running X, even if the rt2500 module is loaded.

Worth noting as a further followup:

Although the crash seems to be dependent on the presence of the rt2500 module when in recovery mode, this is not the case when booting normally.

When booting normally, whether the rt2500 module is loaded or not, 'bouncing' the eth0 interface (whether from the GUI or the CLI) will lock the machine as previously described.

However, it does now appear that the ping/DHCP failure is connected somehow to running X, since that is what provokes that failure under recovery mode.

Di Wu (di-wu) wrote :

Just like to chime in here briefly. I also own an Averatec laptop (3250, I think) and am experiencing the same issue with ethernet in dapper.

However, the ethernet will work properly (even after loading X) if I disable ACPI in grub (adding "acpi=off" to the end of the boot command). Of course this is a suboptimal solution but I hope that helps someone fix this, as I know very little about linux myself.

Paul Sladen (sladen) wrote :

This is PCI routeing related.

Di: can you try booting with just:

  acpi=noirq

this should get you ACPI, but no use ACPI for the IRQ setup. This is likely going to need a workaround in the kernel; can you paste the contents of:

  cat /var/lib/acpi-support/*-*

Di Wu (di-wu) wrote :

Thanks, Paul! Adding "acpi=noirq" works wonderfully. Here are the contents of "cat /var/lib/acpi-support/*-*"

Version 07.00T
AVERATEC
3200
1.0

Chuck Short (zulcss) wrote :

Hi,

Can you attach the output of sudo dmidecode so we can blacklist your motherboard?

Thanks
chuck

This is the output of 'sudo dmidecode' for my Avertec 3250HX-01.

Paul, I can confirm that adding 'acpi=noirq' to entries in /boot/grub/menu.lst eliminates both ethernet problems (ie. both the inability to use the network and the system freeze when bouncing an interface), for both the 2.6.15 and 2.6.17 kernels (the latter provided by Ben Collins for testing) on my 3250HX-01.

Chuck, can you explain what you mean by 'blacklisting' the motherboard?

Centaur5, please:

1) check whether the 'acpi=noirq' fix works for your Averatec 3225HS-20

2) Post the output of 'cat /var/lib/acpi-support/*-*'

3) Attach the output of 'sudo dmidecode'.

I just confirmed my laptop to be a 3225HS (from Averatec's website), the same as Centaur5's, and am attaching my dmidecode output.

Paul Sladen (sladen) wrote :

This are both ID'ing identically:

        Manufacturer: AVERATEC
        Product Name: 3200

perhaps that'll kill the whole lot with one hit. On the downside, there's nothing to tell these models apart.

I suppose that it's possible that the motherboards *are* actually identical, with the main difference between the laptop models being the CPU and attached peripherals.

Ben Collins (ben-collins) wrote :

DMI Match added to kernel. The acpi=noirq should be automatic with this new kernel.

Changed in linux-source-2.6.15:
assignee: ubuntu-kernel-network → ben-collins
status: Needs Info → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Fabián Rodríguez (magicfab) wrote :

I originally reported this in #34958. I can confirm the acpi=noirq option in the appropriate menu.lst entry works. However current ISOs do not include this fix, which makes it very difficult for a new user to update their system unless they are aware of this bug report and read it completely. Is there a better way to let Averatec owners know about this ?

The blacklisting is now automatic, but only after applying a kernel upgrade. So, basically, if one has an Averatec 3250HX-01 like me, they have to first manually modify the menu.lst entry for the kernel they load and add the acpi=noirq option to enable network access, and apply current updates to the kernel.

Ben Collins (ben-collins) wrote :

We have point release dapper CD's coming in Aug or so I think.

Ben, does this just mean updated ISOs for download, or will revised CDs actually be shipped?

On Fri, 2006-07-21 at 23:07 +0000, Michael R. Bernstein wrote:
> Ben, does this just mean updated ISOs for download, or will revised CDs
> actually be shipped?

Both

Rikk03 (apcq66) wrote :

I have a similar problem with my desktop computer, I have a VIA VT6102 Ethernet card installed.

It worked fine with my first ever install of linux - Ubuntu Dapper. Worked fine - as in connecting to the net through my Linksys WAG54G ver.2 router.

However, when I tried to install a USB2 WUSB54G wireless -G Adaptor and tried to configure it / activate it = freeze. Also had difficulty switching from eth0.

 *-usb
       description: Generic USB device
       product: Wireless-G USB Network Adapter
       vendor: Cisco-Linksys
       physical id: 5
       bus info: usb@5:5
       version: 0.04
       capabilities: usb-2.00
       configuration: driver=rtusb maxpower=300mA speed=480.0MB/s

 *-network
       description: Ethernet interface
       product: VT6102 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@00:12.0
       logical name: eth0
       version: 78
       serial: ***********
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegociation

If you want me to provide further information you will have to tell me exactly what to type - also I would like to know how to add the acpi=noirq option - is this my best choice?

Centaur5 (djacks555) wrote :

Similar problem now exists in Feisty with my laptop listed above. Instead of completely locking up the machine it just makes the cpu max out at 100% making the laptop extremely slow but still able to shut down safely. Applied acpi=noirq at the end of the boot line in grub and it fixed the problem again. Let me know if you need additional info.

Bill Egert (begert) wrote :

Using Kubuntu 7.04 and am still seeing this problem. Took me a few days to find this workaround. Added acpi=noirq to the the grub menu.lst at the end of the kernel line and I am now able to use ethernet. Had to do this again after doing an update.

Let me know what I can do to help.

Changed in linux-restricted-modules-2.6.15:
status: New → Fix Released
assignee: nobody → ben-collins
Brian Murray (brian-murray) wrote :

The patch that fixed this bug for Dapper doesn't seem to be available for Gutsy. Could we get it added?

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged
Bill Egert (begert) wrote :

Using Gutsy Tribe 5, if i add the acpi=noirq I am able to use both my ethernet and wireless.

Scottopoly (scottopoly) wrote :

Hello there. I'm not sure this is known or not, but I thought I'd post anyway.

The acpi=noirq fix/workaround is still necessary for this laptop. I have an Averatec 3200 series and just downloaded and installed Gutsy from the Live CD in the last few days. I had the above problems untill I finally searched google for ubuntu averatec internet not work or some such thing and found this thread. Others have the problem too:
http://ubuntuforums.org/showthread.php?p=3752219

As another comment, does this affect acpi functionality at all?

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux:
status: New → Incomplete
Bill Egert (begert) wrote :

I will try and test this when I get some free time.

Bill Egert (begert) wrote :

I tried to test with Kubuntu Alpha3, but I could only get a console login with the LiveCD. I will try again later.

Hi Bill,

Just curious if you have been able to test the latest Hardy Alpha4 release. Please let us know your results? Thanks in advance.

Bill Egert (begert) wrote :

With Alpha4 I still get just a console login with the LiveCD.

-Bill

Timo Aaltonen (tjaalton) wrote :

Bill: please file a new bug about the livecd-problem against 'xorg'.

Can anyone else test with the latest Hardy Alpha release and verify if this is still an issue? We'll keep this report open against the actively developed kernel but against 2.6.22 this will be closed. Thanks.

Changed in linux:
importance: Unknown → Critical
Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
John Jaarsveld (joja) wrote :

I have a compaq armada E500 laptop, just put Hardy beta on it, and can confirm this bug.
To install Hardy I had to use acpi-off, or it would freeze rightaway.

For the rest Hardy works fine, except for networking.
The network-connect-button on right-top bar swirls when I plug the ethernet in, and displays a connection. I also tried to boot with
and without the network connected.

Searching on internet suggests that I may have to do with the BIOS, but I can't really get to fix it.
The latest BIOS update HP offers for the Armada E500 is from 2001, so I guess that is not the solution either.

I included my ping, dmesh, ifconfig and lspci -vv

Hi John,

Sorry for the delayed response. Care to open a new bug report? You seem to have a different set of hardware than the original bug reporter. It is helpful to the development teams if bug reports target one specific issue against a specific set of hardware. We can easily mark bugs as duplicates of one another later on if necessary. Also, in your new bug report if you could include the following debug information that would be great - https://wiki.ubuntu.com/KernelTeamBugPolicies .

Michael, since you are the original reporter, can you comment if this is still an issue with the final Hardy 8.04 release - http://www.ubuntu.com/getubuntu/download . Thanks.

Bill Egert (begert) wrote :

Sorry it has taken me so long, i will dig up my laptop and try to install Hardy on it soon, I will report here when I am done.

Leann, that laptop is currently my SO's primary machine, so I can't 'experiment' on it much (and I couldn't get the beta desktop LiveCD to finish booting in one recent window of opportunity). I'll be upgrading most of our machines to Hardy soon, and I'll check it out then.

I *suspect* it is still a problem, as it certainly was for Gutsy (as Scottopoly reported in November), and the same 'acpi=noirq' solution worked then, but I will (eventually) actually test against Hardy and make sure.

Bill Egert (begert) wrote :

I still just get a console login with the kubuntu live cd.
I will try installing from the main menu and see where I end up.

Bill Egert (begert) wrote :

Trying to install from the main menu did not even get me to a console, I was stuck at:

* Running local boot scripts (/etc/rc.local) [OK]
_

Bill, try installing with the *alternate* desktop CD.

Antonio (amla) wrote :

I can confirm this bug is still active after upgrading to Hardy. I have to add "irqpoll" to the kernel options to make ethernet work.

stedy (stedy6) wrote :

Is this bug in some way related to this ? Bug #118613 , Bug #109725 and Bug #219479 ?

nullack (nullack) wrote :

I have a Via Rhine 6102 rev7c. In my case, I have working eth0 but I "loose" eth0 after a period of no nic use - once this occurs it seems only a reboot with bring eth0 back. Using the grub boot option irqpoll is an effective workaround for my case. My bug is https://bugs.launchpad.net/ubuntu/+source/network-config/+bug/111282

Hi Everyone,

The upcoming Intrepid Ibex 8.10 release is actively being worked on. Care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. Thanks.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

nullack (nullack) wrote :

Hi Leann. As noted earlier in comments I have a VIA RHINE II revision C nic. There is no lockups that occur as the original bug stated through bouncing the network app or bouncing networking all together via the terminal. Also I am very pleased to advise that my related bug that I commented on is also fixed. Thank you to all involved, fantastic :) The latest tests I have done are on Linux PPP 2.6.27-2-generic #1 SMP Thu Aug 28 17:18:43 UTC 2008 x86_64 GNU/Linux,

Changed in linux:
status: Incomplete → Fix Released
Bill Egert (begert) wrote :

Tried 8.10 istall CD, stil just get a login.
Tried 8.10 alternative CD, Partinioning myself didn't sem to work on the CD, so I let it re-partition how it wanted to. Erased everything and then got stuck somewhere.

So basically my laptop is useless to me now and I could NOT verify that this bug has been fixed.

Epic Fail

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Shahar Or (mightyiam) wrote :

I've a Rhine II:
Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)

I've reported https://bugs.launchpad.net/ubuntu/+source/linux/+bug/641658 .

Blessings,
Shahar

To post a comment you must log in.