U9.10 geany cant open files on samba shares

Bug #479266 reported by jahst on 2009-11-09
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by rogmorri

Bug Description

On Ubuntu 9.04, I could mount a samba share and open txt, html, etc files in geany.

Upgraded to 9.10
Run same script to mount share.. share mounts fine.
Open file with geany and it returns an error:

Could not open file /home/username/mounted_share/junkfile.html (Value too large for defined data type)
root gksu geany gives same error.

I can open and edit the file gedit.. but it posts strange errors about the file no longer exists on the disk.
Ignore it and the file saves correctly in gedit.

I can open and save it normally in BlueFish

-------------------

Ubuntu 9.10 Karmic
Kernel Linux 2.6.31-14-generic
GNOME 2.28.1
Memory 993.1 MiB
Intel Pentium(R) 4 CPU 3.20 GHz

geany 0.18-1
gedit 2.28.0-0ubuntu2
bluefish 1.0.7-6ubuntu2

I attached the results of
apport-cli -f -p geany

* My first post to launchpad - I tried to research first, but if I missed something please correct me, so I can fix it next time... thanks.

jahst (christopherbowhuis) wrote :
description: updated
rogmorri (frontporsche) wrote :

See also bug 455122 -- there is a similar issue running gcc on a samba share.

It appears that only programs compiled with large-file support will work in a samba share in Karmic.

Rodrigo Gregorio (osgregs) wrote :

I managed to open the file with gedit, I copied and pasted the code in geany, so I keep editing the file, I saved over the old file while editing and testing the file ...
the other day when I open the file with any editor, could no longer, work a few days were lost because of geany

I think perhaps this may have happened because of the encryption used in ubuntu 9.10, I do not even have it active

if anyone knows this new encryption ubuntu 9:10 appreciate a tip

Pierre (snakepierre) wrote :

Same problem ! Please help, I use geany for work...

Pierre (snakepierre) wrote :

I resolved it : you have to use the nounix and noserverino options when you mount.

Thanks Pierre! I'll try it. I use Geany for work too.

My """solution""" until now was been copying the files to edit to the Linux disk and sync with the samba.

It works like a charm!

Thanks Pierre! Great fix!

jahst (christopherbowhuis) wrote :

Thanks Pierre!

I will try this tomorrow as my web design students are really really missing Geany

I have never heard of these mount options before.. how did you figure out to use them?

Pierre (snakepierre) wrote :

They talk about it in the <a href="https://bugs.launchpad.net/bugs/455122">bug 455122</a>

jahst (christopherbowhuis) wrote :

Tried the fix .. and Geany works fine for all PCs in the lab.

Thanks Pierre.

Do I need to do anything else to this post.. change status somehow?

Pierre (snakepierre) wrote :

Hum i don't know, for me it's not really fixed, these options shouldn't have to be given..

affects: ubuntu → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi jahst,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 479266

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
jahst (christopherbowhuis) wrote :

Well, I've actually updated my lab to 10.04 already... I needed some of the improvements it provides.
I did test it on that system and the error remains.

Ubuntu 10.04
Kernel Linux 2.6.32-21-generic
Gnome 2.30.0

If I remove the "nounix,noserverino" it gives the same issue.

so this works

mount.cifs //sambashare ~/mountpoint/ -o username="$UN",password="$PW",iocharset=utf8,nounix,noserverino,file_mode=0777,dir_mode=0777

But this still does not work

mount.cifs //sambashare ~/mountpoint/ -o username="$UN",password="$PW",iocharset=utf8,file_mode=0777,dir_mode=0777

Still gives Value too large error.

I tried your terminal command and received this error

' Error connecting to Launchpad: 'NoneType' object has no attribute 'makefile'
You can reset the credentials by removing the file "/home/username/.cache/apport/launchpad.credentials" '

But the folder "apport" is empty.

What else can I do?

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
rduke15 (rduke15) wrote :

Yes, this is still a problem in current Ubuntu 10.4. And it is easily reproducible. It needs to remain open until someone is able to find the real cause of the problem.

rduke15 (rduke15) on 2010-08-22
Changed in linux (Ubuntu):
status: Expired → New
rduke15 (rduke15) wrote :

Note only 2nd full link in previous comment 16 is correct. The first automatic link on the text "bug xx" is to something else. Sorry.

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 4328 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd6700000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1179ff66,00100003 HDA:11c11040,11790001,00100200'
   Controls : 17
   Simple ctrls : 11
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: TOSHIBA Satellite L300
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/09/2008
dmi.bios.vendor: INSYDE
dmi.bios.version: 1.50
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr1.50:bd12/09/2008:svnTOSHIBA:pnSatelliteL300:pvrPSLB8C-0HH01X:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite L300
dmi.product.version: PSLB8C-0HH01X
dmi.sys.vendor: TOSHIBA

tags: added: apport-collected
Brad Figg (brad-figg) on 2011-05-04
tags: added: b73a1py79
Brad Figg (brad-figg) wrote :

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in supported series, please file a new bug.

Changed in linux (Ubuntu):
status: New → Won't Fix
tags: removed: b73a1py79
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers