Ubuntu

Ubuntu does not work with rtl2832u-dvb-t-chip

Reported by criticalmess on 2009-11-08
62
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

Ok, installing the driver of this chip wasn't that easy but following several "finnish"-howtos i managed to succesfully build v4l-dvb driver for the rtl2832u-chiped MSI Digivox mini II V3.0.

lsusb:
Bus 001 Device 005: ID 1d19:1101

dmesg (regarded on stick-plugin):
[ 95.620012] usb 1-1: new high speed USB device using ehci_hcd and address 5
[ 95.782039] usb 1-1: configuration #1 chosen from 1 choice
[ 95.788734] dvb-usb: found a 'DK DVBT DONGLE' in warm state.
[ 95.788738] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 95.790373] DVB: registering new adapter (DK DVBT DONGLE)
[ 95.790607] DVB: registering adapter 0 frontend 0 (Realtek RTL2832 DVB-T)...
[ 95.790629] dvb-usb: DK DVBT DONGLE successfully initialized and connected.
[ 95.792426] dvb-usb: found a 'DK DVBT DONGLE' in warm state.
[ 95.792430] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 95.794467] DVB: registering new adapter (DK DVBT DONGLE)
[ 95.794684] DVB: registering adapter 1 frontend 0 (Realtek RTL2832 DVB-T)...
[ 95.794707] dvb-usb: DK DVBT DONGLE successfully initialized and connected.

scan /usr/share/dvb/dvb-t/de-Nordrhein-Westfalen delivers all channels that i know off.
example output:

>>> tune to: 538000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
0x0000 0x4015: pmt_pid 0x0150 RTL World -- RTL Television (running)
0x0000 0x4016: pmt_pid 0x0160 RTL World -- RTL2 (running)
0x0000 0x401b: pmt_pid 0x01b0 RTL World -- Super RTL (running)
0x0000 0x4022: pmt_pid 0x0220 RTL World -- VOX (running)

kaffeine scans all channels properly too and i can watch everything probably if i tune my antenna up to 18db, but kaffeine is kde based and i would like to have gnome/gtk based me-tv.

Me-TV cannot find ANY channels (0) when i use internal scan:
example output:

08.11.2009 15:15:43: Tuning to transponder at 538000000 Hz
08.11.2009 15:15:43: Auf Signalsperre warten … (translation: waiting for signal lock)
08.11.2009 15:15:55: Poking screensaver
08.11.2009 15:15:58: Status: 0
08.11.2009 15:15:58: Currently tuned to freq 538000000, symbol rate 0, inner fec 2
08.11.2009 15:15:58: Exception: Sperren des Kanals fehlgeschlagen (translation: failed to lock channel)
08.11.2009 15:15:58: Failed to tune to transponder at 538000000 Hz

So i tried to import the channels.conf-output that i generated with scan.
Me-Tv seems to work, adds all channels, but stucks heavily and cannot show tv properly due to weak signal...

criticalmess (criticalmess) wrote :

How did i installed it:

sudo apt-get install unrar build-essential mercurial
mkdir digivox; cd digivox
hg clone http://linuxtv.org/hg/v4l-dvb
wget http://media.ubuntuusers.de/forum/attachments/2103272/090730_RTL2832U_LINUX_Ver1.1.rar
unrar x -ep 090730_RTL2832U_LINUX_Ver1.1.rar ./v4l-dvb/linux/drivers/media/dvb/dvb-usb
cd v4l-dvb
for i in `find . -name *.pl`; do chmod +x $i ; done
gedit ./linux/drivers/media/dvb/dvb-usb/Makefile

(Insertion nearly to the end of file:)
dvb-usb-rtl2832u-objs = demod_rtl2832.o dvbt_demod_base.o dvbt_nim_base.o foundation.o math_mpi.o nim_rtl2832_mxl5007t.o nim_rtl2832_fc2580.o nim_rtl2832_mt2266.o rtl2832u.o rtl2832u_fe.o rtl2832u_io.o tuner_mxl5007t.o tuner_fc2580.o tuner_mt2266.o tuner_tua9001.o nim_rtl2832_tua9001.o
obj-$(CONFIG_DVB_USB_RTL2832U) += dvb-usb-rtl2832u.o

gedit ./linux/drivers/media/dvb/dvb-usb/Kconfig

(Insertion to the end of file:)
config DVB_USB_RTL2832U
        tristate "Realtek RTL2832U DVB-T USB2.0 support"
        depends on DVB_USB
        help
          Realtek RTL2832U DVB-T driver

gedit ./linux/drivers/media/dvb/dvb-usb/rtl2832u.c

(1. Remove // of line 12:)
//DVB_DEFINE_MOD_OPT_ADAPTER_NR(adapter_nr);

(2. replace line 61-63 by:)
        if ( ( 0== dvb_usb_device_init(intf,&rtl2832u_1st_properties,THIS_MODULE,NULL,adapter_nr) )||
                ( 0== dvb_usb_device_init(intf,&rtl2832u_2nd_properties,THIS_MODULE,NULL,adapter_nr) ) ||
                ( 0== dvb_usb_device_init(intf,&rtl2832u_3th_properties,THIS_MODULE,NULL,adapter_nr) ))

gedit ./linux/drivers/media/dvb/dvb-usb/tuner_tua9001.c

(search for 19.2 AND 20.48 and replace it by 19_2 AND 20_48:)
#elif defined(CRYSTAL_19.2_MHZ) /* Frequency 19.2 MHz */
#elif defined(CRYSTAL_19_2_MHZ) /* Frequency 19.2 MHz */
#elif defined(CRYSTAL_20.48_MHZ) /* Frequency 20,48 MHz */
#elif defined(CRYSTAL_20_48_MHZ) /* Frequency 20,48 MHz */

make

STRG^C after some secs.

gedit ./v4l/.config

(replace FIREDTV=m by FIREDTV=n:)
CONFIG_DVB_FIREDTV=m
CONFIG_DVB_FIREDTV=n

make clean
make
sudo make install

After that the stick is properly found, registered and is working with kaffeine. But me-tv claims bad signal.

affects: udev (Ubuntu) → me-tv (Ubuntu)

I cannot replicate this.

Changed in me-tv (Ubuntu):
status: New → Incomplete
MarcRandolph (mrand) wrote :

> Michael Lamothe wrote on 2009-12-17
>
> I cannot replicate this.

Howdy Michael, could you please expand on what you mean that you can not replicate?

A) you don't have the hardware to reproduce the issue

-or-

B) you have the hardware and it works fine

criticalmess, is this still a problem? If so, what is the output of "apt-cache policy me-tv"?

MarcRandolph schrieb:
>> criticalmess, is this still a problem? If so, what is the output of "apt-cache policy me-tv"?
>>
I cannot replicate it again, because i have no more access to the
rtl2832u-dvb-t-chip and im very sorry that i lost the link to the
finnish-manual and driver.

Please just close it if anybody claims a rtl2832u-dvb-t-chip working
with me-tv.
All new MSI Digivox mini II V3.0 seem to got those chips; the stick
itself is very cheap.
So if you really wanted so reproduce then you need to buy that stick or
look for people with hardware equiped to troubleshoot functionality.

What i can tell you is that same system with same model-brand named
usb-stick - but different chip (the af9015, which is mine) - worked
without the noted locking errors and that the driver has properly
isntalled and firmware was properly in place, because kaffeine orked on
BOTH chips.

It is possible that it has been fixed at all since a long time, i really
cant tell anymore, sry.

MHB (mhb-monomania) wrote :

I have the same cheap MSI DIGI VOX mini Deluxe DVB-T stick (rtl2832u-dvb-t) as shown above. In Karmic I had similar experiences: working DVB-T for all channels in de-Niedersachsen in VLC and mplayer, but no possibility to scan or import in me-tv. Now in Lucid, again with v4l modules build as above, in Me-TV 1.1.2, scanning picks up all channels available. The only odd thing so far is that the Meters window shows a signal strength or 3% with 0% S/N ratio. Seems a little low to me, but that is probably the module rather than me-tv.

So I'm assuming all is good now.

Changed in me-tv (Ubuntu):
status: Incomplete → Invalid
Mehdi Fattahi (mehdifattahi) wrote :
Download full text (29.1 KiB)

Hi I did everything as described above but I get the following error:
mahdi@mahdi-desktop:~/Desktop/v4l-dvb-82a9eead02b7$ make
make -C /home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l
make[1]: Entering directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l'
No version yet, using 2.6.32-22-generic
make[1]: Leaving directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l'
make[1]: Entering directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l'
scripts/make_makefile.pl
Updating/Creating .config
Preparing to compile for kernel version 2.6.32

***WARNING:*** You do not have the full kernel sources installed.
This does not prevent you from building the v4l-dvb tree if you have the
kernel headers, but the full kernel source may be required in order to use
make menuconfig / xconfig / qconfig.

If you are experiencing problems building the v4l-dvb tree, please try
building against a vanilla kernel before reporting a bug.

Vanilla kernels are available at http://kernel.org.
On most distros, this will compile a newly downloaded kernel:

cp /boot/config-`uname -r` <your kernel dir>/.config
cd <your kernel dir>
make all modules_install install

Please see your distro's web site for instructions to build a new kernel.

V4L2_MEM2MEM_DEV: Requires at least kernel 2.6.33
VIDEO_TVP7002: Requires at least kernel 2.6.34
VIDEO_AK881X: Requires at least kernel 2.6.33
SOC_CAMERA: Requires at least kernel 2.6.33
SOC_CAMERA_MT9M001: Requires at least kernel 2.6.33
SOC_CAMERA_MT9M111: Requires at least kernel 2.6.33
SOC_CAMERA_MT9T031: Requires at least kernel 2.6.33
SOC_CAMERA_MT9V022: Requires at least kernel 2.6.33
SOC_CAMERA_TW9910: Requires at least kernel 2.6.33
SOC_CAMERA_PLATFORM: Requires at least kernel 2.6.33
SOC_CAMERA_OV772X: Requires at least kernel 2.6.33
RADIO_SAA7706H: Requires at least kernel 2.6.34
Created default (all yes) .config file
./scripts/make_myconfig.pl
make[1]: Leaving directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l'
make[1]: Entering directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l'
perl scripts/make_config_compat.pl /lib/modules/2.6.32-22-generic/build ./.myconfig ./config-compat.h
creating symbolic links...
ln -sf . oss
make -C firmware prep
make[2]: Entering directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/firmware'
make[2]: Leaving directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/firmware'
make -C firmware
make[2]: Entering directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/firmware'
  CC ihex2fw
Generating vicam/firmware.fw
Generating dabusb/firmware.fw
Generating dabusb/bitstream.bin
Generating ttusb-budget/dspbootcode.bin
Generating cpia2/stv0672_vp4.bin
Generating av7110/bootcode.bin
make[2]: Leaving directory `/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/firmware'
Kernel build directory is /lib/modules/2.6.32-22-generic/build
make -C /lib/modules/2.6.32-22-generic/build SUBDIRS=/home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.32-22-generic'
  CC [M] /home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/tuner-xc2028.o
  CC [M] /home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/tuner-simple.o
  CC [M] /home/mahdi/Desktop/v4l-dvb-82a9eead02b7/v4l/tun...

Ngassam Nkwenga (cyrildz) wrote :

@MHB: I have the same cheap but I can't have it running. I always have a compile error. how did you manage to have it working ?

Manuel Seoane (msr1317) wrote :

Hi, I have tried to install rtl2832u in Ubuntu 11.04 Natty Narwhal, 2.6.38-8-generic. But I don't get it
Could you help me, please?

lsusb
Bus 002 Device 006: ID 1f4d:b803 G-Tek Electronics Group Lifeview LV5TDLX DVB-T [RTL2832U]

Thank you

Manuel Seoane
<email address hidden>

jan (jan-ubuntu-h-i-s) wrote :

This card is not at all supported by the v4l team.

There was a working version which was not up to coding standards, but ran up / including Ubuntu's last LTS release (Lucid).
After that, the v4l version control and build system has been changed, and the driver does not compile anymore.

I have decided AGAINST making it runnable on newer kernels, as there are some people working right now on a new release.

Once the status becomes more clear, I'll update
http://www.linuxtv.org/wiki/index.php/Realtek_RTL2831U

jan (jan-ubuntu-h-i-s) on 2011-07-02
Changed in me-tv (Ubuntu):
assignee: nobody → jan (jan-ubuntu-h-i-s)
robytrevi (robytrevi) wrote :

@jan

Do you know if there's something new?
I've got the 1f4d:b803 G-Tek Electronics Group Lifeview LV5TDLX DVB-T [RTL2832U]. I tried to compile different drivers but none work. I tried them under Natty and under Oneiric and the result was the same.
You wrote that there was a driver that works with Lucid. Can you explain which is and how to compile/install it properly? By now I'm really confused, I'm trying lots of things but nothing work.
Thanks

Sinisa Radalj (sinisa1hr) wrote :

bump

robytrevi (robytrevi) wrote :

I can't install the driver also on Lucid.

robytrevi (robytrevi) wrote :

On Lucid Linx with kernel 2.6.32-36-generic with the guide I found here http://www.ubuntu-es.org/node/123739#comment-370386 at post "Nueva version 1.4" I installed the correct driver. Now I can use the Device with Kaffeine. Metv found the device but not the channels.

summary: - me-tv does not work with rtl2832u-dvb-t-chip
+ Ubuntu does not work with rtl2832u-dvb-t-chip
affects: me-tv (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 478379

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
artūras (arturaskaunas) wrote :

i've invoked command 'apport-collect 478379' in terminal, but then i got google chromium browser window opened and i choosed 'change anything' The application will be able to access Launchpad on your behalf for reading and changing anything, including private data.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Download full text (3.8 KiB)

If your device work with Kaffeine, it will work with me-tv. The best way to
scan your channel is to create a "channels.conf" file with the command
w_scan in command line (you can also try "scan") then your import it in
me-tv.

On Tue, Dec 6, 2011 at 6:23 AM, robytrevi <email address hidden> wrote:

> On Lucid Linx with kernel 2.6.32-36-generic with the guide I found here
> http://www.ubuntu-es.org/node/123739#comment-370386 at post "Nueva
> version 1.4" I installed the correct driver. Now I can use the Device
> with Kaffeine. Metv found the device but not the channels.
>
> --
> You received this bug notification because you are a member of Me TV
> Development, which is subscribed to me-tv in Ubuntu.
> https://bugs.launchpad.net/bugs/478379
>
> Title:
> me-tv does not work with rtl2832u-dvb-t-chip
>
> Status in “me-tv” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: udev
>
> Ok, installing the driver of this chip wasn't that easy but following
> several "finnish"-howtos i managed to succesfully build v4l-dvb driver
> for the rtl2832u-chiped MSI Digivox mini II V3.0.
>
> lsusb:
> Bus 001 Device 005: ID 1d19:1101
>
> dmesg (regarded on stick-plugin):
> [ 95.620012] usb 1-1: new high speed USB device using ehci_hcd and
> address 5
> [ 95.782039] usb 1-1: configuration #1 chosen from 1 choice
> [ 95.788734] dvb-usb: found a 'DK DVBT DONGLE' in warm state.
> [ 95.788738] dvb-usb: will pass the complete MPEG2 transport stream to
> the software demuxer.
> [ 95.790373] DVB: registering new adapter (DK DVBT DONGLE)
> [ 95.790607] DVB: registering adapter 0 frontend 0 (Realtek RTL2832
> DVB-T)...
> [ 95.790629] dvb-usb: DK DVBT DONGLE successfully initialized and
> connected.
> [ 95.792426] dvb-usb: found a 'DK DVBT DONGLE' in warm state.
> [ 95.792430] dvb-usb: will pass the complete MPEG2 transport stream to
> the software demuxer.
> [ 95.794467] DVB: registering new adapter (DK DVBT DONGLE)
> [ 95.794684] DVB: registering adapter 1 frontend 0 (Realtek RTL2832
> DVB-T)...
> [ 95.794707] dvb-usb: DK DVBT DONGLE successfully initialized and
> connected.
>
> scan /usr/share/dvb/dvb-t/de-Nordrhein-Westfalen delivers all channels
> that i know off.
> example output:
>
> >>> tune to:
> 538000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
> 0x0000 0x4015: pmt_pid 0x0150 RTL World -- RTL Television (running)
> 0x0000 0x4016: pmt_pid 0x0160 RTL World -- RTL2 (running)
> 0x0000 0x401b: pmt_pid 0x01b0 RTL World -- Super RTL (running)
> 0x0000 0x4022: pmt_pid 0x0220 RTL World -- VOX (running)
>
>
> kaffeine scans all channels properly too and i can watch everything
> probably if i tune my antenna up to 18db, but kaffeine is kde based and i
> would like to have gnome/gtk based me-tv.
>
> Me-TV cannot find ANY channels (0) when i use internal scan:
> example output:
>
> 08.11.2009 15:15:43: Tuning to transponder at 538000000 Hz
> 08.11.2009 15:15:43: Auf Signalsperre warten …
> (translation: waiting for signal lock)
> 08.11.2009 15:15:55: Poking screensaver
> 08.11.2009 15:15:58: Status: 0
> 08.11.2009 15:15:58...

Read more...

robytrevi (robytrevi) wrote :

What about newer version of ubuntu. The device is recognise by lsusb but it doesn't work. There's no driver rtl2832u found.

York Wu (yorkwoo) wrote :

I have tried Ubuntu 11.10 and Mint12. Both work successfully.
My device is UPMOST DVB190, which has device ID as 1d19:1102.

I followed steps written on the following page:
https://github.com/ambrosa/DVB-Realtek-RTL2832U-2.2.2-10tuner-mod_kernel-3.0.0

After installed the compiled module, it detected my device and works with me-tv perfectly.
But I still don't get how to make VLC work.
I think it should work for all distributions based on kernel 3.0 or above.

criticalmess, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
robytrevi (robytrevi) wrote :

With this: lots of devices work fine: http://xgazza.altervista.org/Linux/index.html

Alexander Winizki (awinizki) wrote :

My device is:
$ lsusb
Bus 002 Device 006: ID 1f4d:b803 G-Tek Electronics Group Lifeview LV5TDLX DVB-T [RTL2832U]

w_scan
w_scan version 20111203 (compiled for DVB API 5.4)
guessing country 'DE', use -c <country> to override
using settings for GERMANY
DVB aerial
DVB-T Europe
frontend_type DVB-T, channellist 4
output format vdr-1.6
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
main:3079: FATAL: ***** NO USEABLE DVB-T CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

Alexander Winizki (awinizki) wrote :

Sorry, I forgot: I use Oneiric

Alexander Winizki (awinizki) wrote :

I must correct the above: It is 12.04, not Oneiric

Alexander Winizki, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

jan (jan-ubuntu-h-i-s) wrote :

Currently, there is a reasonable workaround:
Follow the steps under
"How to build the v4l-dvb kernel modules from the backport tree"
at http://linuxtv.org/repo/

Drivers for many rtl2832u cards are supported in the current development version.
Inclusion in a main-line kernel will follow later.

robb990099 (rebrown) wrote :

rtl2832u is still a problem on older kernels. Works fine otb for 3.11 e.g on Ubuntu 13.10 but I am trying to get this module compiled for any kernel that will work on sun4i i.e. armv7 such as 3.10.25 which is good on raspberry pi. The source files for the module are not available on kernel 3.4 at sunxi and neither 3.10-reference nor experimental/sunxi-3.10 will boot. Is 3.13 from Hans de Goede likely to be a better prospect?
Thanks for any pointers.

robb990099, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
assignee: jan (jan-ubuntu-h-i-s) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions