wacom bamboo pen & touch not working

Bug #477105 reported by Oscar D. Franco on 2009-11-07
156
This bug affects 26 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Timo Aaltonen
Declined for Lucid by Timo Aaltonen
Declined for Maverick by Timo Aaltonen
xf86-input-wacom (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Timo Aaltonen
Declined for Lucid by Timo Aaltonen
Declined for Maverick by Timo Aaltonen

Bug Description

I recently aquired a very recent wacom model, the bamboo pen & touch, it allows to control the cursor by a tactil and pen input, but ubuntu fails to recognize any of the inputs

I read in some forum that the gesture recognition was far from being developed, I am not that desperate for gesture and tactil input, but I'd really like the pen input to work like any other wacom tablet

The tablet led turns red when the pen comes close to the surface the same way in windows does, and shine brighter when a finger touchs it

I'm not sure if this is the place to post this, but if the other recent models like intuos4 work in karmic with the new wacom support I think this could actually be some kind of conflict between the two inputs

thanks

andrewthe333rd (andrew-graylin) wrote :

I also have the same model.. The CTH-460 and am not finding a low of hits in terms of support on this...

Running Karmic.

Please help :).

Thanks

Iulia (carla-srst) wrote :

I have a Wacom bamboo pen and happens the same for me, nothing works, the only thing I know is that appears here :

Bus 002 Device 005: ID 056a:00d4 Wacom Co., Ltd

Wacom control pannel says no graphic tablet is detected....

Iulia (carla-srst) wrote :

I forgot to say I use 9.04

h3 (h3) wrote :

Same problem here ..

Wacom Bamboo Pen & Touch (Model: CTH-460K)

This is the dmesg I get when pluging the device:

[ 4043.095387] usb 4-1: new full speed USB device using uhci_hcd and address 8
[ 4043.271700] usb 4-1: configuration #1 chosen from 1 choice
[ 4043.442514] usb 5-1: new full speed USB device using uhci_hcd and address 18
[ 4058.560012] usb 5-1: device descriptor read/64, error -110
[ 4073.791263] usb 5-1: device descriptor read/64, error -110
[ 4074.021264] usb 5-1: new full speed USB device using uhci_hcd and address 19
[ 4089.142517] usb 5-1: device descriptor read/64, error -110
[ 4104.370014] usb 5-1: device descriptor read/64, error -110
[ 4104.600013] usb 5-1: new full speed USB device using uhci_hcd and address 20
[ 4115.020020] usb 5-1: device not accepting address 20, error -110
[ 4115.143768] usb 5-1: new full speed USB device using uhci_hcd and address 21
[ 4125.562511] usb 5-1: device not accepting address 21, error -110
[ 4125.562527] hub 5-0:1.0: unable to enumerate USB device on port 1

Linux 2.6.31-16-generic #52-Ubuntu SMP Thu Dec 3 22:07:16 UTC 2009 x86_64 GNU/Linux

h3 (h3) wrote :

I finally got the stylus/eraser working ..

I followed those instructions:

http://ubuntuforums.org/showpost.php?p=8262965&postcount=541

The only difference is that I used the latest drivers version (8.4-4 instead of 8.4-3)

The touch feature and side tablet buttons still don't work and I did not check if the pressure works yet.

I tried to get it working on Virtualbox, but I had to follow this tutorial to get USB working:

http://news.softpedia.com/news/How-to-Fix-VirtualBox-USB-Support-111715.shtml

Now when I enable USB for the Wacom device X crash instantly ..

I'm stuck there :|

h3 (h3) wrote :

OK .. turns out X does not crash if I enable the device while running in seamless mode.

Windows finds the tablet as soon as I activate USB on the Wacom, the Wacom drivers also find the tablet and
is able to configure it.

stylus/pressure/eraser and side buttons works but with some quirks .. the drawing is really lagging and the touch feature is either really hard to use or not working properly .. the only gesture I manage to do is zoom in / zoom out and some scrolling..

Alexandru Bolboaca (alex-boly) wrote :

I have a Wacom Bamboo Fun Pen & Touch and it's not recognized by ubuntu karmic.

The dmesg output is:

[ 3742.001165] usb 5-1: new full speed USB device using uhci_hcd and address 4
[ 3742.167368] usb 5-1: configuration #1 chosen from 1 choice

The xinput --list output is attached (nothing about the tablet).

The xsetwacom list output is empty.

Silvano (silvavlis) wrote :

I just tried the instructions and patches of the post [1] and it works! I'm using Karmic and a Bamboo Pen & Touch (CTH-460).

[1] http://ubuntuforums.org/showpost.php?p=8283168&postcount=1

Letatcest (ksoeteman) wrote :

I followed the instructions in this thread a few times already:

http://ubuntuforums.org/showpost.php?p=8283168&postcount=1

and then I get the Wacom CTH-460 to work. It works quite good after installing it! But, then after a few day's/weeks the pad stops working and I have to follow the ubuntuforums instructions again and everything is fine.

I realise it might have to do with kernel updates, but I remember testing the pad after the most recent update to .20

I don't use the pad on a daily basis, only for some retoutching, but I never take it out of its USB port.

Bryce Harrington (bryce) on 2010-04-06
tags: added: karmic

Subscribers, you can test this bug in Lucid beta2?
Also, here intresting tool for KDE users: http://kde-apps.org/content/show.php/kcm+tablet?content=114856

I have the simpler model (without Touch, CTL 640), and it doesn't work in Lucid either. Thats because you need the newest kernel module from linuxwacom.sf.net If you install that (so just wacom.ko, nothing else) it will work fine in Lucid.

To get it working in Karmic, you also need the .fdi file and the xorg driver.

stblack (stblack-linux) wrote :

Please note that I am using ubuntu 10.04 Beta 2 and the bug is still present.
I have a Wacom Pen 6 Touch (CTH-461).
When I plug in, I see in the dmesg only:
[16936.330110] usb 4-2: new full speed USB device using uhci_hcd and address 4
[16936.561394] usb 4-2: configuration #1 chosen from 1 choice

Thanks
Stefano

tags: added: kj-triage
Bryan Hundven (bryanhundven) wrote :

For lucid, wouldn't this be a duplicate of 568064, or 568064 be a duplicate of this bug?

From related bug #568064: I compilled and installed manually the current stable driver from linuxwacom succesfuly, but it is not the point. Each time the kernel will be updated, will be required to reinstall the wacom module manually, and this is a pain that will stay three long years (This is an LTS). Implementing a solution based on DKMS, is very complex for the user, and at this point the ease of use of Ubuntu is going to heck. I think for the welfare of users and the strength of Ubuntu, this should be an issue to resolve soon.

Richard Corner (rcorner) on 2010-05-01
tags: added: bamboo driver lucid tablet wacom
Marcus Wanner (marcusw-cox) wrote :

Using Wacom Bamboo Pen (CTL-460/K) and Kubuntu 10.04 LST here, followed the instructions here: http://ubuntuforums.org/showpost.php?p=9119518&postcount=782 and that made it work perfectly, including pressure sensitivity in GIMP. Not very user-friendly, though :(

2010/5/12 Marcus Wanner <email address hidden>

> Using Wacom Bamboo Pen (CTL-460/K) and Kubuntu 10.04 LST here, followed
> the instructions here:
> http://ubuntuforums.org/showpost.php?p=9119518&postcount=782 and that
> made it work perfectly, including pressure sensitivity in GIMP. Not very
> user-friendly, though :(
>
> --
> wacom bamboo pen & touch not working in karmic
> https://bugs.launchpad.net/bugs/477105
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thanks Marcus!
I'll try and revert .

--
Ciao
Stblack
http://stblack.blogspot.com/

Any chance of getting this into kernel package (only one file needed to get this bug sorted)?
(found at: http://frankgroeneveld.nl/2010/04/11/get-wacom-bamboo-fun-pen-working-in-ubuntu-lucid/)

sudo apt-get install build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev tk8.4-dev tcl8.4-dev libncurses5-dev
wget http://downloads.sourceforge.net/project/linuxwacom/linuxwacom/0.8.6-2/linuxwacom-0.8.6-2.tar.bz2
tar -xvjf linuxwacom-0.8.6-2.tar.bz2
cd linuxwacom-0.8.6-2
./configure --enable-wacom
cd src/2.6.30/ # I know this is the wrong version, but it's the highest available and it works
make
sudo cp wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/
sudo rmmod wacom
sudo modprobe wacom

Espen: This post is related to Karmic and your instructions are the ones for Lucid. In karmic is a little different, I take it from the frankgroeneweld.nl site as well:

tar -xf linuxwacom-0.8.6.tar.bz2
cd linuxwacom-0.8.6
./configure --enable-wacom
make
# I know 2.6.30 is the wrong number, but it's the highest available and it works just fine
sudo cp src/2.6.30/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/
sudo cp src/util/10-linuxwacom.fdi /usr/share/hal/fdi/policy/20thirdparty/10-linuxwacom.fdi
sudo cp src/xdrv/wacom_drv.so /usr/lib/xorg/modules/input/wacom_drv.so

Nothe the differences:
-- The compilation is executed in the linuxwacom-0.8.6 directory instead of src/2.6.30/
-- In this approach are required to copy de fdi file and the wacom_drv.so as the wacom.ko file

Regards

Jeremy Foshee (jeremyfoshee) wrote :

Hi Oscar,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 477105

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
Thomas Bechtold (toabctl) wrote :

i have a bamboo pen & touch cth 661 which does not work with lucid and also does not work with maverick.

Changed in linux (Ubuntu):
status: Incomplete → New

Thomas:

I suggest you follow the bug report 23 that is related to Lucid. This thread is for Karmic. In that thread there are alternatives to solve the problem.

Sorry. I wrote the wrong bug report in my last post!

I suggest you follow the bug report #568064 which is related to Lucid. This thread is for Karmic. In that thread there are alternatives to solve the problem.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in xf86-input-wacom (Ubuntu):
status: New → Confirmed
mutrax (ed-driesen) wrote :

Hey, had some trouble getting it to work with Frank's instructions (my bad...)... These however " http://ubuntuper.wordpress.com/2010/06/18/installing-new-wacom-pen-in-ubuntu-lucid-lynx-10-04/ " did the trick for me.

madbiologist (me-again) wrote :

@Thomas Bechtold - Please post the output of lsusb. If you have the Pen and Touch CTH661/L (USB ID 0xdb or just db), support has been added upstream in the Linux 2.6.37 kernel.

Duncan McGreggor (oubiwann) wrote :

As madbiologist alluded with the upstream comment, the uTouch team added support for Bamboo in Maverick. Henrik can provide more details.

Changed in utouch:
assignee: nobody → Henrik Rydberg (rydberg)
milestone: none → ubuntu-10.10
milestone: ubuntu-10.10 → none
importance: Undecided → Wishlist
Henrik Rydberg (rydberg) wrote :

Old bug so hard to tell what you fine people are running now, but there are two things that might be possible off-hand:

1. Install the linux-backports-modules-input package (in ubuntu backports repo).

2. Install the hid-wacom-dkms package (utouch ppa)

The first approach should be valid for Lucid, the second for Maverick, and for Natty, none should be needed.

> and for Natty, none should be needed

summary: - wacom bamboo pen & touch not working in karmic
+ wacom bamboo pen & touch not working
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in xf86-input-wacom (Ubuntu):
status: Confirmed → Fix Released
no longer affects: utouch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers