suspend to RAM crash when SD card filesystem mounted

Bug #468298 reported by jpiesing on 2009-11-01
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Binary package hint: pm-utils

Just installed karmic on this laptop. Now if I suspend to RAM with the SD card mounted, the system just hangs some way down in the process. It's 100% reproducible in my tests so far. It worked fine in previous releases. It works fine if I unmount the card (but leave it in the slot).

ProblemType: Bug
Architecture: i386
Date: Sun Nov 1 10:53:49 2009
DistroRelease: Ubuntu 9.10
Package: pm-utils 1.2.5-2ubuntu7
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: pm-utils
Uname: Linux 2.6.31-14-generic i686

jpiesing (jon33040) wrote :
jpiesing (jon33040) wrote :
jpiesing (jon33040) wrote :

I've tried the instructions in the DebuggingKernelSuspendHibernateResume wiki under "Suspending from text mode". The system hangs when I do pm-suspend but no output is printed.

Shady Samir (shadysamirsobhi) wrote :

I have suspend/hibernate problems with Karmic as well. Never thought it's related to the mounted SD card I have. I guess I will test with it to see if it's the real reason behind the problem

Shady Samir (shadysamirsobhi) wrote :

I tested with and without SD card mounted. Problem exists with the SD card. Having no problem suspending/hibernating without an SD card.

Changed in pm-utils (Ubuntu):
status: New → Confirmed
lotharmat (matdcooke) wrote :

I have also tested with and without SD Card.

Worked perfectly well in Jaunty with SD Card Mounted

I can also confirm this. I did a lot of testing to narrow down the problem. When my SD card is formatted with the vfat filesystem, and is mounted, Suspend does not work. I reformatted the SD card with ext3 and ext4 and had no problem.
If I umount the vfat filesystem and keep the card in, suspend works fine.
The only time suspend does not work, is with vfat mounted and the SD card in the slot.
As a work around I have just moved my SD card to ext4
I am using a T61p, with 2.6.31-15.

FlagMan (flagman) wrote :

I had this problem, too.
Thanks to you guys I now have a workaround to share:

I created /etc/pm/sleep.d/20_umount-fat with the content below and did a 'chmod 755' on it.


case "${1}" in
          for MOUNTPOINT in `mount | grep vfat | awk '{print $3}'` ;
            umount $MOUNTPOINT ;
          # nothing

lotharmat (matdcooke) wrote :

Thanks for this FlagMan!

Worked a treat on my laptop!

Antti Kaihola (akaihola) wrote :

I had this problem in Lucid on my Dell Mini 9, and it doesn't seem to be fixed in Maverick.

cement_head (andor-udel) wrote :

Also reported here:

workaround in #8 worked for me.

- CH

jpiesing, thank you for reporting this bug to Ubuntu. Karmic reached EOL on April 30, 2011.
See this document for currently supported Ubuntu releases:

Is this reproducible in the latest release of Ubuntu via ?

If so, please execute the following via a terminal in order for the necessary debugging information to be attached:
apport-collect 468298

affects: pm-utils (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers