Comment 45 for bug 464559

I know this has been closed. I don't think it should, since many people are affected by this. Today, I found the post with a probable solution. It seems, indeed that it has to do with the SOFT and HARD locks. The link to the solution is posted at the end of: http://ubuntuforums.org/showthread.php?t=1311886 (the direct link is http://www.opennet.ru/tips/info/2214.shtml). They provide code to cope with the problem. It has worked for me (for now). I have been having this problem since Karmic. I did not read the full posts, thus I don't know if some other people have been struggling with the nm-applet disabling the wireless connection. At first, I thought that my enable/disable physical switch was the problem, but no. Then I thought it was network-manager: nop. Now, I can run <code>ifconfig wlan0 down && ifconfig wlan0 up</code> without loosing my connection. See the links for an explanation. I am posting this because I really consider that there are a lot of people looking for a solution. By the way, I also tried the ath5k path, but it did not fully work. Cheers