Sound isn't working on MacBook 5,2

Bug #463178 reported by David Stansby on 2009-10-29
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
linux (Ubuntu)
Undecided
Luke Yelavich
Lucid
Undecided
Unassigned

Bug Description

No sound is working on my MacBook 5,2. The only other information I have is that the headphone jack has a red LED on.

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dstansby 1459 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0x93480000 irq 22'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b4a00,00100103'
   Controls : 32
   Simple ctrls : 17
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
NonfreeKernelModules: wl
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/16/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB52.88Z.0088.B05.0904162222
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22788AA
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788AA
dmi.modalias: dmi:bvnAppleInc.:bvrMB52.88Z.0088.B05.0904162222:bd04/16/09:svnAppleInc.:pnMacBook5,2:pvr1.0:rvnAppleInc.:rnMac-F22788AA:rvr:cvnAppleInc.:ct10:cvrMac-F22788AA:
dmi.product.name: MacBook5,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Try this. Open /etc/modprobe.d/alsa-base.conf in an editor, and at the end of this line:

options snd-hda-intel power_save=10 power_save_controller=N

Add "model=mb5" like this:

options snd-hda-intel power_save=10 power_save_controller=N model=mb5

Then reboot, and let me know whether you get sound.

 affects ubuntu/alsa-driver
 status incomplete

Changed in alsa-driver (Ubuntu):
status: New → Incomplete

I've tried that, but still no sound. I do, however, hear the speakers kind of popping (for want of a better word) during the logon process.

Changed in alsa-driver (Ubuntu):
status: Incomplete → New
Daniel T Chen (crimsun) wrote :

Have you tried installing linux-backports-modules-alsa-karmic and rebooting?

On Oct 30, 2009 6:45 AM, "David Stansby" <email address hidden> wrote:

I've tried that, but still no sound. I do, however, hear the speakers
kind of popping (for want of a better word) during the logon process.

** Changed in: alsa-driver (Ubuntu)
      Status: Incomplete => New

-- Sound isn't working on MacBook 5,2
https://bugs.launchpad.net/bugs/463178You received this bug...

I've just installed linux-backports-modules-alsa-karmic and I'm still just getting a slight popping sound from the speakers during the login sequence.

This is still a problem in the latest version of karmic

Just upgraded to Lucid, and sound is working fine for me.

Daniel T Chen (crimsun) on 2010-03-13
Changed in alsa-driver (Ubuntu):
status: New → Fix Released

I've just done a fresh install of Lucid, and sound isn't working again. It must've been some jiggerypokery that I'd done last time to get it working.

Changed in alsa-driver (Ubuntu):
status: Fix Released → New
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

I've just run the alsa shell script, and my sound details can be found here: http://www.alsa-project.org/db/?f=cea0317330f90927f7d155012081c30a38f35465

Could you please add the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=mb5

Once added, save the file, and reboot. Please report back as to whether you have sound working after the reboot.

Thanks

 affects ubuntu/alsa-driver
 status incomplete

Changed in alsa-driver (Ubuntu):
status: New → Incomplete

After adding that line my audio works fine, albeit it sounds a bit tinny.

Luke Yelavich (themuso) wrote :

Ok, thats a start. Are you able to get rid of the tinny sound by adjusting volume settings?

In the meantime, I'll send a patch upstream to make the model-mb5 setting for your hardware perminant, thereby eliminating the need for the options line. This change should land in the final maverick kernel.

 affects ubuntu/alsa-driver
 status triaged

Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
Luke Yelavich (themuso) on 2010-06-22
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: Triaged → In Progress

Cheers, now working out of the box :)

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in mactel-support:
status: New → Fix Released
Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Ubuntu Lucid repo are:

b287a55 ALSA: hda - Add Macbook 5,2 quirk

Changed in linux (Ubuntu):
milestone: none → lucid-updates

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Brad Figg (brad-figg) wrote :

We need some testing of the proposed kernel to see whether this has been resolved - please see comment #24 for information about how to get the proposed kernel.

Thanks

Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers