Karmic & Lucid: OV2640 Webcam no longer works (Inspiron 1520)

Bug #459586 reported by hewbert on 2009-10-24
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrading to Karmic (RC) on this Dell Inspiron 1520, the integrated webcam no longer works. This worked out of the box in Jaunty. It is on the supported list at http://linux-uvc.berlios.de/

$ lsusb
Bus 002 Device 003: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

$ ls /dev/video*
ls: cannot access /dev/video*: No such file or directory

$ uname -srv
Linux 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009

lsmod shows uvcvideo, videodev, and v4l1_compat are loaded.

hewbert (josh-hewbert) wrote :
hewbert (josh-hewbert) wrote :
hewbert (josh-hewbert) wrote :
hewbert (josh-hewbert) wrote :
hewbert (josh-hewbert) wrote :

Well, after loading the 'gspca_ov519' module, the camera now works, just FYI :)

hewbert (josh-hewbert) wrote :

Actually, that must have been a coincidence. That module isn't loaded now, but it works anyway (after a few days and reboots).
# lsmod | grep video
uvcvideo 59080 0
videodev 36736 1 uvcvideo
v4l1_compat 14496 2 uvcvideo,videodev
video 19380 1 i915
output 2780 1 video

Not sure what it was.. Hopefully this may help someone else.

Thibault (tiboz) wrote :

I have the same problem with my Dell XPS M1330. The webcam worked perfectly out of the box in Jaunty.

In Karmic, the webcam is only showing a black screen in Cheese and in Skype video test. But the blue webcam light is on, and I have a /dev/video0.

18:26[pts/1]root@deirdre:/var/log#ls /dev/video0
/dev/video0

_AndreX_ (mgirona) wrote :

Same problem over here on my Dell XPS M1530. On jaunty worked OK.

And I don't have a /dev/video0, even if I load the gspca_ov519 module manually

_AndreX_ (mgirona) wrote :

I don't known what happend, but my camera is now working. I didn't update the kernel, I only rebooted the notebook.
 I will try to reproduce the error and report the steps. I think it has something to do with suspending the machine.

ogro (ogromano) wrote :

Just reporting that I had similar issue...

I upgraded (with a clean install) from 8.04 to 9.10 last week... the first 2 days my webcam (OV2640 on Dell Inspiron 1720) worked fine with Skype and for no apparent reason it just stopped working. Skype would place a grey box where my camera view should be and there was no light indication that the webcam was on. When opening the Skype video menu it said "No device found" for the webcam. Today, out of the blue, I checked again with Skype and it is working fine again... all I have done since then and now, has been to type lsusb in the terminal to find the model number.

Noob question follows:
Could it have something to do with the webcam software/driver not being fully "released" on shutdown?

Koen_VL (koenvl) wrote :

I run a Dell Inspiron 1520
The webcam works after a fresh boot.
But fails after resume from hibernation.

It seems it doesn't get initialized after resume :-s

Koen_VL (koenvl) wrote :

A little update:

After having this problem again I started some tinkering:

sudo rmmod uvcvideo gspca_ov519 gspca_main vloopback videodev V4l1_compat
sudo modprobe videodev gspca_ov519 vloopback v4l1_compat uvcvideo

Now the webcam works :-)

alban (dieteticien) wrote :

Hello,

Sorry for my English ;-)

My Web-Cam does not function any more (OmniVision Technologies, Inc. OV2640 Webcam).
It does not function with the 2.6.31.17 core but it is OK with 16 and 14 for example.
I think that the Cam have never fonction with the Kernel 2.6.31.17 ...
Reboot make nothing better.

I wait for the 2.6.31.18 and hope !!! :-)

Koen_VL (koenvl) wrote :

Try this script, it works for me :-)

alban (dieteticien) wrote :

Hello,

I have no try your script for the moment ... and ... my WebCam worked yesterday ... not work this day ... but it's OK now after a reboot :-o
I dont know why !?!
If I have more problem, I try your script (I have download ; thank).

Good night ; we are today at this time :-s
Sorry for my miserable English.

Agustin (agustin-bosso) wrote :

the script works for me

mayank (mankmonjre) wrote :

I am facing the same problem on Dell XPS M1330 using Karmic. When I resume from sleep mode, there is no /dev/video0 device file. The camera however works after running the script by Koen_vl.

slamdunk (antongiulio05) wrote :

I had the same problem on Dell XPS M1330 using Karmic. Anyway I solved installing:

linux-backports-modules-XXXXXX-generic
linux-backports-modules-karmic
linux-backports-modules-karmic-generic

relative at your kernel version currently used (from shell type "uname -a" to detect it)

Jeremy Kessler (jeremy-kcsrnd) wrote :

Koen_VL's script would return this:

ERROR: Module gspca_ov519 does not exist in /proc/modules
ERROR: Module gspca_main does not exist in /proc/modules
ERROR: Module vloopback does not exist in /proc/modules

I ran the script 3 times with the same result.

Until I ran 'lsmod', then ran the script again and it worked fine.

lemmy (lemmyg) wrote :

Hi,
this problem still appear in lucid beta1 and karmic.

linux 2.6.32-17 amd64 and 2.6.31-20-58 Dell Inspiron 1720.
error message:
(20.021050) uvcvideo: failed to query (129) UVC probe control: -32( exp. 26)

lsusb
Bus 002 Device 003: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

tags: added: kj-triage
Jeremy Foshee (jeremyfoshee) wrote :

Hi hewbert,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 459586

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
phil0stine (philosteen) wrote :

I as well would like to know if Hewbert fixed the problem. I am on a Dell xps1530, Omnivision OV2640 Webcam.

The device is recognized in lsusb, AND it is apparently loaded in dev/video0. No LED activity, however.

Koen_KL script doesnt work for me.

ERROR: Module uvcvideo is in use
ERROR: Module gspca_main is in use by gspca_ov534
ERROR: Module vloopback does not exist in /proc/modules
ERROR: Module videodev is in use by gspca_main,uvcvideo
ERROR: Module v4l1_compat is in use by uvcvideo,videodev
FATAL: Module vloopback not found.

The same type of error comes if I try to "modprobe -r" or "rmmod" uvcvideo, or anything using it.

#lsmod | grep video
uvcvideo 59080 1
videodev 36736 3 gspca_main,uvcvideo
v4l1_compat 14336 2 uvcvideo,videodev
video 19380 0
output 2780 1 video

phil0stine (philosteen) wrote :

For what it's worth, here's the only workaround that works for me. I boot into recovery mode and simply hit the hardware power switch after I log in. I haven't tried "poweroff" or "halt" commands since I haven't needed to, but I guess they would too.

The camera works fine until I suspend or hibernate. Apparently some of my modules are not shut down properly, and I cant even remove/restart them with sudo.

perlhead (fheinz) wrote :

This bug just bit me under Lucid, with the latest kernel upgrade (2.6.32-22-generic)

UbuntuFlo (ubuntuflo) wrote :

This bug ist still persistant in Lucid using a Dell Inspiron 1525 (bought from Dell with Ubuntu 7.10 installed in January 2008).

Some informations about the used system:
$ uname -r → 2.6.32-24-generic
$ lsusb → Bus 001 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

You can get your webcam working by entering these lines in the terminal after becoming root:
rmmod uvcvideo ## unload module
modprobe uvcvideo ## load module
After this command the webcam is working again.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - Karmic: OV2640 Webcam no longer works (Inspiron 1520)
+ Karmic & Lucid: OV2640 Webcam no longer works (Inspiron 1520)
Rew (rew) wrote :

Bitten by this too on the upgrade to Lucid. Dell Precision M4400. Worked fine in Karmic. The cam device doesn't show up under lsusb, and there is no /dev/video.

lainme (lainme) wrote :

I am using Ubuntu10.04 in Dell 1420, the only way to make the webcam work is to reload uvcvideo module.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers