9.10 live CD not booting on HP Compaq 615 (rs780) because of acpi pcmca modules failed (comment #34)

Bug #454268 reported by Dodiak on 2009-10-17
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Rostislav

Bug Description

The new Ubuntu 9.10 AMD64 CD on HP Compa1 615 starts to boot and after few secs. hangs .... I can just switch it off then. I have not try any special CD. The 9.04 had not problem to boot the same notebook.

Dodiak (dodo-sk) wrote :

Solved. 'nolapic' kernel parameter solve the problem.

Changed in ubuntu:
status: New → Fix Committed
Rostislav (fsniper) wrote :

this is not a fix, I think

Changed in ubuntu:
status: Fix Committed → Confirmed

And what wold be the fix then?

On Fri, Oct 23, 2009 at 9:30 PM, Rostislav <email address hidden> wrote:
> this is not a fix, I think
>
> ** Changed in: ubuntu
>       Status: Fix Committed => Confirmed
>
> --
> 9.10 live CD not booting on HP Compaq 615
> https://bugs.launchpad.net/bugs/454268
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tried this on a Dell Optiplex 745 and even with the nolapic option selected under F6 the install and / or live CD option did not work with the 32 bit RC 9.10 image

Niklas Kullberg (niklaskb) wrote :

Using 9.10RC LiveCD, Compaq 615 boots with the "noapic" option.
The "nolapic" did not work.

affects: ubuntu → linux (Ubuntu)
Jouni Mettala (jouni-mettala) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it without more information.

Please run the following command which will attach necessary information:

apport-collect 454268

Information about bug status is at https://wiki.ubuntu.com/Bugs/Status

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3073 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0x94400000 irq 10'
   Mixer name : 'IDT 92HD75B2X5'
   Components : 'HDA:111d7608,103c308c,00100202'
   Controls : 28
   Simple ctrls : 18
DistroRelease: Ubuntu 9.10
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 ppp0 no wireless extensions.
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
MachineType: Hewlett-Packard Compaq 615
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nolapic
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:

Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:3122): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:3122): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:3273): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:3296): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 07/17/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68GVV Ver. F.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 308C
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 27.07
dmi.chassis.asset.tag: CNU9326ML2
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68GVVVer.F.04:bd07/17/2009:svnHewlett-Packard:pnCompaq615:pvrF.04:rvnHewlett-Packard:rn308C:rvrKBCVersion27.07:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: Compaq 615
dmi.product.version: F.04
dmi.sys.vendor: Hewlett-Packard

tags: added: apport-collected

I boot LiveCD with "nolapic", "noapic" DIDN'T workforme!

Rostislav (fsniper) wrote :
Rostislav (fsniper) wrote :
Rostislav (fsniper) wrote :

I've used i386 CD

I have the same problem on my HP Compaq NX7300, on the Koala RC 32bit desktop cd, I choose "install" or "try" and I get a blank screen after 5 or so mins and nothing happens.

* CPU Type
** Mobile DualCore Intel Core 2 Duo T5600, 1833 MHz (11 x 167)

* Motherboard Name
** Hewlett-Packard HP Compaq nx7300 (RH700EA#ACQ)

* Motherboard Chipset
** Mobile Intel Calistoga-GM i945GM

* DIMM1:
** Hynix HYMP512S64CP8-Y5 1 GB DDR2-667 DDR2 SDRAM (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)

* Video Adapter
** Mobile Intel(R) 945GM Express Chipset Family (224 MB)

* 3D Accelerator
** Intel GMA 950

* Audio Adapter
** Analog Devices AD1981HD @ Intel 82801GBM ICH7-M - High Definition Audio Controller [A-1]

* Optical Drive
** TSSTcorp CD/DVDW TS-L632D (DVD+R9:6x, DVD+RW:8x/8x, DVD-RW:8x/6x, DVD-ROM:8x, CD:24x/24x/24x DVD+RW/DVD-RW)

* Network Adapter
** Intel(R) PRO/Wireless 3945ABG Network Connection (192. [ TRIAL VERSION ])

* Network Adapter
** Broadcom 440x 10/100 Integrated Controller (10.0 [ TRIAL VERSION ])

Rostislav (fsniper) wrote :

I've posted same bug in fedora bugzilla, because Fedora 12 beta didn't start too and there I was advised to disable KMS with line radeon.modeset=0 for radeon cards and for intel i think (for capdog) i915.modeset=0 or i945.modeset=0

Rostislav (fsniper) wrote :

I think this bug affects all of us: http://bugs.freedesktop.org/show_bug.cgi?id=24218 and kernel maintainers should disable kms for rs780 videocard until it's fixed

Rostislav (fsniper) on 2009-10-27
summary: - 9.10 live CD not booting on HP Compaq 615
+ 9.10 live CD not booting on HP Compaq 615 (rs780)

Using 9.10 released Live CD, HP DV2432CA hangs before installing, too. BIOS has been updated to latest version from HP.com, and tried both 'noapic' and 'nolapic' options, but still hanging.

Niklas Kullberg (niklaskb) wrote :

9.10 64bit final works with my HP Compaq 615 without setting any kernel parameters.

Niklas Kullberg (niklaskb) wrote :

Correction: Live-CD boots without any kernel parameter. After installation, nolapic is needed.

rasos (rasos) wrote :

Yes, I confirm for HP Compaq 615: USB-boot of ubuntu-netbook.remix 9.10 works without modifications. After installation, GRUB needs to be modified with nolapic. I added nolapic in /etc/default/grub before "quiet splash" parameter and run update-grub after editing.
However, graphics seems extremely slow, will test further.

Rostislav (fsniper) wrote :

I found that someone localised the problem. Yes it is not distribution
specific.

Here is the link http://bbs.archlinux.org/viewtopic.php?id=82052

quote some useful lines:

"The only way to boot is to append acpi=off paramter.
______Problem is caused by pcmcia and pcmcia_core acpi modules(strange indeed
that they are loaded,becouse my laptop has a express not pcmcia slot
neutral)______
Boot with acpi=off and add these modules in rc.conf with ! to disable them from
loading with system,boot again normally and everything will work fine now with
acpi enabled
I also notice that people with similar hardware like my netbook(AMD
chipset)have same problems"

I think now the fix will be trivial. Please squash this bug.

summary: - 9.10 live CD not booting on HP Compaq 615 (rs780)
+ 9.10 live CD not booting on HP Compaq 615 (rs780) because of acpi pcmca
+ modules failed (comment #34)
neuromancer (neuromancer) wrote :

I would install ubuntu 9.10 on a Compaq 610 that was running 9.04 but when I try to install, after choosing language system hang and blank screen appear.
Now I'll try alternate installer and kernel option (nolapic, acpi=off etc.)

axelsvag (darinsson) wrote :

I can confirm this on Toshiba Equim. Installation of 9.10 failed but with noapic enabled installation went fine. None whatsoever problem with installation of 9.04 on the same hardware

neuromancer (neuromancer) wrote :

In my case no option work. Only blank screen.
For the moment in this friend pc I'll keep Ubuntu 9.04

edl (eddy-deluca) wrote :

hi
 also I have a Compaq 615. Same problem: every time it's run on boot, but often it's not run.
Are there news?

neuromancer (neuromancer) wrote :

Just installed Lucid Lynx on Compaq 615
and this time all worked :)

Jouni Mettala (jouni-mettala) wrote :

Thanks. Marking fix released then.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.