Huawei E220 modem unable to connect under Karmic

Bug #449394 reported by Graham Beneke on 2009-10-12
278
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
High
Unassigned
Nominated for Karmic by Mind Booster Noori
Nominated for Lucid by xraynorm
Declined for Maverick by Robbie Williamson
usb-modeswitch (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Mind Booster Noori
Nominated for Lucid by xraynorm
Declined for Maverick by Robbie Williamson

Bug Description

Binary package hint: network-manager

Network-Manager on Ubuntu Karmic beta is not able to bring up a UMTS (3G) connection with a Huawei E220 USB modem.

network-manager:
  Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2

/var/log/messages :

Oct 12 11:18:43 gripen pppd[3031]: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
Oct 12 11:18:43 gripen pppd[3031]: pppd 2.4.5 started by root, uid 0
Oct 12 11:18:43 gripen pppd[3031]: Using interface ppp0
Oct 12 11:18:43 gripen pppd[3031]: Connect: ppp0 <--> /dev/ttyUSB0
Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
Oct 12 11:18:53 gripen pppd[3031]: Could not determine remote IP address: defaulting to 10.64.64.64
Oct 12 11:18:53 gripen pppd[3031]: local IP address 41.28.69.53
Oct 12 11:18:53 gripen pppd[3031]: remote IP address 10.64.64.64
Oct 12 11:19:01 gripen kernel: [ 1675.920665] scsi38 : SCSI emulation for USB Mass Storage devices
Oct 12 11:19:01 gripen pppd[3031]: Modem hangup
Oct 12 11:19:01 gripen pppd[3031]: Connect time 0.2 minutes.
Oct 12 11:19:01 gripen pppd[3031]: Sent 0 bytes, received 0 bytes.
Oct 12 11:19:01 gripen kernel: [ 1702.004328] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Oct 12 11:19:01 gripen kernel: [ 1702.004344] option 4-1:1.0: device disconnected
Oct 12 11:19:01 gripen kernel: [ 1702.004413] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
Oct 12 11:19:01 gripen pppd[3031]: Connection terminated.
Oct 12 11:19:01 gripen kernel: [ 1702.004433] option 4-1:1.1: device disconnected
Oct 12 11:19:01 gripen kernel: [ 1702.118468] usb 4-1: reset full speed USB device using uhci_hcd and address 8
Oct 12 11:19:01 gripen kernel: [ 1702.262388] option 4-1:1.1: GSM modem (1-port) converter detected
Oct 12 11:19:01 gripen kernel: [ 1702.262515] usb 4-1: GSM modem (1-port) converter now attached to ttyUSB1
Oct 12 11:19:01 gripen kernel: [ 1702.266788] option 4-1:1.0: GSM modem (1-port) converter detected
Oct 12 11:19:01 gripen kernel: [ 1702.266921] usb 4-1: GSM modem (1-port) converter now attached to ttyUSB2
Oct 12 11:19:02 gripen pppd[3031]: Exit.
Oct 12 11:19:12 gripen kernel: [ 1702.309314] scsi 38:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
Oct 12 11:19:12 gripen kernel: [ 1702.334268] sr1: scsi-1 drive
Oct 12 11:19:12 gripen kernel: [ 1702.334538] sr 38:0:0:0: Attached scsi generic sg2 type 5

Appears to be a regression - identical hardware is functioning correctly under Ubuntu Jaunty.

HI!

I've marked this bug as a duplicate of 430011, because is the same issue, same kernel, same dongle, so that is the same bug, probably.

FraGe (fragebuntu) wrote :

Hi,

it seems to be a different bug - the E169 are working with the patched Kernel but not our E220.

We need to have kernel 2.6.31.5 and then use
sudo rmmod usb-storage
sudo modprobe usbserial vendor=0x12d1 product=0x1003

and sometimes sudo rmmod usb-storage again. After that, it works. Not always, but for me, it worked after a few trys.

As they guess in the other bug-report, this is not a duplicate.

regards,
FraGe

Changed in network-manager (Ubuntu):
status: New → Confirmed
tags: added: kernel-bug
FraGe (fragebuntu) wrote :
FraGe (fragebuntu) wrote :

sorry, forgot to write anything ;)

I tried a Huawei E270 which works with the new kernel, after that, I disconnected and connected my E220 which gave the output ( in /var/log/messages) I posted before.

Additionally I can say that I see no chance to connect with another USB-Device (Harddisc, Stick) plugged in.

Right now it cost me ages to connect rmmodding usb-serial again and again ...

Patrick Cost (cbrpaddy) wrote :

So what's going on with this bug ? It's still unassigned, and as has been noted in 446146 it's not a duplicate. The importance is undecided and I would say it's a critical bug. Any non-technical user using a Huawei E220 with Karmic has zero web access. They will not even be able to do a search and find the rmmod trick.

As an E220 user myself, I've actually had to leave Ubuntu for the first time in five years and install another distro. Spending anything up to 40 minutes inserting and removing a dongle while rmmodding in the hope I can get a signal, only to have it crash out again five minutes later due to useless 3g networks and having to go through the entire rigmarole again is utterly farcical.

Graham Beneke (graham-beneke) wrote :

I' ve removed the duplicate tag and confirmed that the problem still exists under the current update of Karmic.

It appears to be a kernel bug and not related to network-manager. The kernel appears to repeatedly connect and disconnect the device state and this causes the connection to fail immediately or within a few seconds of bringing it up.

summary: - NM 0.8 fails to bring up UMTS connection
+ Huawei E220 modem unable to connect under Karmic
Changed in linux:
status: New → Confirmed
Changed in linux:
assignee: nobody → Ubuntu Kernel Team (ubuntu-kernel-team)
Bartosz Kosiorek (gang65) wrote :

This bug exists in kernel.
After upgrade from Ubuntu 9.04 to 9.10 my modem Hauwei stops working on the newest kernel (2.6.31-15).

After run Ubuntu 9.10 Karmic Koala with old kernel 2.6.28-13 all works perfectly.

affects: network-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
Allan Hollander (adhollander) wrote :

I have similar behavior with my USRobotics USR5637 USB dialup modem. This particular modem is probably the best choice for a USB dialup modem under Linux now. Anyway, I had no trouble using this modem to connect under Jaunty using gnome-ppp; when I upgraded to Karmic yesterday and tried to connect via PPP, gnome-ppp or wvdialconf would fail to detect the modem. A couple of times when I rebooted the computer gnome-ppp would be able to find the modem, but I would make a ppp connection and a minute or two it would drop the modem again. Fiddling around with

sudo rmmod usb-storage
sudo modprobe usbserial vendor=... as above didn't help me.

However, I just tried booting into the old kernel (2.6.28-15 instead of 2.6.31-14) and I now have no trouble using the modem.

Adrian Murariu (murariu-adrian) wrote :
Download full text (8.5 KiB)

Hi,
just upgraded to 2.6.31-15 using karmic-proposed updates.

I confirm that E220 doesn't work with this kernel too.
Here is the log:

[ 118.384091] usb 5-2: new full speed USB device using uhci_hcd and address 2
[ 118.542461] usb 5-2: configuration #1 chosen from 1 choice
[ 118.677917] usbcore: registered new interface driver usbserial
[ 118.678054] USB Serial support registered for generic
[ 118.678157] usbcore: registered new interface driver usbserial_generic
[ 118.678162] usbserial: USB Serial Driver core
[ 118.693070] USB Serial support registered for GSM modem (1-port)
[ 118.693147] usbcore: registered new interface driver option
[ 118.693151] option: v0.7.2:USB Driver for GSM modems
[ 118.756396] Initializing USB Mass Storage driver...
[ 118.758465] scsi6 : SCSI emulation for USB Mass Storage devices
[ 118.758725] usb-storage: device found at 2
[ 118.758730] usb-storage: waiting for device to settle before scanning
[ 118.758745] usbcore: registered new interface driver usb-storage
[ 118.758752] USB Mass Storage support registered.
[ 118.789069] usbcore: deregistering interface driver option
[ 118.789133] USB Serial deregistering driver GSM modem (1-port)
[ 118.805084] usbcore: deregistering interface driver usbserial_generic
[ 118.805142] USB Serial deregistering driver generic
[ 118.805176] usbcore: deregistering interface driver usbserial
[ 118.828673] usbcore: registered new interface driver usbserial
[ 118.828705] USB Serial support registered for generic
[ 118.828741] usbcore: registered new interface driver usbserial_generic
[ 118.828746] usbserial: USB Serial Driver core
[ 118.834686] USB Serial support registered for GSM modem (1-port)
[ 118.834757] usbcore: registered new interface driver option
[ 118.834761] option: v0.7.2:USB Driver for GSM modems
[ 118.856062] usbcore: deregistering interface driver option
[ 118.856121] USB Serial deregistering driver GSM modem (1-port)
[ 118.872049] usbcore: deregistering interface driver usbserial_generic
[ 118.872100] USB Serial deregistering driver generic
[ 118.872134] usbcore: deregistering interface driver usbserial
[ 118.897925] usbcore: registered new interface driver usbserial
[ 118.897956] USB Serial support registered for generic
[ 118.897991] usbcore: registered new interface driver usbserial_generic
[ 118.897996] usbserial: USB Serial Driver core
[ 118.910110] USB Serial support registered for GSM modem (1-port)
[ 118.910191] usbcore: registered new interface driver option
[ 118.910194] option: v0.7.2:USB Driver for GSM modems
[ 118.944130] usb 5-2: USB disconnect, address 2
[ 119.684059] usb 5-2: new full speed USB device using uhci_hcd and address 3
[ 119.844129] usb 5-2: configuration #1 chosen from 1 choice
[ 119.853846] option 5-2:1.0: GSM modem (1-port) converter detected
[ 119.853994] usb 5-2: GSM modem (1-port) converter now attached to ttyUSB0
[ 119.858152] option 5-2:1.1: GSM modem (1-port) converter detected
[ 119.858311] usb 5-2: GSM modem (1-port) converter now attached to ttyUSB1
[ 119.860878] scsi9 : SCSI emulation for USB Mass Storage devices
[ 119.864950] usb-storage: device found at 3
[ 119.864954] usb-storag...

Read more...

Coming back with latest news, it seems to be an issue with E220 firmware.

I did a E220 FW upgrade with version from http://www.maxis.com.my/maxisbb/download/E220SoftwareUpgrade.zip, using my Win XP home PC.
Right after this upgrade, I tested with 2.6.31-15 kernel and ... worked !

Actually, I am writing this on my notebook with E220 internet connection.

I have upgraded both firmware and dashboard application, but I belive that for Linux, firmware will be the only necessary upgrade.

Cheers !

Fábio Silva (fabiogsilva) wrote :

@Adrian Murariu: That solved my problem! Thank you! :)

Cyril Jaquier (cyril-jaquier) wrote :

I also upgraded the firmware (using WinXP in VirtualBox) and it seems to have solved the problem (Huawei E220). Now both mass storage and modem seems to work.

I think it was clear that all those issues with Huawei modems were caused by buggy firmwares. But a workaround in the kernel is probably not a bad idea because most users will not see this bug report or will not be able to upgrade the firmware.

Helder Fraga (whise) wrote :

how does one upgrade the firmware?

Now, regarding this bug:

 - It's being tracked upstream at http://bugzilla.kernel.org/show_bug.cgi?id=14499

 - I got in touch with a Huawei engineer who will try to reproduce. In the meantime, he needs to know
the FW version on the modems with a problem. I will post the procedure to retrieve that version to the
kernel.org bugzilla entry above. You can reply with your version either there or here

Until kernel team and Huawei engineer will decide what to do next, this is how you upgrade the E220 :

- it is highly recommended to work on a notebook or a PC with UPS, to be protected from power failure or you may loose your E220 dongle
- on a Windows based machine, download archive from http://www.maxis.com.my/maxisbb/download/E220SoftwareUpgrade.zip
- unpack ZIP file in a separate directory, like c:/tmp/E220
- plug-in E220 and wait about 1 minute
- close any software that may autorun when E220 is plugged
- start the exe file with Firmware inside the name and follow on-screen instructions - upgrade will take several minutes, be patient
- start the exe file with Dasboard in its name and follow on-screen instructions up to end of upgrade window
- unplug your E220
- this is how I did it on a XP Windows!

It may happen that deviation could appear , based on Windows you have installed. You have to deal with this by yourself .

Cyril Jaquier (cyril-jaquier) wrote :

Dashboard upgrade is not required. I only upgraded the firmware.

I will try this new firmware this afternoon :)

Many thanks!!!

Craig Hewetson (craighewetson) wrote :

Is there a way to upgrade the firmware from within ubuntu, without using virtualbox etc?

Craig Hewetson wrote:
> Is there a way to upgrade the firmware from within ubuntu, without using
> virtualbox etc?
>

I tried with wine but as expected it didn't work. I fear you will have
to find someone with a Windows computer :( I had to install the drivers
first otherwise the upgrade tool didn't find the modem...

Phuah Yee Keat (ykphuah) wrote :

My Modem Model: E160E, but it shows up as
Bus 002 Device 010: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
in lsusb.

Attached dmesg and usbmon output from using 2.6.31-15-generic from karmic-proposed.

Still doesn't work, and I am still considering whether I want to try the upgrade above as my modem's firmware is newer than the one in the zip file.

Changed in linux:
assignee: Ubuntu Kernel Team (ubuntu-kernel-team) → nobody
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in linux (Ubuntu):
status: Confirmed → Triaged
ar-jar (arto-jarvinen-letter) wrote :

I'm running the E220 with 2.6.31-15-generic. I upgraded the firmware according to post from Adrian M. When trying to upgrade the dashboard my XP gave me a blue-screen so I didn't try that again. The modem still works on XP (lucky me) but is unpredictable on Karmic. Once I got connected. Sometimes it says I'm connected in the network menu but applications can't connect, and sometimes the device is not recognized at all. I attach a dmest output from one of the occasions when the device won't get recognized at all.

FraGe (fragebuntu) wrote :

Ok, I'm finally back. I upgraded my E220 using an old XP notebook I had around. Tried the Modem with kernel 2.6.31-02063105-generic (installed this one before the release, never got a new one *oops*) and it works ootb.

I will try the kernel wich comes with karmic and write an update then.

regards,
FraGe

Changed in linux:
status: Unknown → Fix Released
Graham Beneke (graham-beneke) wrote :

I can confirm that the firmware update resolved the issue for me. I got the Vodafone branded updater from http://www.vodacom.co.za/services/vodacom_broadband/downloads.jsp

I found that I had to stop the dashboard and its status bar applet before the updater was able to detect my device. Aside from that it was just a task of reading the instructions and clicking 'Next' a few times.

Papamatti2 (papamatti2) wrote :

I discoverd that my huawei is not a "e220/270" but it is a e160 (Medion Mobile Web Stick S4011). Does anyone know if there is a newer firmware for this device and vendor?
No webaccess with a huawei e160 !

The firmware update resolved the issue for me too. Thanks my mom got Windows XP. It always connects but often there are no nameservers registered, so the connection is unusuable for applications. This time I had to reconnect three times to get DNS working...

daniel@ubuntu:~$ cat /etc/resolv.conf
# Generated by NetworkManager
daniel@ubuntu:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 212.23.97.3
nameserver 212.23.97.2

Phuah Yee Keat (ykphuah) wrote :

I do not know how to use minicom, but vodafone mobile connect for linux shows that

Model: E160X
Firmware: 11.608.11.00.00

Should I be logging this somewhere? I logged it here because lsusb shows E220/E270.

And I am reluctant to do the firmware upgrade as my second number 608 seems to be bigger than those in the firmwares.

chidalgo (chidalgo-gmail) wrote :

i got the same behavior of #26: get a connected status via NetworkManager, but no DNS nameservers.

And sometimes the modem is not recognised at all.

I'm using the E176 model, but lsusb tell me it's a E220/E270 model :(

linrunner (linrunner) wrote :
Martin Wildam (mwildam) wrote :

I also have discovered that my E160G shows up as E220 / E270 in lsusb so probably my tests to Bug #446146 (https://bugs.launchpad.net/bugs/446146) using different kernels in comment #219 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/446146/comments/219) do apply to here (also). - HTH.

My contact with Huawei confirmed that FW updates should fix the problems. Unfortunately, they are also unable to offer those updates, the only way to get them is via your operators.

ar-jar (arto-jarvinen-letter) wrote :

I have an E220. I first updated according to post #10 and it worked from time to time. Then I checked my operator's (www.tele2.se) support pages and installed their recommended firmware update 11.117.09.01.56 (June 23, 2008), which was older than the version referred to from #10. Same behavior. When I install the modem, I usually get connected once. When I disconnect and connect again, it shows the same behavior as reported in #26 and #28.

Which version of the firmware is supposed to solve this problem and where can I get it (not through my operator obviously)?

Is the firmware generic or operator-specific, i.e. can I use the firmware from any source? The actual desktop software seems to be operator branded at least.

Download full text (3.8 KiB)

Did you upgraded kernel to version 15 ?

Trimis de pe iPhone-ul meu

Pe 13.11.2009, la 10:01, ar-jar <email address hidden> a scris:

> I have an E220. I first updated according to post #10 and it worked
> from
> time to time. Then I checked my operator's (www.tele2.se) support
> pages
> and installed their recommended firmware update 11.117.09.01.56 (June
> 23, 2008), which was older than the version referred to from #10. Same
> behavior. When I install the modem, I usually get connected once.
> When I
> disconnect and connect again, it shows the same behavior as reported
> in
> #26 and #28.
>
> Which version of the firmware is supposed to solve this problem and
> where can I get it (not through my operator obviously)?
>
> Is the firmware generic or operator-specific, i.e. can I use the
> firmware from any source? The actual desktop software seems to be
> operator branded at least.
>
> --
> Huawei E220 modem unable to connect under Karmic
> https://bugs.launchpad.net/bugs/449394
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: network-manager
>
> Network-Manager on Ubuntu Karmic beta is not able to bring up a UMTS
> (3G) connection with a Huawei E220 USB modem.
>
> network-manager:
> Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
>
> /var/log/messages :
>
> Oct 12 11:18:43 gripen pppd[3031]: Plugin /usr/lib/pppd/2.4.4/nm-
> pppd-plugin.so loaded.
> Oct 12 11:18:43 gripen pppd[3031]: pppd 2.4.5 started by root, uid 0
> Oct 12 11:18:43 gripen pppd[3031]: Using interface ppp0
> Oct 12 11:18:43 gripen pppd[3031]: Connect: ppp0 <--> /dev/ttyUSB0
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:53 gripen pppd[3031]: Could not determine remote IP
> address: defaulting to 10.64.64.64
> Oct 12 11:18:53 gripen pppd[3031]: local IP address 41.28.69.53
> Oct 12 11:18:53 gripen pppd[3031]: remote IP address 10.64.64.64
> Oct 12 11:19:01 gripen kernel: [ 1675.920665] scsi38 : SCSI
> emulation for USB Mass Storage devices
> Oct 12 11:19:01 gripen pppd[3031]: Modem hangup
> Oct 12 11:19:01 gripen pppd[3031]: Connect time 0.2 minutes.
> Oct 12 11:19:01 gripen pppd[3031]: Sent 0 bytes, received 0 bytes.
> Oct 12 11:19:01 gripen kernel: [ 1702.004328] option1 ttyUSB0: GSM
> modem (1-port) converter now disconnected from ttyUSB0
> Oct 12 11:19:01 gripen kernel: [ 1702.004344] option 4-1:1.0: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.004413] option1 ttyUSB1: GSM
> modem (1-port) converter now disconnected from ttyUSB1
> Oct 12 11:19:01 gripen pppd[3031]: Connection terminated.
> Oct 12 11:19:01 gripen kernel: [ 1702.004433] option 4-1:1.1: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.118468] usb 4-1: reset full
> speed USB device using uhci_hcd and address 8
> Oct 12 11:19:01 gripen kernel: [ 1702.262388] option 4-1:1.1: GSM
> modem (1-port) converter detected
> Oct 12 11:19:01 gripen kernel: [ 1702.262515] usb 4-1: G...

Read more...

Bartosz Kosiorek (gang65) wrote :
ar-jar (arto-jarvinen-letter) wrote :

Yes, I'm running 2.6.31-15-generic. I have also tried to find updates on huawei.com but can't register from Firefox/Ubuntu as the site doesn't seem to support that combination. And IE/Windows threw me out into a debugger when trying to register. A discouraging first impression :-) Do you know where I can find the latest update as huawei themselves doesn't seem to be easy to access? -A

ar-jar (arto-jarvinen-letter) wrote :

Installed version 16 as per #34. Same behavior as w/ version 15. Usually I get connected ok the first time I try having rebooted or plugged in the modem. When I disconnect and try to connect again, I usually don't get any nameserver.

Martin Wildam (mwildam) wrote :

I have tried now the firmware update on a Windows PC (fortunately I could reach a destination where a Windows PC was available) which was very strange. After recognizing 4 to 6 new mass storages and mobile devices I could install the Three Data Manager and it showed a notice that an update is available. However it refused with the download. Anyway after restart the message was gone and it showed the firmware version 11.604.21.00.156.
I then manually went to the Three site in Austria (where I am located) and found a firmware update package named "E160Update_11.604.21.00.156.B409". Unfortunately the last portion of this very short version number is not displayed in the Data Manager software so I did not have an idea whether I already had the build 409 or not. Anyway I downloaded the update and installed it.

Now my E160G which shows up in lsusb as E220 (that's why I am writing this here ;-) ) even works with the current release kernel of Karmic (2.6.31-14-generic #48-Ubuntu) like a charm! (at least from what I noticed so far after 3 short tests). In the weekend I will test with the different other kernels.

Mistofelees (ptmusta) wrote :

SUCCESS: e220, Kernel 2.6.31-15 and new fimware, No Dashboard update. Finland, Saunalahti. Great many thanks !

Another thing. My son told that they succeeded last night with e169 and vanilla 2.6.31-14 kernel in two netbooks with untouched 9.10 Remix. They wrote username and password to the Basic installation of the broadband modem. The username and password were just the first words they got in their minds. They made no other changes.
Before this name/password they saw the modem in the menu, but it was totally passive.
I have had no possibilities to check this.

ar-jar (arto-jarvinen-letter) wrote :

Referring to post #34, I found a workaround: If I select "Automatic (PPP) addresses only" under my IPv4 settings and enter a nameserver address manually, then I seem to be able to connect consistently. (A little quirk is that I can't delete the last character of the password that I entered during my experimentation. It always comes back)

Martin Wildam (mwildam) wrote :

I can confirm that the E160G (which is showing up as E220/E270 in lsusb) is working after firmware update through all kernels (apw5, apw10 and 2.6.32.rc6). Interestingly: While previously I had to plug the modem stick in before starting my Dell E-5500 now I have to plug in it after log in.

And I experienced also DNS issues for about an hour and then they were gone. For the case there are DNS issues entering the nameserver manually should help - after several tests I think using the manual DNS settings is more reliable (just an impression).

My E156G doesn't works :'(
lsusb shows it as a E220/E270, but I can't update the firmware with the E220 update tool, it fails showing that the device was not found.

Still using 9.04.......

tiqqione (tiqqiman) wrote :

SUCCESS: e220, Kernel 2.6.31-14 -15 and new fimware, Dashboard update. Meditel, Morroco. Great many thanks

Damjan Jovanovic (damjan-jov) wrote :

I got my E220 working (NO firmware upgrades, NO kernel changes) as follows:

1. Cold boot with it unplugged.
2. sudo killall devkit-power-daemon
3. sudo killall devkit-disks-daemon
4. Plug in the E220
5. Wait for a while, when it shows up in Network Manager, connect.

Just got it working like this for the second time.

See my comment on bug 446146 for full details.

Martin Rehn (minpost) wrote :

Still *NOT* working for me. I did the firmware upgrade and also installed the apw10 kernel from here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/446146/comments/162

Still, nineteen times out of twenty, when connecting using network manager, the blue light comes on on the E220 and network manager claims that I am connected. But I can't reach anything through the connection. If I were to guess, I would say that something other than the kernel is at fault here.

I have had some success using the KPPP program for connecting, instead of NetworkManager, but I can't yet say if that works consistently. To use KPPP, disconnect the non-working connection in network manager and then "dial" using KPPP. You may have to configure KPPP first.

Martin Wildam (mwildam) wrote :

Please try to configure the DNS manually in the Network Manager! - Here in Austria for several providers the retrieval of the DNS servers does not work in a reliable way. Adding the DNS servers manually may help a lot here!

Changed in linux:
status: Fix Released → Confirmed
tonbuntu (tonbuntu) wrote :

This step solve my problem :) many thx to u bro......e220 work well @ ubuntu 9.10

- it is highly recommended to work on a notebook or a PC with UPS, to be protected from power failure or you may loose your E220 dongle
- on a Windows based machine, download archive from http://www.maxis.com.my/maxisbb/download/E220SoftwareUpgrade.zip
- unpack ZIP file in a separate directory, like c:/tmp/E220
- plug-in E220 and wait about 1 minute
- close any software that may autorun when E220 is plugged
- start the exe file with Firmware inside the name and follow on-screen instructions - upgrade will take several minutes, be patient
- start the exe file with Dasboard in its name and follow on-screen instructions up to end of upgrade window
- unplug your E220
- this is how I did it on a XP Windows!

note : i use automatic ppp

well done thx guys..........

Carl Heymann (ch-heymann) wrote :

I've been struggling with e220 problems on my laptop as well, ever since installing Karmic (was working fine before). Comment #43 worked for me as well, after upgrading the e220's FW (as recommended in #46).

Without killing devkit-power-daemon and devkit-disks-daemon I can still connect, but the modem appears to disconnect after 10-20 seconds. The e220 light is still on, apparently connected, but communication with the computer is no more. I've tried wvdial as well. When it fails, this is the output:

--> Connect time 0.1 minutes.
--> Disconnecting at Thu Dec 3 17:46:35 2009
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

I'm on 2.6.31-15, regular package manager maintained kernel.

Interestingly, I've got another laptop where the connection has been fine on Karmic from day one, with the same e220 dongle. No need to kill processes there, update donle FW, update the kernel or anything else.

So for me, the question remains: why would the devkit daemons interfere with the operation of a 3g dongle on some hardware, but not others?

I don't know if this is related, but most of the time I can't actually use the connection built up with the network manager. I've tried to edit the 3g connection and check the box "Available to all users" , but this results in the connection being deleted. So am using wvdial right now, as this works consistently.

FraGe (fragebuntu) wrote :

whoops, yesterday I had to use my E220 on a different Notebook and had the same issues as before - my modems firmware is upgraded, the notebook is up to date with latest kernel, but there was no way to connect till I rmmoded usb-storage and then manually typed "modprobe usb-serial" (didn't know the rest by heart) after that, it worked fine.

I had no time to check the logs, so I can't provide anything, just wanted to say, that there are still issues ...

FraGe

Craig Hewetson (craighewetson) wrote :

The device upgrade helped but I still have an annoying issue with connection:
If i "connect" my device the OS says I'm connected, my skype says I'm connected, but firefox refuses to connect. The only way to get my browser to connect is to unplug the device and plugin it in again then fire up my browser and see if it can connect. Quite often I would have to repeat this twice.

I would like to give a log file of some sorts but there is a sea of log files and in each log file there is alot of information and I'm not sure what would be useful to expose the cause of the this problem.

Taufik (tfk252hasan) wrote :
madbiologist (me-again) wrote :

@Craig Hewetson - the appropriate log file to attach should be dmesg. Please also provide the output of lsusb and the output of uname -srm

SP (samipp) wrote :

Updated my Huawei E220 FW to 11.117.10.02.00, now my 9.10 with kernel 2.6.31-17 shows modem first as a USB-drive. Ejected drive (not unmount) and it started to show as a modem like it should. Then just chose from NetworkManager Enable Mobile Network and opened my connection. "Zadamn" I am on internet with my Karmic. Just took me three months to get correct info to get on line. Thanks for everybody for their input. I highly recommend to upgrade FW to latest one you can find.

SP (samipp) wrote :

Works the same way with 2.6.31-18

Startup->
Eject Vodafone USB-drive
NetworkManager->Choose Network provider

Connection made!

HaraldK (pifpafpuf) wrote :

Still not working for me.

Mine is a E160 sold bei Medion (Aldi) in Germany as a S4011 web stick. It has

firmware: 11.608.06.00.52
build: 20090728 195006

% lsusb | grep Huaw

Bus 001 Device 007: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem

I am on ubuntu 9.10 with kernel

Linux nepton 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 i686 GNU/Linux

I tried to upgrade the firmware according to comment #29, but the software wanted a password. I guess the Aussie firmware does not match the one necessary in Germany.

Still hopeful, but I might go looking for another umts modem --- except: which one would work for sure?

Any hints appreciated.

Harald.

madbiologist (me-again) wrote :

@HaraldK - You may have more luck with the firmware in comment #10 (and #15) or comment #24.

> @HaraldK - You may have more luck with the firmware in comment #10 (and #15) or comment #24.

Here is yet another firmware update.
not the most recent, but works fine to fix this problem.

http://gestaodecontakanguru.optimus.pt/de+o+salto/Produtos/SoftWareUpgrade1.htm

--
BUGabundo :o)
(``-_-´´) Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Bruno Cunha (brunoscunha) wrote :

With the latest kernel I still have to use sudo rmmod usb-storage to make the E220 work. This time I connected it, after 30 secs it shows up on the network devices. I try to connect, it connects, the connection drops and the E220 disappears from network devices. And so on and so on....
I will try to upgrade the Firm Ware. I just hope it does not mess up the E220

LeoRochael (leorochael) wrote :

The following page contains links to firmware upgrades for the e220 and e226 for the following operators in Brazil:

 * Claro
 * Vivo
 * TIM
 * Oi

http://www.huawei.com/pt/catalog.do?id=1626

I have not yet been able to test them, though.

HaraldK (pifpafpuf) wrote :

Update to my post #54 on 2010-02-06

As it seems, the firmware is not the problem. I found a wvdial script in this comment

http://www.ende-der-vernunft.org/2009/04/29/eine-pest-namens-networkmanager/comment-page-1/#comment-9912

that worked right away like this:

1) boot, HUAWEI not plugged.
2) plug in HUAWEI. (see dmesg output below)
3) wvdial -C name-of-script umts-pin
  (don't forget to enter your pin in the script)
3) wvdial -C name-of-script umts

So the problem for me seems to be that NetworkManager or rather nm-applet (one of the best documented pieces of software on the planet, haha) does not notice that they could provide a PPP connection through UMTS.

Is there anywhere documentation that explains the chain of events that ought to happen from plugging in the HUAWEI to nm-applet providing me the option to connect through it?

Harald.

HaraldK (pifpafpuf) wrote :

Here the dmesg output missing from my last post:

[ 373.792045] usb 1-4: new high speed USB device using ehci_hcd and address 3
[ 373.935394] usb 1-4: configuration #1 chosen from 1 choice
[ 374.025150] Initializing USB Mass Storage driver...
[ 374.025754] scsi2 : SCSI emulation for USB Mass Storage devices
[ 374.025935] usbcore: registered new interface driver usb-storage
[ 374.025939] USB Mass Storage support registered.
[ 374.027261] usb-storage: device found at 3
[ 374.027264] usb-storage: waiting for device to settle before scanning
[ 374.028229] usb 1-4: USB disconnect, address 3
[ 380.488047] usb 1-4: new high speed USB device using ehci_hcd and address 4
[ 380.631520] usb 1-4: configuration #1 chosen from 1 choice
[ 380.641173] scsi5 : SCSI emulation for USB Mass Storage devices
[ 380.641844] usb-storage: device found at 4
[ 380.641875] usb-storage: waiting for device to settle before scanning
[ 380.641907] scsi6 : SCSI emulation for USB Mass Storage devices
[ 380.655287] usb-storage: device found at 4
[ 380.655291] usb-storage: waiting for device to settle before scanning
[ 380.688739] usbcore: registered new interface driver usbserial
[ 380.688756] USB Serial support registered for generic
[ 380.688791] usbcore: registered new interface driver usbserial_generic
[ 380.688794] usbserial: USB Serial Driver core
[ 380.693333] USB Serial support registered for GSM modem (1-port)
[ 380.693373] option 1-4:1.0: GSM modem (1-port) converter detected
[ 380.693527] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB0
[ 380.693538] option 1-4:1.1: GSM modem (1-port) converter detected
[ 380.693596] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB1
[ 380.693619] usbcore: registered new interface driver option
[ 380.693621] option: v0.7.2:USB Driver for GSM modems
[ 385.641367] usb-storage: device scan complete
[ 385.643460] scsi 5:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 385.654216] usb-storage: device scan complete
[ 385.656232] scsi 6:0:0:0: Direct-Access HUAWEI MMC Storage 2.31 PQ: 0 ANSI: 2
[ 385.666176] sr1: scsi-1 drive
[ 385.666340] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 385.666439] sr 5:0:0:0: Attached scsi generic sg2 type 5
[ 385.666602] sd 6:0:0:0: Attached scsi generic sg3 type 0
[ 385.681054] sd 6:0:0:0: [sdb] Attached SCSI removable disk

Harald.

Emil G (emilgoode) wrote :

The trick in comment #50 seems to have solved the problems with my E220.
I didnt upgrade firmware, but maybe I have the latest one already, dont know.
It not connects perfectly every time (so far).
It is still showing up as a usb drive though.
This is most unfortunate, I just converted my sister to linux and she has the same modem, I fear she will convert into a mac user..
Its been a very long time since the Karmic release, Im wondering why this didnt get fixed early on?

madbiologist (me-again) wrote :

@SP - You might not need to eject the USB-drive anymore on Ubuntu 10.04 "Lucid Lynx". A new version (1.1.0-2) of usb-modeswitch was added to the Lucid repositories 5 days ago. I can't find the page anymore, but I read that this version has added support for several Huawei modems.

javierpedros (javierpedros) wrote :

I think the problem is network-manager because the modem works fine with gnome-ppp.
I have karmic with kernel 2.6.31-16 and modem huawei E220.
I configured gnome-ppp and now the modem works running gnome-ppp.

Suyog (suyog) wrote :

This issue is also with Lucid Lynx daily build which i downloaded on 5th March, please fix it.
I am able to connect with gnome-ppp but not network manager same issue was with 9.10 so i am back to 9.04 where everything works. Huawei EC1260+Reliance Netconnect Broadband+ India

Emil G (emilgoode) wrote :
Download full text (3.4 KiB)

My E160 modem works perfectly with 10.04 alpha 3. The alpha 3 is also
surprisingly stable. Looks very promising!

On Sun, Mar 7, 2010 at 12:55 AM, Suyog <email address hidden> wrote:

> This issue is also with Lucid Lynx daily build which i downloaded on 5th
> March, please fix it.
> I am able to connect with gnome-ppp but not network manager same issue was
> with 9.10 so i am back to 9.04 where everything works. Huawei
> EC1260+Reliance Netconnect Broadband+ India
>
> --
> Huawei E220 modem unable to connect under Karmic
> https://bugs.launchpad.net/bugs/449394
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Confirmed
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: network-manager
>
> Network-Manager on Ubuntu Karmic beta is not able to bring up a UMTS (3G)
> connection with a Huawei E220 USB modem.
>
> network-manager:
> Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
>
> /var/log/messages :
>
> Oct 12 11:18:43 gripen pppd[3031]: Plugin
> /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
> Oct 12 11:18:43 gripen pppd[3031]: pppd 2.4.5 started by root, uid 0
> Oct 12 11:18:43 gripen pppd[3031]: Using interface ppp0
> Oct 12 11:18:43 gripen pppd[3031]: Connect: ppp0 <--> /dev/ttyUSB0
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:53 gripen pppd[3031]: Could not determine remote IP address:
> defaulting to 10.64.64.64
> Oct 12 11:18:53 gripen pppd[3031]: local IP address 41.28.69.53
> Oct 12 11:18:53 gripen pppd[3031]: remote IP address 10.64.64.64
> Oct 12 11:19:01 gripen kernel: [ 1675.920665] scsi38 : SCSI emulation for
> USB Mass Storage devices
> Oct 12 11:19:01 gripen pppd[3031]: Modem hangup
> Oct 12 11:19:01 gripen pppd[3031]: Connect time 0.2 minutes.
> Oct 12 11:19:01 gripen pppd[3031]: Sent 0 bytes, received 0 bytes.
> Oct 12 11:19:01 gripen kernel: [ 1702.004328] option1 ttyUSB0: GSM modem
> (1-port) converter now disconnected from ttyUSB0
> Oct 12 11:19:01 gripen kernel: [ 1702.004344] option 4-1:1.0: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.004413] option1 ttyUSB1: GSM modem
> (1-port) converter now disconnected from ttyUSB1
> Oct 12 11:19:01 gripen pppd[3031]: Connection terminated.
> Oct 12 11:19:01 gripen kernel: [ 1702.004433] option 4-1:1.1: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.118468] usb 4-1: reset full speed USB
> device using uhci_hcd and address 8
> Oct 12 11:19:01 gripen kernel: [ 1702.262388] option 4-1:1.1: GSM modem
> (1-port) converter detected
> Oct 12 11:19:01 gripen kernel: [ 1702.262515] usb 4-1: GSM modem (1-port)
> converter now attached to ttyUSB1
> Oct 12 11:19:01 gripen kernel: [ 1702.266788] option 4-1:1.0: GSM modem
> (1-port) converter detected
> Oct 12 11:19:01 gripen kernel: [ 1702.266921] usb 4-1: GSM modem (1-port)
> converter now attached to ttyUSB2
> Oct 12 11:19:02 gripen pppd[3031]: Exit.
> Oct 12 11:19:12 gripen kernel: [ 1702.309314] scsi 38:0:0:0: CD-ROM
> HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
> Oct 12 11:19:12 gripen kernel: [ ...

Read more...

Emil G (emilgoode) wrote :
Download full text (3.4 KiB)

Sorry Its a E640 modem that I have, built in with asus eee.

On Sun, Mar 7, 2010 at 12:55 AM, Suyog <email address hidden> wrote:

> This issue is also with Lucid Lynx daily build which i downloaded on 5th
> March, please fix it.
> I am able to connect with gnome-ppp but not network manager same issue was
> with 9.10 so i am back to 9.04 where everything works. Huawei
> EC1260+Reliance Netconnect Broadband+ India
>
> --
> Huawei E220 modem unable to connect under Karmic
> https://bugs.launchpad.net/bugs/449394
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Confirmed
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: network-manager
>
> Network-Manager on Ubuntu Karmic beta is not able to bring up a UMTS (3G)
> connection with a Huawei E220 USB modem.
>
> network-manager:
> Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
>
> /var/log/messages :
>
> Oct 12 11:18:43 gripen pppd[3031]: Plugin
> /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
> Oct 12 11:18:43 gripen pppd[3031]: pppd 2.4.5 started by root, uid 0
> Oct 12 11:18:43 gripen pppd[3031]: Using interface ppp0
> Oct 12 11:18:43 gripen pppd[3031]: Connect: ppp0 <--> /dev/ttyUSB0
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:43 gripen pppd[3031]: CHAP authentication succeeded
> Oct 12 11:18:53 gripen pppd[3031]: Could not determine remote IP address:
> defaulting to 10.64.64.64
> Oct 12 11:18:53 gripen pppd[3031]: local IP address 41.28.69.53
> Oct 12 11:18:53 gripen pppd[3031]: remote IP address 10.64.64.64
> Oct 12 11:19:01 gripen kernel: [ 1675.920665] scsi38 : SCSI emulation for
> USB Mass Storage devices
> Oct 12 11:19:01 gripen pppd[3031]: Modem hangup
> Oct 12 11:19:01 gripen pppd[3031]: Connect time 0.2 minutes.
> Oct 12 11:19:01 gripen pppd[3031]: Sent 0 bytes, received 0 bytes.
> Oct 12 11:19:01 gripen kernel: [ 1702.004328] option1 ttyUSB0: GSM modem
> (1-port) converter now disconnected from ttyUSB0
> Oct 12 11:19:01 gripen kernel: [ 1702.004344] option 4-1:1.0: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.004413] option1 ttyUSB1: GSM modem
> (1-port) converter now disconnected from ttyUSB1
> Oct 12 11:19:01 gripen pppd[3031]: Connection terminated.
> Oct 12 11:19:01 gripen kernel: [ 1702.004433] option 4-1:1.1: device
> disconnected
> Oct 12 11:19:01 gripen kernel: [ 1702.118468] usb 4-1: reset full speed USB
> device using uhci_hcd and address 8
> Oct 12 11:19:01 gripen kernel: [ 1702.262388] option 4-1:1.1: GSM modem
> (1-port) converter detected
> Oct 12 11:19:01 gripen kernel: [ 1702.262515] usb 4-1: GSM modem (1-port)
> converter now attached to ttyUSB1
> Oct 12 11:19:01 gripen kernel: [ 1702.266788] option 4-1:1.0: GSM modem
> (1-port) converter detected
> Oct 12 11:19:01 gripen kernel: [ 1702.266921] usb 4-1: GSM modem (1-port)
> converter now attached to ttyUSB2
> Oct 12 11:19:02 gripen pppd[3031]: Exit.
> Oct 12 11:19:12 gripen kernel: [ 1702.309314] scsi 38:0:0:0: CD-ROM
> HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
> Oct 12 11:19:12 gripen kernel: [ 1702.334268] sr1: scsi-1 drive
> Oct 12 11:19:12 grip...

Read more...

Ross Cadogan (ross-cadogan) wrote :

Upgrading the modem's firmware as per comment #15 got my Vodafone Ireland Huawei E220 3G modem working on Ubuntu 9.10. Many thanks!

Damjan Jovanovic (damjan-jov) wrote :

10.04 (Lucid) is still affected by this bug but I found a way to get the E220 working without a firmware update.

In 9.10 (Karmic), my investigation revealed it is user-space software that crashes the E220, and this software could be disabled as follows:
* Cold boot with the E220 unplugged
* sudo killall devkit-power-daemon
* sudo killall devkit-disks-daemon
* Plug in the E220 -> it works

In 10.04 (Lucid) things are a little harder. The first time I got my E220 working I had to do this:
* Cold boot with the E220 unplugged
* sudo killall upowerd
* sudo killall udisks-daemon
* Plug in the E220
* sudo modprobe usbserial vendor=0x12d1 product=0x1003
* then it works

However, in 10.04, I've noticed that when you get it working this way it seems to crash sporadically. A reproducible way to get it to crash is to run "udisks --enumerate" which starts up that udisks-daemon that was killed earlier.

But what does udisks-daemon do that causes the crash? Running "ps fax" shows it does 2 things: "polling /dev/sr0 /dev/sr1" (/dev/sr1 is the E220) and "mount /dev/sr1 ...". Both of these can be disabled with a udev rule.

Look at /etc/udev/rules.d/70-persistent-cd.rules, and change this line:

SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_SERIAL}=="HUAWEI_Mass_Storage-0:0", SYMLINK+="cdrom1", ENV{GENERATED}="1"

to this line:

SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_SERIAL}=="HUAWEI_Mass_Storage-0:0", SYMLINK+="cdrom1", ENV{GENERATED}="1", ENV{UDISKS_DISABLE_POLLING}="1", ENV{UDISKS_PRESENTATION_NOPOLICY}="1"

Just add the rule and reboot.

Adding those UDISKS_DISABLE_POLLING=1 and UDISKS_PRESENTATION_NOPOLICY=1 options causes udisks-daemon to ignore the E220 completely, preventing any crashes from it trying to poll/mount the virtual CD-ROM. In the testing I've done so far with this udev rule, it's worked like a charm, no need for running those earlier commands to get it working.

Good luck everyone and I hope this works out of the box in the next Ubuntu release,
Damjan

Manuel Cameselle (mcamel) wrote :

I'm not sure this is related with this bug, but my Huawei E220 stop working when i've updated from Ubuntu 9.10 to 10.04.

it began to work again when i removed the 'ozerocdoff' packet (i had to install in a previous version of Ubuntu to get the modem work).

David Fraser (davidf) wrote :
Download full text (3.3 KiB)

I had this problem under Karmic. Then under Lucid everything seemed to work fine, until yesterday ...
I tried following Damjan's instructions in #68, but they didn't work for me:
 * I added the rule to /etc/udev/rules.d and did a reboot
 * On plugging in the device, it seemed to initialize OK (light went flashing blue), but I could not see any 3G options under the NetworkManager menu
 * I then tried killing udisks-daemon and upowerd. After that, I plugged in the device again. This time, it showed up under NetworkManager and I got a successful connection
 * Based on the logs (see below), it seems that until I killed udisks-daemon and upowerd this wasn't registered as a GSM modem. But I didn't do a manual modprobe usbserial, that was loaded automatically, but only after killing those processes

Here's /var/log/messages from plugging in the device (initial timestamps and machine name stripped):
 [ 419.520174] usb 6-2: new full speed USB device using uhci_hcd and address 2
 [ 419.678471] usb 6-2: configuration #1 chosen from 1 choice
 [ 419.742527] Initializing USB Mass Storage driver...
 [ 419.744210] scsi5 : SCSI emulation for USB Mass Storage devices
 [ 419.744536] usbcore: registered new interface driver usb-storage
 [ 419.744542] USB Mass Storage support registered.
 [ 419.784205] usb 6-2: USB disconnect, address 2
 [ 420.520193] usb 6-2: new full speed USB device using uhci_hcd and address 3
 [ 420.677333] usb 6-2: configuration #1 chosen from 1 choice
 [ 420.691347] scsi8 : SCSI emulation for USB Mass Storage devices
 [ 425.696685] scsi 8:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
 [ 425.719657] sr1: scsi-1 drive
 [ 425.720083] sr 8:0:0:0: Attached scsi generic sg2 type 5

The following are the processes I killed (didn't seem to be polling sr1):
/usr/lib/udisks/udisks-daemon
udisks-daemon: polling /dev/sr0
/usr/lib/upower/upowerd

Here's /var/log/messages after killing them and plugging in the device again:
 [ 791.452167] usb 6-2: new full speed USB device using uhci_hcd and address 6
 [ 791.608408] usb 6-2: configuration #1 chosen from 1 choice
 [ 791.612235] scsi13 : SCSI emulation for USB Mass Storage devices
 [ 791.952146] usb 6-2: USB disconnect, address 6
 [ 792.248182] usb 6-2: new full speed USB device using uhci_hcd and address 7
 [ 792.405485] usb 6-2: configuration #1 chosen from 1 choice
 [ 792.422272] scsi16 : SCSI emulation for USB Mass Storage devices
 [ 792.462390] usbcore: registered new interface driver usbserial
 [ 792.462995] USB Serial support registered for generic
 [ 792.463155] usbcore: registered new interface driver usbserial_generic
 [ 792.463160] usbserial: USB Serial Driver core
 [ 792.482663] USB Serial support registered for GSM modem (1-port)
 [ 792.482788] option 6-2:1.0: GSM modem (1-port) converter detected
 [ 792.483592] usb 6-2: GSM modem (1-port) converter now attached to ttyUSB0
 [ 792.483621] option 6-2:1.1: GSM modem (1-port) converter detected
 [ 792.483732] usb 6-2: GSM modem (1-port) converter now attached to ttyUSB1
 [ 792.483767] usbcore: registered new interface driver option
 [ 792.483772] option: v0.7.2:USB Driver for GSM modems
 [ 7...

Read more...

Martin Wildam (mwildam) wrote :

Is it possible that we have a race condition here - as experiences vary?

David Fraser (davidf) wrote :

Upgrading firmware as recommended at https://bugzilla.kernel.org/show_bug.cgi?id=14499#c35 seems to have fixed the problem for me. Please check that out if you still have an issue

Mr Lee (leet+) wrote :

My modem is an E156G, which is recognized as an E220. The firmware version is 11.608.05.00.00. I did not have to upgrade the firmware.

Damjan's instructions worked for me, though I had to add "usbserial vendor=0x12d1 product=0x1003" to /etc/modules. Now it works like a charm. Thanks for the post.

Tim O'Brien (timob) wrote :

My modem is a E220, i had the same regression of the problem in 10.04. Updating the firmware fixed the problem for me. I live in New Zealand and the Vodafone site pointed me here to download the firmware.

http://www.business.vodafone.com/site/bus/public/enuk/support/10_productsupport/vista/30_modem/p_modem.jsp

Pedro Côrte-Real (pedrocr) wrote :

I can confirm that Damjan's solution in #68 works great for me.

Martin Wildam (mwildam) wrote :

On Tue, Aug 17, 2010 at 17:07, Pedro Côrte-Real <email address hidden> wrote:
> I can confirm that Damjan's solution in #68 works great for me.

I don't even have to do this. But I already have done a firmware
upgrade, installed usb_modeswitch and using latest officially released
kernel 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010
i686 GNU/Linux

--
Martin Wildam

http://www.google.com/profiles/mwildam

Tim O'Brien (timob) wrote :

My comment #74 , that link is to a too old firmware i got the firmware from the link mentioned in the kernel.org bug comments.

But modem going fine for nearly a month now.

Ian Johnston (ian-orbister) wrote :

I have just upgraded the firmware in my E220. It was already at 11.110.05.00.00 (the one from Vodafone) so I took it to 11.117.09.04.00.

Under 10.04.1 the behaviour is now decidedly odd.

When I plug it in lights flash and the CD part of it shows up. There is no sign of the modem side, though, and network manager does not give any mobile broadband connection options.

If I then plug in a spare ZTE MF627 dongle, mobile broadband appears as an option, and I can connect happily through the E220. After a while network manager offers connections through either device (not at first, though, when only the E220 is used), then it offers a choice. As soon as mobile broadband becomes an option I can remove the ZTE MF627 without causing problems, but it needs to be reinserted if the E220 is disconnected for any reason.

That's all on a fresh 10.04.1 install. usb_modeswitch is not installed, as I understand it should no longer be necessary.

Martin Wildam (mwildam) wrote :

On Tue, Aug 24, 2010 at 13:49, Ian Johnston <email address hidden> wrote:
> Under 10.04.1 the behaviour is now decidedly odd.

Indeed, but that is another story (I have different issues than you
are experiencing).

> [...]
> That's all on a fresh 10.04.1 install. usb_modeswitch is not installed,
> as I understand it should no longer be necessary.

From your description I would say you should install usb_modeswitch (I
did not hear anywhere that it is not required any more). I remember
similar experiences without usb_modeswitch installed.
--
Martin Wildam

http://www.google.com/profiles/mwildam

DannyDei (dei-bnb) wrote :

My E220 it is still working fine on a EeePC with Ubuntu Net 10.04 but on my Samsung Q45 the nm-applet does loop using more than 50% of the memory until I won't unplug the dongle.

The wi-fi icon also blinks at a stupidly fast rhythm and not on a pulse way as it does normally.

The Bugs on Huawei are so many that it is impossible to realise which could be the right one to add this, I'm sorry if I am using this one, I had to pick one.

I've tried with two kernel in case the problem would have been introduced lately but no success.
I'm attaching those trial's info
Thank you for your help on this
Ciao from Tuscany
Danny

manoka (vital233) wrote :

My E220 works fine on 10.04 but not on 9.10.
So if usb-modeswitch needs to be installed on 9.10, how can this be done without a connection to the internet?
Many thanks in advance!
manoka

Changed in linux:
status: Confirmed → Invalid
Didier Raboud (odyx) wrote :

Tagging as «invalid» as this is not an issue of usb-modeswitch (which cannot trigger it's own install…)

Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in usb-modeswitch (Ubuntu):
status: New → Invalid
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.