[Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC and in 10.04 LUCID

Bug #447192 reported by Tom Louwrier on 2009-10-09
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I wasn't doing anything, had logged off and closed the lid. When I re-opened it, things just hung.

enjoy
Tom

ProblemType: KernelOops
Annotation: This occured during a previous hibernate and prevented it from resuming properly.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: thomas 7083 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xc0000000 irq 16'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:14f12bfa,14f100c3,00090000 HDA:83847690,102801f6,00102201'
   Controls : 6
   Simple ctrls : 4
Date: Thu Oct 8 22:32:55 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: hibernate/resume
InterpreterPath: /usr/bin/python2.6
MachineType: Dell Inc. Latitude 131L
Package: linux-image-2.6.31-12-generic 2.6.31-12.41
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-12-generic root=UUID=46062d1f-f00c-4276-9ff1-541279640a93 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
RelatedPackageVersions: linux-firmware 1.21
SourcePackage: linux
Tags: resume hibernate
Title: [Dell Inc. Latitude 131L] hibernate/resume failure
Uname: Linux 2.6.31-12-generic x86_64
UserGroups: root
dmi.bios.date: 05/30/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.4.1
dmi.board.name: 0PM607??????
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvr2.4.1:bd05/30/2006:svnDellInc.:pnLatitude131L:pvrNotSpecified:rvnDellInc.:rn0PM607??????:rvr:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Latitude 131L
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: thomas 2498 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xc0000000 irq 16'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:14f12bfa,14f100c3,00090000 HDA:83847690,102801f6,00102201'
   Controls : 6
   Simple ctrls : 4
CheckboxSubmission: 41a9dc4bbc2c91d7f7445d204c57c74b
CheckboxSystem: d00f84de8a555815fa1c4660280da308
DistroRelease: Ubuntu 10.04
MachineType: Dell Inc. Latitude 131L
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=46062d1f-f00c-4276-9ff1-541279640a93 ro quiet splash
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
Tags: lucid regression-release
TestedUpstream: Yes
Uname: Linux 2.6.32-10-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev root tape video
dmi.bios.date: 05/30/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.4.1
dmi.board.name: 0PM607??????
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvr2.4.1:bd05/30/2006:svnDellInc.:pnLatitude131L:pvrNotSpecified:rvnDellInc.:rn0PM607??????:rvr:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Latitude 131L
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :
Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

hi again,

I'm running Karmic amd64 on a Dell Latitude 131L, updated at least twice a day.
Unfortunately the suspend/resume is (still) broken. Last time I tried it I closed all apps before choosing 'suspend' in the logout / shutdown menu. I didn't even try to just close the lid.
The suspending appears to work fine, but after opening the lid the screen stays black and the system seems to hang. I get no response from either mouse, keys or power button.
This leaves no other option than to lean on the power button until the system does a hard reboot.

Obviously this is not what you want on a laptop. Things worked fine on Jaunty.

Any more information you might need, just ask, but my command line skills are quite rusty now and never were very good in unix anyway.

cheers
Tom

summary: - [Dell Inc. Latitude 131L] hibernate/resume failure
+ [Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC
Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Re: [Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC

Still not working. Anybody started looking into this yet?

cheers
Tom

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : AlsaDevices.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Tom Louwrier (tom-louwrier) wrote : BootDmesg.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Card0.Amixer.values.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Card0.Codecs.codec.0.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Card0.Codecs.codec.1.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : IwConfig.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Lspci.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Lsusb.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : PciMultimedia.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : ProcModules.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : RfKill.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : UdevDb.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : UdevLog.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : WifiSyslog.txt

apport information

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Re: [Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC

See also bug 466868.

hi,

Unfortunately this is still an issue.

Suspend/resume and hibernate/resume all worked fine in Jaunty, but broke when I upgraded to Karmic beta. Never got fixed after Karmic got released as stable.
Some weeks ago I tried some of the packages in Lucid to see if that would fix it for me, but no joy.
Right now I've moved to Lucid completely (and enjoying it) but suspend/resume is still broken. Pretty annoying on a laptop.

Dell Latitude 131L / AMD / amd64 / Lucid on daily updates.
uname -a gives: Linux tom-laptop 2.6.32-10-generic #14-Ubuntu SMP Thu Jan 7 17:38:08 UTC 2010 x86_64 GNU/Linux

Let me know if I can do more to help you of give information.

cheers
Tom

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

See also bug 466868.

OK, today I gave it another try.
When choosing hibernate, the system seems to wind down as you would expect, but just before it should turn off there is a lot of disc activity and I get a straight X login screen (grey, square, not like my Gnome desktop).
It dosn't hang up my pc anymore, but is still not working as desired.

cheers
Tom

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

update-
Just loaded my daily dose of updates and guess what? Suspend/resume seems to work now.
Hibernating is still broken though, same as described above.

greetz
Tom

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

Tried again today after last night's updates. Also I shuffled some partitions around to get more free space (now 1.3GB in / and 1.5GB in /home)
Suspend and resume work fine, hibernate still comes back just when you think it is about to switch off.
Dis a x-post in bug 466868 as well.

cheers
Tom

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

Hibernate is still not working right as of today. Running Lucid amd64, all updates loaded twice a day.

cheers
Tom

Changed in linux (Ubuntu):
status: New → Confirmed
summary: - [Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC
+ [Dell Inc. Latitude 131L] hibernate/resume failure in 9.10 KARMIC and in
+ 10.04 LUCID
Revision history for this message
Michael (michaelnt) wrote :

Booting the kernel 2.6.32-21-generic, suspend and resume works for me on a Dell XPS 1330 but fails if I boot the latest kernel, 2.6.32-22-generic, 2.6.32-23-generic

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

There were some kernel updates recently and I noticed boot and shutdown behaviour changing (good, since I'm having one of those troublesome ATI Xpress 200M chips onboard.)
Gave it another whirl yesterday; chose hibernate manually from the start/stop button (excuse the winblows parlour...).
System took a while, but did go into something that looked like hibernation. This morning I switched on again and after choosing the normal (default) Ubuntu option from Grub, it came back to me exactly as I left it the night before. Hooray.

Will keep an eye out for slip ups and report back in a week or so, but for now this seems solved to me.
Thanx everbody.

cheers
Tom

uname -a
Linux tom-laptop 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 x86_64 GNU/Linux

Revision history for this message
Michael (michaelnt) wrote :

Turns out my suspend problem was caused by having an SD card inserted, if I remove the card then it suspends fine.

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

Yep, keeps working fine now, using hibernate instead of shutdown most of the time.
Thanx!

cheers
Tom

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions