The Synaptic Touchpad on my Eee Pc 701 doesn't work correctly

Bug #441013 reported by Paulo Albuquerque on 2009-10-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by John Gilmore

Bug Description

I have an Eee PC 701 4G and I installed Karmic Beta today. My touch pad doesn't seem to work correctly. I can move the cursor, but it doesn't detect tapping with my finger, I have to use the button.

I see this error in dmesg:
[ 17.277222] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9
[ 17.668728] render error detected, EIR: 0x00000010
[ 17.668738] page table error
[ 17.668742] PGTBL_ER: 0x00000100
[ 17.668750] [drm:i915_handle_error] *ERROR* EIR stuck: 0x00000010, masking
[ 17.668768] render error detected, EIR: 0x00000010
[ 17.668773] page table error
[ 17.668777] PGTBL_ER: 0x00000100

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pmfa 1390 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7eb8000 irq 16'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,104382a1,00100101'
   Controls : 14
   Simple ctrls : 9
Date: Sat Oct 3 02:00:13 2009
DistroRelease: Ubuntu 9.10
MachineType: ASUSTeK Computer INC. 701
Package: linux-image-2.6.31-11-generic 2.6.31-11.38
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=4fc85f8a-ce43-43bf-ac22-d7205d9a942a ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-11-generic N/A
 linux-firmware 1.20
SourcePackage: linux
Tags: ubuntu-unr
Uname: Linux 2.6.31-11-generic i686
XsessionErrors:
 (gnome-settings-daemon:1405): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1405): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1444): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:1441): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.1/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
 (polkit-gnome-authentication-agent-1:1479): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 03/03/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0910
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 701
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0910:bd03/03/2008:svnASUSTeKComputerINC.:pn701:pvrx.x:rvnASUSTeKComputerINC.:rn701:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 701
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

tags: added: lucid
John Gilmore (gnu-gilmore) wrote :

This may be a deliberate UI change. I had the same problem. I found in UNR karmic daily 20091006 that the System Preferences "Mouse" setting now has a "Touchpad" tab, containing a checkbox to "Enable mouse clicks with touchpad" (and some other settings).

When I enabled it here, tapping on the touchpad started working.

This appears to be a regression, since in previous releases, tapping just worked without dinking with settings.

See ChangeLog here: http://changelogs.ubuntu.com/changelogs/pool/main/g/gnome-control-center/gnome-control-center_2.28.0-0ubuntu4/changelog . It isn't specific about stating that they wanted to change this behavior.

John Gilmore (gnu-gilmore) wrote :

There are now more than a dozen bugs reported against this. See the original bug report at #378391.

The problem appears to be that as people report the bug, they are marked as dups and lniked to that bug -- but that one is marked "Fix Released". So nobody does anything to fix the bug, which is that the behavior regressed against Jaunty. (The fact that you can go into a Preferences item and restore the Jaunty behavior is nice, but the bug is that the Jaunty behavior changed. What worked in Jaunty does not work in Karmic.)

All that's needed to *really* fix this bug is to change the default preference -- so that tapping touchpads works by default, rather than only after you enable them.

John Gilmore (gnu-gilmore) wrote :

This is not a ($*#$*#( duplicate! The problem is the regression from Jaunty. That problem was not fixed by adding a new Control Panel item that re-enables the old behavior. The problem is that you NEED to re-enable the old behavior.

Jerone Young (jerone) wrote :

@John
   The behavior in realease Karmic has changed. You will be able to try it on a live cd and install tommorow. "Enable mouse clicks with touchpad" is now enabled by default. It has had this behavior since RC build.

tags: removed: lucid
tags: added: iso-testing
Jeremy Foshee (jeremyfoshee) wrote :

Hi Paulo,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 441013

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
John Gilmore (gnu-gilmore) wrote :

This bug appears to have been fixed. The problem is as reported in comments #3 to #4, and the fix was reported in #5. Someone fixed the default value in the release. I just tested this on Lucid and it worked for me. (I don't have an EEE PC but my Acer Aspire One D250 touchpad had the same trouble before the fix went in.)

Why this would need kernel logs or upstream testing, I have no idea. I think the problem is either some automated robot, or else a human acting like one, added those tags to this bug report.

John Gilmore (gnu-gilmore) wrote :

Oh, I see. If you add tags like "needs-upstream-testing" to a bug, then it becomes "incomplete", so then a robot will expire it a few months later. It's a cheat to get bugs to go away. The product is so much better when bug reports get swept under the rug by people or robots who don't actually understand them.

Jeremy Foshee (jeremyfoshee) wrote :

John,
    Not at all. i use the script to help me manage the 10,000+ bug reports that I am responsible for. I ask for the further testing in cases where it is needed and triage the bugs based on the responsiveness of the reporters. If I get the data I need, then I can put a legitimate bug in front of a Kernel Engineer rather than a bug that seems serious that no one is responding on.

Thanks!

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

Paulo,
    Are you able to confirm that this has been fixed as stated by John above?

Thanks!

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu development release http://cdimage.ubuntu.com/daily-live/current/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers