Ubuntu

ext4 journal error, remounted read-only after resume

Reported by Jochen Römling on 2009-09-28
164
This bug affects 31 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Armando Di Cianno

Bug Description

1. Release:
Description: Ubuntu karmic (development branch)
Release: 9.10

2. Package version:
linux:
  Installed: (none)
  Candidate: 2.6.31.11.22
  Version table:
     2.6.31.11.22 0
        500 http://se.archive.ubuntu.com karmic/main Packages

3. Expected behavior
System resumes and ext4 root filesystem is mounted rw as it was before suspend. No journal errors occur.

4. What happens instead
After suspend/resume, the ext4 root filesystem is mounted as read-only. Some journal-errors can be found in dmesg and a manual fsck finds some inconsistencies that are fixable without problems. Filesystem cannot be remounted rw, because it is "write-protected". I don't know how to disable this write-protection, so the only way of continuing is a reboot. dmesg output could not be saved. This happened several times already (unsure, if EVERY time or only MOST of the times).

Additional info:
uname -a
Linux jochen-m 2.6.31-11-generic #36-Ubuntu SMP Fri Sep 25 06:37:51 UTC 2009 i686 GNU/Linux

cat /proc/version_signature
Ubuntu 2.6.31-11.36-generic

dmesg after reboot and lspci attached.
The root filesystem is on a USB-attached SD-memory-card, because I am testing Ubuntu 9.10 without touching the production system on the harddisk and I don't have space left to have the test system on an own partition on the harddisk.

ProblemType: KernelOops
Annotation: This occured during a previous suspend and prevented it from resuming properly.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC660-VD Analog [ALC660-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC660-VD Analog [ALC660-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jochen 1606 F.... knotify4
                      jochen 1638 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfeaf8000 irq 22'
   Mixer name : 'Realtek ALC660-VD'
   Components : 'HDA:10ec0660,1631c10a,00100001'
   Controls : 17
   Simple ctrls : 11
Date: Mon Sep 28 22:30:22 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=ed1671b3-d85d-44cc-a93c-eef8af6f6777
InterpreterPath: /usr/bin/python2.6
MachineType: Packard Bell BV EasyNote_BG45-U-010
Package: linux-image-2.6.31-11-generic 2.6.31-11.36
ProcCmdLine: root=/dev/sdb1 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apportcheckresume
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions: linux-firmware 1.19
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Tags: resume suspend
Title: [Packard Bell BV EasyNote_BG45-U-010] suspend/resume failure
Uname: Linux 2.6.31-11-generic i686
UserGroups:

dmi.bios.date: 10/03/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: EasyNote_BG45
dmi.board.vendor: PACKARD BELL BV
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: PACKARD BELL BV
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr203:bd10/03/2007:svnPackardBellBV:pnEasyNote_BG45-U-010:pvrPC11E00891:rvnPACKARDBELLBV:rnEasyNote_BG45:rvr1.0:cvnPACKARDBELLBV:ct10:cvr1.0:
dmi.product.name: EasyNote_BG45-U-010
dmi.product.version: PC11E00891
dmi.sys.vendor: Packard Bell BV

if this happens again, I'll try to save the dmesg output to another memory card in order to attach it to this bug.

Jeremy Foshee (jeremyfoshee) wrote :

Jochen,
     Would it be possible for you to also test the latest upstream mainline kernel available? This will allow additional upstream developers to examine this issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Thanks in advance.

-JFo

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete

attaching full dmesg log containing the journal error:

[12044.533766] JBD2: Detected IO errors while flushing file data on sdb1:8
[12044.533801] Aborting journal on device sdb1:8.
[12044.536197] EXT4-fs error (device sdb1): ext4_journal_start_sb: Detected aborted journal
[12044.536207] EXT4-fs (sdb1): Remounting filesystem read-only
[12044.753276] journal commit I/O error
[12044.754345] sd 5:0:0:0: [sdb] Assuming drive cache: write through

performing a fsck gives the following (varying, but always the same kind of message, sometimes it even asks y/n):

fsck from util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
/dev/sdb1: recovering journal
Clearing orphaned inode 88661 (uid=500, gid=1000, mode=0140755, size=0)
/dev/sdb1: clean, 130365/484800 files, 1018223/1938616 blocks

trying to remount rw gives the following

sudo mount -o remount,rw -t ext4 /dev/sdb1 /
mount: cannot remount block device /dev/sdb1 read-write, is write-protected

the error occurs in about 40% of the resume cases and sometimes even after a cold boot.
I will install a mainline kernel as you suggested and see if it still occurs, but maybe you already have some ideas what it can be?

As said before: root is on /dev/sdb1, a built-in, but USB-attached SD-card-reader. I don't have a spare hard disk at hand to test, if this might be the problem.

This is also affecting netbook users (notably Acer Aspire One) who have a SD card in the "storage expansion slot" that mounts as /home, making suspending effectively useless, because a reboot is required afterwards anyway.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
arthurcamargo (camargo-arthur) wrote :

After last update, the ext4 root filesystem is mounted as read-only.

Irishbandit (irishbandit) wrote :

I am having a similar problem with a fresh install of Karmic 9.10 RC.
This is a desktop and it is not set to suspend or resume.
uname -a
Linux Desktop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Olivier Grisel (olivier-grisel) wrote :

Similar isue with both Jaunty and Karmic (same machine before and after upgrade) with EXT4 main partition on an SSD drive (MackbookPro 5.5). I added a noatime option but the problem as occurred again:

dmesg excerpt:

[85177.117155] EXT4-fs error (device sda3): htree_dirblock_to_tree: bad entry in directory #308546: directory entry across blocks - offset=0, inode=3633236108, rec_len=180364, name_len=142
[85177.117178] Aborting journal on device sda3:8.
[85177.117320] EXT4-fs (sda3): Remounting filesystem read-only
[85189.126309] EXT4-fs error (device sda3): htree_dirblock_to_tree: bad entry in directory #308546: directory entry across blocks - offset=0, inode=3633236108, rec_len=180364, name_len=142
[85192.321605] EXT4-fs error (device sda3): htree_dirblock_to_tree: bad entry in directory #308546: directory entry across blocks - offset=0, inode=3633236108, rec_len=180364, name_len=142
[85198.608480] EXT4-fs error (device sda3): htree_dirblock_to_tree: bad entry in directory #308546: directory entry across blocks - offset=0, inode=3633236108, rec_len=180364, name_len=142
[85209.177

mount output:

/dev/sda3 on / type ext4 (rw,noatime,relatime,errors=remount-ro)

uname -a
Linux turingcarpet 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Previous fsck (automatically triggered at reboot) did fixed the bad blocks without loosing important data AFAIK. I hope this will be the case again this time.

Nir Misgav (nirmisgav) wrote :

I have this problem too. After resume from suspend, the ext4 filesystem is mounted as read only, and the desktop is quite stuck.
When I reboot, I get to a console, and I have to do : fsck -y which fixes some things, and then I can boot again.

I can provide some logs if needed.

bitinerant (bitinerant) wrote :

Four times now I have experienced what I think is exactly the same problem ("touch: cannot touch `testfile': Read-only file system") except that it happened while the computer was on rather than after resume. Three of the four times I was away from my laptop when it happened and had to kill the screen saver via ctrl-alt-F1. I could then view everything I had been working on on ctrl-alt-F7, but was unable to save any documents. The next boot says, "Mount of filesystem failed." but "fsck -y" seemed to be able to fix everything without loss of data (other than unsaved open documents). I thought this might be a failing hard drive but I mirrored my drive to another of the same size and the fourth time was with the new hard drive.

One thing in common to all four occurrences is that I was synchronizing files between my laptop and another using Unison (http://www.cis.upenn.edu/~bcpierce/unison/). However this runs as a normal user (not root). My suspicion is that this problem occurs more often (or only?) during periods of heavy disk usage.

I use one huge ext4 volume (mounted as /) with it and swap as LVs on LVM on top of dm-crypt/LUKS encryption. My system is a MacBook 2,1, 160 GB HDD (not SDD), kernel 2.6.31-16-generic with standard updates.

daveted (ajrtin) wrote :

Hello,

I have a similar problem, after a power crash my system reboot normally but as read-only... (Ubuntu Jaunty ext4 root fs)
This is realy annoying and strange...

I have modified the /etc/fstab to force rw...
Here is an output of mount command for the root FS:

/dev/sda1 on / type ext4 (rw)

As you can see it is in read write mode but...

root@kiss:/# echo a > a
bash: a: Système de fichiers accessible en lecture seulement
(read only file system)

?????

But if i enter the command
mount -t ext4 -o rw,remount /dev/sda1 /
it works

I have found a workaround to be able to use the system:
i add:
mount -t ext4 -o rw,remount /dev/sda1 /
to /etc/rc.local

But this is a ugly workaround this is just like if the FS was "locked"...

Stuart (stuartneilson) wrote :

This bug occurs with both ext3 and ext4 filing systems. A separate /home at least allows saving of personal data when the root filesystem locks.

Jeremy Foshee (jeremyfoshee) wrote :

daveted,
    Please file a separate bug as your issue is different.

Thanks!

-JFo

hellslinger (jhemsing) wrote :

This happens to me also during normal usage without any kind of suspend/resume actions. I installed 9.10 as an upgrade from 8.10 recently. When I had 8.10 installed on an EXT3 root partition, this never happened. Hard drive smart status is healthy with no errors.

Kernel Version:

Linux thetank 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

slavik112211 (slavik2121) wrote :

Same for me. After suspend, my ext4 file system contains errors, and mounts read-only.

System is ubuntu 9.10, kde 4.4.1.

I'm using the suspend command from kde menu, which is something like
qdbus org.kde.kded /modules/powerdevil suspend 2

So, could be something with powerdevil not being able to correctly pass to ACPI state S3

Gonna check other commands for the transition to ACPI state S3 (suspend)

slavik112211 (slavik2121) wrote :

hmm, seems like sending 'mem' to /sys/power/state doesn't create any errors on ext4 file system:
echo mem | sudo tee /sys/power/state
(though later it causes problems with X, see here:
http://www.linux.com/news/hardware/laptops/8253-how-to-suspend-and-hibernate-a-laptop-under-linux)

my opinion is that kde software is messing the file system up.
huh, god help linux

I'm experiencing these issues as well. Always after a resume, and so far never the first suspend/resume of an uptime.

I'm running the 10.04 beta (couldn't run anything earlier because of very new KMS on this Intel chipset).

$ uname -a
Linux klesh 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64 GNU/Linux

I don't believe this has anything to do with KDE; I'm running stock (beta) Ubuntu here.

FWIW, I had Gentoo on this box, also with ext4, with a 2.6.33 kernel, and this problem never occurred. I had this box setup using s2ram to enter suspend, and it always worked.

This issue is *extremely* serious. The only way to boot again is to manually run fsck (-y) from an install CD!

slavik112211 (slavik2121) wrote :

hello again.

Yes have to say that the issue remains even with suspend from gnome desktop, and from command line using

echo mem | sudo tee /sys/power/state

looking through the internet it seems like it is a ext4+ suspend problem.

will try this out: http://www.linuxquestions.org/questions/linux-newbie-8/after-suspend-to-ram-unable-to-unlock-or-startx-794397/page3.html

slavik112211 (slavik2121) wrote :

also noticed that ubuntu kernel team accepts bug reports on suspend/hibernate under ubuntu (though seems a bit outdated)

https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting

Stuart (stuartneilson) wrote :

This bug persists in Ubuntu 10.04

Dr. Burnett (cortezb3) wrote :

Hi All,

I had similar problem using 2.6.32-22-generic (64-bit) kernel under Ubuntu 10.04 LTS. I reported it to a similar post in this bug report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/528981

Scott Testerman came up with a protocol for upgrading the Kernel that seemed to help me, but your mileage may vary. Here it is:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/528981/comments/28

I hope this helps you folks.

Stuart (stuartneilson) wrote :

Perhaps this should be a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/528981 ?

asamf (asamf-imran) wrote :

hi.......
my memorycard and micro sd ,ipod and all other portable devices loads as read-only...i cant copy any data to it can any one help me .................................................pls

dcecchin (dcecchin) wrote :

I'm using Kubuntu 10.10 on 2.6.35 and I have this exact same problem so it must not be a duplicate of that bug.

Gigabyte X58A-UD3R
Intel i7-930
G.Skill-NQ 6GB Kit (3x2GB) DDR31600 RAM
Gigabyte 1280M GTX470
OCZ Vertex 120GB and OCZ Vertex 2 120GB
Controller: Vertex 1 with Indilinx Vertex 2 with Sandforce

Incidentally I also found this thread: http://www.ocztechnologyforum.com/forum/showthread.php?80161-Vertex-2-60GB-running-great-except-suspend-to-RAM-causes-file-system-errors

John Wells (jfw) wrote :

Exact same problem here with Maverick, default 2.6.35-23-generic kernel, amd64.

Also a Gigabyte x58a-ud3r, and an OCZ Vertex 2 SSD (as well as a Patriot Warp SSD)

Reports of ext4 corruption, and devices mounted ro after resuming from suspend.

John Wells (jfw) wrote :

Exact same problem here with Maverick, default 2.6.35-23-generic kernel, amd64.

Also a Gigabyte x58a-ud3r, and an OCZ Vertex 2 SSD (as well as a Patriot Warp SSD)

Reports of ext4 corruption, and devices mounted ro after resuming from suspend.

pierrelux (pierrelucbacon) wrote :

I started noticing this problem a few days ago. My system has been running smoothly since the original install (10.10). However, it has become totally usuable today. I used to "fix" the problem by inserting a live CD and running fsck, but this time, the bug is systematic. It was apparently just happening after a resume, but now this is also straight after a coldboot, 100% of the time (5 live-cd, fsck, reboot cycles in a row).

I think that this might have something to do with recent power optimization I have made using PowerTop (the problem started to occur approximately at the same time). I remember having set some option related to the hard disk. This might be some kind of bug caused by timeout due to the spinoff on the disk while EXT4 is trying to flush data.

I would have liked to post more details from dmesg, but when this problem happens, it's the whole system that becomes usuable, even the browser.

From the top of my head, this was kernel 2.6.35-icantsayfutherthanthat, on 32 bits install, under 10.10, with EXT4.

I'm now re-installing the whole thing, but this time I won't play with powertop, just to see if it makes any difference.

pierrelux (pierrelucbacon) wrote :

Starting with a clean install, and not having used powertop this time, I got the same problem again today.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Hassan Abbas (habbas99) wrote :

I have Ubuntu Server 12.10 installed on my Lenovo ThinkServer 12.10 machine. I can`t remember what I had changed, but when I rebooted my machine it would not boot in standard mode and would stay on the following line:

Adding 4162556K swap ib /dev/sda3: Priority: -1 Extents: 1 Across: 4162556K
Ext4-fs (sda2): re-mounted. Opts: errors=remount-ro

On the other side, I am able to boot using recovery mode using its normal boot. But then a reboot would give me the same result (as above).

Here is the fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda2 during installation
UUID=18a057a7-53b4-4725-b5b9-98c033902313 / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda1 during installation
UUID=B83C-5D4C /boot/efi vfat defaults 0 1
# swap was on /dev/sda3 during installation
UUID=e23378b5-cb32-48b8-9eb6-9d6950ca8a62 none swap sw 0 0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers