move to HZ=100 on non-i386/lpia for efficiency...

Bug #438234 reported by Daniel J Blueman
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Karmic
Medium
Tim Gardner

Bug Description

Upstream defaulted to HZ=100 to improve efficiency where highres timers are available; see benchmark at http://lwn.net/Articles/331607/ .

To remain competitive, Ubuntu Karmic should consider where this is possible. At present, i386 and lpia often don't provide a HPET or such adequate timer, thus leave HZ=250 on these arches. The opportunity thus exists on other architectures.

Further discussion at:
http://groups.google.com/group/linux.kernel/browse_thread/thread/e6b370e71ddfe153/f164d6068360b034?#f164d6068360b034

Justification: keep Ubuntu Karmic competitive with other distros, and maximise user experience due to more efficiency

Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-11.37

---------------
linux (2.6.31-11.37) karmic; urgency=low

  [ Tim Gardner ]

  * [Config] Increase kernel log buffer to 256K for amd64 flavours
    - LP: #424810
  * [Config] Set HZ=100 for amd64 flavours
    - LP: #438234
  * [Upstream] e1000e: Emit notice instead of an error when
    pci_enable_pcie_error_reporting() fails
    - LP: #436370

  [ Upstream Kernel Changes ]

  * n_tty: honor opost flag for echoes
  * n_tty: move echoctl check and clean up logic
    - LP: #438310

  * Revert "[Upstream] drm/i915: Check that the relocation points to within
    the target" - Use upstream cherry-pick.
  * drm/i915: Check that the relocation points to within the target
    - LP: #429241

  * drm/i915: fix tiling on IGDNG
  * drm/i915: add B43 chipset support
  * agp/intel: Add B43 chipset support
    Intel request from kernel team mailing list.

  * HID: completely remove apple mightymouse from blacklist
    - LP: #428111

 -- Tim Gardner <email address hidden> Mon, 28 Sep 2009 11:47:29 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Revision history for this message
Peter P. (peter-p-launchpad) wrote :
Revision history for this message
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers