BUG: unable to handle kernel NULL pointer dereference at 00000040

Bug #437258 reported by vongoldi
410
This bug affects 108 people
Affects Status Importance Assigned to Milestone
Linux
Won't Fix
Undecided
Unassigned
linux (Ubuntu)
Medium
John Johansen
Karmic
Medium
Unassigned

Bug Description

SRU Justification: This can cause an oops at 000068. This will happen to all processes confined or unconfined when name resolution fails at exec. This can happen in a couple different cases, applications like psx, and mugen munge the process during their decrompress and set up links so that a valid name does not exist. The other way that this can happen is executing code from a path that has been lazily unmounted. This can occur with nfs and automounters, or any mount point that gets unmounted with lazy unmount allowed.

I use kerel 2.6.31-11
whene i start the Playstation Emulator epsxe came a message killed and that crashreport.
The Playstation Emulator pSX doesen t work too. but it is not the same problem.
Whit the Kernel 2.6.29 the Emulators run very good. but since one week i have problems with the sound ander kernel 2.6.29.

When i start linux with kernel 2.6.31-11 came a black screen. then i go in a console by pressing strg alt F2 and make startx.

ProblemType: KernelOops
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: andreas 4589 F.... knotify4
                      andreas 4596 F.... pulseaudio
                      andreas 4667 F.... kmix
 /dev/snd/seq: timidity 3656 F.... timidity
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SIS966'/'HDA SIS966 at 0xfe0f4000 irq 21'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,146263f6,00100002 HDA:11c11040,11c10001,00100200'
   Controls : 29
   Simple ctrls : 17
Date: Sat Sep 26 18:02:29 2009
DistroRelease: Ubuntu 9.10
Failure: oops
HibernationDevice: RESUME=UUID=f75160d9-0bf9-4094-b704-5e9db7d2fabf
MachineType: LG Electronics E500-V.APRAG
NonfreeKernelModules: fglrx
Package: linux-image-2.6.31-11-generic 2.6.31-11.36
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=e47e02e6-569f-43fc-b441-b53221582909 ro quiet splash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions: linux-firmware 1.19
RfKill:

SourcePackage: linux
Tags: kernel-oops
Title: BUG: unable to handle kernel NULL pointer dereference at 00000040
Uname: Linux 2.6.31-11-generic i686
WpaSupplicantLog:

dmi.bios.date: 04/10/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: A163LSL1 V1.0A
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-163L
dmi.board.vendor: LG Electronics
dmi.board.version: Ver 1.000
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrA163LSL1V1.0A:bd04/10/2008:svnLGElectronics:pnE500-V.APRAG:pvrVer1.000:rvnLGElectronics:rnMS-163L:rvrVer1.000:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: E500-V.APRAG
dmi.product.version: Ver 1.000
dmi.sys.vendor: LG Electronics

Revision history for this message
vongoldi (vongoldi) wrote :
Revision history for this message
Pierre Cardoso (gonnalose) wrote :

Hello,
I am affected by (apparently) the same problem, with the same app (epsxe v1.6.0).
This app worked fine with Kubuntu Jaunty, it no longer starts with Kubuntu Karmic RC.
I attached a bit of my "dmesg" output.
Anyway, this issue looks a lot like bug #446164 too. I removed the apparmor package to see if it changed anything (since the kernel message mentions apparmor_bprm_set_creds) , but no : even with apparmor removed, the same crash happens.
Thanks.

Revision history for this message
Pierre Cardoso (gonnalose) wrote :

Just a word about epsxe 1.6. I just noticed libgtk-1.2 has been removed from Karmic, but epsxe needs it.
So, epsxe won't run on Karmic anyway (as far as I know).

Revision history for this message
routtj (routtj) wrote :

It will if you just download libgtk1.2 and its dependencies anyway.

Revision history for this message
Mike (mwielgosz) wrote :

You must install the package 'upx-ucl'
'sudo apt-get install upx-ucl'
Navigate to the epsxe binary [/usr/local/bin/epsxe] and run:
'sudo upx -d epsxe'

The kernel will not crash upon running epsxe.

With the Karmic release, libgtk1.2 has been removed and it is not in the package manager. You must manually install it. I did this through the Ubuntu Package Website:
http://packages.ubuntu.com/dapper/libgtk1.2

Dependencies:
dpkg http://packages.ubuntu.com/dapper/dpkg
libc6 http://packages.ubuntu.com/dapper/libc6
libglib1.2 http://packages.ubuntu.com/dapper/libglib1.2
libgtk1.2-common http://packages.ubuntu.com/dapper/libgtk1.2-common
libx11-6 http://packages.ubuntu.com/dapper/libx11-6
libxext6 http://packages.ubuntu.com/dapper/libxext6
libxi6 http://packages.ubuntu.com/dapper/libxi6

Personally, I had to install libglib1.2 and libgtk1.2-common in order to satisfy the libgtk1.2 dependencies.

The kernel problem was solved after completing this process.
I did have one other problem. The link to 'epsxe' that was located in '/usr/local/bin/epsxe' would not load the plugins or configurations. I ended up navigating to '/usr/local/games/epsxe/' where all my plugins and configurations are located and ran:
'sudo upx -d epsxe'
I then created a launcher pointing at '/usr/local/games/epsxe/epsxe' Now my configurations load and the emulator is playable once again.

Revision history for this message
Pierre Cardoso (gonnalose) wrote :

This works for me. Thanks!

For Kubuntu Karmic, I manually installed (with 'sudo dpkg -i') the three following Jaunty packages :
http://packages.ubuntu.com/jaunty/libglib1.2ldbl
http://packages.ubuntu.com/jaunty/libgtk1.2
http://packages.ubuntu.com/jaunty/libgtk1.2-common
And then installed and used 'upx-ucl' as stated above.

If I sum up what happens, the "epsxe" executable is compressed, and somehow doesn't manage to decompress itself on Karmic - so that you have to decompress it once and for all using upx.

I don't know how big an issue this could be, since epsxe isn't even part of Ubuntu...

Revision history for this message
ArmandiuxGS (patagonia92) wrote :

Igual yo, cuando inicio 'epsxe' (sin instalar, sino en otro directorio (mi carpeta personal)), recibo el mensaje de "Terminado (Killed)", (aun cuando lo instalo en "/usr/local/bin/epsxe").

*Excuse me for write in Spanish.

description: updated
Stefan Bader (smb)
Changed in linux (Ubuntu):
assignee: nobody → John Johansen (jjohansen)
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu Karmic):
importance: Undecided → Medium
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-4.5

---------------
linux (2.6.32-4.5) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] SERIO_LIBPS2 and SERIO_I8042 must match
  * rebase to v2.6.32-rc7
  * resync with Karmic proposed

  [ John Johansen ]

  * SAUCE: AppArmor: Fix oops after profile removal
    - LP: #475619
  * SAUCE: AppArmor: Fix Oops when in apparmor_bprm_set_creds
    - LP: #437258
  * SAUCE: AppArmor: Fix cap audit_caching preemption disabling
    - LP: #479102
  * SAUCE: AppArmor: Fix refcounting bug causing leak of creds
    - LP: #479115
  * SAUCE: AppArmor: Fix oops there is no tracer and doing unsafe
    transition.
    - LP: #480112

  [ Ubuntu Changes ]

  * resync with Karmic proposed (ddbc670a86a3dee18541a3734149f250ff307adf)

  [ Upstream Kernel Changes ]

  * rebase to v2.6.32-rc7
 -- Andy Whitcroft <email address hidden> Fri, 13 Nov 2009 11:35:13 +0000

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
John Reiser (jreiser) wrote :

linux-image generic-pae 2.6.31-16.53 from -proposed fixes bug 471819 (fail to exec result of upx --force-execve) which has been marked as a duplicate of this bug 437258.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Werner E. Goedecke Rodriguez (goedecke) wrote :

5

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (11.9 KiB)

This bug was fixed in the package linux - 2.6.31-17.54

---------------
linux (2.6.31-17.54) karmic-proposed; urgency=low

  [ John Johansen ]

  * SAUCE: AppArmor: Fix oops after profile removal
    - LP: #475619
  * SAUCE: AppArmor: Fix Oops when in apparmor_bprm_set_creds
    - LP: #437258
  * SAUCE: AppArmor: Fix cap audit_caching preemption disabling
    - LP: #479102
  * SAUCE: AppArmor: Fix refcounting bug causing leak of creds
    - LP: #479115
  * SAUCE: AppArmor: Fix oops there is no tracer and doing unsafe
    transition.
    - LP: #480112

  [ Leann Ogasawara ]

  * Revert "[Upstream] (drop after 2.6.31) usb-storage: Workaround devices
    with bogus sense size"
    - LP: #461556
  * Revert "[Upstream] (drop after 2.6.31) Input: synaptics - add another
    Protege M300 to rate blacklist"
    - LP: #480144

  [ Tim Gardner ]

  * [Config] udeb: Add squashfs to fs-core-modules
    - LP: #352615

  [ Upstream Kernel Changes ]

  * Revert "e1000e: swap max hw supported frame size between 82574 and
    82583"
    - LP: #461556
  * Revert "drm/i915: Fix FDI M/N setting according with correct color
    depth"
    - LP: #480144
  * Revert "agp/intel: Add B43 chipset support"
    - LP: #480144
  * Revert "drm/i915: add B43 chipset support"
    - LP: #480144
  * Revert "ACPI: Attach the ACPI device to the ACPI handle as early as
    possible"
    - LP: #327499, #480144
  * SCSI: Retry ADD_TO_MLQUEUE return value for EH commands
    - LP: #461556
  * SCSI: Fix protection scsi_data_buffer leak
    - LP: #461556
  * SCSI: sg: Free data buffers after calling blk_rq_unmap_user
    - LP: #461556
  * ARM: pxa: workaround errata #37 by not using half turbo switching
    - LP: #461556
  * tracing/filters: Fix memory leak when setting a filter
    - LP: #461556
  * x86/paravirt: Use normal calling sequences for irq enable/disable
    - LP: #461556
  * USB: ftdi_sio: remove tty->low_latency
    - LP: #461556
  * USB: ftdi_sio: remove unused rx_byte counter
    - LP: #461556
  * USB: ftdi_sio: clean up read completion handler
    - LP: #461556
  * USB: ftdi_sio: re-implement read processing
    - LP: #461556
  * USB: pl2303: fix error characters not being reported to ldisc
    - LP: #461556
  * USB: digi_acceleport: Fix broken unthrottle.
    - LP: #461556
  * USB: serial: don't call release without attach
    - LP: #461556
  * USB: option: Toshiba G450 device id
    - LP: #461556
  * USB: ipaq: fix oops when device is plugged in
    - LP: #461556
  * USB: cp210x: Add support for the DW700 UART
    - LP: #461556
  * USB: Fix throttling in generic usbserial driver
    - LP: #461556
  * USB: storage: When a device returns no sense data, call it a Hardware
    Error
    - LP: #400652, #461556
  * arm, cris, mips, sparc, powerpc, um, xtensa: fix build with bash 4.0
    - LP: #461556
  * intel-iommu: Cope with broken HP DC7900 BIOS
    - LP: #461556
  * futex: Detect mismatched requeue targets
    - LP: #461556
  * futex: Fix wakeup race by setting TASK_INTERRUPTIBLE before queue_me()
    - LP: #461556
  * tpm-fixup-pcrs-sysfs-file-update
    - LP: #461556
  * TPM: fix pcrread
    - LP: #461556
  * Bluetooth: Disconnect HIDRAW devices on disconnect
    - LP...

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

please don't change bug status without explanation.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brad Figg (brad-figg) wrote : Unsupported series, setting status to "Won't Fix".

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux:
status: New → Won't Fix
To post a comment you must log in.