Headphone jack sense doesn't work on MacBook Pro 15" unibody (5,1 late 2008)

Bug #437150 reported by Gionn on 2009-09-26
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned
linux-backports-modules-2.6.31 (Ubuntu)
Undecided
Unassigned

Bug Description

I have managed how to manually mute internal speaker without muting headphones:
I dropped down to 0 the volume of Front/Surround/LFE (not muted them, otherwise also headphones will mute) and after un-mute the HP channel and rise volume.

ProblemType: Bug
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: scorp 1824 F.... pulseaudio
 /dev/snd/pcmC0D0p: scorp 1824 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xdf480000 irq 21'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b4000,00100103'
   Controls : 36
   Simple ctrls : 20
Date: Sat Sep 26 13:32:22 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: alsa-driver
Uname: Linux 2.6.31-11-generic x86_64

Gionn (giovanni.toraldo) wrote :
Jon Ramvi (ramvi) wrote :

On my Macbook5,1
"ramvi@ramvi-laptop:~$ sudo dmidecode -s system-product-name
MacBookPro5,1"
the sense doesn't work as the title says, but I can't get sound through it either. What can I do to help out?

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Jon Ramvi (ramvi) wrote :

Running Karmic final

Daniel T Chen (crimsun) on 2009-11-11
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
Daniel T Chen (crimsun) wrote :

Install linux-backports-modules-alsa-karmic-generic and reboot.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
status: Fix Released → Triaged
viniciolindo (giulio-pernice) wrote :

sorry but i have already installed linux-backports-modules but the problem is the same.
I will try to install new pulseaudio 0.9.20 manually

Daniel T Chen (crimsun) wrote :

@viniciolindo
l-b-m-a-k-g is only one part of the workaround, and I mistakenly mistriaged this bug earlier.

Alex Murray (alexmurray) wrote :

I've developed a patch against alsa-driver-1.0.22.1 which should fix this (which I've attached to this bug), which you can test as follows:

First make sure you don't have any versions of linux-backports-modules-alsa installed:

apt-cache --names-only search linux-backports-modules-alsa | cut -f 1 -d ' ' | xargs sudo apt-get remove --purge

Now download alsa driver source and the patch, and compile and install a patched version of the driver:

cd ~
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.22.1.tar.bz2
wget http://dl.dropbox.com/u/174251/alsa-driver-1.0.22.1-mb5.patch
tar xjf alsa-driver-1.0.22.1.tar.bz2
patch -p0 < alsa-driver-1.0.22.1-mb5.patch
cd alsa-driver-1.0.22.1
./configure
make
sudo make install

Now you need to reboot your machine. If this works I'll push the patch upstream and hopefully we can get it applied to linux-backports-modules-alsa as well.

viniciolindo (giulio-pernice) wrote :

for me this patch is perfect! thank's

Alex Murray (alexmurray) wrote :

No worries, thanks for the feedback.

Knut Funkel (knut-funkel) wrote :

Hey,

Now the headphone jacket is recognized by the sound preferences, and that is really good!
However, I do not seem to be able to switch between the external speakers and the headphone jacket?

thanks for the patch!!

Knut Funkel (knut-funkel) wrote :

Yess. I can change to external speaker!!.

Portege_moi (portegemoi) wrote :

yeah,
this works perfectly for me!

thank you very much!

my problem was, that i've heard the sound from both, the speakers and the headphones.
this patch solved my problem, thanks again!

Cole Mickens (colemickens) wrote :

This patch works beautifully for disabling analog line out (and muting my internal speakers) but it seems to disable/break the digital out ability. Before installing the patches alsa-backport I was able to switch to a profile and see red light coming out of my headphone jack. I'm at home now with the optical wire only to find that I can't select a a hardware profile in my sound options that will enable this.

Alex Murray (alexmurray) wrote :

This patch doesn't change any of the digital pins or mixer elements, so this is perhaps more likely a bug in ALSA itself or pulseaudio I would say.

tags: added: patch
Kjetil Thuen (kjetil-thuen) wrote :

For the record; this patch does not seem to do anything on my MacBook5,1

Kjetil Thuen (kjetil-thuen) wrote :

Sorry, I spoke too soon. It actually works flawlessly. Turns out I had the model=mbp3 string that used to be recomended in my alsa-base.conf. Removing that made the patch work.

Josh Huckabee (jhuckabee) wrote :

+1 for this patch. Works great on my MacBook 5,1

Works also for me. Thank you Alex.

No worries, glad I could help.

2010/3/5 Νίκος Αλεξανδρής <email address hidden>:
> Works also for me. Thank you Alex.
>
> --
> Headphone jack sense doesn't work on MacBook Pro 15" unibody (5,1 late 2008)
> https://bugs.launchpad.net/bugs/437150
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Iain Lane (laney) wrote :

Right, I don't have this patch installed, but jack sense now works for me using my MB 5.1 (Late 2008) on Lucid. Alex, did you get the patch upstream or is it just fixed coincidentally? Can someone else confirm?

Alex Murray (alexmurray) wrote :

@Iain - yes patch is upstream, was accepted into 2.6.33 and the most 2.6.32 stable update as well, hence why it is in Lucid.

Changed in linux (Ubuntu):
status: Won't Fix → Fix Released
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: Triaged → Fix Released
Alex Murray (alexmurray) wrote :

Marking as fix released for Lucid and linux-backports-modules for Karmic as well as was just pushed to karmic-proposed.

Changed in mactel-support:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers