Kernel isn't very useful without a boot loader, but doesn't depend on one

Bug #43531 reported by Mark Shuttleworth on 2006-05-08
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Lee Jones

Bug Description

I asked my system to clean out packages that are not required for
ubuntu-desktop, and it happily removed grub. I don't have lilo. It also
installed a new kernel, but of course the boot loader is not updated to
reflect that. I've spoken with Colin Watson who does not want to add
grub to ubuntu-desktop, but one way or the other we must have some
requirement of a bootloader, and the kernel should make some sort of
noise if you try to install a new kernel WITHOUT one.

 affects /distros/ubuntu

Matt Zimmerman (mdz) wrote :

The kernel currently suggests a boot loader; this should be at least a Recommends. It is valid to have a kernel without one (e.g. floppy or network boots) though these configurations are increasingly rare.

description: updated
Ben Collins (ben-collins) wrote :

The other configuration where one isn't needed is a dual boot system with an operating system that can easily boot Linux (WinNT, another Linux dist).

I can change it to recommends though.

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Unconfirmed → Fix Committed

Ben Collins wrote:
> The other configuration where one isn't needed is a dual boot system with an operating system that can easily boot Linux (WinNT, another Linux dist).
>
> I can change it to recommends though.
>
That still won't prevent it from being installed. I would much rather
that it always be installed, but that you can stop it from writing to
the boot sector.

Mark

Ben Collins (ben-collins) wrote :

The only way this would even be feasible is to create a "boot-loader" meta package that grub, lilo, and friends can provide. That way they can install a "no-boot-loader" meta-package to work around it. This is much easier than having to have a way to disable grub and lilo.

On Wed, May 10, 2006 at 07:14:42PM -0000, Mark Shuttleworth wrote:
> Ben Collins wrote:
> > The other configuration where one isn't needed is a dual boot system with an operating system that can easily boot Linux (WinNT, another Linux dist).
> >
> > I can change it to recommends though.
> >
> That still won't prevent it from being installed. I would much rather
> that it always be installed, but that you can stop it from writing to
> the boot sector.

Neither grub nor lilo will install itself in the boot sector by default when
the package is installed, so at least those two should be safe. I am unsure
about other architectures' boot loaders.

The installer handles boot loader installation quite carefully, however, and
I recommend that we don't complicate this in the final weeks of Dapper.
Removing grub doesn't make the system unbootable, and it won't be removed
automatically by any packaging tools (it's explicitly installed during
installation, not brought in as a dependency).

Can we revisit this after the release?

--
 - mdz

Yes we can revisit after release if you'll put it on a list of "warts to
be looked at" :-). Thanks!

Matt Zimmerman (mdz) on 2006-05-10
Changed in linux-source-2.6.15:
status: Fix Committed → Confirmed
Matt Zimmerman (mdz) wrote :

Targeting for edgy.

Ben, do you have a clear idea of how to accomplish the goal here, or should we get it on the agenda to discuss in Paris?

Ben Collins (ben-collins) wrote :

It's very simple actually. I'll create a no-bootloader metapackage, file bugs on grub/lilo/yaboot/palo/etc, to:

Provide: boot-loader

Then the kernel can then depend on boot-loader. If someone wants no boot-loader (diskless systems, etc) they can manually install the no-bootloader metapackage, and uninstall grub/lilo/whatever.

Please make sure the no-boot-loader package is automatically installed on powerpc systems with no newworld boot partition - e.g. oldworld Powermacs booted by BootX. Take a look at bug #46521.

Bryan Haskins (bryan-h) wrote :

Wouldn't a package that can fetch either grub or lilo work? With the option for no bootloader of course.

Example:
In a certain environment kernelxyz depends on bootoptions (Needs a more creative name, just an example.) after installing this bootoptions package executes a prompt explaining the pros and cons of it all and tells you that choosing no bootloader should be avoided without cause. Of course: This bootoptions package could perhaps just be run when the Distro is first installed ie a prompt on both installer types.

Just a thought, newcomer to Launchpad, thought I would throw a thought at you all.

Matt Russell (mjohnrussell) wrote :

Bryan, I don't know if your idea is feasible or not, but surely this is the sort of option that most normal users would want to avoid? Almost no one will want no bootloader, only those in the exceptional cases mentioned above will. Maybe provide this sort of option in the "alternate install" CD? But personally I prefer the idea of a no-bootloader package.

Colin Watson (cjwatson) wrote :

Note that there is already a nobootloader installer component, so there is no need for complicated schemes involving asking the user strange questions, since the framework's already there in the installer in the event that neither grub nor lilo nor yaboot (etc.) is appropriate. nobootloader.postinst should apt-install this new no-boot-loader package. (A name that's less confusing given the existence of nobootloader would be nice, though!)

Matt Zimmerman (mdz) wrote :

Reminder that this is targeted for Edgy

Colin Watson (cjwatson) wrote :

This didn't make it for Edgy (argh!). Ben, please look at this early in Feisty (hence the "later" milestone).

Tollef Fog Heen (tfheen) wrote :

Moving to .20 kernel, milestoning for herd 4. Ben, _please_ get this fixed ASAP.

Tollef Fog Heen (tfheen) wrote :

Ben, please, please, please get this fixed soon, it's been around for a long time and getting it fixed would be good.

Milestone moved forward.

Changed in linux-source-2.6.20:
status: Confirmed → In Progress

Migrating this forward to the "linux" kernel package.

Changed in linux (Ubuntu):
assignee: Ben Collins (ben-collins) → nobody
Lee Jones (lag) wrote :

Is this still causing an issue?

As Ben is no longer with us (Canonical), I'm happy to help put this bug to bed in any way I can.

Changed in linux (Ubuntu):
assignee: nobody → Lee Jones (lag)
tags: added: kernel-core kernel-needs-review
Changed in linux (Ubuntu):
status: In Progress → Triaged

On Mon, Aug 23, 2010 at 12:58:35PM -0000, Lee Jones wrote:
> Is this still causing an issue?

Current linux-image-* packages have:

Recommends: grub-pc | grub | lilo (>= 19.1)

and as such I think this bug can be closed.

--
 - mdz

Lee Jones (lag) wrote :

Thanks Matt.

Another one bites the dust.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Mark Shuttleworth (sabdfl) wrote :

Those 5-digit bug reports are endangered!

Lee Jones (lag) wrote :

They'll be extinct if I have my way. =:-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers