Intel 5300 AGN does not work at all Karmic Alpha 6

Bug #435141 reported by Chai on 2009-09-23
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Leonardo Silva Amaral

Bug Description

Hello,

I have recently updated from Jaunty to Karmic Alpha 6. My wireless card 5300 does not work at all. I think it is not related with bug Bug 352228 since I have not the message "No space for Tx". My card directly does not work :(

My laptop is a Dell Latitude E 4300

ProblemType: Bug
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: imyelmo 3830 F.... pulseaudio
                      imyelmo 3850 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,1028024d,00100302 HDA:80862802,80860101,00100000'
   Controls : 32
   Simple ctrls : 19
Date: Wed Sep 23 11:18:00 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=248aa693-94e0-4e0f-92b8-98618dc622f8
MachineType: Dell Inc. Latitude E4300
Package: linux-image-2.6.31-10-generic 2.6.31-10.35
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=e7dc2beb-528a-43a4-925d-d0710de9d3c1 ro vga=792 splash quiet splash
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-10-generic 2.6.31-10.12
 linux-firmware 1.19
SourcePackage: linux
Uname: Linux 2.6.31-10-generic x86_64
WifiSyslog:

WpaSupplicantLog:

dmi.bios.date: 12/18/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0T296D
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd12/18/2008:svnDellInc.:pnLatitudeE4300:pvr:rvnDellInc.:rn0T296D:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E4300
dmi.sys.vendor: Dell Inc.

Chai (isaiasmy) wrote :
Chai (isaiasmy) wrote :
Chai (isaiasmy) wrote :
Chai (isaiasmy) wrote :

Sorry but I have not found the way to attach several files at once. Let me know anything you need

description: updated

I have the kernel build just before yours and I'm running the x86 kernel and my 5300 works fine.

$uname -a:
Linux sreyan-laptop 2.6.31-10-generic #34-Ubuntu SMP Wed Sep 16 00:23:19 UTC 2009 i686 GNU/Linux

whereas yours is
Linux chundachunda 2.6.31-10-generic #35-Ubuntu SMP Tue Sep 22 17:33:14 UTC 2009 x86_64 GNU/Linux

relevant ls-pci line:

03:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection
 Subsystem: Intel Corporation Device 1001
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 29
 Region 0: Memory at 75200000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: <access denied>
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

Can anyone see if this is specific to builds >= 2.6.31-10-generic #35 or specific to the amd64 kernel?

Chai (isaiasmy) wrote :

Hello,

I have use a live CD of Kubuntu Karmic Koala Alpha 6 and the wireless works !!!

I attach the dmesg file where the lines related with the wifi are:

[ 70.287783] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
[ 70.287785] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[ 70.288365] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 70.288394] iwlagn 0000:0c:00.0: setting latency timer to 64
[ 70.288442] iwlagn 0000:0c:00.0: Detected Intel Wireless WiFi Link 5300AGN REV=0x24
[ 70.328575] iwlagn 0000:0c:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[ 70.328655] iwlagn 0000:0c:00.0: irq 29 for MSI/MSI-X
[ 72.284097] phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 73.964328] iwlagn 0000:0c:00.0: firmware: requesting iwlwifi-5000-2.ucode
[ 78.175907] iwlagn 0000:0c:00.0: loaded firmware version 8.24.2.12
[ 78.358739] Registered led device: iwl-phy0::radio
[ 78.358762] Registered led device: iwl-phy0::assoc
[ 78.358784] Registered led device: iwl-phy0::RX
[ 78.358807] Registered led device: iwl-phy0::TX
[ 306.635578] Registered led device: iwl-phy0::radio
[ 306.635626] Registered led device: iwl-phy0::assoc
[ 306.635668] Registered led device: iwl-phy0::RX
[ 306.635709] Registered led device: iwl-phy0::TX

In my updated ubuntu from Jaunty to Karmic Koala Alpha6 do not appear this lines

[ 78.175907] iwlagn 0000:0c:00.0: loaded firmware version 8.24.2.12
[ 78.358739] Registered led device: iwl-phy0::radio
[ 78.358762] Registered led device: iwl-phy0::assoc
[ 78.358784] Registered led device: iwl-phy0::RX
[ 78.358807] Registered led device: iwl-phy0::TX
[ 306.635578] Registered led device: iwl-phy0::radio
[ 306.635626] Registered led device: iwl-phy0::assoc
[ 306.635668] Registered led device: iwl-phy0::RX
[ 306.635709] Registered led device: iwl-phy0::TX

It could be a problem of updating instead of doing a fresh install, some idea on how to fix it or how to see what's the problem before the final release?

Regards

lsi:
  * I just tested a karmic alpha 6 amd64 clean install on a 64 bit machine and manually installed the same kernel you had and I can wireless just works. I will try again and see if i can reproduce the transient issue by going from jaunty to karmic.

I wll try to investigate what happens, let me know if you need anything.

--
Isaias Martinez Yelmo

On Thursday 24 September 2009 14:54:01 Sindhudweep Sarkar wrote:
> lsi:
> * I just tested a karmic alpha 6 amd64 clean install on a 64 bit machine
> and manually installed the same kernel you had and I can wireless just
> works. I will try again and see if i can reproduce the transient issue by
> going from jaunty to karmic.
>

Chai (isaiasmy) wrote :

I have the old kernel from Jaunty installed and I have remove the kernel and modules of karmic and reinstalled, it has not worked :(

One addititional comment, the interface wlan0 is created, in fact you can see it if you run in a termianl "ifconfig -a". However, If i try to activate it I have the next result:

sudo ifconfig wlan0 up
SIOCSIFFLAGS: Unknown error 132

Network Manager seems to detect the wireless but it detects the wireless like unactivated, i tick the option of "Enable Wireless" in knetworkmanager but nothing happens :( Always it is the same after the karmic update. I will not reinstall the machine unless i need the wireless for something special. While, I will wait to see what is the problem

Chai (isaiasmy) wrote :

Finally I have found how to make run the wifi, using rfkill.

rfkill initially shows:

 rfkill list
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no

However the device can be unblocked:

rfkill unblock 0
[rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no

Therefore the probem is why with a fresh install is not necessary to this and it is necessary if you have done an upgrade from jaunty

I hope this help

Chai (isaiasmy) wrote :

Unfortunately I having problems with the authentication of my AP. I attach dmesg. The problem seems to be:

wlan0: deauthenticating by local choice (reason=3)

Same problem here with Atheros. General kernel wifi breakeage?

leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0 -cwireless_astolfonet.conf
[sudo] password for leleobhz:
CTRL-EVENT-SCAN-RESULTS
Trying to associate with 00:25:9c:1c:76:01 (SSID='astolfonet' freq=2412 MHz)
Association request to the driver failed
Associated with 00:25:9c:1c:76:01
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
^CCTRL-EVENT-TERMINATING - signal 2 received
leleobhz@astra:~$ vi wireless_astolfonet.conf
leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0 -cwireless_astolfonet.conf
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
l2_packet_receive - recvfrom: Network is down
ioctl[SIOCGIWSCAN]: Network is down
ioctl[SIOCSIWSCAN]: Network is down
Failed to initiate AP scan.
ioctl[SIOCGIWSCAN]: Network is down
ioctl[SIOCSIWSCAN]: Network is down
Failed to initiate AP scan.
^CCTRL-EVENT-TERMINATING - signal 2 received
leleobhz@astra:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: Erro desconhecido 132
leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0 -cwireless_astolfonet.conf
SIOCSIFFLAGS: Unknown error 132
Could not set interface 'wlan0' UP
Failed to initialize driver interface
leleobhz@astra:~$ lspci | grep Ether
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
06:06.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
leleobhz@astra:~$ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
leleobhz@astra:~$ rfkill unblock 0
Can't open RFKILL control device: Permission denied
leleobhz@astra:~$ sudo rfkill unblock 0
leleobhz@astra:~$ rfkill unblock 0
Can't open RFKILL control device: Permission denied
leleobhz@astra:~$ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
leleobhz@astra:~$

And dmesg:

[ 6509.499989] wlan0: authenticate with AP 00:25:9c:1c:76:01
[ 6509.502140] wlan0: authenticated
[ 6509.502144] wlan0: associate with AP 00:25:9c:1c:76:01
[ 6509.504201] wlan0: RX AssocResp from 00:25:9c:1c:76:01 (capab=0x431 status=0 aid=1)
[ 6509.504206] wlan0: associated
[ 6509.505255] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 6509.513635] wlan0: disassociating by local choice (reason=3)
[ 6533.213379] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6533.213413] wlan0: deauthenticating by local choice (reason=3)

Chai (isaiasmy) wrote :

For me "sudo rfkill unblock 0" works but i have to do it each time I start
the machine. It happens after updating in Karmic Alpha 6. With the live cd
works.

Perhaps my problem is related with:

http://patchwork.kernel.org/patch/38437/
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544319
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/430809

Ciao,

Isaías

--
Isaias Martinez Yelmo

On Friday 02 October 2009 15:23:40 Leonardo Silva Amaral wrote:
> Same problem here with Atheros. General kernel wifi breakeage?
>
> leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0
> -cwireless_astolfonet.conf [sudo] password for leleobhz:
> CTRL-EVENT-SCAN-RESULTS
> Trying to associate with 00:25:9c:1c:76:01 (SSID='astolfonet' freq=2412
> MHz) Association request to the driver failed
> Associated with 00:25:9c:1c:76:01
> WPA: 4-Way Handshake failed - pre-shared key may be incorrect
> CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> ioctl[SIOCSIWSCAN]: Device or resource busy
> Failed to initiate AP scan.
> ^CCTRL-EVENT-TERMINATING - signal 2 received
> leleobhz@astra:~$ vi wireless_astolfonet.conf
> leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0
> -cwireless_astolfonet.conf CTRL-EVENT-DISCONNECTED - Disconnect event -
> remove keys
> l2_packet_receive - recvfrom: Network is down
> ioctl[SIOCGIWSCAN]: Network is down
> ioctl[SIOCSIWSCAN]: Network is down
> Failed to initiate AP scan.
> ioctl[SIOCGIWSCAN]: Network is down
> ioctl[SIOCSIWSCAN]: Network is down
> Failed to initiate AP scan.
> ^CCTRL-EVENT-TERMINATING - signal 2 received
> leleobhz@astra:~$ sudo ifconfig wlan0 up
> SIOCSIFFLAGS: Erro desconhecido 132
> leleobhz@astra:~$ sudo wpa_supplicant -Dwext -iwlan0
> -cwireless_astolfonet.conf SIOCSIFFLAGS: Unknown error 132
> Could not set interface 'wlan0' UP
> Failed to initialize driver interface
> leleobhz@astra:~$ lspci | grep Ether
> 06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
> RTL-8139/8139C/8139C+ (rev 10) 06:06.0 Ethernet controller: Atheros
> Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
> leleobhz@astra:~$ rfkill list
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: yes
> leleobhz@astra:~$ rfkill unblock 0
> Can't open RFKILL control device: Permission denied
> leleobhz@astra:~$ sudo rfkill unblock 0
> leleobhz@astra:~$ rfkill unblock 0
> Can't open RFKILL control device: Permission denied
> leleobhz@astra:~$ rfkill list
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: yes
> leleobhz@astra:~$
>
>
> And dmesg:
>
> [ 6509.499989] wlan0: authenticate with AP 00:25:9c:1c:76:01
> [ 6509.502140] wlan0: authenticated
> [ 6509.502144] wlan0: associate with AP 00:25:9c:1c:76:01
> [ 6509.504201] wlan0: RX AssocResp from 00:25:9c:1c:76:01 (capab=0x431
> status=0 aid=1) [ 6509.504206] wlan0: associated
> [ 6509.505255] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
> [ 6509.513635] wlan0: disassociating by local choice (reason=3)
> [ 6533.213379] ADDRCONF(NETDEV_UP): wlan0: link is not ready
> [ 6533.213413] wlan0: deauthenticating by local choice (reason=3)
>

Isaías, i got no progress with rfkill. Appear to do notting. And im still without wireless. BTW, RF Switch dont work anymore (Ill try some combinations before kernel loading...)

leleobhz@astra:~$ sudo rfkill unblock 0
[sudo] password for leleobhz:
leleobhz@astra:~$ sudo rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
leleobhz@astra:~$

John Ward (automail) wrote :

Karmic in use: BETA
Laptop: Dell Vostro 1520
Wireless: Intel PRO/Wireless 5300 AGN

In LiveCD mode (although I'm using a LiveUSB) this device is detected although Network manager says the "wireless is disabled".

I'm now installed on HD, fully up to date and still wireless is disabled. Is this a new bug? Like bug reporter, I get no "Tx" errors as I'm not even able to make a successful wireless connection.

John Ward (automail) wrote :

OK some good slightly good news.

I ran ifconfig with up command:

john@vostro:~# sudo ifconfig wlan0 up

And then did:

john@vostro:~# sudo iwlist scanning

And it found my home network at least, never did that before, it also took a few seconds to give a result which isn't typical for iwlist. But at least it's scanning.

Anything to try from here?

According to: http://ubuntuforums.org/showthread.php?t=1256339

I followed a post saying to edit /etc/NetworkManager/nm-system-settings.conf

change:

[ifupdown]
managed=false

to this:
[ifupdown]
managed=true

Chai (isaiasmy) wrote :

My wifi worked if I manually performed this action:

sudo rfkill unblock wifi

However with the last kernel update (2.6.31-12) , the wireless extensions associated with my interface are not detected.

Chai (isaiasmy) wrote :

The work on bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/430809 seems to fix my problem with rfkill but the patch is applied over the kernel 2.6.31-12 so my interface is enabled but the wireless extensions are not availabe as I have explained above.

Regards

Chai (isaiasmy) wrote :

No the wifi works perfectly

lsi: As you said wifi works perfectly I'm closing this bug. Feel free to reopen if you still hit issues.

Changed in linux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.