ubuntu-bug alsa-base Poppting Clicking Pulse Audio crashing

Bug #433782 reported by onewithnature83 on 2009-09-21
120
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This device displays Popping sound from speakers when the sound card is initialised after short period of non use. matter of seconds between sound outputs.

Pulse audio crashes and is unable to auto generate bug report.

tj@quad:~$ uname -a
Linux quad 2.6.31-10-generic #34-Ubuntu SMP Wed Sep 16 00:23:19 UTC 2009 i686 GNU/Linux

tj@quad:~$ lspci |grep Audio
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)

/var/log/syslog :
Sep 21 00:35:44 quad pulseaudio[5061]: ratelimit.c: 98 events suppressed

/var/log/messages :

Sep 20 23:16:56 quad pulseaudio[5061]: ratelimit.c: 152 events suppressed
Sep 20 23:17:25 quad pulseaudio[5061]: ratelimit.c: 101 events suppressed
Sep 20 23:24:23 quad pulseaudio[5061]: ratelimit.c: 177 events suppressed
Sep 20 23:24:28 quad pulseaudio[5061]: ratelimit.c: 176 events suppressed
Sep 20 23:24:33 quad pulseaudio[5061]: ratelimit.c: 38 events suppressed
Sep 20 23:25:02 quad pulseaudio[5061]: ratelimit.c: 125 events suppressed
Sep 21 00:19:53 quad pulseaudio[5061]: ratelimit.c: 138 events suppressed
Sep 21 00:25:34 quad pulseaudio[5061]: ratelimit.c: 97 events suppressed
Sep 21 00:25:39 quad pulseaudio[5061]: ratelimit.c: 99 events suppressed
Sep 21 00:35:44 quad pulseaudio[5061]: ratelimit.c: 98 events suppressed
Sep 21 00:36:43 quad pulseaudio[5061]: ratelimit.c: 146 events suppressed

Victor Vargas (kamus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

This information can be gathered for you automatically using the command apport-collect -p alsa-base 433782. Additionaly, have you tried to update your Karmic system to latest version?

Regards

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
peddy (peddy22) wrote :

To shut the thing up temporarily comment out the last line of /etc/modprobe.d/alsa-base.conf (something like "options snd-hda-intel power_save=10 ...").

callum (callumdryden) wrote :

I also have this problem

Yunkwan (chanyunkwan0217) wrote :

I have this issue too.

Florian Apolloner (apollo13) wrote :

I can confirm this, here the info from alsa-info:
http://paste.pocoo.org/show/145082

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tj 3257 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,103c2a6d,00100101'
   Controls : 35
   Simple ctrls : 20
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
Uname: Linux 2.6.31-12-generic i686
UserGroups:

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Guys, this problem is affecting me too, but Peddy's suggestion fixing it. See his post:
To shut the thing up temporarily comment out the last line of /etc/modprobe.d/alsa-base.conf (something like "options snd-hda-intel power_save=10 ...").

I wonder, is it correct at all to have "options snd-hda-intel..." for nvidia soundcard?

Noah (noahod) wrote :

Hi guys, I am having this exact same problem.

This is a very prominent bug affecting users of intel sound on the release version of ubuntu. Bug reports are all over the web;

http://www.webupd8.org/2009/10/fixing-popping-sound-in-ubuntu-karmic.html

http://ubuntuforums.org/showthread.php?t=1307340

http://www.youtube.com/watch?v=RSbw42MkPvE

http://www.ubuntuhq.com/content/fixing-popping-sound-ubuntu-karmic

http://www.geekinterview.com/talk/16337-linux-tips-fixing-popping-sound-ubuntu.html

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/444385

I have Intel sound on a Dell XPS Studio desktop system. (core i7 based)

Matthew Eaton (powder) wrote :

Confirmed here too. Peddy's comment also solved the problem for me.

spoot (spoot-b) wrote :

it's solved my problem ///but!!
i still hear a "high" sound when the power cable isn't connected. (very distorving !)

Confirmed here too. Edition alsa-base.conf worked for me too. Intel with realtek on Asus PL5D2 Motherbord.

Nagy Ferenc László (nfl) wrote :

Problem does not appear in lucid clean install.

Jeremy Foshee (jeremyfoshee) wrote :

Hi onewithnature83,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 433782

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Matthew Eaton (powder) wrote :

This is also fixed for me in Lucid.

tags: removed: needs-kernel-logs
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers