ath5k: phy0: failed to wakeup the MAC Chip

Bug #432353 reported by Gonzhauser on 2009-09-18
98
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Linux
Expired
Medium
Debian
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-image-generic

The right package is linux-image-2.6.31-020631-generic, but launchpad doesn't let me enter that.

After resuming, my wireless card isn't working anymore.
I have to do a manual pccardctl eject/insert to make it work again.

lspci:
03:00.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)

kern.log:
ath5k phy0: failed to wakeup the MAC Chip
ath5k phy0: can't reset hardware (-5)

There's a bug entry:
http://bugzilla.kernel.org/show_bug.cgi?id=13900

and a patch:
http://patchwork.kernel.org/patch/38550/

I think this shold be included before karmic is released. Are you going to track 2.6.31.y stable for karmic? Mr. Copeland emailed me that this patch is going to be included there.

Otherwise karmic will be broken for me. :(

kernel-janitor (kernel-janitor) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and set the Status to Confirmed, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Gonzhauser (gonzhauser) wrote :

A fix is in the stable queue for 2.6.31.2. Since karmic is tracking linux-stable it will be hopefully in the kernel before the release.

Gonzhauser (gonzhauser) wrote :

Works with linux-image-2.6.31-12-386. The fix from stable 2.6.31.2 is in the karmic kernel.

Changed in linux (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) wrote :

no its not fixed. today i got this 2 times.

Omer Akram (om26er) wrote :

i am using acer aspire one. and i don't suspend the system. after using internet for 5hours my wifi disconnect from the interent. and don't work unless i power off and then start. rebooting don't work. poweroff is required. i faced this in jaunty and now in karmic

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Omer Akram (om26er) wrote :

uname -a :Linux ubuntugeek 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Mark Shuttleworth (sabdfl) wrote :

I see this on an Aspire One as well, with both Karmic and Lucid-dev

Omer Akram (om26er) wrote :

uname -a: Linux lucidtest 2.6.32-13-generic #18-Ubuntu SMP Wed Feb 10 21:24:20 UTC 2010 i686 GNU/Linux
I rebooted and no wireless then I powered off and then got wireless.

Omer Akram (om26er) wrote :
Download full text (27.3 KiB)

  307.044831] Skipping EDID probe due to cached edid
[ 1632.836089] CE: hpet increasing min_delta_ns to 15000 nsec
[ 2405.908843] wlan0: deauthenticated from 00:1d:0f:e2:ef:b4 (Reason: 7)
[ 2407.380815] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 (try 1)
[ 2407.383281] wlan0: direct probe responded
[ 2407.383295] wlan0: authenticate with AP 00:1d:0f:e2:ef:b4 (try 1)
[ 2407.385836] wlan0: authenticated
[ 2407.385929] wlan0: associate with AP 00:1d:0f:e2:ef:b4 (try 1)
[ 2407.389348] wlan0: RX AssocResp from 00:1d:0f:e2:ef:b4 (capab=0x421 status=0 aid=1)
[ 2407.389367] wlan0: associated
[13242.192676] wlan0: deauthenticated from 00:1d:0f:e2:ef:b4 (Reason: 7)
[13243.688138] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 (try 1)
[13243.690637] wlan0: direct probe responded
[13243.690650] wlan0: authenticate with AP 00:1d:0f:e2:ef:b4 (try 1)
[13243.692319] wlan0: authenticated
[13243.692376] wlan0: associate with AP 00:1d:0f:e2:ef:b4 (try 1)
[13243.694424] wlan0: RX AssocResp from 00:1d:0f:e2:ef:b4 (capab=0x421 status=0 aid=1)
[13243.694435] wlan0: associated
[14088.205036] Skipping EDID probe due to cached edid
[15555.916828] Skipping EDID probe due to cached edid
[16149.570381] ath5k phy0: failed to wakeup the MAC Chip
[16149.570401] ath5k phy0: can't reset hardware (-5)
[16149.914504] ath5k phy0: failed to wakeup the MAC Chip
[16149.914530] ath5k phy0: can't reset hardware (-5)
[16149.960729] ath5k phy0: failed to wakeup the MAC Chip
[16149.960741] ath5k phy0: can't reset hardware (-5)
[16150.302418] ath5k phy0: failed to wakeup the MAC Chip
[16150.302439] ath5k phy0: can't reset hardware (-5)
[16150.348737] ath5k phy0: failed to wakeup the MAC Chip
[16150.348757] ath5k phy0: can't reset hardware (-5)
[16155.136182] No probe response from AP 00:1d:0f:e2:ef:b4 after 500ms, disconnecting.
[16155.442496] __ratelimit: 22 callbacks suppressed
[16155.442510] ath5k phy0: failed to wakeup the MAC Chip
[16155.442525] ath5k phy0: can't reset hardware (-5)
[16155.488788] ath5k phy0: failed to wakeup the MAC Chip
[16155.488805] ath5k phy0: can't reset hardware (-5)
[16155.535151] ath5k phy0: failed to wakeup the MAC Chip
[16155.535172] ath5k phy0: can't reset hardware (-5)
[16155.581436] ath5k phy0: failed to wakeup the MAC Chip
[16155.581454] ath5k phy0: can't reset hardware (-5)
[16155.627881] ath5k phy0: failed to wakeup the MAC Chip
[16155.627901] ath5k phy0: can't reset hardware (-5)
[16156.091076] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 (try 1)
[16156.288172] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 (try 2)
[16156.488164] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 (try 3)
[16156.688146] wlan0: direct probe to AP 00:1d:0f:e2:ef:b4 timed out
[16161.266455] __ratelimit: 20 callbacks suppressed
[16161.266470] ath5k phy0: failed to wakeup the MAC Chip
[16161.266484] ath5k phy0: can't reset hardware (-5)
[16161.313026] ath5k phy0: failed to wakeup the MAC Chip
[16161.313052] ath5k phy0: can't reset hardware (-5)
[16161.359286] ath5k phy0: failed to wakeup the MAC Chip
[16161.359305] ath5k phy0: can't reset hardware (-5)
[16161.405749] ath5k phy0: failed to wakeup the MAC Chip
[16161.405777] ath5k phy0: can't reset hardware (-5)
[16161.452180] ath5k phy...

Omer Akram (om26er) wrote :

I never suspended or hibernated just was surfing internet

Changed in linux:
status: Unknown → Confirmed

Just a side comment, the error is upstream, it's there on Fedora 12 too:

[root@acerone log]# uname -a
Linux acerone.kostyrka.org 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686 i686 i386 GNU/Linux

Omer Akram (om26er) wrote :

I have sent it upstream. and I also installed wireless backports but still got the issue. marking triaged now

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Dana Olson (adolson) wrote :

I realize the bug is upstream, but just adding another report here - I also have an Acer Aspire One with Ubuntu 10.04 final, receiving this bug. It seems to be much more frequent in 10.04 than it was in 9.10 or 9.04.

Anton (anton56577) wrote :

Ubuntu 10.04 on Aspire One 110
Linux a-netbook 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

after 2-3 hours in dmesg:
[ 1661.574017] ath5k phy0: failed to wakeup the MAC Chip
[ 1661.574028] ath5k phy0: can't reset hardware (-5)

amichair (amichai2) wrote :

Kubuntu Netbook Remix 10.04 on an Acer Aspire One ZG5 (a.k.a. AOA150)

Linux ubuntu 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux

This happens very consistently: netbook boots up, wireless connects (via network-manager-kde), I run rsync on the netbook to copy several GB from a remote machine to the netbook, and within a couple of minutes (a few hundreds of MB transferred), the wireless dies, with the log below.

Interestingly, once wireless freezes, not even a reboot brings it back (even rebooting into winxp!), only a full shutdown, waiting a few seconds, and powering back up. There is no hibernation/suspend involved - this is on a fresh boot within a few minutes of startup, doing nothing but copying files over wireless. Also, in winxp there is no problem ever, so it's not the hardware itself.

This bug makes wireless on the netbook hardly usable (requires power cycle every couple of minutes).

[ 226.409020] CE: hpet increasing min_delta_ns to 15000 nsec
[ 233.454922] ath5k phy0: failed to wakeup the MAC Chip
[ 233.454935] ath5k phy0: can't reset hardware (-5)
[ 238.316136] No probe response from AP <address goes here> after 500ms, disconnecting.
[ 238.651369] ath5k phy0: failed to wakeup the MAC Chip
[ 238.651388] ath5k phy0: can't reset hardware (-5)
[ 238.697655] ath5k phy0: failed to wakeup the MAC Chip
[ 238.697674] ath5k phy0: can't reset hardware (-5)
[ 238.744031] ath5k phy0: failed to wakeup the MAC Chip
[ 238.744055] ath5k phy0: can't reset hardware (-5)
[ 238.790191] ath5k phy0: failed to wakeup the MAC Chip
[ 238.790202] ath5k phy0: can't reset hardware (-5)
[ 238.836517] ath5k phy0: failed to wakeup the MAC Chip
[ 238.836537] ath5k phy0: can't reset hardware (-5)
[ 244.390333] __ratelimit: 18 callbacks suppressed
[ 244.390347] ath5k phy0: failed to wakeup the MAC Chip
...
<and so on repeatedly>

Andrew Dittes (adittes) wrote :

I see the same issue on my Acer Aspire One 150.

Relevant Log output:
ath5k phy0: failed to wakeup the MAC Chip
ath5k phy0: can't reset hardware (-5)
(repeated many times over the course of more than a day)

andrew@galactica:/var/log$ uname -a
Linux galactica 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

This is on Ubuntu 10.04 installed from the Alternate ISO. I do not suspend or hibernate this machine, as it has a broken screen and I am using it as a server. I have not been paying close attention to the computer, but it appears that this happens after the computer has been running for about a day.

I realize there is a kernel update available; I will try downloading and installing that shortly.

FR. Loïc (hackurx) wrote :

Watch the drivers in backtrack 4 to see.

Anibal (elkan9) wrote :

I have the same problem from about a year on an Acer laptop and Atheros AR5BXB63. At the beginning with 9.10, 10.04, 10.10, and now with Debian testing. The LiveCD works fine, but with the actualizations the problem begins. Only with a power off the card start to work again.

I used to transfer files within computers and to surf INTERNET, nothing else. I don't thing the problem was the driver, or never would work. Some package it breaks the normal working of the card.

If someone have some light please post it.

Thanks.

HacKurx, What backtrack?

Neilen Marais (neilenmarais) wrote :

Most recent comment (#18) on upstream bug http://bugzilla.kernel.org/show_bug.cgi?id=15382 seems to indicate that the kernel option:

CONFIG_PCIEASPM=y

solved the problem for one user at least. Checking on my 10.04 system:

brick@sneeupenaar:~$ cat /boot/config-2.6.32-27-generic | grep -i aspm
# CONFIG_PCIEASPM is not set

indeed indicates that the option is not set.

My little Aspire one hardly has space left on its 8GB SSD to do a kernel compile, but if someone could package up such a kernel I'd be more than willing to test on my machine!

Changed in linux:
status: Confirmed → Expired
Changed in linux:
importance: Unknown → Medium

Gonzhauser, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/432353/comments/3 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Stager (stager) wrote :
Download full text (15.0 KiB)

I have this bug now.
After reboot through 30sec, or 1 - 5 min - wi-fi down, with "failed to wakeup the MAC Chip" log.
Same as after resuming, or on/off wi-fi by hardware or software button.

 ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

stager-Satellite-L40 3.13.0-36-generic i686, Ubuntu 14.04.1 LTS, trusty

CPU : Intel(R) Celeron(R) M CPU 520 @ 1.60GHz
Memory : 993 MB
Uptime : 14:05:06 up 4 min, 2 users, load average: 3,01, 1,91, 0,78

lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)
 Subsystem: Askey Computer Corp. WLL3141 (Toshiba PA3613U-1MPC) 802.11bg Wireless Mini PCIe Card [144f:7128]
 Kernel driver in use: ath5k
--
05:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
 Subsystem: Toshiba America Info Systems Device [1179:ff40]
 Kernel driver in use: 8139too

lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~

PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface Soft blocked Hard blocked
0: phy0: Wireless LAN no no

lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ath5k 134977 0
ath 23922 1 ath5k
mac80211 546051 1 ath5k
cfg80211 409394 3 ath,ath5k,mac80211

module parameters ~~~~~~~~~~~~~~~~~~

ath5k (3): e=Е.0 | e=Е | fastchanswitch=N | nohwcrypt=N | no_hw_rfkill_switch=N
cfg80211 (2): e=Е.0 | e=Е | cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
mac80211 (5): e=Е.0 | e=Е | beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500

nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: disconnected
================o=============o=========o==============o=========o===========o==============o===========
 Interface & ID | Type | Driver | State | Default | Speed | Support | HW Addr
================o=============o=========o==============o=========o===========o==============o===========
 eth0 | Wired | 8139too | unavailable | no | | | <MAC eth0>
----------------+-------------+---------+--------------+---------+-----------+--------------+-----------
 wlan0 | 802.11 WiFi | ath5k | disconnected | no | | WEP/WPA/WPA2 | <MAC wlan0>

    ASUSrt: Infra, <MAC C-NA ASUSrt 1>, F...

Stager, thank you for your comment. Unfortunately, as this bug report is closed, it is not scoped to you, or your problem. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.