Ubuntu

AHCI mode not supported

Reported by Patrice Vetsel on 2009-09-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Expired
High
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Under Karmic (also on Jaunty) with kernel 2.6.31-10-generic I can't boot the system if AHCI is set for sata under the BIOS. I must set it to IDE.

I attach some outputs

Problem is that this netbook : PACKARD BELL DOT M/U.FR-020 is sold with Windows Vista, and VIsta don't like at all that I change AHCI to IDE under the BIOS.

Patrice Vetsel (vetsel-patrice) wrote :

dmesg log

Patrice Vetsel (vetsel-patrice) wrote :

lshw log

Patrice Vetsel (vetsel-patrice) wrote :

lspci > lspci.txt

Patrice Vetsel (vetsel-patrice) wrote :

lspci -vvv > lspcivvv.txt

description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
Patrice Vetsel (vetsel-patrice) wrote :

Set to High because I can't use iso if I let AHCI for SATA access (because I want to keep Vista on the netbook).

Changed in linux (Ubuntu):
importance: Medium → High
Changed in linux (Ubuntu):
status: New → Triaged
Olivier Guéry (nemolivier) wrote :

Please notice that it’s the same motherboard and component than the Acer Timeline 1810. But I don’t know if the same problem realy occure (I don’t have this laptop).

Changed in linux:
status: Unknown → Confirmed
Punkadiddle (punkadiddle) wrote :

Same problem on Acer Travelmate 8371 (2.6.31-10-generic #35-Ubuntu SMP Tue Sep 22 17:33:14 UTC 2009 x86_64 GNU/Linux)

Patrice Vetsel (vetsel-patrice) wrote :

A workaround is to add : acpi=off in kernel boot parameters

Patrice Vetsel (vetsel-patrice) wrote :

Using this tutorial :
https://wiki.ubuntu.com/KernelTeam/Netconsole#Netcat%20(Linux)

I can have informations on boot with SATA=IDE (see attachment), but with SATA=AHCI I have no output on my netconsole

Florian Reisecker (epipremnum) wrote :

I can confirm this problem, also occurs on my Acer Travelmate 8371 with latest BIOS (1.13). Its ablo to boot with AHCI but it takes ages >2min (while about 20-40sec with ide-mode set in bios). Attached dmesg.0.

Florian Reisecker (epipremnum) wrote :

Sorry, forget to mention that I use Karmic beta with latest updates.

suaefar (marc-r-schaedler) wrote :

On my Acer Travelmate 8371 returning to 1.09 solved this problem.
I backed up the bios version 1.09 from another travelmate 8371 and flashed mine with it.
ahci-mode is working flawlessly.

tags: added: iso-testing
chris (kriz3) wrote :

I recently installed the last BIOS from Acer (1.15) and the problem is solved.

Olivier Guéry (nemolivier) wrote :

It seem’s that installing the last bios (send with windows 7) solve the problem under packardbell too… but I can’t find the bios on packardbell site and one send me the file but it’s for windows, I can’t install it from freedos (and it’s too big).
Any help will be kind.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Tim Gardner (timg-tpi) wrote :

No activity from the original reporter in over a year.

Changed in linux (Ubuntu):
importance: High → Undecided
status: Triaged → Invalid
Changed in linux:
importance: Unknown → High
Changed in linux:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.