Suspend/Hibernate not working in -10 kernel

Bug #426906 reported by Robbie Williamson on 2009-09-09
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Andy Whitcroft
Karmic
Critical
Andy Whitcroft

Bug Description

I confirmed that it does work with the -9 kernel. Seeing this issue on my Lenovo x301, Asus EeePC 900, and Dell Mini 9.

Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robbiew 2309 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0620000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211f,00100000'
   Controls : 15
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=e5078b9d-33a9-49ee-b6c2-3a5c3e9096cd
MachineType: LENOVO 2777CTO
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.30-generic
RelatedPackageVersions: linux-firmware 1.16
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET41WW (3.01 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET41WW(3.01):bd05/15/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robbiew 2000 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7eb8000 irq 16'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,10438337,00100101'
   Controls : 17
   Simple ctrls : 11
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=9e8215be-7637-4e97-bc41-db335d94e39e
MachineType: ASUSTeK Computer INC. 900
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=c2e54d91-c33b-4d23-9a4c-3f3f25803db8 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.30-generic
RelatedPackageVersions: linux-firmware 1.16
Tags: ubuntu-unr
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 03/03/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1006
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1006:bd03/03/2009:svnASUSTeKComputerINC.:pn900:pvr0802:rvnASUSTeKComputerINC.:rn900:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900
dmi.product.version: 0802
dmi.sys.vendor: ASUSTeK Computer INC.

tags: added: apport-collected

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2231 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0540000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,102802b0,00100101'
   Controls : 17
   Simple ctrls : 11
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=637785bf-df5b-43f5-ab1a-d83c83b17614
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. Inspiron 910
NonfreeKernelModules: wl
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=962a87ca-3aa3-4a66-b138-aaf95bcae7f7 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.30-generic
RelatedPackageVersions: linux-firmware 1.16
Tags: ubuntu-unr
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/05/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0J14
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/05/2008:svnDellInc.:pnInspiron910:pvrA00:rvnDellInc.:rnCN0J14:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 910
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Critical
Tim Gardner (timg-tpi) on 2009-09-09
Changed in linux (Ubuntu Karmic):
assignee: nobody → Andy Whitcroft (apw)
milestone: none → karmic-alpha-6
status: Confirmed → In Progress
tags: added: regression-potential
Andy Whitcroft (apw) wrote :

@Robbie -- are these all Iintel i915 graphics? Do you get blinky keybaord lights when it fails? If so its highly likely this is triggered by the bug fixed by the commit below:

  commit e6890f6f3dc2d9024a08b1a149d9bd5208eea350
  Author: Linus Torvalds <email address hidden>
  Date: Tue Sep 8 17:09:24 2009 -0700

    i915: disable interrupts before tearing down GEM state

Jorge Juan (jjchico) wrote :

Definitively it should be a kernel bug because if I boot with my old Jaunty kernel, suspend works right (and of course KMS has disapeared).

$ uname -a
Linux jjchico-netbook 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux

Robbie Williamson (robbiew) wrote :

@Andy Well...yes they are, but this also occurs on my AMD64 box with Nvidia graphics...sending apport info

Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: robbiew 2910 F.... pulseaudio
 /dev/snd/controlC0: robbiew 2910 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 21'
   Mixer name : 'Nvidia MCP78 HDMI'
   Components : 'HDA:10ec0888,10250153,00100202 HDA:10de0002,10de0101,00100000'
   Controls : 37
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'Camera'/'V Micro. Corp. PC Camera at usb-0000:00:02.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0ac8:0302'
   Controls : 3
   Simple ctrls : 2
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=5a9acafb-398b-4dfe-a694-df1066dccfa4
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Acer Aspire X1200
NonfreeKernelModules: nvidia
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=3baa4110-0e2c-41ad-b660-cd6418ff8aff ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.30-generic
RelatedPackageVersions: linux-firmware 1.16
RfKill:
 0: acer-wireless: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 07/29/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: R01-A3
dmi.board.name: WMCP78M
dmi.board.vendor: Acer
dmi.chassis.asset.tag: 0000000000000000000000
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrR01-A3:bd07/29/2008:svnAcer:pnAspireX1200:pvrR01-A3:rvnAcer:rnWMCP78M:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire X1200
dmi.product.version: R01-A3
dmi.sys.vendor: Acer

Robbie Williamson (robbiew) wrote :

Fixed when running with packages from ubuntu-boot ppas (PPA and Staging)...I suspect it may be acpid - 1.0.6-9ubuntu6~boot2, but not sure.

Robbie Williamson (robbiew) wrote :

FYI - Fixed on machines with both 30 and 31 kernels, so perhaps suggests not an issue in the kernel package.

Jorge Juan (jjchico) on 2009-09-14
description: updated
Jorge Juan (jjchico) wrote :

My MSI U100 still does not suspend/hibernate after using ubuntu-boot PPA's. It just worked the first time I rebooted with ubuntu-boot/ppa, but stopped working after a new reboot. Enabling ubuntu-boot/staging did not update any packege and still does not work. I filled a new bug #427327.

Anmar Oueja (anmar) wrote :

I think bug #413082 is a similar one.

Robbie Williamson (robbiew) wrote :

This is fixed for me across the board, so I'm fine if it is closed out.

I fixed this problem on my laptop using instructions from the following web
page:
http://blog.adl.pl/suspending-a-laptop-dell-latitude-d620-with-nvidia-video-adapter/66

On Wed, Sep 16, 2009 at 10:54 AM, Robbie Williamson <email address hidden>wrote:

> This is fixed for me across the board, so I'm fine if it is closed out.
>
> --
> Suspend/Hibernate not working in -10 kernel
> https://bugs.launchpad.net/bugs/426906
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: In Progress
> Status in linux in Ubuntu Karmic: In Progress
>
> Bug description:
> I confirmed that it does work with the -9 kernel. Seeing this issue on my
> Lenovo x301, Asus EeePC 900, and Dell Mini 9.
>
>
>

Andy Whitcroft (apw) on 2009-09-17
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments