Address Collision

Bug #424142 reported by blubaustin on 2009-09-04
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Brad Figg
Lucid
Medium
Seth Forshee

Bug Description

http://pastebin.org/14902

line 248 [ 0.144678] pci 0000:01:0a.0: BAR 6: address space collision on of device [0xff600000-0xff6fffff]

And also if noticed acpi is being loaded but in my /etc/default/grub, grub2 config file, I have attemtped to disable acpi and acpi PCI, then also run 'update-grub', restart to no avail. And also the system seems to be tad unstable, unable to run nexuiz but in the stable version of ubuntu it runs fine. So I would like to fix the problem asap. Thank you.

cl333r (cl333r) wrote :

I'd like to confirm that I also got this issue.
Using latest Karmic x64 with 2.6.31-11-generic kernel.
On same computer I also got Jaunty x64 and this issue is not present there.

I'm attaching the dmesg and lshw (hardware) from Karmic in 1 gzipped file.

Dennis Roch (ysae) wrote :

I can confirm this bug for the karmic alpha 6 live system. The output of dmesg and lshw is attached.

whoop (whoopwhoop) wrote :

Having this also on xubuntu karmic 32bit

FrenchNux (christophe-pauc) wrote :

having same issue on Karmic 64 bits beta

bug attachments :

Changed in ubuntu:
status: New → Confirmed

Affecting me too in Ubuntu Karmic 32bit Beta. Attached dmesg and lshw outputs.

Luca Aluffi (aluffilu) wrote :

Affected. Here my datas.

Luca Aluffi (aluffilu) wrote :

oops. Forgotten lspci...

Daniel Lee (longinus00) wrote :

Looks like it's an upstream kernel issue.

http://patchwork.kernel.org/patch/39988/

Russ W. Knize (rknize) wrote :

I can confirm this as well on a Dell C640.

hypeiv (hypeiv) wrote :

I am having a similar error on my dell dimension 9200. Ubuntu 9.10 beta AMD64

[ 1.863478] pci 0000:04:05.0: BAR 6: address space collision on of device [0xdbe00000-0xdbe7ffff]
[ 3.553122] e1000e 0000:00:19.0: pci_enable_pcie_error_reporting failed 0xfffffffb

maxstirner (philipp-d) wrote :

Having this as well, latest Karmic.. Older laptop (2003 Gericom - company defunct ;)

I also get X hardware freezes I haven't been able to find a bug for

John Gelm (jgelm) wrote :

I can't even boot the live CD.

I have nearly the same error on both i386 and AMD64 from CD. I also tried AMD64 from USB and have same error. I am booting from the same device that wrote the CDs under 9.04.

If I try to "check CD" the system just reboots and I cannot run the test.

Karmic Beta ( the first one)

Motherboard:
 GA-MA785GM-US2H (rev. 1.0)
http://www.gigabyte.com.tw/Products/Motherboard/Products_Spec.aspx?ClassValue=Motherboard&ProductID=3141&ProductName=GA-MA785GM-US2H

see the attached image(beta1.jpg) for the complete text of the error

blubaustin (blubaustin) wrote :

Since its a address collision, with a memory allocation problem....couldn't someone just try a temporary patch that changes what things get what address, and memory?

pburdick (perry-burdick) wrote :

This bug is also effecting my Compaq 6715b laptop running the Karmic beta. I have attached the output from lshw, lspci, and uname. The bug has the unfortunate side effect of disrupting the new usplash for Karmic, and that is probably my biggest concern! I found a post from Linus Torvalds on kernel.org thoroughly explaining the address collision bug, and that (in my interpretation) the fix won't be applied until after 2.6.31. Will the final release of Karmic be released with 2.6.31? It would be a shame to release it broken. Here is the URL for Linus' post on kernel.org: http://patchwork.kernel.org/patch/39988/

John Gelm (jgelm) wrote :

Cannot boot beta 9.10 i386 on MSI Wind U100

This try froze part way into the boot.

Screen image attached.

C de-Avillez (hggdh2) wrote :

Setting affected package as linux. Folks, please do not confirm a bug without a package assigned.

affects: ubuntu → linux (Ubuntu)
ramses delgado (ramsesdm) wrote :

anything new about this bug???

The One (m-sussitz) wrote :

I get the same message and can't boot. :(

hypeiv (hypeiv) wrote :

I no longer get this message after update...

$ uname -a
Linux ------ 2.6.31-13-generic #43-Ubuntu SMP Fri Oct 9 17:41:46 UTC 2009 x86_64 GNU/Linux

Twig (pfirth) wrote :

Are you certain it isn't hidden by the new boot process. I have the same kernel version yet if I do:

twig@twig-desktop:~$ dmesg | grep BAR
[ 0.140150] pci 0000:02:03.0: BAR 6: address space collision on of device [0xfe8e0000-0xfe8effff]

I still get the same message.

ramses delgado (ramsesdm) wrote :

But I notice that with the new kernel version, the boot time is longer than with the other version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Twig wrote:
> Are you certain it isn't hidden by the new boot process. I have the
> same kernel version yet if I do:
>
> twig@twig-desktop:~$ dmesg | grep BAR [ 0.140150] pci
> 0000:02:03.0: BAR 6: address space collision on of device
> [0xfe8e0000-0xfe8effff]
>
> I still get the same message.
>

This is probably just being hidden now. From the changelog to the kernel

* SAUCE: Raise the default console 'quiet' level to 2
    This supresses all but critical and emergency level messages.
    https://lists.ubuntu.com/archives/kernel-team/2009-October/007476.html

http://changelogs.ubuntu.com/changelogs/pool/main/l/linux/linux_2.6.31-13.42/changelog
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBCAAGBQJK0NOpAAoJEIltSrFpUGtePX0IALGPDoiFnuCGze0gqMIP8n/y
DwUpQ4kvbB8kJ6rKxXlTRG3sLHTLrJTqApsB4yWAApxubljUMocAdVlRpzNN2mVf
6WkfV2Q1nESExayW9It6twMpojvk7t/isMtghO6fXQeCErVYF7gUMyHSn45sNTV8
qH3nj+cfeidlon7j50wAH8WKWyq90uJ3eNLiBJ4YHxSrXv8rPj3ibnUWTnvyQzyd
yOJIPkIRb8Cm4AYR4e1IJMihYyJYKB/pdfCILfuW8TmVB29HZv9I5qbYVe69cnmp
REVJ8piJUEC4xcfYZio0LisJWIRD2lVfip7yL4YxCSvmG3mmX+DXMcAdqVISuh0=
=g4XU
-----END PGP SIGNATURE-----

i have the same message on my packard Bell
but there is no probleme for the boot

Harry (harry33) wrote :

Exactly Nick B, it is hidden by a new usplash.
Only emergency messages are shown from now on.

hypeiv (hypeiv) wrote :

Ah yes I do still have the message just not being shown at boot up:

$ dmesg | grep "BAR 6"
[ 2.185237] pci 0000:04:05.0: BAR 6: address space collision on of device [0xdbe00000-0xdbe7ffff]

$ uname -a
Linux ------ 2.6.31-13-generic #44-Ubuntu SMP Sat Oct 10 15:27:14 UTC 2009 x86_64 GNU/Linux

Jack Deslippe (jdeslip) wrote :

I have this message during boot on Karmic. Also, today my system stops booting half-way (right after doing fsck) and I am left with a bunch of modem-manager messages on the screen. It does this about 9 of every 10 boot attempts. 1 of every 10 it manages to actually boot successfully. Do you think this weird boot problem is related to the address bug?

Richard Hurt (rnhurt) wrote :

I just installed a Karmic LTSP server on my Dell 1650 server and got this error. The install went fine and even the first reboot worked without a problem. But ever since then it just boots, throws this error, and dumps to a Busybox shell.

BAR 6: address space collision on of device [0xfea00000-0xfea1ffff]
BAR 6: address space collision on of device [0xfea00000-0xfea1ffff]
BAR 6: address space collision on of device [0xfea00000-0xfea1ffff]
Gave up waiting for root device. Common problems:
...

knoobie (g63marty) wrote :

The collision error occurs for both the kernels using kubuntu 9.10 AMD64 Desktop version on HP s3220n AMD5000+

BAR 6: address space collision on of device [0xfea00000-0xfea1ffff]

2.6.31-11-generic SMP AMD64
2.6.31-14-generic SMP AMD64

I see this in dmesg after every boot.

p10ing (p10ing) wrote :

I think this could be a symptom of a problem with 2.6.31 itself. I'm using a custom kernel on Fedora 8 (x86_64) that's giving a conflict between two PCI (32-bit) cards:

[ 0.828847] pci 0000:02:07.0: BAR 6: address space collision on of device [0xfbfa0000-0xfbfbffff]
[ 0.828929] pci 0000:02:08.0: BAR 6: address space collision on of device [0xfbf90000-0xfbf9ffff]

This problem is not specific to Ubuntu. I am also seeing it with linux 2.6.31 on Debian:

$ dmesg | grep collision
[ 0.257209] pci 0000:05:04.0: BAR 6: address space collision on of device [0xfeac0000-0xfeadffff]

draco (draco31-fr) wrote :

I've got the same message on dmesg.
My system can boot but it freezes/hangs frequently for many minutes before coming back alive.
The message dosn't appear on the screen with the latest up to date Karmic x86_64 (maybe due to usplash).

I try the latest kernel 2.6.32.2 from here : http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32.2/
Now, the message appear during the boot despite of usplash.
It is the exact same message with the exact same addresses.

It's to soon to say if there is improvement of the system stability between the two kernel version.

draco (draco31-fr) wrote :

After more search on launchpad, I've found many other bug reports that have been marked as duplicate of Bug #413419 because the message appear during the boot process.

Bug #413419 has been marked as "fix released" because the message doesn't appear anymore on the screen during the boot process from Karmic with latest update.

However, most of users have reported bugs to fix the problem behind the message.
So, the following bug reports should get a second attention :
    * Bug #432164
    * Bug #440296
    * Bug #441874
    * Bug #443006
    * Bug #445321
    * Bug #447647

This message also appears with 2.6.32 kernels from Debian:

$ uname -a
Linux jophur 2.6.32-3-amd64 #1 SMP Thu Feb 25 07:33:41 UTC 2010 x86_64 GNU/Linux

$ dmesg | grep BAR
[ 0.212204] pci 0000:05:04.0: BAR 6: address space collision on of device [0xfeac0000-0xfeadffff]

However, it has disappeared with kernel 2.6.33 from Debian experimental:

$ dmesg | grep BAR

[ 0.212313] pci 0000:00:1c.0: BAR 14: assigned [mem 0x80000000-0x803fffff]
[ 0.212316] pci 0000:00:1c.2: BAR 15: assigned [mem 0x80400000-0x805fffff 64bit pref]
[ 0.212319] pci 0000:00:1c.5: BAR 15: assigned [mem 0x80600000-0x807fffff 64bit pref]
[ 0.212321] pci 0000:00:1c.0: BAR 13: assigned [io 0x1000-0x1fff]
[ 0.212324] pci 0000:00:1f.3: BAR 0: assigned [mem 0x80800000-0x808000ff]
[ 0.212328] pci 0000:00:1f.3: BAR 0: set to [mem 0x80800000-0x808000ff] (PCI address [0x80800000-0x808000ff]

starfear (utdilya) wrote :

This patch from 2.6.33 help to me.

https://patchwork.kernel.org/patch/39988/

diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
index dbd0f94..89efbb5 100644
--- a/drivers/pci/pci.c
+++ b/drivers/pci/pci.c
@@ -367,8 +367,12 @@ pci_find_parent_resource(const struct pci_dev *dev, struct resource *res)
    continue; /* Wrong type */
   if (!((res->flags ^ r->flags) & IORESOURCE_PREFETCH))
    return r; /* Exact match */
- if ((res->flags & IORESOURCE_PREFETCH) && !(r->flags & IORESOURCE_PREFETCH))
- best = r; /* Approximating prefetchable by non-prefetchable */
+ /* We can't insert a non-prefetch resource inside a prefetchable parent .. */
+ if (r->flags & IORESOURCE_PREFETCH)
+ continue;
+ /* .. but we can put a prefetchable resource inside a non-prefetchable one */
+ if (!best)
+ best = r;
  }
  return best;
 }

Seth Forshee (sforshee) wrote :

This has long been fixed upstream, so setting the development task to Fix Released. A test build for Lucid is available at

http://people.canonical.com/~sforshee/lp424142/2.6.32-32.62~lp424142v201105231936/

Changed in linux (Ubuntu Lucid):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Ben Collins (ben-collins) wrote :

I've tested the above Lucid packages and confirmed that it indeed fixes the problem on two separate boxes and does not cause regressions on a third that did not exhibit the problem.

Seth Forshee (sforshee) wrote :

Attaching SRU patch.

SRU Justification:

Impact: PCI devices may fail to work due to a resource allocation
failure. When this happens the kernel prints a "address space collision"
message.

Fix: Upstream commit 8c8def26bfaa704db67d515da3eb92cf26067548

Test case: Boot a kernel on an affected machine and observe that the
"address space collision" messages are no longer present. Resources for
the affected devices will appear in /proc/iomem and /proc/ioports with
the patch applied.

Seth Forshee (sforshee) on 2011-05-25
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag
'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by one week from today, this fix will be
dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Steve Conklin (sconklin) wrote :

The verification period for this kernel will close soon, and we have not received verification that the problem is resolved in Lucid. Please test and post results to this bug or the fix will be reverted from the release.

Ben Collins (ben-collins) wrote :

I've verified the kernel in -proposed includes the working fix for this problem.

Steve Conklin (sconklin) on 2011-06-16
tags: added: verification-done-lucid
removed: verification-needed-lucid
Launchpad Janitor (janitor) wrote :
Download full text (17.2 KiB)

This bug was fixed in the package linux - 2.6.32-33.70

---------------
linux (2.6.32-33.70) lucid-proposed; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #807175

  [ Upstream Kernel Changes ]

  * Revert "x86: Flush TLB if PGD entry is changed in i386 PAE mode"
    - LP: #805209

linux (2.6.32-33.69) lucid-proposed; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #802554

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.32-33.68) lucid-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #798305
  * Fix abi directory

linux (2.6.32-33.67) lucid-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "iwlagn: Support new 5000 microcode."

linux (2.6.32-33.66) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #794098

  [ Upstream Kernel Changes ]

  * Revert "xhci: Fix full speed bInterval encoding."
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - fix unsafe macro definitions"

linux (2.6.32-33.65) lucid-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * xhci: Fix full speed bInterval encoding.
    - LP: #792959

linux (2.6.32-33.64) lucid-proposed; urgency=low

  [ Herton R. Krzesinski ]

   * Release Tracking Bug
     - LP: #789325

  [ Leann Ogasawara ]

  * SAUCE: (no-up) Fix up KVM: VMX: Fix host userspace gsbase corruption
    - LP: #787675

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "(pre-stable): input: Support Clickpad devices in ClickZone
    mode"
    - LP: #780588

  [ Upstream Kernel Changes ]

  * Revert "GFS2: Fix writing to non-page aligned gfs2_quota structures"
    - LP: #780588
  * Revert "mmc: build fix: mmc_pm_notify is only available with
    CONFIG_PM=y"
    - LP: #780588
  * Revert "mmc: fix all hangs related to mmc/sd card insert/removal during
    suspend/resume"
    - LP: #780588
  * Revert "econet: fix CVE-2010-3848"
    - LP: #780588
  * Revert "dell-laptop: Add another Dell laptop family to the DMI
    whitelist"
    - LP: #780588
  * Revert "dell-laptop: Add another Dell laptop family to the DMI
    whitelist"
    - LP: #780588
  * Revert "xen: set max_pfn_mapped to the last pfn mapped"
  * cifs: always do is_path_accessible check in cifs_mount
    - LP: #770050
  * video: sn9c102: world-wirtable sysfs files
    - LP: #770050
  * UBIFS: restrict world-writable debugfs files
    - LP: #770050
  * NET: cdc-phonet, handle empty phonet header
    - LP: #770050
  * x86: Fix a bogus unwind annotation in lib/semaphore_32.S
    - LP: #770050
  * tioca: Fix assignment from incompatible pointer warnings
    - LP: #770050
  * mca.c: Fix cast from integer to pointer warning
    - LP: #770050
  * ramfs: fix memleak on no-mmu arch
    - LP: #770050
  * MAINTAINERS: update STABLE BRANCH info
    - LP: #770050
  * UBIFS: fix oops when R/O file-system is fsync'ed
    - LP: #770050
  * x86, cpu: AMD errata checking framework
    - LP: #770050
  * x86, cpu: Clean up AMD erratum 400 workaround
    - LP: #770050
  * x86, AMD: Se...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers