Ubuntu

TV/radio tuner card stoped working after upgrade to kernel 2.6.31-7

Reported by ts_petrov on 2009-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.31-7-generic

I have "PixelView PlayTV Pro 3" TV tuner card, and it worked fine with linux-image-2.6.31-6 and the previous versions.
( FYI, the kernel module is loaded with the following options:
options saa7134 card=42 tuner=38
given in /etc/modprobe.d/options.conf file)
After the system upgrade to linux-image-2.6.31-7 a week or two ago, the card stopped working. Namely, if for example I start gnomeradio program, there is a noise coming from the card like of not tuned radio, but changing the station/frequency does not seem to work. If I restart the system and select the old kernel 2.6.31-6, it works again.
Today the system upgrade installed linux-image-2.6.31-9, but the problem still exists with it.
I'm using Ubuntu Karmic (development branch), with all recent upgrades.

ts_petrov (ts-petrov) on 2009-09-01
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
James Henstridge (jamesh) wrote :

I ran into a similar issue with different hardware that might be the same bug (my report is bug 475165).

I found that my radio card could be tuned correctly if the video4linux 2 API was used, but failed if you tried to tune it using video4linux 1. Now the v4l1 support is handled through a module that translates the v4l1 calls to equivalent v4l2 calls, so if a bug exists in that code it would affect us both even though we have different hardware.

I wrote a patch for gnomeradio to get it to use v4l2, but the way it has been integrated means that it will use v4l1 in preference to v4l2. You can force it to use the v4l2 API by changing a gconf key though.

If you want to test my hypothesis, do the following:

1. Boot into a kernel that exhibits the tuning problem.
2. run gconf-editor, browse to /apps/gnomeradio and change the driver key from "any" to "v4l2".
3. Start gnomeradio and see if it can tune the radio.

ts_petrov (ts-petrov) wrote :

Thank you, James! Using gnomeradio with "v4l2" driver did the trick and it works again.
So, most probably the problem is in v4l1 module, not in "saa7134" or "tuner" modules as I thought before.

Hi ts_petrov,

I'm going to go ahead mark this as a duplicate to James' bug 475165. Please continue to track this issue at that report. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers