Ubuntu

Coolbox QBook 270-02: volume keys produce more than one key event

Reported by salva on 2009-08-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: udev

Hi,

Volume control keys do not work reliably on my netbook (Coolbox QBook 270-02).

Those keys are pressed as a combination of Fn + right and Fn + left.

When I press any of them, sometimes they are ignored, sometimes they generate and endless number of keypress/keyrelease event pairs while the rest of the keys stop to work.

Attached is the output xev gets (after killing the gnome-settings-daemon) while I do some single keypresses

Below is the output from /lib/udev/keymap -i input/event4.

root@melon:/usr/share/doc/udev# /lib/udev/keymap -i input/event4
Press ESC to finish
scan code: 0xB0 key code: volumeup
scan code: 0xAE key code: volumedown
scan code: 0xB0 key code: volumeup
scan code: 0xAE key code: volumedown
scan code: 0x39 key code: space
scan code: 0xB0 key code: volumeup
scan code: 0xAE key code: volumedown
scan code: 0xAE key code: volumedown
scan code: 0xB0 key code: volumeup
scan code: 0x01 key code: esc

ProblemType: Bug
Architecture: i386
Date: Fri Aug 28 12:58:18 2009
DistroRelease: Ubuntu 9.10
MachineType: FOXCONN QBOOK
Package: udev 146-1
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: root=UUID=71f90e4a-e6ca-43fa-83fb-529dd0eb250a ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
SourcePackage: udev
Uname: Linux 2.6.31-7-generic i686
dmi.bios.date: 11/04/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: QBOOK
dmi.board.vendor: FOXCONN
dmi.board.version: 1.1
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd11/04/2008:svnFOXCONN:pnQBOOK:pvr1.1:rvnFOXCONN:rnQBOOK:rvr1.1:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: QBOOK
dmi.product.version: 1.1
dmi.sys.vendor: FOXCONN

salva (sfandino) wrote :
salva (sfandino) wrote :
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Confirmed
Martin Pitt (pitti) wrote :

There's a possibility that the acpi-support scripts also catch these events and duplicate the key presses.

Can you please try

  sudo dpkg -P acpi-support

and check if it still behaves the same?

However, that wouldn't explain the irregular behaviour you sometimes get, like endless number of repeats.

udev's keymap itself seems to be right here (or, rather, not affected at all), the key symbols seem to be correct. So if acpi-support isn't the culprit, this would be a kernel bug.

Changed in udev (Ubuntu):
status: Confirmed → Incomplete
summary: - too many key events for volume keys
+ Coolbox QBook 270-02: volume keys produce more than one key event

----- Original Message ----
> From: Martin Pitt <email address hidden>
> To: <email address hidden>
> Sent: Wednesday, September 9, 2009 1:12:15 PM
> Subject: [Bug 420473] Re: too many key events for volume keys
>
> There's a possibility that the acpi-support scripts also catch these
> events and duplicate the key presses.
>
> Can you please try
>
> sudo dpkg -P acpi-support
>
> and check if it still behaves the same?

removing acpi-support did not cause any appreciable difference, I am still getting the same erratic behaviour.

Do you know if there is any utility similar to /lib/udev/keymap but able to generate more detailed info I could use to monitor everything the kernel sends to input/event4?

Cheers

- Salva

>
> However, that wouldn't explain the irregular behaviour you sometimes
> get, like endless number of repeats.
>
> udev's keymap itself seems to be right here (or, rather, not affected at
> all), the key symbols seem to be correct. So if acpi-support isn't the
> culprit, this would be a kernel bug.
>
> ** Changed in: udev (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Summary changed:
>
> - too many key events for volume keys
> + Coolbox QBook 270-02: volume keys produce more than one key event
>
> --
> Coolbox QBook 270-02: volume keys produce more than one key event
> https://bugs.launchpad.net/bugs/420473
> You received this bug notification because you are a direct subscriber
> of the bug.

Martin Pitt (pitti) wrote :

> Do you know if there is any utility similar to /lib/udev/keymap but able to generate more detailed info I could use to > monitor everything the kernel sends to input/event4?

You can try using input-events from the "input-utils" package, but it's not that much more detail.

This seems to be a kernel driver problem now, reassigning.

affects: udev (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
assignee: Martin Pitt (pitti) → nobody
salva (sfandino) wrote :

input-events shows that no "release" events are being generated for those keys!

Changed in linux (Ubuntu):
status: New → Triaged
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Kamal Mostafa (kamalmostafa) wrote :

Ubuntu 10.04 Beta users can install a test fix for this problem from this PPA:
  https://launchpad.net/~kamalmostafa/+archive/lucid-volume-keys

Feedback to this bug report will be appreciated.

Changed in udev (Ubuntu):
status: New → Incomplete
Kamal Mostafa (kamalmostafa) wrote :

Attached patch adds this model (FOXCONN/QBOOK) to the common-volume-keys release quirk.
Prerequisite patch: common-volume-keys.patch from LP: #565459.

Martin Pitt (pitti) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-12

---------------
udev (151-12) lucid; urgency=low

  * Cherrypick keymap fixes from trunk:
    - Unite laptop models needing common volume-key release quirk. Many laptop
      models need the same volume-key release quirk. Currently, two models
      have identical force-release-maps/ keymap files (dell-studio-1557 and
      fujitsu-amilo-si1848) and two more need to be added (Mitac and Coolbox
      QBook). This replaces the identical force-release-maps files with one
      'common-volume-keys' file to make adding new models easier.
      (LP: #565459)
    - Add force-release quirk for Coolbox QBook 270-02 (LP: #420473)
    - Add force-release quirk for Mitac 8050QDA (LP: #374884)
 -- Martin Pitt <email address hidden> Mon, 19 Apr 2010 10:58:13 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers