Option 225 3G USB Stick removal causes system lock

Bug #418499 reported by Alan Lord on 2009-08-25
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Fully updated Ubuntu Karmic as of today (25/08/09 at 10:05 BST).

Hardware: Asus 1008HA

3G dongle: Option ICON 225 (Uses kernel module hso.ko)

Plugging in the USB stick and removing it without attempting to make a connection does not cause the failure.

To cause failure, plug in the USB device, attempt to make a connection in NM (it doesn't matter if the connection succeeds or not) then disconnect using the NM interface. OK so far.

Upon removing the dongle, the entire system locks up.

FYI, these symptoms used to happen with the early versions of the hso module prior to being included in the mainstream kernel tree in 2.6.27 IIRC. I tested this with all available Karmic kernels on my system: 2.6.31.3-generic, 2.6.31.4-generic, 2.6.31.5-generic, 2.6.31.6-generic, 2.6.31.7-generic, and the problem is the same. However, I am *pretty sure* this did not used to happen a couple of weeks ago. Not much help I know.

It is repeatable *every-time*. No mouse movement is possible, no keyboard commands are accepted apart from doing Alt+SysRq REISUB will cause a reboot.

I had an ssh connection into the device and was tailing /var/log/messages. No output upon removal and the ssh connection is also broken.

Alan Bell (alanbell) wrote :

I just reproduced this issue. Fully updated Karmic box, connected OK to Orange, removed the dongle and it locked up. Was OK a little while ago on Karmic

tags: added: hso
tags: added: karmic kernel-oops nm
Alan Bell (alanbell) on 2009-08-25
Changed in ubuntu:
status: New → Confirmed
Luke Faraone (lfaraone) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it without more information.

Please run the following command which will attach necessary information:

apport-collect BUGNUMBER
if you are using Karmic Koala (9.10) or newer, or

apport-collect -p linux-image-`uname -r` BUGNUMBER
if you are using Jaunty Jackalope (9.04)

Bear in mind that you may need to install the python-launchpadlib package from the universe repository with 'sudo apt-get install python-launchpadlib'. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

If you are using an older release or cannot use apport please at least add the following information (pay attention to lspci's additional options):
First run the following commands:
1) uname -a > uname-a.log
2) dmesg > dmesg.log
3) sudo lspci -vvnn > lspci-vvnn.log
4) cat /proc/version_signature > version.log
then attach the files separately to the bug report (not pasted into comments or tar/zip-ed).

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies. Thanks in advance!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Gytis Raciukaitis (noxxious) wrote :

This affects me too on karmic, with Option UMTS USB/PCMCIA Card.

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: noxxious 2902 F.... pulseaudio
 /dev/snd/pcmC0D0c: noxxious 2902 F...m pulseaudio
 /dev/snd/pcmC0D0p: noxxious 2902 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211c,00100000'
   Controls : 14
   Simple ctrls : 7
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=d9dfcf3d-9050-458d-833c-42a0ae113c50
MachineType: LENOVO 6474B84
NonfreeKernelModules: symap_custom_2.6.31_11_generic_pae_i686 symev_custom_2.6.31_11_generic_pae_i686
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-12-generic-pae root=/dev/mapper/vg_system-lv_root ro quiet splash
ProcEnviron:
 SHELL=/bin/zsh
 LC_PAPER=en_GB.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic-pae
RelatedPackageVersions: linux-firmware 1.21
Uname: Linux 2.6.31-12-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET71WW (3.01 )
dmi.board.name: 6474B84
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET71WW(3.01):bd05/15/2009:svnLENOVO:pn6474B84:pvrThinkPadT400:rvnLENOVO:rn6474B84:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6474B84
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alord 1520 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbcb8000 irq 16'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1043834a,00100004'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=61fe39b9-ea86-4245-9639-5020f7b49249
MachineType: ASUSTeK Computer INC. 1008HA
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-12-generic root=UUID=e361e34f-efd6-489c-98fd-0b7337ec46ea ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
RelatedPackageVersions: linux-firmware 1.21
Uname: Linux 2.6.31-12-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1534): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1534): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1629): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1650): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1628): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -16 and height 24
dmi.bios.date: 08/18/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1103
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1008HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1103:bd08/18/2009:svnASUSTeKComputerINC.:pn1008HA:pvrx.x:rvnASUSTeKComputerINC.:rn1008HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1008HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Download full text (5.0 KiB)

Hello

I have the same problem on my Asus EEE PC 901 with an Option iCon 401 USB. The system froze, but after a little while it became responsive. Here is the dmesg output:

[ 83.561141] usb 1-2: new high speed USB device using ehci_hcd and address 3
[ 83.698907] usb 1-2: configuration #1 chosen from 1 choice
[ 85.214417] usb 1-2: USB disconnect, address 3
[ 85.256232] hso: /build/buildd/linux-2.6.31/drivers/net/usb/hso.c: 1.2 Option Wireless
[ 85.256345] usbcore: registered new interface driver hso
[ 85.284866] Initializing USB Mass Storage driver...
[ 85.285078] usbcore: registered new interface driver usb-storage
[ 85.285091] USB Mass Storage support registered.
[ 85.568130] usb 1-2: new high speed USB device using ehci_hcd and address 4
[ 85.689103] usb 1-2: device descriptor read/64, error -32
[ 85.942072] usb 1-2: configuration #1 chosen from 1 choice
[ 85.978888] hso0: Disabled Privacy Extensions
[ 85.995250] hso 1-2:1.10: Not our interface
[ 85.995479] scsi7 : SCSI emulation for USB Mass Storage devices
[ 86.020140] usb-storage: device found at 4
[ 86.020148] usb-storage: waiting for device to settle before scanning
[ 86.143292] usb 1-2: hso received invalid serial state notification
[ 91.020771] usb-storage: device scan complete
[ 91.021701] scsi 7:0:0:0: Direct-Access ZCOption HSUPA Modem PQ: 0 ANSI: 2
[ 91.023880] sd 7:0:0:0: Attached scsi generic sg2 type 0
[ 91.028502] sd 7:0:0:0: [sdc] Attached SCSI removable disk
[ 103.716873] ===>rt_ioctl_giwscan. 4(4) BSS returned, data->length = 528
[ 163.712818] ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 445
[ 164.638414] ERROR!!! RTMPCancelTimer failed, Timer hasn't been initialize!
[ 164.640067] ERROR!!! RTMPCancelTimer failed, Timer hasn't been initialize!
[ 177.680286] ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 445
[ 177.681194] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 236.892104] usb 1-2: USB disconnect, address 4
[ 243.469363] BUG: unable to handle kernel NULL pointer dereference at 00000008
[ 243.469381] IP: [<c056a039>] __mutex_unlock_slowpath+0x29/0x50
[ 243.469402] *pde = 7e275067
[ 243.469411] Oops: 0000 [#1] SMP
[ 243.469420] last sysfs file: /sys/devices/pci0000:00/0000:00:1d.7/usb1/idVendor
[ 243.469430] Modules linked in: usb_storage hso binfmt_misc ppdev joydev snd_hda_codec_realtek fbcon tileblit font bitblit
[ 243.469540]
[ 243.469550] Pid: 771, comm: modem-manager Tainted: G C (2.6.31-12-generic #40-Ubuntu) 901
[ 243.469561] EIP: 0060:[<c056a039>] EFLAGS: 00010213 CPU: 0
[ 243.469571] EIP is at __mutex_unlock_slowpath+0x29/0x50
[ 243.469580] EAX: 00000000 EBX: f6910040 ECX: f6afe060 EDX: 00000000
[ 243.469588] ESI: f6910044 EDI: 00000001 EBP: f6a0fe64 ESP: f6a0fe5c
[ 243.469597] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 243.469607] Process modem-manager (pid: 771, ti=f6a0e000 task=f6a5f110 task.ti=f6a0e000)
[ 243.469614] Stack:
[ 243.469619] f6910600 f5a25000 f6a0fe6c c056a004 f6a0fe90 f816d516 c03791be f5a250b4
[ 243.469639] <0> 00000000 f6910664 f5a25000 f5bc0700 00000000 f6a0ff38 c037adb0 00000001
[ 243.469660] <0> 000000...

Read more...

Luke Faraone (lfaraone) on 2009-10-10
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: needs-upstream-testing
Luke Faraone (lfaraone) wrote :

Hi,

Can you also confirm that this bug occurs in the mainline (unmodified upstream) kernel? See https://wiki.ubuntu.com/KernelTeam/MainlineBuilds for more information on how to test this out. If this issue still occurs on that kernel, then it is also an upstream bug.

I can confirm that the same happens with mainline kernel 2.6.31-02063103. System froze completely. I could not get the kernel messages.

Luke Faraone (lfaraone) on 2009-10-10
tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → Triaged

This works better with the new kernel 2.6.31-14-generic. The system does not hang when the device is removed while disconnected, but when the devices is removed while connected to the Internet, the system hangs like before.

Eric Miao (eric.y.miao) wrote :

Hein,

Could you please attach the error message (dmesg) when the system hangs
while connected to the Internet? Is it the same symptom and same message?

Sorry, but I haven't been able to get the error message as the system now freezes completely after device removal. It is the same symtom, but I managed to get the error message one time before.

Saulius Sinkunas (ssinkunas) wrote :

I guess the problem is with the HSO module. It doesn't unload itself fully - device /dev/ttyHS1 remains in the system (although other /dev/ttyHS* are removed). Maybe that's why everything locks up. There is a new HSO version 1.12 but it doesn't compile on 2.6.31 because of changed structures.

BTW only Network Manager locks up the system. Using HSO Connect to connect to the Internet doesn't cause such failure - it becomes impossible to connect to the Internet but at least it doesn't lock up the system.

hello!

I have to reconfigure nm every time i want to use the option icon 225 dongle. dmesg says modem-manager segfaults. if i can help you, please tell me what to do.

Iain Cheyne (icheyne) on 2009-11-30
description: updated
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Alan Lord (theopensourcerer) wrote :

Well, I used the 225 yesterday on my netbook with Lucid, yanked the dongle out and the system worked as I'd expect, e.g. I got a notification that my network connection had been disconnected and everything else continued to operate.

So I guess this now resolved.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.