[karmic] cracking sounds before sound playback

Bug #417302 reported by Sancho on 2009-08-22
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have an Intel audio on my HP laptop.
When playing any sound (e.g. warning sounds from command line, etc.) the output I hear is a loud crack in speakers and than the sound. The speakers do the crack sound even when the headphones are connected, just the sound is played back in the headphones only.
It seems like something with power saving - windows is performing simmiliar behaviour. But I still have an installation of Intrepid and there is no such thing - the playback is smooth, no cracking, nothing. The cracking sound does not appear when playing two sounds with minimal time difference (e.g. 10 seconds), but with bigger difference (e.g. a minute), the cracking is back.
Also, now I noticed, that before the playback the mute icon (the diode on the laptop body, not the indicator in main panel of Ubuntu) shines for a short time, than turns off again. Maybe that's the reason of the cracking sound, but as I said, such behaviour did not exists in Intrepid.

Sancho (sancho-sancho) on 2009-08-22
description: updated
description: updated
Sancho (sancho-sancho) on 2009-08-22
summary: - [keramic] cracking sounds before and after sound playback
+ [karmic] cracking sounds before sound playback
Alex Valavanis (valavanisalex) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

If you are using Jaunty this information can be gathered for you automatically using the command:

apport-collect -p alsa-base 417302

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sancho 9019 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4804000 irq 16'
   Mixer name : 'Analog Devices AD1981'
   Components : 'HDA:11d41981,103c30c0,00100200 HDA:11c11040,103c1378,00100200'
   Controls : 11
   Simple ctrls : 9
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.26-generic
Uname: Linux 2.6.31-6-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

Sancho (sancho-sancho) wrote :
Sancho (sancho-sancho) wrote :

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sancho 2937 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4804000 irq 16'
   Mixer name : 'Analog Devices AD1981'
   Components : 'HDA:11d41981,103c30c0,00100200 HDA:11c11040,103c1378,00100200'
   Controls : 11
   Simple ctrls : 9
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.26-generic
Uname: Linux 2.6.31-6-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

Sancho (sancho-sancho) wrote :
Sancho (sancho-sancho) wrote :
Sancho (sancho-sancho) wrote :
Sancho (sancho-sancho) wrote :
Sancho (sancho-sancho) wrote :

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sancho 2937 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4804000 irq 16'
   Mixer name : 'Analog Devices AD1981'
   Components : 'HDA:11d41981,103c30c0,00100200 HDA:11c11040,103c1378,00100200'
   Controls : 11
   Simple ctrls : 9
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.26-generic
Uname: Linux 2.6.31-6-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

Sancho (sancho-sancho) wrote :

As you can see, the appport has some issues with my installation (defect already reported), so I had to do the alsa script. Result is attached.

Sancho (sancho-sancho) wrote :

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sancho 2937 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4804000 irq 16'
   Mixer name : 'Analog Devices AD1981'
   Components : 'HDA:11d41981,103c30c0,00100200 HDA:11c11040,103c1378,00100200'
   Controls : 11
   Simple ctrls : 9
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.26-generic
Uname: Linux 2.6.31-6-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: justin 3032 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe100000 irq 17'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,17aa20dc,00100100'
   Controls : 18
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
Uname: Linux 2.6.31-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Sancho (sancho-sancho) wrote :

We can close this thread.
It is not a defect in alsa or anything else.
The main problem is the power-saving option in the intel hda module.
The sufficient fix is to modify the line in /etc/modprobe.d/alsa-base.conf containing something like
options snd-hda-intel power_save=X
Just remove the whole power_save=X option and that's it.
Restart is required than.

Changed in linux (Ubuntu):
status: New → Invalid
Id2ndR (id2ndr) wrote :

I commented out the line "options snd-hda-intel power_save=X" and I confirm that the cracking sounds disappear.

But if everyone whose got an intel audio chipset got this trouble, why this option is not removed by default ? i think this trouble is annoying for most of users and only few users may want the power_save state enable. It may be better if these users add this option if them want.

On Sun, Sep 20, 2009 at 4:51 PM, Id2ndR <email address hidden> wrote:
> I commented out the line "options snd-hda-intel power_save=X" and I
> confirm that the cracking sounds disappear.

What codec are you using? Use:
head -6 /proc/asound/card*/codec*

Can you see if using "options snd-hda-intel power_save=10
power_save_controller=0" helps?
i.e., add power_save_controller=0

> But if everyone whose got an intel audio chipset got this trouble, why
> this option is not removed by default ? i think this trouble is annoying
> for most of users and only few users may want the power_save state
> enable. It may be better if these users add this option if them want.

It's not removed, because I'm about to adjust the default option based
on what people report for their codecs.

Additionally, it's misleading to say "everyone whose [sic] got an
intel audio chipset", because what matters is the _codec_.

Also, I have some patches enqueued for Realtek codecs.

Id2ndR (id2ndr) wrote :

Here is the result of the command :

$ head -6 /proc/asound/card*/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices AD1981
Address: 0
Function Id: 0x1
Vendor Id: 0x11d41981
Subsystem Id: 0x11790311
Revision Id: 0x100200

==> /proc/asound/card0/codec#1 <==
Codec: LSI Si3054
Address: 1
Function Id: 0x2
Vendor Id: 0x11c13026
Subsystem Id: 0x11790001
Revision Id: 0x100700

adding power_save_controller=0 didn't help in my case (example running totem /usr/share/sounds/question.wav after the 10s timeout will "cut" the first musical note of the three).

Sorry for my misunderstanding between the chipset and the codec, and thanks for your explanation.

Id2ndR (id2ndr) wrote :

$ head -6 /proc/asound/card*/codec*
Codec: Realtek ALC888
Address: 0
Function Id: 0x1
Vendor Id: 0x10ec0888
Subsystem Id: 0x1462356a
Revision Id: 0x100001

On this hardware, adding power_save_controller=0 is worth than without : it introduce crackling. Without the option, totem seems to cut the first musical note of question.wav after the delay.

Percy Leonhardt (p3y) wrote :

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC1200
Address: 0
Function Id: 0x1
Vendor Id: 0x10ec0888
Subsystem Id: 0x10250121
Revision Id: 0x100101

==> /proc/asound/card0/codec#1 <==
Codec: Conexant ID 2c06
Address: 1
Function Id: 0x2
Vendor Id: 0x14f12c06
Subsystem Id: 0x10250121
Revision Id: 0x100000

Using "power_save_controller=0" does not help to remove the crackle.

Radek Stastny (tonous) wrote :

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC883
Address: 0
Function Id: 0x1
Vendor Id: 0x10ec0883
Subsystem Id: 0x1043829f
Revision Id: 0x100002

==> /proc/asound/card0/codec#1 <==
Codec: Silicon Image SiI1392 HDMI
Address: 1
Function Id: 0x1
Vendor Id: 0x10951392
Subsystem Id: 0xffffffff
Revision Id: 0x100000

Using "power_save_controller=0" does not help to remove the crackle. SO I have to remove whole line of options for snd_hda_intel

Peter B. (puk007-gmail) wrote :

I can confirm reported problem also with my audio:
lspci:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

commenting out of mentioned line in /etc/modprobe.d/alsa-base.conf solved this problem for me

thanks for solution, but would be cool to have it running out of the box

Id2ndR (id2ndr) wrote :

Codec: Realtek ALC889A
Address: 2
Function Id: 0x1
Vendor Id: 0x10ec0885
Subsystem Id: 0x15bd3112
Revision Id: 0x100101

Removing "power_save=10 power_save_controller=0" solve the problem.

TomasHnyk (sup) wrote :

I was also affected by this. I think this is a bug - speakers should not produce unpleasant sounds for not apparent reason. Thus confirming it.

Changed in linux (Ubuntu):
status: Invalid → Confirmed

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marino 1799 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 22'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1043829e,00100002'
   Controls : 35
   Simple ctrls : 20
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic-pae
Uname: Linux 2.6.31-15-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

wow, that was more than I expected!

I had already commented out

#options snd-hda-intel power_save=10 power_save_controller=N

which is currently working for me :)

Lutz (webmaster-phatsonic) wrote :

I have the same problem (since updating to Ubuntu 9.10 yesterday).
The problem didn't happen on 8.04.

My codec is this:

head -6 /proc/asound/card*/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Motorola Si3054
Address: 0
Function Id: 0x2
Vendor Id: 0x10573055
Subsystem Id: 0x10573055
Revision Id: 0x100700

==> /proc/asound/card0/codec#1 <==
Codec: Realtek ALC883
Address: 1
Function Id: 0x1
Vendor Id: 0x10ec0883
Subsystem Id: 0x17340000
Revision Id: 0x100002

I'll try the given workaroud and report back later.

Lutz (webmaster-phatsonic) wrote :

OK, seems to work. My eardrums are still there.

Btw, not sure if it's the same for everyone, but for me the crack was in the speakers and the headphones at the same time. And fucking LOUD too. ;)

obstriegel (obstriegel) wrote :

$ head -6 /proc/asound/card*/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC1200
Address: 0
Function Id: 0x1
Vendor Id: 0x10ec0888
Subsystem Id: 0x10438357
Revision Id: 0x100101

I can also confirm that setting "power_save_controller=0" does not help here

Merijn Schering (mschering) wrote :

This doesn't work for 10.04 lucid. Does anyone have an idea on how to fix it?

Merijn Schering (mschering) wrote :

I found that adding the following line to /etc/modprobe.d/alsa-base.conf works:

options snd-hda-intel enable_msi=1

Merijn, please file a separate bug against alsa-driver entitled
"[needed quirk] enable_msi=1" so that we can get your hardware info.

chelz (twelvetales64) wrote :

Hi I just did an upgrade from 8.10, to 9.04, then to 9.10 and I'm experiencing this, as in playing audio would begin with a crackle almost always. I didn't experience any high-pitched noises or crackles periodically, as mentioned in other bugs that suggested the "comment out snd-hda-intel" fix, only when playing audio.

Commenting out
options snd-hda-intel power_save=10 power_save_controller=N
in
/etc/modprobe.d/alsa-base.conf
then rebooting gets rid of them.

I would like to supply any info about my system that might help in the fixing of this issue. Here is something that might help:
http://www.alsa-project.org/db/?f=c61bab84cc5ec0eda37eb85051385da2a834bf5a

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.