Still doesn't cleanup /lib/modules/$(uname -r) properly

Bug #415832 reported by Loïc Minier
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft

Bug Description

Hi

I got bug #348395 again in karmic; I'm opening a new bug since the other one was against jaunty and was claimed to be fix, so I assume I must be seeing another bug.

After purging old linux-image packages on my laptop, I still see:
/lib/modules/2.6.31-3-generic
/lib/modules/2.6.31-4-generic
/lib/modules/2.6.31-5-generic
all of them with the same files:
/lib/modules/2.6.31-5-generic/modules.alias.bin
/lib/modules/2.6.31-5-generic/modules.dep.bin
/lib/modules/2.6.31-5-generic/modules.symbols.bin

on my desktop, I see the same thing:
dpkg: warning: while removing linux-image-2.6.31-4-generic, directory '/lib/modules/2.6.31-4-generic' not empty so not removed.
...

% find /lib/modules/2.6.31-5-generic
/lib/modules/2.6.31-5-generic
/lib/modules/2.6.31-5-generic/modules.dep.bin
/lib/modules/2.6.31-5-generic/modules.alias.bin
/lib/modules/2.6.31-5-generic/modules.symbols.bin

dpkg: warning: while removing linux-image-2.6.31-5-generic, directory '/lib/modules/2.6.31-5-generic' not empty so not removed.

Thanks

ProblemType: Bug
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lool 6453 F.... pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0620000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211f,00100000'
   Controls : 14
   Simple ctrls : 7
Date: Wed Aug 19 12:12:11 2009
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 2777CTO
Package: linux-image-2.6.31-6-generic 2.6.31-6.25
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-6-generic root=/dev/mapper/hostname--vg0-ubuntu--root ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-6-generic N/A
 linux-firmware 1.16
SourcePackage: linux
Uname: Linux 2.6.31-6-generic x86_64
WpaSupplicantLog:

dmi.bios.date: 03/12/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET27WW (1.08 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET27WW(1.08):bd03/12/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

Revision history for this message
Loïc Minier (lool) wrote :
Revision history for this message
Loïc Minier (lool) wrote :

The original fix I had proposed in bug #348395 still applied; I see it was committed in 189ef5279c2f530b7b3b4f92a22570e8b6f7a1da in ubuntu/ubuntu-jaunty.git but isn't in ubuntu/ubuntu-karmic.git.

Changed in linux (Ubuntu):
status: New → Triaged
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → In Progress
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-10.35

---------------
linux (2.6.31-10.35) karmic; urgency=low

  [ Amit Kucheria ]

  * Disable CONFIG_UEVENT_HELPER_PATH

  [ Andy Whitcroft ]

  * [Config] Enable CONFIG_USB_GADGET_DUMMY_HCD
  * remove the tlsup driver
  * remove lmpcm logitech driver support

  [ Bryan Wu ]

  * Add 3 missing files to prerm remove file list
    - LP: #345623, #415832

  [ Chris Wilson ]

  * [Upstream] drm/i915: Check that the relocation points to within the
    target
    - LP: #429241

  [ Luke Yelavich ]

  * [Config] Set CONFIG_EXT4_FS=y on ports architectures

  [ Manoj Iyer ]

  * SAUCE: Added quirk to recognize GE0301 3G modem as an interface.
    - LP: #348861

  [ Tim Gardner ]

  * Revert "[Upstream] ACPI: Add Thinkpad W500, W700, & W700ds to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad R400 & Thinkpad R500 to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad X300 & Thinkpad X301 to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad X200, X200s, X200t to OSI(Linux) white-list"
  * Revert "[Upstream] ACPI: Add Thinkpad T400 & Thinkpad T500 to OSI(Linux) white-list"
    Upstream suggests that this is not the right approach.

  * [Config] Set default I/O scheduler to DEADLINE
    CFQ seems to have some load related problems which are often exacerbated by sreadahead.
    - LP: #381300

  [ <email address hidden> ]

  * SAUCE: ipw2200: Enable LED by default
    - LP: #21367

  [ Upstream Kernel Changes ]

  * ALSA: hda - Add support for new AMD HD audio devices
    - LP: #430564

 -- Andy Whitcroft <email address hidden> Wed, 16 Sep 2009 15:37:49 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers