PC beep no longer works in Karmic alpha4

Bug #414795 reported by أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-08-17
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ubuntu Audio Team
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

  PC beep used to work in Karmic alpha3 after I modprobe pcspkr. Last successful test was with
 linux-image-2.6.31-5-generic 2.6.31-5.24
 pulseaudio 1:0.9.16~test4-0ubuntu4

Yet it doesn't work anymore with Karmic alpha4. Currently I'm using:
linux-image-2.6.31-6-generic 2.6.31-6.25
pulseaudio 1:0.9.16~test4-0ubuntu6

I'm not sure if this bug should be against the kernel or pulseaudio or what.

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/pcmC0D3p', '/dev/snd/by-path', '/dev/snd/pcmC0D0p', '/dev/snd/controlC0', '/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D0c', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer2', '/dev/sequencer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6afc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,10280263,00100302 HDA:14f12c06,14f1000f,00100000 HDA:80862802,80860101,00100000'
   Controls : 35
   Simple ctrls : 19
Date: Mon Aug 17 15:33:27 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=2d2733cb-5183-499b-805f-443db67429ab
MachineType: Dell Inc. Latitude E5500
NonfreeKernelModules: wl
Package: linux-image-2.6.31-6-generic 2.6.31-6.25
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-6-generic root=UUID=f7569fdd-a8bf-4fd1-ae2d-d4842dbf5621 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
RelatedPackageVersions: linux-firmware 1.16
SourcePackage: linux
Uname: Linux 2.6.31-6-generic i686
dmi.bios.date: 04/15/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0DW634
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd04/15/2009:svnDellInc.:pnLatitudeE5500:pvr:rvnDellInc.:rn0DW634:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E5500
dmi.sys.vendor: Dell Inc.

Rohan Garg (rohangarg) wrote :

Confirmed in Kubuntu Karmic Alpha 4
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Linux shadeslayer 2.6.31-6-generic #25-Ubuntu SMP Fri Aug 14 16:28:28 UTC 2009 x86_64 GNU/Linux

Hello,

  I just found out that beep works (although the beep sound is very wierd) if pcspkr is not modprobe'd !

Actually modprobe'ing pcspkr make pulseaudio sound system not work for some reason.

Vish (vish) wrote :

the pcspkr is now blacklisted > Bug #290204
This may be a pulse audio problem

Please find the wierd beep sound attached.

I tried to unlist pcspkr from blacklist.conf, and added pcspkr to /etc/modules, but I still get that awkward beep.

John Vivirito (gnomefreak) wrote :

I commented out the blacklist and rebooted 5 or so times and the system beep still doesnt work
The only time i get the system beep is on shutdown/reboot and only beeps once.
Here is sound card info from lspci -v

02:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
 Subsystem: Creative Labs Device 8022
 Flags: bus master, medium devsel, latency 64, IRQ 16
 I/O ports at ece0 [size=32]
 Capabilities: <access denied>
 Kernel driver in use: EMU10K1_Audigy
 Kernel modules: snd-emu10k1

02:07.1 Input device controller: Creative Labs SB Live! Game Port (rev 07)
 Subsystem: Creative Labs Device 0020
 Flags: bus master, medium devsel, latency 64
 I/O ports at ecd8 [size=8]
 Capabilities: <access denied>
 Kernel driver in use: Emu10k1_gameport
 Kernel modules: emu10k1-gp

Just to make sure we both have the same problem: Did you try to run
alsamixer and unmute "PC Beep" from there ?

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7 (@ subkeys.pgp.net)
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

John Vivirito (gnomefreak) wrote :

its set to 20 so it should beep

John Vivirito (gnomefreak) wrote :

Marked as confirmed since i have the same problem as above we ran some tests to confirm this is the same bug and it is.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Andy Whitcroft (apw) wrote :

@Ahmed -- that sounds a lot like a low frequency beep. The 'volume' for the PC Beep channel is actually a frequency selector (mad I know). Try selecting a different 'higher' volume and see if that sounds better.

On Tue, Sep 08, 2009 at 09:24:25AM -0000, Andy Whitcroft wrote:
> @Ahmed -- that sounds a lot like a low frequency beep. The 'volume' for
> the PC Beep channel is actually a frequency selector (mad I know). Try
> selecting a different 'higher' volume and see if that sounds better.
---end quoted text---

I tried that but it gives the same sound, but just louder.

Btw, please note that by modprobe'ing pcspkr, I don't get any beeps at
all !

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7 (@ subkeys.pgp.net)
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Please note that according to the beep recording that I attached (beep.ogg), the HDA PC beep is not a clean note.

Another issue in using HDA for PC beep, is that if for example I plug the headphone, the PC beep will come into the headphone not the PC speaker.

Lupe Christoph (lupe) wrote :

Just upgraded to Karmic Beta, and I ran into the same problem.

echo ^G
-- silence ---

But after modprobe'ing pcspkr, I get a sound. Also without the pcspkr driver, the "beep" utility is useless, with it, I can do all kinds of interesting beeps.

Lupe Christoph (lupe) wrote :

Just to emphasize - the sound produced by "echo ^G" when pcspkr is loaded is the same I had with Intrepid. As far as I can tell.

gali98 (korylp) wrote :

I have the same problem as Above.
I think the problem is just that pcspkr is not getting loaded automatically.
You can add it to /etc/modules
Kory

On Mon, Oct 05, 2009 at 09:45:28PM -0000, gali98 wrote:
> I think the problem is just that pcspkr is not getting loaded automatically.
> You can add it to /etc/modules
---end quoted text---

Did that, but still got the same problem.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7 (@ subkeys.pgp.net)
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Duane Hinnen (duanedesign) wrote :

pcspkr is now blacklisted. That is the expected behavior. However un-blacklisting it, and loading the module, should result in the sound being played again. However if i understand bug #77010 Pulse Audio is supposed to now take over and play a user defined, and much more reasonable, beep.
In the above referenced bug there are a few ways mentioned to turn off/on this beep including gconf-editor. I am not sure if this might help you Ahmed get your beep back.

Duane Hinnen (duanedesign) wrote :

This is the gconf setting i mentioned in my previous post. I am posting it here for convenience and in hopes that it helps.

run gconf-editor from terminal and set
/desktop/gnome/peripherals/keyboard/bell_mode
to 'off' rather than 'on'

Of course you would do the opposite to turn the sound on.

Good Luck

On Tue, Oct 06, 2009 at 05:36:24AM -0000, duanedesign wrote:
> run gconf-editor from terminal and set
> /desktop/gnome/peripherals/keyboard/bell_mode
> to 'off' rather than 'on'
---end quoted text---

That doesn't change anything, tried both "on" & "off". Anyways, I don't
expect it to change anything either, since this is a Gnome setting,
while the problem I am talking about even happens in the virtual
console.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7 (@ subkeys.pgp.net)
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Andy Whitcroft (apw) on 2009-10-07
Changed in linux (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Ubuntu Audio Team (ubuntu-audio)
Steve Langasek (vorlon) wrote :

evidence indicates this is a bug with the kernel module, not with pulseaudio; closing the pulseaudio task.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Invalid
tags: added: regression-release
removed: regression-potential
tags: added: karmic
atlantique (atlantique) wrote :

I made the mistake of upgrading my office computer to "Ubuntu 9.10 \n \l "
and the command "beep" (beep-1.2.2) stopped working, although the speaker or membrane
certainly works. At home I runt "Ubuntu 9.04 \n \l" and "beep works without problems.

I have tried removing the line "blacklist pcspkr" from /etc/modprobe.d/blacklist.conf
but "beep" still fails.

My office computer does not have speakers, therefore "beep" is very useful for me.
I would like to know whether there any way of circumventing this problem
without having reinstall my older version of Ubuntu? Perhaps by installing
an older version of "beep" or an older version the audio system?

Any suggestions will be appreciated.

Thanks.

John Vivirito (gnomefreak) wrote :

Please see bug #512415 for info on why I was told it wouldn't happen

John Vivirito (gnomefreak) wrote :

Steven for me it isn't the kernel module since on shutdown/reboot the system beep works but after that it doesn't work

This became worse in Maverick, as there is no beep at all !

This is not just kernel related (at least in Maverick), since I just tried booting Maverick with the latest Lucid kernel (there was a beep sound in Lucid, yet an awkward one since it was generated by pulseaudio somehow), yet there is still no beep at all as I inidicated in my last comment

Changed in pulseaudio (Ubuntu):
status: Invalid → New
Daniel T Chen (crimsun) wrote :

This symptom is unrelated to PulseAudio.

Changed in pulseaudio (Ubuntu):
status: New → Invalid
Daniel T Chen (crimsun) wrote :

For the kernel module, see bug 582350.

Daniel T Chen (crimsun) wrote :

I may as well address all the comments, so WRT Andy's comment, please see http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=commitdiff;h=1b0e372d7b52c9fc96348779015a6db7df7f286e for the applied upstream fix.

On Wed, Sep 08, 2010 at 12:54:08PM -0000, Daniel T Chen wrote:
> This symptom is unrelated to PulseAudio.
---end quoted text---

I don't understand, what is it related to then ? As I've mentioned in my
last change, it is not related to the kernel, because I booted Maverick
with Lucid's 2.6.32-25 kernel and there are no beeps (yet there were
beeps in Lucid).

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

On Wed, Sep 08, 2010 at 04:26:28PM +0200, <email address hidden> wrote:
> I don't understand, what is it related to then ? As I've mentioned in my
> last change, it is not related to the kernel, because I booted Maverick
> with Lucid's 2.6.32-25 kernel and there are no beeps (yet there were
> beeps in Lucid).
---end quoted text---

I just added this line to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel beep_mode=1

then rebooted, and beeping works again in Maverick (same wierd sound as
in Lucid). Yet I still don't understand why that didn't work when I
booted Maverick using Lucid's kernel.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

On Wed, Sep 08, 2010 at 01:02:51PM -0000, Daniel T Chen wrote:
> I may as well address all the comments, so WRT Andy's comment, please
> see
> http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-2.6.git;a=commitdiff;h=1b0e372d7b52c9fc96348779015a6db7df7f286e
> for the applied upstream fix.
---end quoted text---

So, Ubuntu needs to apply this patch to fix wierd beep sound ?

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Daniel T Chen (crimsun) wrote :

Yes, it needs to be applied to Maverick's linux.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

This should be resolved as of 2.6.35-21.30. Marking Fix Released for Maverick.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

On Tue, Sep 14, 2010 at 10:57:25PM -0000, Leann Ogasawara wrote:
> This should be resolved as of 2.6.35-21.30. Marking Fix Released for
> Maverick.
---end quoted text---

Yes, this fixed it indeed. Thanks a lot.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers