Ubuntu 6.06 beta installation problem (dual IDE controller or raid related?)

Bug #40993 reported by Gisli Ottarsson
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Confirmed
Medium
Unassigned

Bug Description

I am having a curious problem installing Ubuntu 6.06 beta on my system. This system has previously run Ubuntu 5.08 but I thought I would try a clean install.

After a successful installation, I am unable to log in because the system claims to be unable to mount the root filesystem on /dev/sda1. A novice inspection suggests that the reason for this may be that the order of disks has changed between installation and first boot. Let me add a little bit more detail:

My machine has four 120Gb IDE hard drives attached, in pairs, to two separate IDE controllers. Each of the disks has one large partition which I intend to set up in a 1+0 configuration. This does not seem to be possible during installation and I was going to tend to this later. These partitions were not mentioned during the installation and I don't think this is an issue. Each disk also has a swap partition (/dev/sd[abcd]2) and a 8.5 Gb partition (/dev/sd[abcd]1). One of these /dev/sda1 was to serve as my / partition and the other three (/dev/sdb1, /dev/sdc1 and /dev/sdd1) were set up as a RAID5 to hold /usr. None of this seemed to be an issue during the installation. Both contain the Reiser filesystem.

At first boot, it seems as if the order of the two IDE controllers has been switched. The system is unable to mount /dev/sda1 and when I use the busybox shell (which I am dumped into following the failed installation) to look at /dev/mdstat, it seems that /dev/sda1 is one of the partitions that the system now believes is involved in the RAID5. I can manually mount /dev/md0, but /dev/sda1 is claimed to be busy. On a lark I tried to mount /dev/sdc1 and it seems to hold the contents of /

Unfortunately I do not know how to dig deeper by myself, but I would be honored to assist in the resolution of this matter.

Best regards

  Gisli

PS: Please note that /dev/md0 existed from previously running Ubuntu. It was not created by 6.06. I was somewhat surprised not to see it directly in the partitioner but I selected the option to define a RAID but immediately finished and then the RAID was found. I then asked to have it formatted and mounted as /usr. No complaints.

Tags: linux
Revision history for this message
Gisli Ottarsson (gisli) wrote :

Sorry, when I said Ubuntu 5.08 I naturally meant 5.10.

Gisli

Revision history for this message
Gisli Ottarsson (gisli) wrote :

In case it might be useful, I went back to 5.10 an traced through exactly the same steps I had repeatedly attempted with 6.06. Version 5.10 gave me no problems at all. I will dist-upgrade the machine up to Dapper to see if the disk problems surface there, but even if they do not I could probably be persuaded to go back to square one in order to track this problem.

Let me know

  Gisli

Revision history for this message
Gisli Ottarsson (gisli) wrote :

Per my earlier comment I used apt to perform a dist-upgrade from 5.10 to 6.06 (beta) on this problematic system. I was starting from a fresh 5.10 installation. The upgrade went off without a hitch until the subsequent reboot. Then I encountered the same problem as I had previously. The boot was unable to find the root filesystem.
Recall that / is supposed to be mounted from /dev/sda1.

I dug a little bit deeper. In the busybox shell, the root filesystem was mysterously found on /dev/sdc1. On a lark, I decided to edit the grub commands and get root from /dev/sdc1. This allowed the boot to proceed.

The next problem I ran into was that /usr (which I had placed on /dev/md1 during the installation process) could not be mounted. It turned out that this partition was, post boot, known as /dev/md0.

By telling grub to get /root from /dev/sdc1 and editing fstab to get /usr from /dev/md0 I am now able to enter the system.

In summary:

During installation I define the following mount points

/dev/sda1 /
/dev/md1 /usr

I must tell grub that root is on /dev/sdc1 in order to boot.

The /etc/fstab file contains the mount points in order to successfully perform the initial mounts:

/dev/sda1 /
/dev/md0 /usr

Hopefully this is making sense to someone.

Additional information and experimentation available upon request.

Gisli

Revision history for this message
kko (kko) wrote :

Related to / Duplicate of bug 6367? Worth a comment there?

Revision history for this message
Gisli Ottarsson (gisli) wrote :

Thank you kko. I will take a look at bug 6367. However, for completeness, let me add some recent findings here.

As I have alluded to, my computer's motherboard has two IDE controllers, one Intel one Promise. In order to improve the performance of my RAID 0+1 (or is it RAID 1+0?) I have two of my four disks attached to one controller, two to the other. The problem seems to have been that the percieved order of these controllers (and consequently the definition of /dev/sd[ab] vs. /dev/sd[cd]) changed between installation and first boot. The only way to enter the system is to manually edit the grub commands and tell grub that root is on /dev/sdc1 (which it is not).

My motherboard is an ASUS PC-DL. The two disks connected to the Promise are Ultra-IDE and the two disks contected to the Intel controller are SATA.

Now I have all four disks connected to the Promise controller and my problems go away. Not only does grub now find root on /dev/sda1, but /usr is now found on /dev/md1, which is how /usr was defined during installation.

Thanks. Heading over to 6367

  Gisli

Revision history for this message
Paul Sladen (sladen) wrote :

Yup, as well as 'sda' and 'sdc' swapping, you'll probably find that 'sdb' and 'sdd' swapped too...

As you've later discovered, it's the order that the IDE controllers are being probbed in.

Could you provide the output of:

  /sbin/lsmod

I'm wondering if 'ide-generic' is being used.

Revision history for this message
Gisli Ottarsson (gisli) wrote : Re: [Bug 40993] Re: Ubuntu 6.06 beta installation problem (dual IDE controller or raid related?)
Download full text (4.4 KiB)

As requested, the output of lsmod on my system. Please note that this
generated with the system in a functioning state, i.e., with all four
disks attached to the same controller:

gisli@loki:~$ lsmod
Module Size Used by
acpi_sbs 19980 0
i2c_acpi_ec 5120 1 acpi_sbs
i2c_core 21904 1 i2c_acpi_ec
battery 9988 1 acpi_sbs
ac 5252 1 acpi_sbs
thermal 13576 0
processor 23360 1 thermal
fan 4868 0
button 6672 0
e1000 118840 0
nls_utf8 2176 1
udf 88452 1
ipv6 265600 6
rfcomm 40216 0
l2cap 26244 5 rfcomm
bluetooth 49892 4 rfcomm,l2cap
speedstep_lib 4484 0
cpufreq_powersave 1920 0
cpufreq_stats 5636 0
cpufreq_userspace 4696 0
cpufreq_ondemand 6428 0
cpufreq_conservative 7332 0
freq_table 4740 1 cpufreq_stats
tc1100_wmi 6916 0
video 16260 0
container 4608 0
pcc_acpi 12416 0
sony_acpi 5516 0
dev_acpi 11140 0
hotkey 11556 0
dm_mod 58936 1
raid1 22656 1
sbp2 24196 0
lp 11844 0
rsrc_nonstatic 13440 0
pcmcia_core 42640 1 rsrc_nonstatic
af_packet 22920 2
tsdev 8000 0
snd_intel8x0 33820 5
floppy 62148 0
snd_ac97_codec 92704 1 snd_intel8x0
snd_ac97_bus 2304 1 snd_ac97_codec
snd_pcm_oss 53664 0
snd_mixer_oss 18688 1 snd_pcm_oss
parport_pc 35780 1
parport 36296 2 lp,parport_pc
ohci1394 35124 0
snd_mpu401 6728 0
snd_mpu401_uart 7680 1 snd_mpu401
snd_rawmidi 25504 1 snd_mpu401_uart
snd_seq_device 8716 1 snd_rawmidi
analog 12320 0
gameport 15496 1 analog
psmouse 36228 0
rtc 13492 0
snd_pcm 89736 4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 25220 4 snd_pcm
ieee1394 299832 2 sbp2,ohci1394
serio_raw 7300 0
nvidia 3921884 0
snd 55268 16
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer
soundcore 10208 1 snd
usblp 13056 1
pcspkr 2180 0
snd_page_alloc 10632 2 snd_intel8x0,snd_pcm
hw_random 5652 0
shpchp 45632 0
intel_agp 22940 1
agpgart 34888 2 nvidia,intel_agp
pci_hotplug 29236 1 shpchp
sg 37920 0
evdev 9856 1
reiserfs 268016 4
raid5 28544 1
xor 15624 1 raid5
raid0 8832 2
md_mod 72532 5 raid1,raid5,raid0
ide_generic 1536 0
ehci_h...

Read more...

Revision history for this message
Launchpad Janitor (janitor) wrote : This bug is now reported against the 'linux' package

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers