Ubuntu

Seeing drm:intel_dp_i2c_init errors on boot

Reported by Robbie Williamson on 2009-08-05
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Low
linux (Ubuntu)
Medium
Tim Gardner
Karmic
Medium
Tim Gardner

Bug Description

During boot up of my Lenovo X301 laptop, I'm seeing the following 2 messages:
  [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-B
  [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-D

I have not noticed any graphics related issues while using my machine, however it does affect the boot experience by causing a flicker to show the message on the console.

Architecture: amd64
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=e5078b9d-33a9-49ee-b6c2-3a5c3e9096cd
MachineType: LENOVO 2777CTO
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-5-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-5-generic N/A
Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET41WW (3.01 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET41WW(3.01):bd05/15/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
tags: added: apport-collected
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium

Hardware: Thinkpad T400

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Software: Debian unstable, 2.6.31-rc6-amd64

Problem:

[ 48.870645] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-D

in dmesg during load.

Please attach the full dmesg and Xorg.0.log.

I've got the same error on G45 (and some MTRR allocation failed error as well), I posted my logs in a separate bug to avoid clutting up this one though:
https://bugs.freedesktop.org/show_bug.cgi?id=23588

Created an attachment (id=28997)
dmesg

(From update of attachment 28997)
fix attachment mime-type

Here are the logs.

2martin: It's perfectly fine to duplicate #23588 and then post your logs here.

Martin Olsson (mnemo) wrote :

Confirm on intel G45 using latest karmic bits as of 29th Aug (have seen the error on every boot for more than a month now):
[ 1.933896] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-B
[ 1.944881] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-C

The dmesg just before those errors are:
[ 1.901688] agpgart-intel 0000:00:00.0: Intel G45/G43 Chipset
[ 1.903191] agpgart-intel 0000:00:00.0: detected 32764K stolen memory
[ 1.906008] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[ 1.918992] [drm] Initialized drm 1.1.0 20060810
[ 1.925547] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1.925551] i915 0000:00:02.0: setting latency timer to 64
[ 1.928312] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[ 1.928314] [drm] MTRR allocation failed. Graphics performance may suffer.
[ 1.928524] alloc irq_desc for 26 on node 0
[ 1.928526] alloc kstat_irqs on node 0
[ 1.928532] i915 0000:00:02.0: irq 26 for MSI/MSI-X
[ 1.933896] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-B
[ 1.944881] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-C
[ 1.972387] i2c-adapter i2c-1: unable to read EDID block.
[ 1.972389] i915 0000:00:02.0: DVI-D-1: no EDID data

Card:
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e22] (rev 03)

2D:
2:2.8.1-1ubuntu1

libdrm-intel1:
2.4.12+git20090801.45078630-0ubuntu1

---

I assume that the "DP" in intel_dp_i2c_init] means DisplayPort? I've got my SyncMaster 2253BW connected through DVI though.

Martin Olsson (mnemo) wrote :

Robbie, the BootDmesg.gz that you attached seems corrupt and the CurrentDmesg.txt doesn't show the error. Can you please run "dmesg" and attach the output of that? It's interesting to see if you have both the displayport error and the MTRR allocation failed or if you have just the displayport error.

Anyway, I've upstreamed this to intel:
https://bugs.freedesktop.org/show_bug.cgi?id=23588

Changed in linux:
status: Unknown → Confirmed

*** Bug 23588 has been marked as a duplicate of this bug. ***

Created an attachment (id=29033)
Xorg.0.log.gz

Ugh, looks like I did not attach the Xorg.0.log (though I did try, honestly!). Here it is.

Heh, actually server was not able to chew in such a big file. Attached again, gzipped.

Changed in linux:
status: Confirmed → Invalid

Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robbiew 3137 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0620000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211f,00100000'
   Controls : 15
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=e5078b9d-33a9-49ee-b6c2-3a5c3e9096cd
MachineType: LENOVO 2777CTO
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-8-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-8.28-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-8-generic N/A
 linux-firmware 1.16
Uname: Linux 2.6.31-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET41WW (3.01 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET41WW(3.01):bd05/15/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Changed in linux:
status: Invalid → Confirmed
Changed in linux:
status: Confirmed → Invalid
Martin Olsson (mnemo) wrote :

manually updated upstream bug URL since the LP bug watcher seems to think that upstream duplicates are "INVALID".

Changed in linux:
status: Invalid → Unknown
Changed in linux:
status: Unknown → Confirmed
Changed in linux (Ubuntu Karmic):
importance: Medium → Low
Tuukka Hastrup (tuukkah) wrote :

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tuukka 1962 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4500000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10250284,00100004'
   Controls : 21
   Simple ctrls : 12
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=3a0cc818-d22b-4df4-9947-61373f45494c
MachineType: Acer TravelMate 8371
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=58fdc759-1719-40df-b6b6-1902991b8bba ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions: linux-firmware 1.19
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video
dmi.bios.date: 08/05/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.11
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: TravelMate 8371
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.11:bd08/05/2009:svnAcer:pnTravelMate8371:pvrV1.11:rvnAcer:rnTravelMate8371:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: TravelMate 8371
dmi.product.version: V1.11
dmi.sys.vendor: Acer

Jono Bacon (jonobacon) wrote :

I am also experiencing this in Karmic, and my last update was today (Wed 30th Sep). Here is some messages from dmesg:

[ 16.753618] usbcore: registered new interface driver zaurus
[ 16.757099] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-B
[ 16.809951] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-C
[ 16.815012] [drm:intel_dp_i2c_init] *ERROR* i2c_init DPDDC-D
[ 16.977137] i2c-adapter i2c-2: unable to read EDID block.
[ 16.977140] i915 0000:00:02.0: DVI-D-1: no EDID data
[ 16.984028] i2c-adapter i2c-4: unable to read EDID block.
[ 16.984030] i915 0000:00:02.0: DVI-D-2: no EDID data
[ 16.992953] [drm] fb0: inteldrmfb frame buffer device
[ 16.995850] acpi device:03: registered as cooling_device2
[ 16.996049] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/input/input7
[ 16.996075] ACPI: Video Device [VID] (multi-head: yes rom: no post: no)
[ 16.996114] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[ 16.996142] heci 0000:00:03.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 16.996147] heci 0000:00:03.0: setting latency timer to 64
[ 16.997853] heci: link layer has been established.

Changed in linux (Ubuntu Karmic):
importance: Low → Medium
tags: added: ubuntu-boot
tags: added: ubuntu-boot-experience
removed: ubuntu-boot
Tim Gardner (timg-tpi) on 2009-09-30
Changed in linux (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
milestone: none → ubuntu-9.10
status: Confirmed → In Progress
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-11.38

---------------
linux (2.6.31-11.38) karmic; urgency=low

  [ Stefan Bader ]

  * [Upstream] acerhdf: Limit modalias matching to supported boards
    - LP: #435958

  [ Tim Gardner ]

  * [Config] Added sata_via to d-i/modules/sata-modules
    - LP: #434827
  * SAUCE: (drop after 2.6.31) Disable iwl-1000 series wireless adapters
    - LP: #439285
  * [Upstream] i915: Fix i2c init message
    - LP: #409361
  * [Config] Add sym53c8xx.ko to virtual sub-flavour
    - LP: #439415

  [ Upstream Kernel Changes ]

  * sched: Disable NEW_FAIR_SLEEPERS for now
    - LP: #436342

  * ACPI video: ignore buggy _BQC
  * ACPI video: work-around BIOS AML bug in _BQC
    - LP: #428910
  * ALSA: hda - Added quirk to enable sound on Toshiba NB200
    - LP: #438318

 -- Tim Gardner <email address hidden> Thu, 01 Oct 2009 13:52:09 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released

This wasn't actually an error, just a stray debugging printk since reduced in priority.

Changed in linux:
importance: Unknown → Low
status: Confirmed → Fix Released
Changed in linux:
importance: Low → Unknown
Changed in linux:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.