[Regression] Bluetooth Causes Suspend to fail

Bug #409233 reported by Pete Graner on 2009-08-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Karmic
Undecided
Tim Gardner

Bug Description

Suspending on a Dell XPS m1330 was causing the machine to wedge on the way down with a blank screen and the backlight still on.

Debugging with no_console_suspend showed that the bluetooth driver was not behaving properly. By running:

rfkill block bluetooth

would allow the machine to suspend and resume properly.

Architecture: amd64
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. XPS M1330
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-5-generic root=UUID=55735533-713a-4888-80f3-5de0ffb4a009 ro no_console_suspend
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-5-generic N/A
Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare video
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0N6705
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn0N6705:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → High
status: New → Triaged
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
Pete Graner (pgraner) wrote :
tags: added: apport-collected
Ken VanDine (ken-vandine) wrote :

Architecture: amd64
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=875eb13b-bdb6-4731-bb3f-99f61c60a11e
MachineType: LENOVO 7417CTO
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-5-generic root=UUID=2ed62596-c710-48ac-8b6a-27d661f1a801 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions:

Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout kvm lpadmin plugdev sambashare
dmi.bios.date: 02/13/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET61WW (2.07 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET61WW(2.07):bd02/13/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :

Architecture: amd64
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=875eb13b-bdb6-4731-bb3f-99f61c60a11e
MachineType: LENOVO 7417CTO
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-5-generic root=UUID=2ed62596-c710-48ac-8b6a-27d661f1a801 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions:

Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout kvm lpadmin plugdev sambashare
dmi.bios.date: 02/13/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET61WW (2.07 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET61WW(2.07):bd02/13/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Ken VanDine (ken-vandine) wrote :
Andy Whitcroft (apw) on 2009-09-08
tags: added: regression-potential
Andy Whitcroft (apw) wrote :

@pete, @ken -- we need to first confirm whether this is a bug introduced in the Ubuntu delta, as there seems to be almost no mention of this issue elsewhere in the community. Could you test the equivalent mainline kernel to the latest kernel you are seeing this on. You can identify the correct kernel to test at the URL below:

    http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html

and get the mainline kernel you need from here:

    https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Please report both versions and the results back here. Thanks!

Andy Whitcroft (apw) wrote :

@pete -- also as you were able to get some kind of report/error with no_console_suspend, could you include a picture of that?

Noel J. Bergman (noeljb) wrote :

Is this problem still happening? I reported Bug 408654 a couple of days earlier than this one, and have since marked it as FIX RELEASED because suspend started working again for me in the 2.6.31-8 time-frame.

Vish (vish) wrote :

Nope... not fixed here , I cant Suspend or Hibernate...
[ Acer Aspire 5672WLMi ] and kernel -10.32

I tried #rfkill block bluetooth
and was able to suspend , but that crashed a *lot* of processes

Vish (vish) wrote :

update gnome-bluetooth (2.27.90-0ubuntu1) to 2.27.90-0ubuntu2
seems to have solved this problem for me.
Now i'm able to suspend and hibernate.

If no one else has this problem this bug can be closed.

Pete Graner (pgraner) wrote :

@apw, I tested this with 16 Sep daily live and the problem has gone away. This was on the same machine on which I originally reported the problem.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
importance: High → Undecided
status: Triaged → Invalid
Pete Graner (pgraner) on 2011-03-11
Changed in linux (Ubuntu Karmic):
status: Invalid → Fix Released
Changed in linux (Ubuntu):
status: Invalid → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers